source: projects/specs/trunk/v/vala/vala-vl.spec @ 521

Revision 521, 8.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        A modern programming language for GNOME
2Summary:        GNOME 用のモダンなプログラミング言語
3
4Name:           vala
5Version:        0.7.10
6Release:        1%{?_dist_release}
7
8Group:          Development/Languages
9# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
10License:        LGPLv2+ and BSD
11URL:            http://live.gnome.org/Vala
12Source0:        http://download.gnome.org/sources/vala/0.7/vala-%{version}.tar.bz2
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildRequires:  gtk2-devel flex bison devhelp gecko-libs >= 1.9
16Requires:       gtk2-devel
17
18%description
19Vala is a new programming language that aims to bring modern programming
20language features to GNOME developers without imposing any additional
21runtime requirements and without using a different ABI compared to
22applications and libraries written in C.
23
24valac, the Vala compiler, is a self-hosting compiler that translates
25Vala source code into C source and header files. It uses the GObject
26type system to create classes and interfaces declared in the Vala source
27code. It's also planned to generate GIDL files when gobject-
28introspection is ready.
29
30The syntax of Vala is similar to C#, modified to better fit the GObject
31type system.
32
33
34%package        devel
35Summary:        Development files for %{name}
36Group:          Development/Libraries
37Requires:       %{name} = %{version}-%{release}
38Requires:       pkgconfig
39
40%description    devel
41Vala is a new programming language that aims to bring modern programming
42language features to GNOME developers without imposing any additional
43runtime requirements and without using a different ABI compared to
44applications and libraries written in C.
45
46This package contains development files for %{name}. This is not necessary for
47using the %{name} compiler.
48
49
50%package        tools
51Summary:        Tools for creating projects and bindings for %{name}
52Group:          Development/Languages
53License:        LGPLv2+
54Requires:       %{name} = %{version}-%{release}
55Requires:       gnome-common intltool libtool
56Provides:       %{name}-vapigen = %{version}-%{release}
57Obsoletes:      %{name}-vapigen < %{version}-%{release}
58
59%description    tools
60Vala is a new programming language that aims to bring modern programming
61language features to GNOME developers without imposing any additional
62runtime requirements and without using a different ABI compared to
63applications and libraries written in C.
64
65This package contains tools to generate Vala projects, as well as API bindings
66from existing C libraries, allowing access from Vala programs.
67
68
69%package        doc
70Summary:        Documentation for %{name}
71Group:          Documentation
72License:        LGPLv2+
73Requires:       %{name} = %{version}-%{release}
74Requires:       devhelp
75Provides:       %{name}-docs = %{version}-%{release}
76Obsoletes:      %{name}-docs < %{version}-%{release}
77
78
79%description    doc
80Vala is a new programming language that aims to bring modern programming
81language features to GNOME developers without imposing any additional
82runtime requirements and without using a different ABI compared to
83applications and libraries written in C.
84
85This package contains documentation in a devhelp HTML book.
86
87
88%prep
89%setup -q
90
91
92%build
93%configure --enable-vapigen
94# Don't use rpath!
95sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
96sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
97make %{?_smp_mflags}
98
99
100# checks currently utilize installed Vala, not the one being compiled
101#%check
102#make check
103
104
105%install
106rm -rf $RPM_BUILD_ROOT
107make install DESTDIR=$RPM_BUILD_ROOT
108rm $RPM_BUILD_ROOT%{_libdir}/libvala.la
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(-,root,root,-)
119%doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
120%{_bindir}/valac
121%{_datadir}/vala
122%{_libdir}/libvala.so.*
123%{_mandir}/*/valac*
124
125%files devel
126%defattr(-,root,root,-)
127%{_includedir}/vala-1.0
128%{_libdir}/libvala.so
129%{_libdir}/pkgconfig/vala-1.0.pc
130
131%files tools
132%defattr(-,root,root,-)
133%{_bindir}/*gen*
134%{_bindir}/vapicheck
135%{_libdir}/vala
136%{_mandir}/*/*gen*
137
138%files doc
139%defattr(-,root,root,-)
140%{_datadir}/devhelp/books/vala
141
142
143%changelog
144* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
145- new upstream release
146
147* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
148- new upstream release
149
150* Tue Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
151- new upstream release
152
153* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
154- initial build for Vine Linux
155
156* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
157- Update to 0.7.5
158
159* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
160- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
161
162* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
163- Patch broken ModuleInit attribute (upstream bug 587444)
164
165* Tue Jul  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
166- Update to 0.7.4
167
168* Wed Jun  3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
169- Update to 0.7.3
170
171* Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
172- Update to 0.6.1
173
174* Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
175- Update to 0.5.7
176
177* Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
178- Update to 0.5.6
179
180* Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
181- Update to 0.5.3
182
183* Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
184- Fix bug in Emacs version detection
185
186* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
187- Use buildsystem variables to determine available Emacs version
188- BR on gecko-devel >= 1.9, since older version is also in RHEL repo
189
190* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
191- Update to 0.5.2
192
193* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
194- Update to 0.5.1
195
196* Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
197- Update to 0.3.5
198
199* Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
200- Add vala-mode for editing Vala code in Emacs
201
202* Tue Jul  1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
203- Update to 0.3.4
204
205* Wed Jun  4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
206- Update to 0.3.3
207
208* Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
209- Update to 0.3.2
210
211* Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
212- Update to 0.2.0
213
214* Wed Mar  5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
215- Update to 0.1.7
216- -tool subpackage now requires gnome-common, intltool and libtoolize
217  for out-of-the-box vala-gen-project support
218
219* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
220- Autorebuild for GCC 4.3
221
222* Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
223- Update to 0.1.6
224- Revert vapi addition, needed declarations have been inlined (r846)
225- Rename -docs subpackage to -doc, to comply with guidelines
226
227* Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
228- Manually add Gee vapi file to package (bz #428692)
229
230* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
231- Backport patch to autodetect location of automake shared files
232
233* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
234- Add build dependency on gtk2-devel
235
236* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
237- Enable project generator tool
238
239* Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
240- Update to 0.1.5
241
242* Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
243- Add build dependency on devhelp
244
245* Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
246- Update to 0.1.4
247- Put newly-added documentation in its own subpackage (depends on devhelp)
248
249* Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
250- vapigen subpackage: add missing Require: on perl-XML-Twig
251
252* Sat Sep  8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
253- Split -vapigen subpackage. It is functionally self-contained and the license
254  is more restricted
255- Updated license declarations
256
257* Wed Sep  5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
258- Licensing and URL updates
259
260* Tue Sep  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
261- Enable binding generation tools
262
263* Sun Sep  2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
264- Update to 0.1.3
265
266* Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
267- Update to 0.0.8
268
269* Wed Mar  7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
270- Update to 0.0.7
271
272* Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
273- Update to 0.0.6
274
275* Mon Nov  6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
276- Initial package
Note: See TracBrowser for help on using the repository browser.