source: projects/specs/trunk/v/vala/vala-vl.spec @ 7119

Revision 7119, 11.0 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.2

Line 
1%global api_ver 0.18
2
3Summary:        A modern programming language for GNOME
4Summary:        GNOME 用のモダンなプログラミング言語
5
6Name:           vala
7Version:        0.18.1
8Release:        1%{?_dist_release}
9
10Group:          Development/Languages
11# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
12License:        LGPLv2+ and BSD
13URL:            http://live.gnome.org/Vala
14Source0:        http://download.gnome.org/sources/vala/0.18/vala-%{version}.tar.xz
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  glib2-devel
18BuildRequires:  flex
19BuildRequires:  bison
20BuildRequires:  libxslt
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26Vala is a new programming language that aims to bring modern programming
27language features to GNOME developers without imposing any additional
28runtime requirements and without using a different ABI compared to
29applications and libraries written in C.
30
31valac, the Vala compiler, is a self-hosting compiler that translates
32Vala source code into C source and header files. It uses the GObject
33type system to create classes and interfaces declared in the Vala source
34code. It's also planned to generate GIDL files when gobject-
35introspection is ready.
36
37The syntax of Vala is similar to C#, modified to better fit the GObject
38type system.
39
40
41%package        devel
42Summary:        Development files for %{name}
43Group:          Development/Libraries
44Requires:       %{name} = %{version}-%{release}
45Requires:       pkgconfig
46
47%description    devel
48Vala is a new programming language that aims to bring modern programming
49language features to GNOME developers without imposing any additional
50runtime requirements and without using a different ABI compared to
51applications and libraries written in C.
52
53This package contains development files for %{name}. This is not necessary for
54using the %{name} compiler.
55
56
57%package        tools
58Summary:        Tools for creating projects and bindings for %{name}
59Group:          Development/Languages
60License:        LGPLv2+
61Requires:       %{name} = %{version}-%{release}
62Requires:       gnome-common intltool libtool
63Provides:       %{name}-vapigen = %{version}-%{release}
64Obsoletes:      %{name}-vapigen < %{version}-%{release}
65
66%description    tools
67Vala is a new programming language that aims to bring modern programming
68language features to GNOME developers without imposing any additional
69runtime requirements and without using a different ABI compared to
70applications and libraries written in C.
71
72This package contains tools to generate Vala projects, as well as API bindings
73from existing C libraries, allowing access from Vala programs.
74
75
76%package        doc
77Summary:        Documentation for %{name}
78Group:          Documentation
79License:        LGPLv2+
80
81BuildArch:      noarch
82Requires:       %{name} = %{version}-%{release}
83Requires:       devhelp
84Provides:       %{name}-docs = %{version}-%{release}
85Obsoletes:      %{name}-docs < %{version}-%{release}
86
87
88%description    doc
89Vala is a new programming language that aims to bring modern programming
90language features to GNOME developers without imposing any additional
91runtime requirements and without using a different ABI compared to
92applications and libraries written in C.
93
94This package contains documentation in a devhelp HTML book.
95
96
97%prep
98%setup -q
99
100%build
101%configure --enable-vapigen
102# Don't use rpath!
103sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
104sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
105make %{?_smp_mflags}
106
107# checks currently utilize installed Vala, not the one being compiled
108#%check
109#make check
110
111%install
112rm -rf $RPM_BUILD_ROOT
113make install DESTDIR=$RPM_BUILD_ROOT
114rm $RPM_BUILD_ROOT%{_libdir}/libvala-%{api_ver}.la
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120
121%postun -p /sbin/ldconfig
122
123%files
124%defattr(-,root,root,-)
125%doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
126%{_bindir}/vala
127%{_bindir}/valac
128%{_bindir}/vala-%{api_ver}
129%{_bindir}/valac-%{api_ver}
130%{_datadir}/vala-%{api_ver}
131%{_libdir}/libvala-%{api_ver}.so.*
132%{_mandir}/*/valac*
133
134%files devel
135%defattr(-,root,root,-)
136%{_includedir}/vala-%{api_ver}
137%{_libdir}/libvala-%{api_ver}.so
138%{_libdir}/pkgconfig/libvala-%{api_ver}.pc
139%{_datadir}/aclocal/vala.m4
140%{_datadir}/aclocal/vapigen.m4
141%{_datadir}/pkgconfig/vapigen.pc
142%{_datadir}/pkgconfig/vapigen-%{api_ver}.pc
143%{_datadir}/vala/Makefile.vapigen
144
145%files tools
146%defattr(-,root,root,-)
147%{_bindir}/vala-gen-introspect
148%{_bindir}/vapicheck
149%{_bindir}/vapigen
150%{_bindir}/vala-gen-introspect-%{api_ver}
151%{_bindir}/vapicheck-%{api_ver}
152%{_bindir}/vapigen-%{api_ver}
153%{_libdir}/vala-%{api_ver}
154%{_mandir}/*/*gen*
155
156%files doc
157%defattr(-,root,root,-)
158%{_datadir}/devhelp/books/vala-%{api_ver}
159
160
161%changelog
162* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.1-1
163- new upstream release
164
165* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
166- new upstream release
167
168* Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
169- new upstream release
170
171* Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
172- new upstream release
173
174* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
175- new upstream release
176
177* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
178- new upstream release
179
180* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
181- new upstream release
182- remove BuildRequires: gtk2-devel, xulrunner-devel
183- add BuildRequires: glib2-devel, libxslt
184
185* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
186- new upstream release
187- remove BuildRequires: devhelp
188
189* Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
190- new upstream release
191
192* Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
193- new upstream release
194
195* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
196- new upstream release
197
198* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
199- rebuilt with rpm-4.8.1 for pkg-config
200
201* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
202- new upstream release
203- made -doc subpackage noarch
204
205* Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
206- new upstream release
207
208* Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
209- new upstream release
210
211* Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
212- new upstream release
213
214* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
215- new upstream release
216
217* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
218- new upstream release
219- change BuildRequires: gecko-libs -> xulrunner-devel
220
221* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
222- new upstream release
223
224* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
225- new upstream release
226
227* Tue Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
228- new upstream release
229
230* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
231- initial build for Vine Linux
232
233* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
234- Update to 0.7.5
235
236* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
237- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
238
239* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
240- Patch broken ModuleInit attribute (upstream bug 587444)
241
242* Tue Jul  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
243- Update to 0.7.4
244
245* Wed Jun  3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
246- Update to 0.7.3
247
248* Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
249- Update to 0.6.1
250
251* Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
252- Update to 0.5.7
253
254* Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
255- Update to 0.5.6
256
257* Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
258- Update to 0.5.3
259
260* Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
261- Fix bug in Emacs version detection
262
263* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
264- Use buildsystem variables to determine available Emacs version
265- BR on gecko-devel >= 1.9, since older version is also in RHEL repo
266
267* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
268- Update to 0.5.2
269
270* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
271- Update to 0.5.1
272
273* Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
274- Update to 0.3.5
275
276* Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
277- Add vala-mode for editing Vala code in Emacs
278
279* Tue Jul  1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
280- Update to 0.3.4
281
282* Wed Jun  4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
283- Update to 0.3.3
284
285* Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
286- Update to 0.3.2
287
288* Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
289- Update to 0.2.0
290
291* Wed Mar  5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
292- Update to 0.1.7
293- -tool subpackage now requires gnome-common, intltool and libtoolize
294  for out-of-the-box vala-gen-project support
295
296* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
297- Autorebuild for GCC 4.3
298
299* Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
300- Update to 0.1.6
301- Revert vapi addition, needed declarations have been inlined (r846)
302- Rename -docs subpackage to -doc, to comply with guidelines
303
304* Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
305- Manually add Gee vapi file to package (bz #428692)
306
307* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
308- Backport patch to autodetect location of automake shared files
309
310* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
311- Add build dependency on gtk2-devel
312
313* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
314- Enable project generator tool
315
316* Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
317- Update to 0.1.5
318
319* Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
320- Add build dependency on devhelp
321
322* Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
323- Update to 0.1.4
324- Put newly-added documentation in its own subpackage (depends on devhelp)
325
326* Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
327- vapigen subpackage: add missing Require: on perl-XML-Twig
328
329* Sat Sep  8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
330- Split -vapigen subpackage. It is functionally self-contained and the license
331  is more restricted
332- Updated license declarations
333
334* Wed Sep  5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
335- Licensing and URL updates
336
337* Tue Sep  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
338- Enable binding generation tools
339
340* Sun Sep  2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
341- Update to 0.1.3
342
343* Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
344- Update to 0.0.8
345
346* Wed Mar  7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
347- Update to 0.0.7
348
349* Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
350- Update to 0.0.6
351
352* Mon Nov  6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
353- Initial package
Note: See TracBrowser for help on using the repository browser.