source: projects/specs/trunk/v/vala/vala-vl.spec @ 4616

Revision 4616, 10.2 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%global api_ver 0.12
2
3Summary:        A modern programming language for GNOME
4Summary:        GNOME 用のモダンなプログラミング言語
5
6Name:           vala
7Version:        0.12.1
8Release:        1%{?_dist_release}
9
10Group:          Development/Languages
11# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
12License:        LGPLv2+ and BSD
13URL:            http://live.gnome.org/Vala
14Source0:        http://download.gnome.org/sources/vala/0.12/vala-%{version}.tar.bz2
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  gtk2-devel
18BuildRequires:  flex
19BuildRequires:  bison
20BuildRequires:  xulrunner-devel >= 1.9
21Requires:       gtk2-devel
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27Vala is a new programming language that aims to bring modern programming
28language features to GNOME developers without imposing any additional
29runtime requirements and without using a different ABI compared to
30applications and libraries written in C.
31
32valac, the Vala compiler, is a self-hosting compiler that translates
33Vala source code into C source and header files. It uses the GObject
34type system to create classes and interfaces declared in the Vala source
35code. It's also planned to generate GIDL files when gobject-
36introspection is ready.
37
38The syntax of Vala is similar to C#, modified to better fit the GObject
39type system.
40
41
42%package        devel
43Summary:        Development files for %{name}
44Group:          Development/Libraries
45Requires:       %{name} = %{version}-%{release}
46Requires:       pkgconfig
47
48%description    devel
49Vala is a new programming language that aims to bring modern programming
50language features to GNOME developers without imposing any additional
51runtime requirements and without using a different ABI compared to
52applications and libraries written in C.
53
54This package contains development files for %{name}. This is not necessary for
55using the %{name} compiler.
56
57
58%package        tools
59Summary:        Tools for creating projects and bindings for %{name}
60Group:          Development/Languages
61License:        LGPLv2+
62Requires:       %{name} = %{version}-%{release}
63Requires:       gnome-common intltool libtool
64Provides:       %{name}-vapigen = %{version}-%{release}
65Obsoletes:      %{name}-vapigen < %{version}-%{release}
66
67%description    tools
68Vala is a new programming language that aims to bring modern programming
69language features to GNOME developers without imposing any additional
70runtime requirements and without using a different ABI compared to
71applications and libraries written in C.
72
73This package contains tools to generate Vala projects, as well as API bindings
74from existing C libraries, allowing access from Vala programs.
75
76
77%package        doc
78Summary:        Documentation for %{name}
79Group:          Documentation
80License:        LGPLv2+
81
82BuildArch:      noarch
83Requires:       %{name} = %{version}-%{release}
84Requires:       devhelp
85Provides:       %{name}-docs = %{version}-%{release}
86Obsoletes:      %{name}-docs < %{version}-%{release}
87
88
89%description    doc
90Vala is a new programming language that aims to bring modern programming
91language features to GNOME developers without imposing any additional
92runtime requirements and without using a different ABI compared to
93applications and libraries written in C.
94
95This package contains documentation in a devhelp HTML book.
96
97
98%prep
99%setup -q
100
101%build
102%configure --enable-vapigen
103# Don't use rpath!
104sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
105sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
106make %{?_smp_mflags}
107
108# checks currently utilize installed Vala, not the one being compiled
109#%check
110#make check
111
112%install
113rm -rf $RPM_BUILD_ROOT
114make install DESTDIR=$RPM_BUILD_ROOT
115rm $RPM_BUILD_ROOT%{_libdir}/libvala-%{api_ver}.la
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post -p /sbin/ldconfig
121
122%postun -p /sbin/ldconfig
123
124%files
125%defattr(-,root,root,-)
126%doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
127%{_bindir}/vala
128%{_bindir}/valac
129%{_bindir}/vala-%{api_ver}
130%{_bindir}/valac-%{api_ver}
131%{_datadir}/vala-%{api_ver}
132%{_libdir}/libvala-%{api_ver}.so.*
133%{_mandir}/*/valac*
134
135%files devel
136%defattr(-,root,root,-)
137%{_includedir}/vala-%{api_ver}
138%{_libdir}/libvala-%{api_ver}.so
139%{_libdir}/pkgconfig/libvala-%{api_ver}.pc
140%{_datadir}/aclocal/vala.m4
141
142%files tools
143%defattr(-,root,root,-)
144%{_bindir}/vala-gen-introspect
145%{_bindir}/vapicheck
146%{_bindir}/vapigen
147%{_bindir}/vala-gen-introspect-%{api_ver}
148%{_bindir}/vapicheck-%{api_ver}
149%{_bindir}/vapigen-%{api_ver}
150%{_libdir}/vala-%{api_ver}
151%{_mandir}/*/*gen*
152
153%files doc
154%defattr(-,root,root,-)
155%{_datadir}/devhelp/books/vala-%{api_ver}
156
157
158%changelog
159* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
160- new upstream release
161- remove BuildRequires: devhelp
162
163* Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
164- new upstream release
165
166* Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
167- new upstream release
168
169* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
170- new upstream release
171
172* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
173- rebuilt with rpm-4.8.1 for pkg-config
174
175* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
176- new upstream release
177- made -doc subpackage noarch
178
179* Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
180- new upstream release
181
182* Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
183- new upstream release
184
185* Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
186- new upstream release
187
188* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
189- new upstream release
190
191* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
192- new upstream release
193- change BuildRequires: gecko-libs -> xulrunner-devel
194
195* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
196- new upstream release
197
198* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
199- new upstream release
200
201* Tue Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
202- new upstream release
203
204* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
205- initial build for Vine Linux
206
207* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
208- Update to 0.7.5
209
210* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
211- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
212
213* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
214- Patch broken ModuleInit attribute (upstream bug 587444)
215
216* Tue Jul  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
217- Update to 0.7.4
218
219* Wed Jun  3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
220- Update to 0.7.3
221
222* Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
223- Update to 0.6.1
224
225* Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
226- Update to 0.5.7
227
228* Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
229- Update to 0.5.6
230
231* Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
232- Update to 0.5.3
233
234* Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
235- Fix bug in Emacs version detection
236
237* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
238- Use buildsystem variables to determine available Emacs version
239- BR on gecko-devel >= 1.9, since older version is also in RHEL repo
240
241* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
242- Update to 0.5.2
243
244* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
245- Update to 0.5.1
246
247* Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
248- Update to 0.3.5
249
250* Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
251- Add vala-mode for editing Vala code in Emacs
252
253* Tue Jul  1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
254- Update to 0.3.4
255
256* Wed Jun  4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
257- Update to 0.3.3
258
259* Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
260- Update to 0.3.2
261
262* Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
263- Update to 0.2.0
264
265* Wed Mar  5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
266- Update to 0.1.7
267- -tool subpackage now requires gnome-common, intltool and libtoolize
268  for out-of-the-box vala-gen-project support
269
270* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
271- Autorebuild for GCC 4.3
272
273* Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
274- Update to 0.1.6
275- Revert vapi addition, needed declarations have been inlined (r846)
276- Rename -docs subpackage to -doc, to comply with guidelines
277
278* Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
279- Manually add Gee vapi file to package (bz #428692)
280
281* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
282- Backport patch to autodetect location of automake shared files
283
284* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
285- Add build dependency on gtk2-devel
286
287* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
288- Enable project generator tool
289
290* Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
291- Update to 0.1.5
292
293* Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
294- Add build dependency on devhelp
295
296* Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
297- Update to 0.1.4
298- Put newly-added documentation in its own subpackage (depends on devhelp)
299
300* Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
301- vapigen subpackage: add missing Require: on perl-XML-Twig
302
303* Sat Sep  8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
304- Split -vapigen subpackage. It is functionally self-contained and the license
305  is more restricted
306- Updated license declarations
307
308* Wed Sep  5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
309- Licensing and URL updates
310
311* Tue Sep  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
312- Enable binding generation tools
313
314* Sun Sep  2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
315- Update to 0.1.3
316
317* Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
318- Update to 0.0.8
319
320* Wed Mar  7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
321- Update to 0.0.7
322
323* Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
324- Update to 0.0.6
325
326* Mon Nov  6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
327- Initial package
Note: See TracBrowser for help on using the repository browser.