source: projects/specs/trunk/v/vala/vala-vl.spec @ 1803

Revision 1803, 9.6 KB checked in by kudoh, 14 years ago (diff)
Line 
1%global api_ver 0.10
2
3Summary:        A modern programming language for GNOME
4Summary:        GNOME 用のモダンなプログラミング言語
5
6Name:           vala
7Version:        0.9.8
8Release:        1%{?_dist_release}
9
10Group:          Development/Languages
11# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
12License:        LGPLv2+ and BSD
13URL:            http://live.gnome.org/Vala
14Source0:        http://download.gnome.org/sources/vala/0.9/vala-%{version}.tar.bz2
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  gtk2-devel flex bison devhelp xulrunner-devel >= 1.9
18Requires:       gtk2-devel
19
20%description
21Vala is a new programming language that aims to bring modern programming
22language features to GNOME developers without imposing any additional
23runtime requirements and without using a different ABI compared to
24applications and libraries written in C.
25
26valac, the Vala compiler, is a self-hosting compiler that translates
27Vala source code into C source and header files. It uses the GObject
28type system to create classes and interfaces declared in the Vala source
29code. It's also planned to generate GIDL files when gobject-
30introspection is ready.
31
32The syntax of Vala is similar to C#, modified to better fit the GObject
33type system.
34
35
36%package        devel
37Summary:        Development files for %{name}
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40Requires:       pkgconfig
41
42%description    devel
43Vala is a new programming language that aims to bring modern programming
44language features to GNOME developers without imposing any additional
45runtime requirements and without using a different ABI compared to
46applications and libraries written in C.
47
48This package contains development files for %{name}. This is not necessary for
49using the %{name} compiler.
50
51
52%package        tools
53Summary:        Tools for creating projects and bindings for %{name}
54Group:          Development/Languages
55License:        LGPLv2+
56Requires:       %{name} = %{version}-%{release}
57Requires:       gnome-common intltool libtool
58Provides:       %{name}-vapigen = %{version}-%{release}
59Obsoletes:      %{name}-vapigen < %{version}-%{release}
60
61%description    tools
62Vala is a new programming language that aims to bring modern programming
63language features to GNOME developers without imposing any additional
64runtime requirements and without using a different ABI compared to
65applications and libraries written in C.
66
67This package contains tools to generate Vala projects, as well as API bindings
68from existing C libraries, allowing access from Vala programs.
69
70
71%package        doc
72Summary:        Documentation for %{name}
73Group:          Documentation
74License:        LGPLv2+
75
76BuildArch:      noarch
77Requires:       %{name} = %{version}-%{release}
78Requires:       devhelp
79Provides:       %{name}-docs = %{version}-%{release}
80Obsoletes:      %{name}-docs < %{version}-%{release}
81
82
83%description    doc
84Vala is a new programming language that aims to bring modern programming
85language features to GNOME developers without imposing any additional
86runtime requirements and without using a different ABI compared to
87applications and libraries written in C.
88
89This package contains documentation in a devhelp HTML book.
90
91
92%prep
93%setup -q
94
95%build
96%configure --enable-vapigen
97# Don't use rpath!
98sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
99sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
100make %{?_smp_mflags}
101
102# checks currently utilize installed Vala, not the one being compiled
103#%check
104#make check
105
106%install
107rm -rf $RPM_BUILD_ROOT
108make install DESTDIR=$RPM_BUILD_ROOT
109rm $RPM_BUILD_ROOT%{_libdir}/libvala-%{api_ver}.la
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%files
119%defattr(-,root,root,-)
120%doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
121%{_bindir}/vala
122%{_bindir}/valac
123%{_bindir}/vala-%{api_ver}
124%{_bindir}/valac-%{api_ver}
125%{_datadir}/vala-%{api_ver}
126%{_libdir}/libvala-%{api_ver}.so.*
127%{_mandir}/*/valac*
128
129%files devel
130%defattr(-,root,root,-)
131%{_includedir}/vala-%{api_ver}
132%{_libdir}/libvala-%{api_ver}.so
133%{_libdir}/pkgconfig/vala-%{api_ver}.pc
134%{_datadir}/aclocal/vala.m4
135
136%files tools
137%defattr(-,root,root,-)
138%{_bindir}/vala-gen-introspect
139%{_bindir}/vapicheck
140%{_bindir}/vapigen
141%{_bindir}/vala-gen-introspect-%{api_ver}
142%{_bindir}/vapicheck-%{api_ver}
143%{_bindir}/vapigen-%{api_ver}
144%{_libdir}/vala-%{api_ver}
145%{_mandir}/*/*gen*
146
147%files doc
148%defattr(-,root,root,-)
149%{_datadir}/devhelp/books/vala-%{api_ver}
150
151
152%changelog
153* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
154- new upstream release
155- made -doc subpackage noarch
156
157* Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
158- new upstream release
159
160* Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
161- new upstream release
162
163* Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
164- new upstream release
165
166* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
167- new upstream release
168
169* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
170- new upstream release
171- change BuildRequires: gecko-libs -> xulrunner-devel
172
173* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
174- new upstream release
175
176* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
177- new upstream release
178
179* Tue Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
180- new upstream release
181
182* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
183- initial build for Vine Linux
184
185* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
186- Update to 0.7.5
187
188* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
189- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
190
191* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
192- Patch broken ModuleInit attribute (upstream bug 587444)
193
194* Tue Jul  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
195- Update to 0.7.4
196
197* Wed Jun  3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
198- Update to 0.7.3
199
200* Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
201- Update to 0.6.1
202
203* Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
204- Update to 0.5.7
205
206* Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
207- Update to 0.5.6
208
209* Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
210- Update to 0.5.3
211
212* Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
213- Fix bug in Emacs version detection
214
215* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
216- Use buildsystem variables to determine available Emacs version
217- BR on gecko-devel >= 1.9, since older version is also in RHEL repo
218
219* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
220- Update to 0.5.2
221
222* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
223- Update to 0.5.1
224
225* Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
226- Update to 0.3.5
227
228* Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
229- Add vala-mode for editing Vala code in Emacs
230
231* Tue Jul  1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
232- Update to 0.3.4
233
234* Wed Jun  4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
235- Update to 0.3.3
236
237* Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
238- Update to 0.3.2
239
240* Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
241- Update to 0.2.0
242
243* Wed Mar  5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
244- Update to 0.1.7
245- -tool subpackage now requires gnome-common, intltool and libtoolize
246  for out-of-the-box vala-gen-project support
247
248* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
249- Autorebuild for GCC 4.3
250
251* Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
252- Update to 0.1.6
253- Revert vapi addition, needed declarations have been inlined (r846)
254- Rename -docs subpackage to -doc, to comply with guidelines
255
256* Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
257- Manually add Gee vapi file to package (bz #428692)
258
259* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
260- Backport patch to autodetect location of automake shared files
261
262* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
263- Add build dependency on gtk2-devel
264
265* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
266- Enable project generator tool
267
268* Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
269- Update to 0.1.5
270
271* Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
272- Add build dependency on devhelp
273
274* Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
275- Update to 0.1.4
276- Put newly-added documentation in its own subpackage (depends on devhelp)
277
278* Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
279- vapigen subpackage: add missing Require: on perl-XML-Twig
280
281* Sat Sep  8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
282- Split -vapigen subpackage. It is functionally self-contained and the license
283  is more restricted
284- Updated license declarations
285
286* Wed Sep  5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
287- Licensing and URL updates
288
289* Tue Sep  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
290- Enable binding generation tools
291
292* Sun Sep  2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
293- Update to 0.1.3
294
295* Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
296- Update to 0.0.8
297
298* Wed Mar  7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
299- Update to 0.0.7
300
301* Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
302- Update to 0.0.6
303
304* Mon Nov  6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
305- Initial package
Note: See TracBrowser for help on using the repository browser.