source: projects/specs/trunk/v/vala/vala-vl.spec @ 9791

Revision 9791, 12.0 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%global api_ver 0.30
2
3Summary:        A modern programming language for GNOME
4Summary:        GNOME 用のモダンなプログラミング言語
5
6Name:           vala
7Version:        0.30.0
8Release:        1%{?_dist_release}
9
10Group:          Development/Languages
11# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
12License:        LGPLv2+ and BSD
13URL:            http://live.gnome.org/Vala
14Source0:        http://download.gnome.org/sources/vala/0.30/vala-%{version}.tar.xz
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  glib2-devel
18BuildRequires:  flex
19BuildRequires:  bison
20BuildRequires:  libxslt
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26Vala is a new programming language that aims to bring modern programming
27language features to GNOME developers without imposing any additional
28runtime requirements and without using a different ABI compared to
29applications and libraries written in C.
30
31valac, the Vala compiler, is a self-hosting compiler that translates
32Vala source code into C source and header files. It uses the GObject
33type system to create classes and interfaces declared in the Vala source
34code. It's also planned to generate GIDL files when gobject-
35introspection is ready.
36
37The syntax of Vala is similar to C#, modified to better fit the GObject
38type system.
39
40
41%package        devel
42Summary:        Development files for %{name}
43Summary(ja):    %{name} の開発用ファイル
44Group:          Development/Libraries
45Requires:       %{name} = %{version}-%{release}
46Requires:       pkgconfig
47
48%description    devel
49Vala is a new programming language that aims to bring modern programming
50language features to GNOME developers without imposing any additional
51runtime requirements and without using a different ABI compared to
52applications and libraries written in C.
53
54This package contains development files for %{name}. This is not necessary for
55using the %{name} compiler.
56
57
58%package        tools
59Summary:        Tools for creating projects and bindings for %{name}
60Summary(ja):    %{name} のプロジェクト作成やバインディングのためのツール集
61Group:          Development/Tools
62License:        LGPLv2+
63Requires:       %{name} = %{version}-%{release}
64Requires:       gnome-common intltool libtool
65Provides:       %{name}-vapigen = %{version}-%{release}
66Obsoletes:      %{name}-vapigen < %{version}-%{release}
67
68%description    tools
69Vala is a new programming language that aims to bring modern programming
70language features to GNOME developers without imposing any additional
71runtime requirements and without using a different ABI compared to
72applications and libraries written in C.
73
74This package contains tools to generate Vala projects, as well as API bindings
75from existing C libraries, allowing access from Vala programs.
76
77
78%package        doc
79Summary:        Documentation for %{name}
80Summary(ja):    %{name} のドキュメント
81Group:          Documentation
82License:        LGPLv2+
83
84BuildArch:      noarch
85Requires:       %{name} = %{version}-%{release}
86Requires:       devhelp
87Provides:       %{name}-docs = %{version}-%{release}
88Obsoletes:      %{name}-docs < %{version}-%{release}
89
90
91%description    doc
92Vala is a new programming language that aims to bring modern programming
93language features to GNOME developers without imposing any additional
94runtime requirements and without using a different ABI compared to
95applications and libraries written in C.
96
97This package contains documentation in a devhelp HTML book.
98
99
100%prep
101%setup -q
102
103%build
104%configure --enable-vapigen
105# Don't use rpath!
106sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
107sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
108make %{?_smp_mflags}
109
110# checks currently utilize installed Vala, not the one being compiled
111#%check
112#make check
113
114%install
115rm -rf $RPM_BUILD_ROOT
116make install DESTDIR=$RPM_BUILD_ROOT
117rm $RPM_BUILD_ROOT%{_libdir}/libvala-%{api_ver}.la
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post -p /sbin/ldconfig
123
124%postun -p /sbin/ldconfig
125
126%files
127%defattr(-,root,root,-)
128%doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
129%{_bindir}/vala
130%{_bindir}/valac
131%{_bindir}/vala-%{api_ver}
132%{_bindir}/valac-%{api_ver}
133%{_datadir}/vala-%{api_ver}
134%{_libdir}/libvala-%{api_ver}.so.*
135%{_mandir}/*/valac*
136
137%files devel
138%defattr(-,root,root,-)
139%{_includedir}/vala-%{api_ver}
140%{_libdir}/libvala-%{api_ver}.so
141%{_libdir}/pkgconfig/libvala-%{api_ver}.pc
142%{_datadir}/aclocal/vala.m4
143%{_datadir}/aclocal/vapigen.m4
144%{_datadir}/pkgconfig/vapigen.pc
145%{_datadir}/pkgconfig/vapigen-%{api_ver}.pc
146%{_datadir}/vala/Makefile.vapigen
147
148%files tools
149%defattr(-,root,root,-)
150%{_bindir}/vala-gen-introspect
151%{_bindir}/vapicheck
152%{_bindir}/vapigen
153%{_bindir}/vala-gen-introspect-%{api_ver}
154%{_bindir}/vapicheck-%{api_ver}
155%{_bindir}/vapigen-%{api_ver}
156%{_libdir}/vala-%{api_ver}
157%{_mandir}/*/*gen*
158
159%files doc
160%defattr(-,root,root,-)
161%{_datadir}/devhelp/books/vala-%{api_ver}
162
163
164%changelog
165* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.30.0-1
166- new upstream release
167
168* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.1-1
169- new upstream release
170
171* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.0-1
172- new upstream release
173
174* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.26.2-1
175- new upstream release
176
177* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.26.1-1
178- new upstream release
179- moved tools subpackage to Development/Tools Group
180
181* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.0-1
182- new upstream release
183
184* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
185- new upstream release
186
187* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.0-1
188- new upstream release
189
190* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.1-1
191- new upstream release
192
193* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.1-1
194- new upstream release
195
196* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
197- new upstream release
198
199* Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
200- new upstream release
201
202* Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
203- new upstream release
204
205* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
206- new upstream release
207
208* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
209- new upstream release
210
211* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
212- new upstream release
213- remove BuildRequires: gtk2-devel, xulrunner-devel
214- add BuildRequires: glib2-devel, libxslt
215
216* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
217- new upstream release
218- remove BuildRequires: devhelp
219
220* Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
221- new upstream release
222
223* Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
224- new upstream release
225
226* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
227- new upstream release
228
229* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
230- rebuilt with rpm-4.8.1 for pkg-config
231
232* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
233- new upstream release
234- made -doc subpackage noarch
235
236* Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
237- new upstream release
238
239* Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
240- new upstream release
241
242* Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
243- new upstream release
244
245* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
246- new upstream release
247
248* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
249- new upstream release
250- change BuildRequires: gecko-libs -> xulrunner-devel
251
252* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
253- new upstream release
254
255* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
256- new upstream release
257
258* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
259- new upstream release
260
261* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
262- initial build for Vine Linux
263
264* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
265- Update to 0.7.5
266
267* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
268- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
269
270* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
271- Patch broken ModuleInit attribute (upstream bug 587444)
272
273* Tue Jul  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
274- Update to 0.7.4
275
276* Wed Jun  3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
277- Update to 0.7.3
278
279* Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
280- Update to 0.6.1
281
282* Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
283- Update to 0.5.7
284
285* Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
286- Update to 0.5.6
287
288* Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
289- Update to 0.5.3
290
291* Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
292- Fix bug in Emacs version detection
293
294* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
295- Use buildsystem variables to determine available Emacs version
296- BR on gecko-devel >= 1.9, since older version is also in RHEL repo
297
298* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
299- Update to 0.5.2
300
301* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
302- Update to 0.5.1
303
304* Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
305- Update to 0.3.5
306
307* Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
308- Add vala-mode for editing Vala code in Emacs
309
310* Tue Jul  1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
311- Update to 0.3.4
312
313* Wed Jun  4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
314- Update to 0.3.3
315
316* Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
317- Update to 0.3.2
318
319* Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
320- Update to 0.2.0
321
322* Wed Mar  5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
323- Update to 0.1.7
324- -tool subpackage now requires gnome-common, intltool and libtoolize
325  for out-of-the-box vala-gen-project support
326
327* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
328- Autorebuild for GCC 4.3
329
330* Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
331- Update to 0.1.6
332- Revert vapi addition, needed declarations have been inlined (r846)
333- Rename -docs subpackage to -doc, to comply with guidelines
334
335* Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
336- Manually add Gee vapi file to package (bz #428692)
337
338* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
339- Backport patch to autodetect location of automake shared files
340
341* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
342- Add build dependency on gtk2-devel
343
344* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
345- Enable project generator tool
346
347* Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
348- Update to 0.1.5
349
350* Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
351- Add build dependency on devhelp
352
353* Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
354- Update to 0.1.4
355- Put newly-added documentation in its own subpackage (depends on devhelp)
356
357* Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
358- vapigen subpackage: add missing Require: on perl-XML-Twig
359
360* Sat Sep  8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
361- Split -vapigen subpackage. It is functionally self-contained and the license
362  is more restricted
363- Updated license declarations
364
365* Wed Sep  5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
366- Licensing and URL updates
367
368* Tue Sep  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
369- Enable binding generation tools
370
371* Sun Sep  2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
372- Update to 0.1.3
373
374* Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
375- Update to 0.0.8
376
377* Wed Mar  7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
378- Update to 0.0.7
379
380* Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
381- Update to 0.0.6
382
383* Mon Nov  6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
384- Initial package
Note: See TracBrowser for help on using the repository browser.