source: projects/specs/trunk/v/vala/vala-vl.spec @ 12550

Revision 12550, 13.8 KB checked in by tomop, 3 years ago (diff)

updated 5 packages

eudev-3.2.10-1

libappindicator-12.10.0-2

libindicator-12.10.1-3

nasm-2.15.05-1

vala-0.48.13-1

Line 
1%global api_ver 0.48
2%define _unpackaged_files_terminate_build 1
3
4Summary:        A modern programming language for GNOME
5Summary(ja):    GNOME 用のモダンなプログラミング言語
6
7Name:           vala
8# LTS 0.48
9Version:        0.48.13
10Release:        1%{?_dist_release}
11Group:          programming
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15# Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
16License:        LGPLv2+ and BSD
17URL:            https://wiki.gnome.org/Projects/Vala
18%global         shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
19Source0:        https://download.gnome.org/sources/vala/%{shortver}/vala-%{version}.tar.xz
20BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
21
22BuildRequires:  glib2-devel
23BuildRequires:  gobject-introspection-devel
24BuildRequires:  flex
25BuildRequires:  bison
26BuildRequires:  libxslt
27BuildRequires:  graphviz-devel
28
29%description
30Vala is a new programming language that aims to bring modern programming
31language features to GNOME developers without imposing any additional
32runtime requirements and without using a different ABI compared to
33applications and libraries written in C.
34
35valac, the Vala compiler, is a self-hosting compiler that translates
36Vala source code into C source and header files. It uses the GObject
37type system to create classes and interfaces declared in the Vala source
38code. It's also planned to generate GIDL files when gobject-
39introspection is ready.
40
41The syntax of Vala is similar to C#, modified to better fit the GObject
42type system.
43
44
45%package        devel
46Summary:        Development files for %{name}
47Summary(ja):    %{name} の開発用ファイル
48Group:          programming
49Requires:       %{name} = %{version}-%{release}
50Requires:       pkgconfig
51
52%description    devel
53Vala is a new programming language that aims to bring modern programming
54language features to GNOME developers without imposing any additional
55runtime requirements and without using a different ABI compared to
56applications and libraries written in C.
57
58This package contains development files for %{name}. This is not necessary for
59using the %{name} compiler.
60
61
62%package        tools
63Summary:        Tools for creating projects and bindings for %{name}
64Summary(ja):    %{name} のプロジェクト作成やバインディングのためのツール集
65Group:          programming
66License:        LGPLv2+
67Requires:       %{name} = %{version}-%{release}
68Requires:       gnome-common intltool libtool
69Provides:       %{name}-vapigen = %{version}-%{release}
70Obsoletes:      %{name}-vapigen < %{version}-%{release}
71
72%description    tools
73Vala is a new programming language that aims to bring modern programming
74language features to GNOME developers without imposing any additional
75runtime requirements and without using a different ABI compared to
76applications and libraries written in C.
77
78This package contains tools to generate Vala projects, as well as API bindings
79from existing C libraries, allowing access from Vala programs.
80
81
82%package        doc
83Summary:        Documentation for %{name}
84Summary(ja):    %{name} のドキュメント
85Group:          documentation
86License:        LGPLv2+
87
88BuildArch:      noarch
89Requires:       %{name} = %{version}-%{release}
90Requires:       devhelp
91Provides:       %{name}-docs = %{version}-%{release}
92Obsoletes:      %{name}-docs < %{version}-%{release}
93
94%description    doc
95Vala is a new programming language that aims to bring modern programming
96language features to GNOME developers without imposing any additional
97runtime requirements and without using a different ABI compared to
98applications and libraries written in C.
99
100This package contains documentation in a devhelp HTML book.
101
102
103%package -n     valadoc
104Summary:        Vala documentation generator
105Summary(ja):    Valaのドキュメントジェネレータ
106Group:          programming
107License:        LGPLv2+
108Requires:       vala = %{version}-%{release}
109
110%description -n valadoc
111Valadoc is a documentation generator for generating API documentation from Vala
112source code.
113
114
115%package -n     valadoc-devel
116Summary:        Development files for valadoc
117Summary(ja):    valadocを利用した開発のためのファイル群
118Group:          programming
119License:        LGPLv2+
120Requires:       valadoc = %{version}-%{release}
121
122%description -n valadoc-devel
123Valadoc is a documentation generator for generating API documentation from Vala
124source code.
125
126The valadoc-devel package contains libraries and header files for
127developing applications that use valadoc.
128
129
130%debug_package
131
132
133%prep
134%setup -q
135
136%build
137%configure --enable-vapigen
138# Don't use rpath!
139sed -i 's|/lib /usr/lib|/lib /usr/lib /lib64 /usr/lib64|' libtool
140make %{?_smp_mflags}
141
142
143%install
144rm -rf $RPM_BUILD_ROOT
145make install DESTDIR=$RPM_BUILD_ROOT
146find %{buildroot}%{_libdir} -type f -name 'lib*.la' | xargs rm -f
147
148%check
149make check
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
154
155%ldconfig_scriptlets
156
157
158%files
159%defattr(-,root,root,-)
160%license COPYING
161%doc AUTHORS ChangeLog NEWS README THANKS
162%{_bindir}/vala
163%{_bindir}/valac
164%{_bindir}/vala-%{api_ver}
165%{_bindir}/valac-%{api_ver}
166%{_datadir}/vala-%{api_ver}
167%{_datadir}/vala
168%{_libdir}/libvala-%{api_ver}.so.*
169%{_mandir}/*/valac*
170
171%files devel
172%defattr(-,root,root,-)
173%{_includedir}/vala-%{api_ver}
174%{_libdir}/libvala-%{api_ver}.so
175%{_libdir}/pkgconfig/libvala-%{api_ver}.pc
176%{_datadir}/aclocal/vala.m4
177%{_datadir}/aclocal/vapigen.m4
178%{_libdir}/pkgconfig/vapigen.pc
179%{_libdir}/pkgconfig/vapigen-%{api_ver}.pc
180%{_datadir}/vala/Makefile.vapigen
181
182%files tools
183%defattr(-,root,root,-)
184%{_bindir}/vala-gen-introspect
185%{_bindir}/vapigen
186%{_bindir}/vala-gen-introspect-%{api_ver}
187%{_bindir}/vapigen-%{api_ver}
188%{_libdir}/vala-%{api_ver}
189%{_mandir}/*/*gen*
190
191%files doc
192%defattr(-,root,root,-)
193%{_datadir}/devhelp/books/vala-%{api_ver}
194
195%files -n valadoc
196%defattr(-,root,root,-)
197%{_bindir}/valadoc*
198%{_libdir}/libvaladoc-%{api_ver}.so.*
199%{_libdir}/valadoc-%{api_ver}
200%{_datadir}/valadoc-%{api_ver}
201%{_mandir}/*/valadoc*
202
203%files -n valadoc-devel
204%{_libdir}/libvaladoc-%{api_ver}.so
205%{_libdir}/pkgconfig/valadoc-%{api_ver}.pc
206%{_includedir}/valadoc-%{api_ver}
207
208
209%changelog
210* Thu Feb 25 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.48.13-1
211- new upstream release.
212
213* Mon Aug 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.48.8-1
214- new upstream release.
215
216* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.44.7-1
217- new upstream release.
218
219* Mon Dec 10 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40.11-1
220- new upstream release (LTS 0.40).
221
222* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.38.4-1
223- new upstream release.
224- added subpackages "valadoc" and "valadoc-devel".
225
226* Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.32.1-1
227- new upstream release
228
229* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.30.0-1
230- new upstream release
231
232* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.1-1
233- new upstream release
234
235* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.0-1
236- new upstream release
237
238* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.26.2-1
239- new upstream release
240
241* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.26.1-1
242- new upstream release
243- moved tools subpackage to Development/Tools Group
244
245* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.0-1
246- new upstream release
247
248* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
249- new upstream release
250
251* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.0-1
252- new upstream release
253
254* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.1-1
255- new upstream release
256
257* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.1-1
258- new upstream release
259
260* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
261- new upstream release
262
263* Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
264- new upstream release
265
266* Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
267- new upstream release
268
269* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
270- new upstream release
271
272* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
273- new upstream release
274
275* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
276- new upstream release
277- remove BuildRequires: gtk2-devel, xulrunner-devel
278- add BuildRequires: glib2-devel, libxslt
279
280* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
281- new upstream release
282- remove BuildRequires: devhelp
283
284* Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
285- new upstream release
286
287* Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
288- new upstream release
289
290* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
291- new upstream release
292
293* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
294- rebuilt with rpm-4.8.1 for pkg-config
295
296* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
297- new upstream release
298- made -doc subpackage noarch
299
300* Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
301- new upstream release
302
303* Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
304- new upstream release
305
306* Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
307- new upstream release
308
309* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
310- new upstream release
311
312* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
313- new upstream release
314- change BuildRequires: gecko-libs -> xulrunner-devel
315
316* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
317- new upstream release
318
319* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
320- new upstream release
321
322* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
323- new upstream release
324
325* Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
326- initial build for Vine Linux
327
328* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
329- Update to 0.7.5
330
331* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
332- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
333
334* Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
335- Patch broken ModuleInit attribute (upstream bug 587444)
336
337* Tue Jul  7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
338- Update to 0.7.4
339
340* Wed Jun  3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
341- Update to 0.7.3
342
343* Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
344- Update to 0.6.1
345
346* Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
347- Update to 0.5.7
348
349* Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
350- Update to 0.5.6
351
352* Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
353- Update to 0.5.3
354
355* Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
356- Fix bug in Emacs version detection
357
358* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
359- Use buildsystem variables to determine available Emacs version
360- BR on gecko-devel >= 1.9, since older version is also in RHEL repo
361
362* Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
363- Update to 0.5.2
364
365* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
366- Update to 0.5.1
367
368* Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
369- Update to 0.3.5
370
371* Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
372- Add vala-mode for editing Vala code in Emacs
373
374* Tue Jul  1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
375- Update to 0.3.4
376
377* Wed Jun  4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
378- Update to 0.3.3
379
380* Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
381- Update to 0.3.2
382
383* Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
384- Update to 0.2.0
385
386* Wed Mar  5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
387- Update to 0.1.7
388- -tool subpackage now requires gnome-common, intltool and libtoolize
389  for out-of-the-box vala-gen-project support
390
391* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
392- Autorebuild for GCC 4.3
393
394* Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
395- Update to 0.1.6
396- Revert vapi addition, needed declarations have been inlined (r846)
397- Rename -docs subpackage to -doc, to comply with guidelines
398
399* Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
400- Manually add Gee vapi file to package (bz #428692)
401
402* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
403- Backport patch to autodetect location of automake shared files
404
405* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
406- Add build dependency on gtk2-devel
407
408* Tue Dec  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
409- Enable project generator tool
410
411* Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
412- Update to 0.1.5
413
414* Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
415- Add build dependency on devhelp
416
417* Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
418- Update to 0.1.4
419- Put newly-added documentation in its own subpackage (depends on devhelp)
420
421* Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
422- vapigen subpackage: add missing Require: on perl-XML-Twig
423
424* Sat Sep  8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
425- Split -vapigen subpackage. It is functionally self-contained and the license
426  is more restricted
427- Updated license declarations
428
429* Wed Sep  5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
430- Licensing and URL updates
431
432* Tue Sep  4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
433- Enable binding generation tools
434
435* Sun Sep  2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
436- Update to 0.1.3
437
438* Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
439- Update to 0.0.8
440
441* Wed Mar  7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
442- Update to 0.0.7
443
444* Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
445- Update to 0.0.6
446
447* Mon Nov  6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
448- Initial package
Note: See TracBrowser for help on using the repository browser.