source: projects/specs/trunk/v/v4l-utils/v4l-utils-vl.spec @ 10470

Revision 10470, 8.5 KB checked in by tomop, 8 years ago (diff)

v4l-utils-1.10.1-1

Line 
1Name:           v4l-utils
2Version:        1.10.1
3Release:        1%{?_dist_release}
4Summary:        Utilities for video4linux and DVB devices
5Group:          Applications/System
6# ir-keytable and v4l2-sysfs-path are GPLv2 only
7License:        GPLv2+ and GPLv2
8URL:            http://www.linuxtv.org/downloads/v4l-utils/
9Source0:        http://linuxtv.org/downloads/v4l-utils/v4l-utils-%{version}.tar.bz2
10BuildRequires:  libjpeg-devel qt4-devel kernel-headers desktop-file-utils
11BuildRequires:  alsa-lib-devel doxygen gettext
12# For /lib/udev/rules.d ownership
13Requires:       eudev
14Requires:       libv4l = %{version}-%{release}
15
16%description
17v4l-utils is a collection of various video4linux (V4L) and DVB utilities. The
18main v4l-utils package contains cx18-ctl, ir-keytable, ivtv-ctl, v4l2-ctl and
19v4l2-sysfs-path.
20
21
22%package        devel-tools
23Summary:        Utilities for v4l2 / DVB driver development and debugging
24# decode_tm6000 is GPLv2 only
25License:        GPLv2+ and GPLv2
26Requires:       libv4l = %{version}-%{release}
27
28%description    devel-tools
29Utilities for v4l2 / DVB driver authors: decode_tm6000, v4l2-compliance and
30v4l2-dbg.
31
32
33%package -n     qv4l2
34Summary:        QT v4l2 test control and streaming test application
35License:        GPLv2+
36Requires:       libv4l = %{version}-%{release}
37
38%description -n qv4l2
39QT v4l2 test control and streaming test application.
40
41
42%package -n     libv4l
43Summary:        Collection of video4linux support libraries
44Group:          System Environment/Libraries
45# Some of the decompression helpers are GPLv2, the rest is LGPLv2+
46License:        LGPLv2+ and GPLv2
47URL:            http://hansdegoede.livejournal.com/3636.html
48
49%description -n libv4l
50libv4l is a collection of libraries which adds a thin abstraction layer on
51top of video4linux2 devices. The purpose of this (thin) layer is to make it
52easy for application writers to support a wide variety of devices without
53having to write separate code for different devices in the same class. libv4l
54consists of 3 different libraries: libv4lconvert, libv4l1 and libv4l2.
55
56libv4lconvert offers functions to convert from any (known) pixel-format
57to V4l2_PIX_FMT_BGR24 or V4l2_PIX_FMT_YUV420.
58
59libv4l1 offers the (deprecated) v4l1 API on top of v4l2 devices, independent
60of the drivers for those devices supporting v4l1 compatibility (which many
61v4l2 drivers do not).
62
63libv4l2 offers the v4l2 API on top of v4l2 devices, while adding for the
64application transparent libv4lconvert conversion where necessary.
65
66
67%package -n     libdvbv5
68Summary:        Libraries to control, scan and zap on Digital TV channels
69Group:          Development/Libraries
70License:        GPLv2
71
72%description -n libdvbv5
73Libraries to control, scan and zap on Digital TV channels
74
75
76%package -n     libv4l-devel
77Summary:        Development files for libv4l
78Group:          Development/Libraries
79License:        LGPLv2+
80URL:            http://hansdegoede.livejournal.com/3636.html
81Requires:       libv4l = %{version}-%{release}
82
83%description -n libv4l-devel
84The libv4l-devel package contains libraries and header files for
85developing applications that use libv4l.
86
87
88%package -n     libdvbv5-devel
89Summary:        Development files for libdvbv5
90Group:          Development/Libraries
91License:        GPLv2
92Requires:       libdvbv5%{?_isa} = %{version}-%{release}
93
94%description -n libdvbv5-devel
95The libdvbv5-devel package contains libraries and header
96files for developing applications that use libdvbv5.
97
98
99%prep
100%setup -q
101
102%build
103%configure --disable-static --enable-libdvbv5 --enable-doxygen-man
104# Don't use rpath!
105sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
106sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
107make %{?_smp_mflags}
108make doxygen-run
109
110
111%install
112%make_install
113find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
114rm -f $RPM_BUILD_ROOT%{_libdir}/{v4l1compat.so,v4l2convert.so}
115mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
116cp -arv %{_builddir}/%{name}-%{version}/doxygen-doc/man/man3 $RPM_BUILD_ROOT%{_mandir}/
117rm $RPM_BUILD_ROOT%{_mandir}/man3/_*3
118desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/qv4l2.desktop
119%find_lang %{name}
120%find_lang libdvbv5
121
122
123%post -n libv4l -p /sbin/ldconfig
124
125%postun -n libv4l -p /sbin/ldconfig
126
127%post -n libdvbv5 -p /sbin/ldconfig
128
129%postun -n libdvbv5 -p /sbin/ldconfig
130
131%post -n qv4l2
132touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
133
134%postun -n qv4l2
135if [ $1 -eq 0 ] ; then
136    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
137    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
138fi
139
140%posttrans -n qv4l2
141gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
142
143
144%files
145%doc README
146%dir %{_sysconfdir}/rc_keymaps
147%config(noreplace) %{_sysconfdir}/rc_maps.cfg
148/lib/udev/rules.d/70-infrared.rules
149/lib/udev/rc_keymaps/*
150%{_bindir}/cx18-ctl
151%{_bindir}/dvb*
152%{_bindir}/ir-keytable
153%{_bindir}/ivtv-ctl
154%{_bindir}/media-ctl
155%{_bindir}/rds-ctl
156%{_bindir}/v4l2-ctl
157%{_bindir}/v4l2-sysfs-path
158%{_mandir}/man1/*.1*
159%exclude %{_mandir}/man1/qv4l2.1*
160%exclude %{_mandir}/man1/v4l2-compliance.1*
161
162%files devel-tools
163%doc README
164%{_bindir}/decode_tm6000
165%{_bindir}/v4l2-compliance
166%{_mandir}/man1/v4l2-compliance.1*
167%{_sbindir}/v4l2-dbg
168
169%files -n qv4l2
170%doc README
171%{_bindir}/qv4l2
172%{_datadir}/applications/qv4l2.desktop
173%{_datadir}/icons/hicolor/*/apps/qv4l2.*
174%{_mandir}/man1/qv4l2.1*
175
176%files -n libv4l
177%doc ChangeLog README.libv4l TODO
178%license COPYING.libv4l COPYING
179%{_libdir}/libv4l
180%{_libdir}/libv4l*.so.*
181
182%files -n libv4l-devel
183%doc README.lib-multi-threading
184%{_includedir}/libv4l*.h
185%{_libdir}/libv4l*.so
186%{_libdir}/pkgconfig/libv4l*.pc
187
188%files -n libdvbv5 -f libdvbv5.lang
189%doc ChangeLog lib/libdvbv5/README
190%license COPYING
191%{_libdir}/libdvbv5*.so.*
192
193%files -n libdvbv5-devel
194%{_includedir}/libdvbv5/*.h
195%{_libdir}/libdvbv5*.so
196%{_libdir}/pkgconfig/libdvbv5*.pc
197%{_mandir}/man3/*.3*
198
199
200%changelog
201* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.10.1-1
202- new upstream release.
203
204* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
205- initial build for Vine Linux
206
207
208* Sat Aug  3 2013 Hans de Goede <hdegoede@redhat.com> - 1.0.0-1
209- New upstream release 1.0.0 final
210- Drop libdvb5 (made private upstream for now)
211
212* Fri Jun 14 2013 Hans de Goede <hdegoede@redhat.com> - 0.9.5-2
213- Add a few libv4l2rds patches from upstream, which bring libv4l2rds to its
214  final API / ABI, so that apps build against it won't need a rebuild in the
215  future
216
217* Sun Jun  9 2013 Hans de Goede <hdegoede@redhat.com> - 0.9.5-1
218- New upstream release 0.9.5 (rhbz#970412)
219- Modernize specfile a bit
220
221* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.8-6
222- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
223
224* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 0.8.8-5
225- rebuild due to "jpeg8-ABI" feature drop
226
227* Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.8.8-4
228- rebuild against new libjpeg
229
230* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.8-3
231- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
232
233* Mon Jul  9 2012 Hans de Goede <hdegoede@redhat.com> - 0.8.8-2
234- Cherry-pick 2 patches from upstream git fixing an exotic crash (rhbz#838279)
235
236* Tue May 22 2012 Hans de Goede <hdegoede@redhat.com> - 0.8.8-1
237- New upstream release 0.8.8
238- Add patches from upstream git to improve Pixart JPEG decoding
239- Add patch from upstream git to fix building with latest kernels (rhbz#823863)
240
241* Mon Apr  9 2012 Hans de Goede <hdegoede@redhat.com> - 0.8.7-1
242- New upstream release 0.8.7
243- Fixes rhbz#807656
244
245* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-2
246- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
247
248* Sun Jul 17 2011 Hans de Goede <hdegoede@redhat.com> 0.8.5-1
249- New upstream release 0.8.5
250- Fixes rhbz#711492
251
252* Wed Jun  1 2011 Hans de Goede <hdegoede@redhat.com> 0.8.4-1
253- New upstream release 0.8.4
254
255* Sat Mar 12 2011 Hans de Goede <hdegoede@redhat.com> 0.8.3-2
256- Add a .desktop file for qv4l2
257- Add fully versioned Requires on libv4l to other (sub)packages
258
259* Thu Feb 10 2011 Hans de Goede <hdegoede@redhat.com> 0.8.3-1
260- New upstream release 0.8.3
261
262* Wed Jan 26 2011 Hans de Goede <hdegoede@redhat.com> 0.8.2-3
263- Add missing BuildRequires: kernel-headers
264
265* Mon Jan 24 2011 Hans de Goede <hdegoede@redhat.com> 0.8.2-2
266- Change tarbal to official upstream 0.8.2 release
267- This fixes multiple Makefile issues pointed out in the review (#671883)
268- Add ir-keytable config files
269- Explicitly specify CXXFLAGS so that qv4l2 gets build with rpm_opt_flags too
270
271* Sat Jan 22 2011 Hans de Goede <hdegoede@redhat.com> 0.8.2-1
272- Initial Fedora package
Note: See TracBrowser for help on using the repository browser.