source: projects/specs/trunk/v/v4l-utils/v4l-utils-vl.spec @ 8916

Revision 8916, 7.1 KB checked in by Takemikaduchi, 10 years ago (diff)

v4l-utils: new package
libebml,libemf,libmatroska,libmms,libmodplug,t1utils,usbutils: new upstream release
self-build-mikutter: update to 3.0.5
others: rebuild

Line 
1Name:           v4l-utils
2Version:        1.0.0
3Release:        1%{?_dist_release}
4Summary:        Utilities for video4linux and DVB devices
5Group:          Applications/System
6# ir-keytable and v4l2-sysfs-path are GPLv2 only
7License:        GPLv2+ and GPLv2
8URL:            http://www.linuxtv.org/downloads/v4l-utils/
9Source0:        http://linuxtv.org/downloads/v4l-utils/v4l-utils-%{version}.tar.bz2
10BuildRequires:  libjpeg-devel qt4-devel kernel-headers desktop-file-utils
11# For /lib/udev/rules.d ownership
12Requires:       eudev
13Requires:       libv4l = %{version}-%{release}
14
15%description
16v4l-utils is a collection of various video4linux (V4L) and DVB utilities. The
17main v4l-utils package contains cx18-ctl, ir-keytable, ivtv-ctl, v4l2-ctl and
18v4l2-sysfs-path.
19
20
21%package        devel-tools
22Summary:        Utilities for v4l2 / DVB driver development and debugging
23# decode_tm6000 is GPLv2 only
24License:        GPLv2+ and GPLv2
25Requires:       libv4l = %{version}-%{release}
26
27%description    devel-tools
28Utilities for v4l2 / DVB driver authors: decode_tm6000, v4l2-compliance and
29v4l2-dbg.
30
31
32%package -n     qv4l2
33Summary:        QT v4l2 test control and streaming test application
34License:        GPLv2+
35Requires:       libv4l = %{version}-%{release}
36
37%description -n qv4l2
38QT v4l2 test control and streaming test application.
39
40
41%package -n     libv4l
42Summary:        Collection of video4linux support libraries
43Group:          System Environment/Libraries
44# Some of the decompression helpers are GPLv2, the rest is LGPLv2+
45License:        LGPLv2+ and GPLv2
46URL:            http://hansdegoede.livejournal.com/3636.html
47
48%description -n libv4l
49libv4l is a collection of libraries which adds a thin abstraction layer on
50top of video4linux2 devices. The purpose of this (thin) layer is to make it
51easy for application writers to support a wide variety of devices without
52having to write separate code for different devices in the same class. libv4l
53consists of 3 different libraries: libv4lconvert, libv4l1 and libv4l2.
54
55libv4lconvert offers functions to convert from any (known) pixel-format
56to V4l2_PIX_FMT_BGR24 or V4l2_PIX_FMT_YUV420.
57
58libv4l1 offers the (deprecated) v4l1 API on top of v4l2 devices, independent
59of the drivers for those devices supporting v4l1 compatibility (which many
60v4l2 drivers do not).
61
62libv4l2 offers the v4l2 API on top of v4l2 devices, while adding for the
63application transparent libv4lconvert conversion where necessary.
64
65
66%package -n     libv4l-devel
67Summary:        Development files for libv4l
68Group:          Development/Libraries
69License:        LGPLv2+
70URL:            http://hansdegoede.livejournal.com/3636.html
71Requires:       libv4l = %{version}-%{release}
72
73%description -n libv4l-devel
74The libv4l-devel package contains libraries and header files for
75developing applications that use libv4l.
76
77
78%prep
79%setup -q
80
81
82%build
83%configure --disable-static
84# Don't use rpath!
85sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
86sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
87make %{?_smp_mflags}
88
89
90%install
91%make_install
92find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
93rm $RPM_BUILD_ROOT%{_libdir}/{v4l1compat.so,v4l2convert.so}
94desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/qv4l2.desktop
95
96
97%post -n libv4l -p /sbin/ldconfig
98
99%postun -n libv4l -p /sbin/ldconfig
100
101%post -n qv4l2
102touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
103
104%postun -n qv4l2
105if [ $1 -eq 0 ] ; then
106    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
107    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
108fi
109
110%posttrans -n qv4l2
111gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
112
113
114%files
115%doc README
116%dir %{_sysconfdir}/rc_keymaps
117%config(noreplace) %{_sysconfdir}/rc_maps.cfg
118/lib/udev/rules.d/70-infrared.rules
119/lib/udev/rc_keymaps/*
120%{_bindir}/cx18-ctl
121%{_bindir}/dvb*
122%{_bindir}/ir-keytable
123%{_bindir}/ivtv-ctl
124%{_bindir}/rds-ctl
125%{_bindir}/v4l2-ctl
126%{_bindir}/v4l2-sysfs-path
127%{_mandir}/man1/ir-keytable.1*
128
129%files devel-tools
130%doc README
131%{_bindir}/decode_tm6000
132%{_bindir}/v4l2-compliance
133%{_sbindir}/v4l2-dbg
134
135%files -n qv4l2
136%doc README
137%{_bindir}/qv4l2
138%{_datadir}/applications/qv4l2.desktop
139%{_datadir}/icons/hicolor/*/apps/qv4l2.*
140
141%files -n libv4l
142%doc COPYING.libv4l COPYING ChangeLog README.libv4l TODO
143%{_libdir}/libv4l
144%{_libdir}/libv4l*.so.*
145
146%files -n libv4l-devel
147%doc README.lib-multi-threading
148%{_includedir}/libv4l*.h
149%{_libdir}/libv4l*.so
150%{_libdir}/pkgconfig/libv4l*.pc
151
152
153%changelog
154* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
155- initial build for Vine Linux
156
157
158* Sat Aug  3 2013 Hans de Goede <hdegoede@redhat.com> - 1.0.0-1
159- New upstream release 1.0.0 final
160- Drop libdvb5 (made private upstream for now)
161
162* Fri Jun 14 2013 Hans de Goede <hdegoede@redhat.com> - 0.9.5-2
163- Add a few libv4l2rds patches from upstream, which bring libv4l2rds to its
164  final API / ABI, so that apps build against it won't need a rebuild in the
165  future
166
167* Sun Jun  9 2013 Hans de Goede <hdegoede@redhat.com> - 0.9.5-1
168- New upstream release 0.9.5 (rhbz#970412)
169- Modernize specfile a bit
170
171* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.8-6
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
173
174* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 0.8.8-5
175- rebuild due to "jpeg8-ABI" feature drop
176
177* Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.8.8-4
178- rebuild against new libjpeg
179
180* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.8-3
181- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
182
183* Mon Jul  9 2012 Hans de Goede <hdegoede@redhat.com> - 0.8.8-2
184- Cherry-pick 2 patches from upstream git fixing an exotic crash (rhbz#838279)
185
186* Tue May 22 2012 Hans de Goede <hdegoede@redhat.com> - 0.8.8-1
187- New upstream release 0.8.8
188- Add patches from upstream git to improve Pixart JPEG decoding
189- Add patch from upstream git to fix building with latest kernels (rhbz#823863)
190
191* Mon Apr  9 2012 Hans de Goede <hdegoede@redhat.com> - 0.8.7-1
192- New upstream release 0.8.7
193- Fixes rhbz#807656
194
195* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-2
196- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
197
198* Sun Jul 17 2011 Hans de Goede <hdegoede@redhat.com> 0.8.5-1
199- New upstream release 0.8.5
200- Fixes rhbz#711492
201
202* Wed Jun  1 2011 Hans de Goede <hdegoede@redhat.com> 0.8.4-1
203- New upstream release 0.8.4
204
205* Sat Mar 12 2011 Hans de Goede <hdegoede@redhat.com> 0.8.3-2
206- Add a .desktop file for qv4l2
207- Add fully versioned Requires on libv4l to other (sub)packages
208
209* Thu Feb 10 2011 Hans de Goede <hdegoede@redhat.com> 0.8.3-1
210- New upstream release 0.8.3
211
212* Wed Jan 26 2011 Hans de Goede <hdegoede@redhat.com> 0.8.2-3
213- Add missing BuildRequires: kernel-headers
214
215* Mon Jan 24 2011 Hans de Goede <hdegoede@redhat.com> 0.8.2-2
216- Change tarbal to official upstream 0.8.2 release
217- This fixes multiple Makefile issues pointed out in the review (#671883)
218- Add ir-keytable config files
219- Explicitly specify CXXFLAGS so that qv4l2 gets build with rpm_opt_flags too
220
221* Sat Jan 22 2011 Hans de Goede <hdegoede@redhat.com> 0.8.2-1
222- Initial Fedora package
Note: See TracBrowser for help on using the repository browser.