source: projects/specs/trunk/v/v4l-utils/v4l-utils-vl.spec @ 12184

Revision 12184, 9.0 KB checked in by tomop, 5 years ago (diff)

v4l-utils-1.16.7-1

Line 
1Name:           v4l-utils
2Version:        1.16.7
3Release:        1%{?_dist_release}
4Summary:        Utilities for video4linux and DVB devices
5Group:          Applications/System
6# ir-keytable and v4l2-sysfs-path are GPLv2 only
7License:        GPLv2+ and GPLv2
8URL:            https://linuxtv.org/downloads/v4l-utils/
9Source0:        https://linuxtv.org/downloads/v4l-utils/v4l-utils-%{version}.tar.bz2
10BuildRequires:  libudev-devel libjpeg-devel kernel-headers desktop-file-utils
11BuildRequires:  alsa-lib-devel doxygen gettext
12BuildRequires:  qt5-qtbase-devel qt5-qt3d-devel
13# For /lib/udev/rules.d ownership
14Requires:       eudev
15Requires:       libv4l = %{version}-%{release}
16
17Vendor: Project Vine
18Distribution: Vine Linux
19
20%description
21v4l-utils is a collection of various video4linux (V4L) and DVB utilities. The
22main v4l-utils package contains cx18-ctl, ir-keytable, ivtv-ctl, v4l2-ctl and
23v4l2-sysfs-path.
24
25
26%package        devel-tools
27Summary:        Utilities for v4l2 / DVB driver development and debugging
28# decode_tm6000 is GPLv2 only
29License:        GPLv2+ and GPLv2
30Requires:       libv4l = %{version}-%{release}
31
32%description    devel-tools
33Utilities for v4l2 / DVB driver authors: decode_tm6000, v4l2-compliance and
34v4l2-dbg.
35
36
37%package -n     qv4l2
38Summary:        QT v4l2 test control and streaming test application
39License:        GPLv2+
40Requires:       libv4l = %{version}-%{release}
41
42%description -n qv4l2
43QT v4l2 test control and streaming test application.
44
45
46%package -n     libv4l
47Summary:        Collection of video4linux support libraries
48Group:          System Environment/Libraries
49# Some of the decompression helpers are GPLv2, the rest is LGPLv2+
50License:        LGPLv2+ and GPLv2
51URL:            http://hansdegoede.livejournal.com/3636.html
52
53%description -n libv4l
54libv4l is a collection of libraries which adds a thin abstraction layer on
55top of video4linux2 devices. The purpose of this (thin) layer is to make it
56easy for application writers to support a wide variety of devices without
57having to write separate code for different devices in the same class. libv4l
58consists of 3 different libraries: libv4lconvert, libv4l1 and libv4l2.
59
60libv4lconvert offers functions to convert from any (known) pixel-format
61to V4l2_PIX_FMT_BGR24 or V4l2_PIX_FMT_YUV420.
62
63libv4l1 offers the (deprecated) v4l1 API on top of v4l2 devices, independent
64of the drivers for those devices supporting v4l1 compatibility (which many
65v4l2 drivers do not).
66
67libv4l2 offers the v4l2 API on top of v4l2 devices, while adding for the
68application transparent libv4lconvert conversion where necessary.
69
70
71%package -n     libdvbv5
72Summary:        Libraries to control, scan and zap on Digital TV channels
73Group:          Development/Libraries
74License:        GPLv2
75
76%description -n libdvbv5
77Libraries to control, scan and zap on Digital TV channels
78
79
80%package -n     libv4l-devel
81Summary:        Development files for libv4l
82Group:          Development/Libraries
83License:        LGPLv2+
84URL:            http://hansdegoede.livejournal.com/3636.html
85Requires:       libv4l = %{version}-%{release}
86
87%description -n libv4l-devel
88The libv4l-devel package contains libraries and header files for
89developing applications that use libv4l.
90
91
92%package -n     libdvbv5-devel
93Summary:        Development files for libdvbv5
94Group:          Development/Libraries
95License:        GPLv2
96Requires:       libdvbv5%{?_isa} = %{version}-%{release}
97
98%description -n libdvbv5-devel
99The libdvbv5-devel package contains libraries and header
100files for developing applications that use libdvbv5.
101
102
103%prep
104%setup -q
105
106%build
107%configure --disable-static --enable-libdvbv5 --enable-doxygen-man
108# Don't use rpath!
109sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
110sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
111make %{?_smp_mflags}
112make doxygen-run
113
114
115%install
116%make_install
117find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
118rm -f $RPM_BUILD_ROOT%{_libdir}/{v4l1compat.so,v4l2convert.so}
119mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3/
120cp -arv %{_builddir}/%{name}-%{version}/doxygen-doc/man/man3 $RPM_BUILD_ROOT%{_mandir}/
121rm $RPM_BUILD_ROOT%{_mandir}/man3/_*3
122desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/qv4l2.desktop
123%find_lang %{name}
124%find_lang libdvbv5
125
126
127%post -n libv4l -p /sbin/ldconfig
128
129%postun -n libv4l -p /sbin/ldconfig
130
131%post -n libdvbv5 -p /sbin/ldconfig
132
133%postun -n libdvbv5 -p /sbin/ldconfig
134
135%post -n qv4l2
136touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
137
138%postun -n qv4l2
139if [ $1 -eq 0 ] ; then
140    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
141    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
142fi
143
144%posttrans -n qv4l2
145gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
146
147
148%files -f %{name}.lang
149%doc README
150%dir %{_sysconfdir}/rc_keymaps
151%config(noreplace) %{_sysconfdir}/rc_maps.cfg
152/lib/udev/rules.d/70-infrared.rules
153/lib/udev/rc_keymaps/*
154%{_bindir}/cec-compliance
155%{_bindir}/cec-ctl
156%{_bindir}/cec-follower
157%{_bindir}/cx18-ctl
158%{_bindir}/dvb*
159%{_bindir}/ir-ctl
160%{_bindir}/ir-keytable
161%{_bindir}/ivtv-ctl
162%{_bindir}/media-ctl
163%{_bindir}/rds-ctl
164%{_bindir}/v4l2-ctl
165%{_bindir}/v4l2-sysfs-path
166%{_mandir}/man1/*.1*
167%exclude %{_mandir}/man1/qv4l2.1*
168%exclude %{_mandir}/man1/v4l2-compliance.1*
169
170%files devel-tools
171%doc README
172%{_bindir}/decode_tm6000
173%{_bindir}/v4l2-compliance
174%{_mandir}/man1/v4l2-compliance.1*
175%{_sbindir}/v4l2-dbg
176
177%files -n qv4l2
178%doc README
179%{_bindir}/qv4l2
180%{_bindir}/qvidcap
181%{_datadir}/applications/qv4l2.desktop
182%{_datadir}/applications/qvidcap.desktop
183%{_datadir}/icons/hicolor/*/apps/qv4l2.*
184%{_datadir}/icons/hicolor/*/apps/qvidcap.*
185%{_mandir}/man1/qv4l2.1*
186
187
188%files -n libv4l
189%doc ChangeLog README.libv4l TODO
190%license COPYING.libv4l COPYING
191%{_libdir}/libv4l
192%{_libdir}/libv4l*.so.*
193
194%files -n libv4l-devel
195%doc README.lib-multi-threading
196%{_includedir}/libv4l*.h
197%{_libdir}/libv4l*.so
198%{_libdir}/pkgconfig/libv4l*.pc
199
200%files -n libdvbv5 -f libdvbv5.lang
201%doc ChangeLog lib/libdvbv5/README
202%license COPYING
203%{_libdir}/libdvbv5*.so.*
204
205%files -n libdvbv5-devel
206%{_includedir}/libdvbv5/*.h
207%{_libdir}/libdvbv5*.so
208%{_libdir}/pkgconfig/libdvbv5*.pc
209%{_mandir}/man3/*.3*
210
211
212%changelog
213* Thu Sep 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.16.7-1
214- new upstream release.
215
216* Wed Feb 21 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.14.2-1
217- new upstream release.
218
219* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.10.1-1
220- new upstream release.
221
222* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
223- initial build for Vine Linux
224
225
226* Sat Aug  3 2013 Hans de Goede <hdegoede@redhat.com> - 1.0.0-1
227- New upstream release 1.0.0 final
228- Drop libdvb5 (made private upstream for now)
229
230* Fri Jun 14 2013 Hans de Goede <hdegoede@redhat.com> - 0.9.5-2
231- Add a few libv4l2rds patches from upstream, which bring libv4l2rds to its
232  final API / ABI, so that apps build against it won't need a rebuild in the
233  future
234
235* Sun Jun  9 2013 Hans de Goede <hdegoede@redhat.com> - 0.9.5-1
236- New upstream release 0.9.5 (rhbz#970412)
237- Modernize specfile a bit
238
239* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.8-6
240- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
241
242* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 0.8.8-5
243- rebuild due to "jpeg8-ABI" feature drop
244
245* Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.8.8-4
246- rebuild against new libjpeg
247
248* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.8-3
249- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
250
251* Mon Jul  9 2012 Hans de Goede <hdegoede@redhat.com> - 0.8.8-2
252- Cherry-pick 2 patches from upstream git fixing an exotic crash (rhbz#838279)
253
254* Tue May 22 2012 Hans de Goede <hdegoede@redhat.com> - 0.8.8-1
255- New upstream release 0.8.8
256- Add patches from upstream git to improve Pixart JPEG decoding
257- Add patch from upstream git to fix building with latest kernels (rhbz#823863)
258
259* Mon Apr  9 2012 Hans de Goede <hdegoede@redhat.com> - 0.8.7-1
260- New upstream release 0.8.7
261- Fixes rhbz#807656
262
263* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-2
264- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
265
266* Sun Jul 17 2011 Hans de Goede <hdegoede@redhat.com> 0.8.5-1
267- New upstream release 0.8.5
268- Fixes rhbz#711492
269
270* Wed Jun  1 2011 Hans de Goede <hdegoede@redhat.com> 0.8.4-1
271- New upstream release 0.8.4
272
273* Sat Mar 12 2011 Hans de Goede <hdegoede@redhat.com> 0.8.3-2
274- Add a .desktop file for qv4l2
275- Add fully versioned Requires on libv4l to other (sub)packages
276
277* Thu Feb 10 2011 Hans de Goede <hdegoede@redhat.com> 0.8.3-1
278- New upstream release 0.8.3
279
280* Wed Jan 26 2011 Hans de Goede <hdegoede@redhat.com> 0.8.2-3
281- Add missing BuildRequires: kernel-headers
282
283* Mon Jan 24 2011 Hans de Goede <hdegoede@redhat.com> 0.8.2-2
284- Change tarbal to official upstream 0.8.2 release
285- This fixes multiple Makefile issues pointed out in the review (#671883)
286- Add ir-keytable config files
287- Explicitly specify CXXFLAGS so that qv4l2 gets build with rpm_opt_flags too
288
289* Sat Jan 22 2011 Hans de Goede <hdegoede@redhat.com> 0.8.2-1
290- Initial Fedora package
Note: See TracBrowser for help on using the repository browser.