source: projects/specs/trunk/u/uucp/uucp-vl.spec @ 521

Revision 521, 8.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _localstatedir /var
2
3%define _newconfigdir   %{_sysconfdir}/uucp
4%define _oldconfigdir   %{_sysconfdir}/uucp/oldconfig
5%define _varlogdir      %{_localstatedir}/log/uucp
6%define _varlockdir     %{_localstatedir}/lock
7%define _varspooldir    %{_localstatedir}/spool
8
9Summary: The uucp utility for copying files between systems.
10Summary(ja): ¥·¥¹¥Æ¥à´Ö¤Ç¥Õ¥¡¥¤¥ëžÁ÷¤ò¹Ô¤¦ uucp ¥æ¡¼¥Æ¥£¥ê¥Æ¥£
11Name: uucp
12Version: 1.06.1
13Release: 33vl1
14Copyright: GPL
15Group: Applications/Communications
16Source0: ftp://prep.ai.mit.edu/pub/gnu/uucp-1.06.1.tar.gz
17Source1: uucp.log
18Patch0: uucp-1.06.1-misc.patch
19Patch1: uucp-1.06.1-uureroute.patch
20Patch2: uucp-perl.patch
21Patch3: uucp-1.06.1-sigfpe.patch
22Patch4: uucp-1.06.1-cfgmake.patch
23Patch5: uucp-1.06.1-lock.patch
24Patch6: uucp-1.06.1-baudboy.patch
25Patch7: uucp-1.06.1-vetargs2.patch
26Prereq: fileutils /sbin/install-info
27#BuildPrereq: lockdev-devel >= 1.0.0-14
28#Requires: lockdev >= 1.0.0-14
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30
31%description
32The uucp command copies files between systems. Uucp is primarily used
33by remote machines downloading and uploading email and news files to
34local machines.
35
36%description -l ja
37uucp ¥³¥Þ¥ó¥É¤Ï¥·¥¹¥Æ¥à´Ö¤Ç¥Õ¥¡¥¤¥ë¤ò¥³¥Ô¡¼¤·¤Þ¤¹¡¥
38uucp ¤Î¼ç¤Ê»È¤ï¤ìÊý¤È¤·¤Æ¤Ï¡¤ÅŻҥ᡼¥ë¤ä¥Ë¥å¡¼¥¹¥Õ¥¡¥¤¥ë¤Î
39±ó³Ö¥Þ¥·¥ó¤Ø¤Î¥À¥¦¥ó¥í¡¼¥É/¥¢¥Ã¥×¥í¡¼¥ÉÅù¤¬¤¢¤ê¤Þ¤¹¡¥
40
41%prep
42%setup -q
43%patch -p1 -b .config
44%patch1 -p1 -b .perlpath
45%patch3 -p0
46%patch4 -p1 -b .cfgmake
47#%patch5 -p1 -b .lock
48#%patch6 -p1 -b .baudboy
49%patch7 -p1 -b .vetargs2
50
51find . -name "*.perlpath" -exec rm {} \;
52autoconf
53
54%build
55
56%configure
57make \
58    owner=uucp group=uucp \
59    newconfigdir=%{_newconfigdir} \
60    oldconfigdir=%{_oldconfigdir} \
61    man1dir=%{_mandir}/man1 \
62    man8dir=%{_mandir}/man8 \
63        all
64
65%install
66rm -rf ${RPM_BUILD_ROOT}
67mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
68mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
69mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
70
71%makeinstall \
72    owner=$(id -un) group=$(id -gn) \
73    newconfigdir=${RPM_BUILD_ROOT}%{_newconfigdir} \
74    oldconfigdir=${RPM_BUILD_ROOT}%{_oldconfigdir} \
75    man1dir=${RPM_BUILD_ROOT}%{_mandir}/man1 \
76    man8dir=${RPM_BUILD_ROOT}%{_mandir}/man8 \
77        install-info
78
79gzip -9nf ${RPM_BUILD_ROOT}%{_infodir}/uucp*
80
81mkdir -p ${RPM_BUILD_ROOT}%{_varlogdir}
82mkdir -p ${RPM_BUILD_ROOT}%{_varlockdir}
83
84mkdir -p ${RPM_BUILD_ROOT}%{_varspooldir}/uucp
85mkdir -p ${RPM_BUILD_ROOT}%{_varspooldir}/uucppublic
86mkdir -p ${RPM_BUILD_ROOT}%{_oldconfigdir}
87
88strip ${RPM_BUILD_ROOT}%{_sbindir}/* || :
89strip ${RPM_BUILD_ROOT}%{_bindir}/* || :
90
91mkdir -p ${RPM_BUILD_ROOT}/usr/lib/uucp
92ln -sf ../../sbin/uucico ${RPM_BUILD_ROOT}/usr/lib/uucp/uucico
93
94mkdir -p ${RPM_BUILD_ROOT}/etc/logrotate.d
95install -m 644 $RPM_SOURCE_DIR/uucp.log ${RPM_BUILD_ROOT}/etc/logrotate.d/uucp
96
97# Create ghost files
98for n in Log Stats Debug; do
99    touch ${RPM_BUILD_ROOT}%{_varlogdir}/$n
100done
101
102# the following is kind of gross, but it is effective
103for i in dial passwd port dialcode sys call ; do
104cat > ${RPM_BUILD_ROOT}%{_newconfigdir}/$i <<EOF
105# This is an example of a $i file. This file have the syntax compatible
106# with Taylor UUCP (not HDB, not anything else). Please check uucp
107# documentation if you are not sure how Taylor config files are supposed to
108# look like. Edit it as appropriate for your system.
109
110# Everything after a '#' character is a comment.
111EOF
112done
113
114# some more documentation
115texi2html -monolithic uucp.texi
116
117%clean
118rm -rf ${RPM_BUILD_ROOT}
119
120%post
121# Create initial log files so that logrotate doesn't complain
122for n in Log Stats Debug; do
123        [ -f %{_varlogdir}/$n ] || touch %{_varlogdir}/$n
124        chown uucp:uucp %{_varlogdir}/$n
125done
126chmod 644 %{_varlogdir}/Log %{_varlogdir}/Stats
127chmod 600 %{_varlogdir}/Debug
128
129/sbin/install-info %{_infodir}/uucp.info.gz %{_infodir}/dir
130
131%preun
132/sbin/install-info --del %{_infodir}/uucp.info.gz %{_infodir}/dir
133
134# 1.06.1-31vl0, 1.06.1-31vl1 owned /var/lock directory
135%triggerpostun -- uucp = 1.06.1-31vl1
136# owner/group/perms inconsistency with filesystem 775 root.uucp be fixed
137if [ -d /var/lock ];then
138        chown root.uucp /var/lock >/dev/null 2>&1 || :
139        chmod 775 /var/lock >/dev/null 2>&1 || :
140fi
141exit 0
142
143%triggerpostun -- uucp = 1.06.1-31vl0
144# owner/group/perms inconsistency with filesystem 775 root.uucp be fixed
145if [ -d /var/lock ];then
146        chown root.uucp /var/lock >/dev/null 2>&1 || :
147        chmod 775 /var/lock >/dev/null 2>&1 || :
148fi
149exit 0
150
151%files
152%defattr(-,root,root)
153%doc README COPYING ChangeLog MANIFEST NEWS
154%doc sample contrib uucp.html
155
156%attr(6555,uucp,uucp)           %{_bindir}/cu
157%attr(4555,uucp,uucp)           %{_bindir}/uucp
158%attr(0755,root,root)           %{_bindir}/uulog
159%attr(6555,uucp,uucp)           %{_bindir}/uuname
160%attr(0755,root,root)           %{_bindir}/uupick
161%attr(4555,uucp,uucp)           %{_bindir}/uustat
162%attr(0755,root,root)           %{_bindir}/uuto
163%attr(4555,uucp,uucp)           %{_bindir}/uux
164
165%attr(6555,uucp,uucp)           %{_sbindir}/uucico
166%attr(6555,uucp,uucp)           %{_sbindir}/uuxqt
167%attr(0755,uucp,uucp)           %{_sbindir}/uuchk
168%attr(0755,uucp,uucp)           %{_sbindir}/uuconv
169%attr(0755,root,root)           %{_sbindir}/uusched
170
171
172%attr(755,uucp,uucp)    %dir    /usr/lib/uucp
173/usr/lib/uucp/uucico
174
175%{_mandir}/man[18]/*
176%{_infodir}/uucp.info*
177
178%attr(0755,uucp,uucp)   %dir    %{_varlogdir}
179%attr(0644,uucp,uucp)   %ghost  %{_varlogdir}/Log
180%attr(0644,uucp,uucp)   %ghost  %{_varlogdir}/Stats
181%attr(0600,uucp,uucp)   %ghost  %{_varlogdir}/Debug
182#XXX: we dont put this file at the momennt
183#%attr(755,uucp,uucp)   %dir    %{_varlockdir}
184%attr(755,uucp,uucp)    %dir    %{_varspooldir}/uucp
185%attr(755,uucp,uucp)    %dir    %{_varspooldir}/uucppublic
186
187%config(noreplace)      /etc/logrotate.d/uucp
188
189%dir    %{_newconfigdir}
190%dir    %{_oldconfigdir}
191%attr(0640,root,uucp)   %config(noreplace)      %{_newconfigdir}/call
192%config(noreplace)      %{_newconfigdir}/dial
193%config(noreplace)      %{_newconfigdir}/dialcode
194%attr(0640,root,uucp)   %config(noreplace)      %{_newconfigdir}/passwd
195%config(noreplace)      %{_newconfigdir}/port
196%config(noreplace)      %{_newconfigdir}/sys
197
198%changelog
199* Sat Feb 09 2002 Toru Sagami <sagami@vinelinux.org> 1.06.1-33vl1
200- sync with 1.06.1-33.6.2 (filter all the long option aliases as well.)
201- don't own /var/lock and fix owner/permission in triggerpostun script
202
203* Wed Jan 23 2002 Toru Sagami <sagami@vinelinux.org> 1.06.1-31vl1
204- follow up with 1.06.1-31.6x (RHSA-2001:165-08)
205- fixed: man8 pages are installed into man1 dir
206
207* Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
208- 1.06.1-25vl2
209- define %%_localstatedir as /var (might implicitly want it done by rpmmacros)
210
211* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
212- 1.06.1-25vl1
213- based on 1.06.1-25 from Rawhide
214- added nochown patch for non-root rebuild (Patch10)
215- added Japanese summary and description
216
217* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
218- automatic rebuild
219
220* Fri Jun  2 2000 Jeff Johnson <jbj@redhat.com>
221- FHS packaging.
222- map perms/owners into %%files to build as non-root.
223
224* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
225- rebuild for sparc baud rates > 38400.
226
227* Sun Feb 13 2000 Florian La Roche <Florian.LaRoche@redhat.com>
228- change perms to be root:root for the config files and
229  0640,root:uucp for config files containing passwords
230- add patch from #6151 (division by zero, SIGFPE)
231- make %post work also for simple sh-versions
232
233* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
234- compress man pages.
235
236* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
237- add notifempty/missingok to logrotate config file (#4138).
238
239* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
240- auto rebuild in the new build environment (release 19)
241
242* Tue Dec 22 1998 Bill Nottingham <notting@redhat.com>
243- expunge /usr/local/bin/perl reference in docs
244
245* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
246- build for glibc 2.1
247
248* Tue May 05 1998 Prospector System <bugs@redhat.com>
249- translations modified for de, fr, tr
250
251* Sat Apr 11 1998 Cristian Gafton <gafton@redhat.com>
252- manhattan rebuild
253- added sample config files in /etc/uucp
254
255* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
256- spec file cleanups
257- added install-info support
258- uses a build root
259
260* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
261- patched uureroute to find perl in /usr/bin instead of /usr/local/bin
262- made log files ghosts
263
264* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
265- built against glibc
266
267* Tue Apr 22 1997 Erik Troan <ewt@redhat.com>
268- Brian Candler fixed /usr/lib/uucp/uucico symlink
269- Added "create" entries to log file rotation configuration
270- Touch log files on install if they don't already exist to allow proper
271  rotation
272
273* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
274- symlinked /usr/sbin//uucico into /usr/lib/uucp
275- (all of these changes are from Brian Candler <B.Candler@pobox.com>)
276- sgid bit added on uucico so it can create lock files
277- log files moved to /var/log/uucp/ owned by uucp (so uucico can create them)
278- log rotation added
279- uses /etc/uucp/oldconfig instead of /usr/lib/uucp for old config files
280- package creates /etc/uucp and /etc/uucp/oldconfig directories
281- man pages reference the correct locations for spool and config files
282
Note: See TracBrowser for help on using the repository browser.