source: projects/specs/trunk/u/utf8proc/utf8proc-vl.spec @ 12120

Revision 12120, 5.3 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Summary: Library for processing UTF-8 encoded Unicode strings
2Name:    utf8proc
3Version: 2.4.0
4Release: 2%{?_dist_release}
5License: Unicode and MIT
6URL:     http://julialang.org/utf8proc/
7Source:  https://github.com/JuliaLang/utf8proc/archive/v%{version}.tar.gz#/%{name}-v%{version}.tar.gz
8BuildRequires: gcc
9BuildRequires: perl
10
11Vendor:        Project Vine
12Distribution:  Vine Linux
13
14%description
15utf8proc is a library for processing UTF-8 encoded Unicode strings.
16Some features are Unicode normalization, stripping of default ignorable
17characters, case folding and detection of grapheme cluster boundaries.
18A special character mapping is available, which converts for example
19the characters “Hyphen” (U+2010), “Minus” (U+2212) and “Hyphen-Minus
20(U+002D, ASCII Minus) all into the ASCII minus sign, to make them
21equal for comparisons.
22
23This package only contains the C library.
24
25%package devel
26Summary:  Header files, libraries and development documentation for %{name}
27Requires: %{name}%{?_isa} = %{version}-%{release}
28
29%description devel
30Contains header files for developing applications that use the %{name}
31library.
32
33The documentation for the C library is found in the utf8proc.h header file.
34"utf8proc_map" is most likely the function you will be using for mapping UTF-8
35strings, unless you want to allocate memory yourself.
36
37%prep
38%setup -qn %{name}-%{version}
39# Disable slow tests and tests which require network access
40sed -i '/-C bench/d;/\ttest.* data/d' Makefile
41touch data/NormalizationTest.txt data/GraphemeBreakTest.txt
42
43%build
44export CFLAGS="%{optflags}"
45make %{?_smp_mflags}
46
47%check
48make %{?_smp_mflags} check
49
50%install
51make install DESTDIR=%{buildroot} prefix=%{_prefix} includedir=%{_includedir} libdir=%{_libdir}
52rm %{buildroot}%{_libdir}/libutf8proc.a
53
54%post -p /sbin/ldconfig
55
56%postun -p /sbin/ldconfig
57
58%files
59%license LICENSE.md
60%doc NEWS.md README.md
61%{_libdir}/libutf8proc.so.*
62
63%files devel
64%{_includedir}/utf8proc.h
65%{_libdir}/libutf8proc.so
66%{_libdir}/pkgconfig/libutf8proc.pc
67
68%changelog
69* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.0-2
70- initial build for Vine Linux.
71
72* Thu May 16 2019 Milan Bouchet-Valat <nalimilan@club.fr> - 2.4.0-1
73- New upstream release.
74
75* Sun Apr 21 2019  Milan Bouchet-Valat <nalimilan@club.fr> - 2.3.0-1
76- New upstream release.
77
78* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.1-5
79- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
80
81* Mon Jul 23 2018 Joe Orton <jorton@redhat.com> - 2.1.1-4
82- update License tag to Unicode and MIT
83- BR gcc (#1606627)
84- run minimal tests
85
86* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.1-3
87- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
88
89* Mon Apr 30 2018  Milan Bouchet-Valat <nalimilan@club.fr> - 2.1.1-2
90- Fix missing build flags (RHBZ #1573115).
91
92* Fri Apr 27 2018  Milan Bouchet-Valat <nalimilan@club.fr> - 2.1.1-1
93- New upstream release.
94
95* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-5
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
97
98* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-4
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
100
101* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-3
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
103
104* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-2
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
106
107* Sat Jan 7 2017  Milan Bouchet-Valat <nalimilan@club.fr> - 2.1.0
108- New upstream release.
109
110* Thu Sep 15 2016  Milan Bouchet-Valat <nalimilan@club.fr> - 2.0.2-1
111- New upstream release.
112
113* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
115
116* Tue Nov 03 2015  Milan Bouchet-Valat <nalimilan@club.fr> - 1.3.1-1
117- New upstream release.
118
119* Tue Aug 11 2015 Milan Bouchet-Valat <nalimilan@club.fr> - 1.3-1
120- New upstream release.
121
122* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-2
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
124
125* Sat Mar 28 2015 Milan Bouchet-Valat <nalimilan@club.fr> - 1.2-1
126- New upstream release.
127
128* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.6-5
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
130
131* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.6-4
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
133
134* Sun May 4 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 1.1.6-3
135- Add downstream SONAME version 0.1 since upstream does not set one.
136
137* Fri Feb 14 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 1.1.6-2
138- Fix package Group.
139- Do not remove build root on install phase.
140
141* Sun Jan 26 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 1.1.6-1
142- Adapt package to Fedora.
143- Updated to release 1.1.6.
144
145* Sat Aug 29 2009 Dries Verachtert <dries@ulyssis.org> - 1.1.4-1 - 7981/dag
146- Updated to release 1.1.4.
147
148* Sun Jul 29 2007 Dries Verachtert <dries@ulyssis.org> - 1.1.2-1
149- Updated to release 1.1.2.
150
151* Mon Jul 23 2007 Dries Verachtert <dries@ulyssis.org> - 1.1.1-1
152- Updated to release 1.1.1.
153
154* Tue Apr 17 2007 Dries Verachtert <dries@ulyssis.org> - 1.0.3-1
155- Initial package.
Note: See TracBrowser for help on using the repository browser.