source: projects/specs/trunk/u/utempter/utempter-vl.spec @ 521

Revision 521, 4.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:   A privileged helper for utmp/wtmp updates.
2Name:      utempter
3Version:   0.5.5
4Release:   6%{?_dist_release}
5License:   MIT/LGPL
6Group:     System Environment/Base
7Source:    utempter-%{version}.tar.gz
8Prereq:    /usr/sbin/groupadd, /sbin/ldconfig, fileutils
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10
11%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
12
13
14%description
15Utempter is a utility which allows some non-privileged programs to
16have required root access without compromising system
17security. Utempter accomplishes this feat by acting as a buffer
18between root and the programs.
19
20
21%package -n compat32-%{name}
22Summary:   A privileged helper for utmp/wtmp updates.
23Group:     System Environment/Base
24Requires: %{name} = %{version}-%{release}
25
26
27%description -n compat32-%{name}
28Utempter is a utility which allows some non-privileged programs to
29have required root access without compromising system
30security. Utempter accomplishes this feat by acting as a buffer
31between root and the programs.
32
33
34%prep
35%setup  -q
36
37
38%build
39make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
40
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make PREFIX=$RPM_BUILD_ROOT LIBDIR=%{_libdir} install
45/sbin/ldconfig -n $RPM_BUILD_ROOT/%{_libdir}
46
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51
52%pre
53/usr/sbin/groupadd -g 22 -r -f utmp
54
55
56%post
57{
58    /sbin/ldconfig
59    for file in /var/log/wtmp /var/run/utmp ; do
60        if [ -f $file ]; then
61            chown root:utmp $file
62            chmod 664 $file
63        fi
64    done
65}
66
67
68%postun -p /sbin/ldconfig
69
70
71%post -n compat32-%{name} -p /sbin/ldconfig
72
73
74%postun -n compat32-%{name} -p /sbin/ldconfig
75
76
77%files
78%defattr(-,root,root)
79%attr(02755, root, utmp) %{_sbindir}/utempter
80%doc COPYING
81%{_libdir}/libutempter.so*
82%{_includedir}/utempter.h
83
84
85%if %{build_compat32}
86%files -n compat32-%{name}
87%defattr(-,root,root)
88%{_libdir}/libutempter.so*
89%endif
90
91
92%changelog
93* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.5.5-6vl5
94- applied new versioning policy
95
96* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 0.5.5-6vl2
97- added compat32- packages for x86_64 architecture support
98
99* Mon Jun 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.5-6vl1
100- based on Fedora 0.5.5-6
101  * Mon Apr 19 2004 Mike A. Harris <mharris@redhat.com> 0.5.5-1
102  - [SECURITY] Fix CAN-2004-0233 utempter directory traversal symlink attack
103    issue for immediate erratum release.
104  - Build all-arch test package 0.5.5-1 in dist-fc2-scratch
105  * Mon Feb 23 2004 Mike A. Harris <mharris@redhat.com> 0.5.4-1
106  - Rewrote post install script to be a bit cleaner and rebuilt in rawhide to
107    pick up twaugh's chown change
108  - Added 'srpm-x' target to Makefile for package maintainer SRPM building
109  * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
110  - Use ':' instead of '.' as separator for chown.
111
112* Sat Oct  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.3-2vl1
113- based on Redhat Rawhide 0.5.3-2
114  -  Fri May 30 2003 Mike A. Harris <mharris@redhat.com> 0.5.3-1
115  - Bump version and release and rebuild to strip debug info into .debuginfo
116    package, as the Red Hat Linux 9 package shipped unstripped (#91664)
117  - Updated license field to reflect dual license MIT style + LGPL
118  - Changed spec file Copyright tag to proper License tag
119  - Removed stupid crackrock "version" macro define
120
121  - Thu Jun 20 2002 Elliot Lee <sopwith@redhat.com> 0.5.2-9
122  - Don't strip binary
123  - Thu Feb 24 2000 Erik Troan <ewt@redhat.com>
124  - added LGPL notice
125
126* Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-4vl2
127- rebuild to remove rpmlib dependancy
128
129* Tue May 29 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
130- 0.5.2-4vl1
131- rebuilt for Vine Linux
132
133* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
134- automatic rebuild
135
136* Sat Jun 17 2000 Matt Wilson <msw@redhat.com>
137- defattr root
138
139* Thu Feb 24 2000 Erik Troan <ewt@redhat.com>
140- added LGPL notice
141
142* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
143- strip utempter
144
145* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
146- add utmp as group 22
147
148* Fri Jun  4 1999 Jeff Johnson <jbj@redhat.com>
149- ignore SIGCHLD while processing utmp.
Note: See TracBrowser for help on using the repository browser.