source: projects/specs/trunk/u/ushare/ushare-vl.spec @ 521

Revision 521, 2.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Universal Plug'nPlay (uPNP) Media Server
2Summary(ja): ユニバーサルプラグアンドプレイ(uPNP)メディアサーバ
3Name: ushare
4Version: 1.0
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/Multimedia
8URL: http://ushare.geexbox.org/
9
10Source: http://ushare.geexbox.org/releases/ushare-%{version}.tar.bz2
11Source1: ushare.init
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildRequires: pkgconfig >= 0.9.0, libupnp-devel
15Requires(post): chkconfig
16Requires(preun): initscripts, chkconfig
17Requires(postun): initscripts
18
19%description
20uShare is a UPnP (TM) A/V Media Server. It implements the server
21component that provides UPnP media devices with information on
22available multimedia files. uShare uses the built-in http server
23of libupnp to stream the files to clients.
24
25%prep
26%setup
27
28%build
29%configure
30%{__make} %{?_smp_mflags}
31
32%install
33%{__rm} -rf %{buildroot}
34%{__make} install DESTDIR="%{buildroot}"
35%{__install} -Dp -m0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/rc.d/init.d/ushare
36%{__install} -d -m0755 %{buildroot}%{_localstatedir}/lib/ushare/
37%find_lang %{name}
38
39%{__rm} %{buildroot}%{_sysconfdir}/init.d/ushare
40
41%pre
42if ! /usr/bin/id ushare &>/dev/null; then
43        /usr/sbin/useradd -r -M -d %{_localstatedir}/lib/ushare -s /bin/false -c "ushare service accoung" ushare ||:
44fi
45
46%post
47/sbin/chkconfig --add ushare
48
49%preun
50if [ $1 -eq 0 ]; then
51        /sbin/service ushare stop &>/dev/null || :
52        /sbin/chkconfig --del ushare
53fi
54
55%postun
56if [ $1 -eq 0 ]; then
57        /usr/sbin/userdel ushare ||:
58        /usr/sbin/groupdel ushare ||:
59fi
60if [ $1 -ge 1 ]; then
61        /sbin/service ushare condrestart &>/dev/null || :
62fi
63
64%clean
65%{__rm} -rf %{buildroot}
66
67%files -f %{name}.lang
68%defattr(-, root, root, 0755)
69%doc AUTHORS ChangeLog COPYING NEWS README
70%doc %{_mandir}/man1/ushare.1*
71%config(noreplace) %{_sysconfdir}/ushare.conf
72%attr(755,root,root) %{_sysconfdir}/rc.d/init.d/ushare
73%{_bindir}/ushare
74
75%defattr(-, ushare, ushare, 0770)
76%{_localstatedir}/lib/ushare/
77
78%changelog
79* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1vl5
80- applied new versioning policy, spec in utf-8
81
82* Tue Jul 31 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-0vl1
83- new upstream release
84
85* Sat May 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.10-0vl1
86- initial build for Vine Linux
87
88* Thu Mar 01 2007 Dag Wieers <dag@wieers.com> - 0.9.10-1 - 5190+/dag
89- Updated to release 0.9.10.
90
91* Wed Feb 21 2007 Dag Wieers <dag@wieers.com> - 0.9.8-1
92- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.