source: projects/specs/trunk/u/usermode/usermode-vl.spec @ 521

Revision 521, 20.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Tools for certain user account management tasks.
2Summary(ja): ユーザアカウント管理用ツール
3Name: usermode
4Version: 1.98
5Release: 1%{?_dist_release}
6License: GPLv2+
7Group: Applications/System
8URL: https://fedorahosted.org/usermode/
9
10Source: https://fedorahosted.org/releases/u/s/usermode/usermode-%{version}.tar.bz2
11## Vine Source(s)/Patch(es)
12Source10: usermode-1.98-ja.po
13Patch10: usermode-1.37-halt-p.patch
14Requires: util-linux-ng, pam >= 0.75, passwd
15Conflicts: SysVinit < 2.74-14
16BuildPrereq: desktop-file-utils, glib2-devel, gtk2-devel
17BuildPrereq: libglade2-devel, libuser-devel, pam-devel, util-linux-ng, libwnck-devel
18BuildRequires: perl-XML-Parser, libSM-devel, startup-notification-devel, gettext
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21%description
22The usermode package contains the userhelper program, which can be
23used to allow configured programs to be run with superuser privileges
24by ordinary users.
25
26%description -l ja
27usermode パッケージには、一般ユーザが設定されたプログラムをスーパーユー
28ザとして実行できるようにするユーザヘルパープログラムが含まれています。
29
30%package gtk
31Summary: Graphical tools for certain user account management tasks.
32Summary(ja): ユーザアカウント管理用グラフィカルツール
33Group: Applications/System
34Requires: %{name} = %{version}-%{release}
35
36%description gtk
37The usermode-gtk package contains several graphical tools for users:
38userinfo, usermount and userpasswd.  Userinfo allows users to change
39their finger information.  Usermount lets users mount, unmount, and
40format filesystems.  Userpasswd allows users to change their
41passwords.
42
43Install the usermode-gtk package if you would like to provide users with
44graphical tools for certain account management tasks.
45
46%description gtk -l ja
47usermode-gtk には userinfo, usermount, userpasswd といったユーザ用
48グラフィカルツールも収められています。userinfo を使うと一般ユーザが自
49分のアカウントの finger 情報を変更することが出来ます.
50usermount は一般ユーザがファイルシステムのマウント/アンマウント/初期化を
51行うことを可能にします.userpasswd は一般ユーザが自分のパスワードを
52変更するのに使います.
53
54一般ユーザ向けに,アカウント管理用グラフィカルツールを提供したい場合は
55usermode パッケージをインストールして下さい.
56
57%prep
58%setup -q
59cp -f %{SOURCE10} po/ja.po
60
61%patch10 -p1 -b .halt-p
62
63%build
64intltoolize --force --copy
65autoreconf
66%configure
67make -C po usermode.pot
68make -C po update-po
69make
70
71%install
72rm -rf $RPM_BUILD_ROOT
73make install DESTDIR=$RPM_BUILD_ROOT
74
75# We set up the shutdown programs to be wrapped in this package.  Other
76# packages are on their own....
77mkdir -p $RPM_BUILD_ROOT/etc/pam.d $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps
78for wrappedapp in halt reboot poweroff ; do
79        ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/${wrappedapp}
80        install -m644 $wrappedapp $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/${wrappedapp}
81        cp shutdown.pamd $RPM_BUILD_ROOT/etc/pam.d/${wrappedapp}
82done
83echo 'USER=root' > $RPM_BUILD_ROOT/etc/security/console.apps/config-util
84
85for desktopfile in $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
86do
87  mv $desktopfile ${desktopfile/redhat-/}
88done
89
90%find_lang %{name}
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%files -f %{name}.lang
96%defattr(-,root,root)
97%attr(4711,root,root) /usr/sbin/userhelper
98%{_bindir}/consolehelper
99%{_mandir}/man8/userhelper.8*
100%{_mandir}/man8/consolehelper.8*
101# PAM console wrappers
102%{_bindir}/halt
103%{_bindir}/reboot
104%{_bindir}/poweroff
105%{_bindir}/shutdown
106%config(noreplace) /etc/pam.d/halt
107%config(noreplace) /etc/pam.d/reboot
108%config(noreplace) /etc/pam.d/poweroff
109%config(noreplace) /etc/security/console.apps/config-util
110%config /etc/security/console.apps/halt
111%config /etc/security/console.apps/reboot
112%config /etc/security/console.apps/poweroff
113
114%files gtk
115%defattr(-,root,root)
116%{_bindir}/usermount
117%{_mandir}/man1/usermount.1*
118%{_bindir}/userinfo
119%{_mandir}/man1/userinfo.1*
120%{_bindir}/userpasswd
121%{_mandir}/man1/userpasswd.1*
122%{_bindir}/consolehelper-gtk
123%{_bindir}/pam-panel-icon
124%{_datadir}/%{name}
125%{_datadir}/pixmaps/*
126%{_datadir}/applications/*
127
128%changelog
129* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.98-1
130- new upstream release
131
132* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.86-1vl5
133- applied new versioning policy, spec in utf-8
134
135* Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.86-0vl3
136- rebuilt with libwnck 2.20.2
137- added Patch100 for avoiding desktop-file-install failure
138- fixed *.desktop.in files
139
140* Tue Sep 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.86-0vl2
141- fix Patch12
142  - The old patch changes the application's locale by mistake.
143
144* Thu Sep 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.86-0vl1
145- new upstream release
146- add Patch12 to fix broken messages in consolehelper-gtk (<BTS:181>)
147- update ja.po
148
149* Thu Jun 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.85-0vl1
150- new upstream release
151
152* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.81-0vl1
153- new upstream release
154- rebuild with new libwnck
155
156* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.70-4vl3
157- rebuild with new libwnck
158
159* Sat Jul  3 2004 Tomoya TAKA <taka@vinelinux.org> 1.70-4vl2
160- fix lack of %%{_bindir}/shutdown
161
162* Mon Jun 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.70-4vl1
163- new upstream release
164- fixed spec's kanji code.
165- split gui related utilities to usermode-gtk subpackage.
166
167* Mon Nov 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.69-1vl1
168- new upstream release
169
170* Tue Oct 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.68-0vl1
171- new upstream release
172
173* Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.65-1vl1
174- merged with Vine Linux package 1.42-1vl5
175  * Sat Aug 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.42-1vl5
176  - enable system authentication even if %%{build6x} is set to 0
177    (for compatibility with previous version)
178  * Mon Aug 05 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.42-1vl4
179  - reinstated /usr/bin/shutdown
180  * Fri Aug 02 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.42-1vl3
181  - rebuild with pam-0.75-39vl1
182  - set build6x to 0
183  * Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.42-1vl2
184  - rebuild to remove rpmlib dependancy
185  * Fri Jun 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
186  - 1.42-1vl1
187  - based on 1.42-1 from Rawhide and merged some from 1.37-2vl2
188  - %%define build6x 1 for Vine
189
190* Mon Jan 20 2003 Nalin Dahyabhai <nalin@redhat.com> 1.65-1
191- pass-through DESKTOP_STARTUP_ID
192
193* Mon Jan  6 2003 Nalin Dahyabhai <nalin@redhat.com> 1.64-1
194- set the requesting user PAM item to the invoking user's name (#81255)
195
196* Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.63-2
197- remove directory names from PAM config files, allowing the same config
198  files to work for both arches on multilib boxes
199- translation updates
200
201* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.63-1
202- userhelper: swallow the exec'd program's exit stauts, which would be
203  misinterpreted by consolehelper anyway
204
205* Tue Sep  3 2002 Nalin Dahyabhai <nalin@redhat.com> 1.62-1
206- consolehelper: suppress dialog on successful execution
207- userhelper: return 0 on success, not 1 (what was I *thinking*?)
208
209* Mon Sep  2 2002 Nalin Dahyabhai <nalin@redhat.com> 1.61-1
210- userinfo: exit properly on escape. handle site_info field properly. go
211  insensitive while running child process.
212- userpasswd: exit properly on cancel.
213- all of the above: reap the child instead of checking for pipe close -- this
214  way is more robust (#68578,72684).
215- usermount: run mount/umount synchronously. capture stderr and display in a
216  dialog. desensitize action buttons when no filesystems are selected.
217- consolehelper: display errors if we're attempting to run bogus programs
218  (#72127)
219- translation updates (#70278)
220
221* Wed Aug 14 2002 Nalin Dahyabhai <nalin@redhat.com> 1.60-1
222- reconnect the "cancel" and "ok" buttons in userinfo
223- heed the cancel button when prompting for passwords in userinfo (#68578)
224- translation update
225
226* Wed Aug 14 2002 Nalin Dahyabhai <nalin@redhat.com> 1.59-2
227- change "forget password" to "forget authorization", because we don't actually
228  remember the password (that would be scary, #71476)
229- translation update
230
231* Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 1.59-1
232- pam-panel-icon: overhaul, change the 'locked' icon to keyring-small, nix the
233  'unlocked' icon
234- consolehelper-gtk: properly set up the dialog buttons (should be 'cancel/ok'
235  when we're asking questions, was always 'close')
236- disappear pam_timestamp_init
237
238* Wed Aug  7 2002 Nalin Dahyabhai <nalin@redhat.com> 1.58-2
239- install the new 'unlocked' icon
240
241* Tue Aug  6 2002 Jonathan Blandford <jrb@redhat.com>
242- New version.
243
244* Mon Aug  5 2002 Nalin Dahyabhai <nalin@redhat.com> 1.57-1
245- add support for BANNER and BANNER_DOMAIN in the userhelper configuration
246
247* Mon Aug  5 2002 Nalin Dahyabhai <nalin@redhat.com> 1.56-4
248- mark strings in the .glade file as translatable (#70278)
249- translation updates
250
251* Wed Jul 31 2002 Nalin Dahyabhai <nalin@redhat.com> 1.56-3
252- add icons for userpasswd and usermount
253
254* Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 1.56-2
255- actually include the icons
256- translation updates
257
258* Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 1.56-1
259- userinfo: prevent users from selecting "nologin" as a shell (#68579)
260- don't strip binaries by default; leave that to the buildroot policy
261- use desktop-file-install
262
263* Wed Jun 19 2002 Havoc Pennington <hp@redhat.com>
264- put pam-panel-icon in file list
265
266* Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 1.55-2
267- don't strip binaries which have no special privileges
268
269* Wed May 15 2002 Nalin Dahyabhai <nalin@redhat.com> 1.55-1
270- remove the pixmap we don't use any more (we use stock pixmaps now)
271- update translations
272
273* Thu Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 1.54-1
274- suppress even error messages from Xlib when consolehelper calls
275  gtk_init_check() to see if the display is available
276
277* Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 1.53-2
278- refresh translations
279
280* Thu Apr 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.53-1
281- refresh shell variable code from authconfig (#63175)
282
283* Tue Apr  9 2002 Nalin Dahyabhai <nalin@redhat.com> 1.52-2
284- refresh translations
285
286* Mon Apr  1 2002 Nalin Dahyabhai <nalin@redhat.com> 1.52-1
287- attempt to make prompts at the console more meaningful
288- when falling back, reset the entire environment to the user's
289
290* Thu Mar 28 2002 Nalin Dahyabhai <nalin@redhat.com>
291- stop giving the user chances to enter the right password if we get a
292  conversation error reading a response (appears to be masked by libpam)
293  (#62195)
294- always center consolehelper dialog windows
295
296* Wed Mar 27 2002 Nalin Dahyabhai <nalin@redhat.com> 1.51-1
297- patch to make gettext give us UTF-8 strings (which GTK needs) from ynakai
298
299* Fri Mar 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-6
300- update translations
301- actually include the glade files (#61665)
302
303* Mon Mar 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-5
304- update translations
305
306* Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-4
307- rebuild
308
309* Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-3
310- update translations
311
312* Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-2
313- rebuild to fix dependencies
314
315* Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 1.50-1
316- fix userpasswd dialog message being incorrect for password changes
317- use a dumb conversation function when text mode is invoked without a tty -- if
318  the service's configuration doesn't call for prompts, then it'll still work
319- port from pwdb to libuser
320- catch child-exit errors correctly again
321- fix keyboard-grabbing
322
323* Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 1.49-3
324- add default locations for certain binaries to configure.in
325
326* Thu Jan  3 2002 Nalin Dahyabhai <nalin@redhat.com> 1.49-2
327- munge glade file to use stock items for buttons where possible
328
329* Mon Dec 10 2001 Nalin Dahyabhai <nalin@redhat.com> 1.49-1
330- the console.apps configs shouldn't be missingok
331- fix buildprereqs for gtk2/libglade2
332
333* Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com>
334- more gtk2 changes
335- split off a -gtk subpackage with all of the gtk-specific functionality
336
337* Wed Nov 28 2001 Nalin Dahyabhai <nalin@redhat.com>
338- the grand libglade/gtk2 overhaul
339- allow disabling display of GUI windows by setting "GUI=false" in the
340  console.apps configuration file (default: TRUE)
341- allow disabling display of GUI windows by recognizing a magic option
342  on the command-line of the program being wrapped (NOXOPTION, no default)
343
344* Fri Nov  9 2001 Nalin Dahyabhai <nalin@redhat.com> 1.46-1
345- restore the previous XAUTHORITY setting before opening PAM sessions
346
347* Fri Nov  2 2001 Nalin Dahyabhai <nalin@redhat.com> 1.45-1
348- propagate environment variables from libpam to applications
349
350* Fri Oct  3 2001 Nalin Dahyabhai <nalin@redhat.com> 1.44-1
351- only try to call gtk_main_quit() if we've got a loop to get out of (#54109)
352- obey RPM_OPT_FLAGS, obey
353
354* Tue Aug 28 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 1.43-1
355- Update translations
356
357* Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
358- add build requirements on glib-devel, gtk+-devel, pam-devel (#49726)
359
360* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
361- Bump release + rebuild.
362
363* Wed Feb 14 2001 Preston Brown <pbrown@redhat.com>
364- final translation merge.
365
366* Wed Feb 14 2001 Nalin Dahyabhai <nalin@redhat.com>
367- clear the supplemental groups list before running binaries as root (#26851)
368
369* Wed Feb  7 2001 Nalin Dahyabhai <nalin@redhat.com>
370- set XAUTHORITY if we fall back to regular behavior (#26343)
371- make the suid helper 04711 instead of 04755
372
373* Mon Feb  5 2001 Nalin Dahyabhai <nalin@redhat.com>
374- refresh translations
375
376* Mon Jan 29 2001 Preston Brown <pbrown@redhat.com>
377- use lang finding script.
378
379* Thu Jan 25 2001 Yukihiro Nakai <ynakai@redhat.com>
380- Some fix for Japanese environment.
381- Use gtk_set_locale() instead of setlocale()
382- Copyright update.
383
384* Sun Jan  7 2001 Yukihiro Nakai <ynakai@redhat.com>
385- Add gettextized
386
387* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
388- fix segfault in userhelper (#20027)
389
390* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
391- /sbin/shutdown, not /usr/sbin/shutdown (#19034)
392
393* Fri Oct  6 2000 Nalin Dahyabhai <nalin@redhat.com>
394- don't pass on arguments to halt and reboot, because they error out
395
396* Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
397- fix the /usr/bin/shutdown wrapper so that root can call shutdown
398- only include the /usr/bin/shutdown wrapper on 6.x
399- also sanitize LC_MESSAGES
400- tweak sanitizing checks (from mkj)
401
402* Wed Oct  4 2000 Jakub Jelinek <jakub@redhat.com>
403- fix a security bug with LC_ALL/LANG variables (#18046)
404
405* Mon Aug 28 2000 Nalin Dahyabhai <nalin@redhat.com>
406- mark defined strings translateable (#17006)
407
408* Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
409- fix incorrect user name
410- add a shell wrapper version of /usr/bin/shutdown
411- build for 6.x errata
412- bump revision to upgrade the errata
413
414* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
415- fix stdin/stdout redirection shenanigans (#11706)
416- fix authentication and execution as users other than root
417- make sure the right descriptors are terminals before dup2()ing them
418- cut out an extra-large CPU waster that breaks GUI apps
419
420* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
421- fix typo (#16664)
422
423* Sun Aug 20 2000 Nalin Dahyabhai <nalin@redhat.com>
424- previous fix, part two
425
426* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
427- fix inadvertent breakage of the shell-changing code
428
429* Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
430- fix the "run unprivileged" option
431
432* Mon Aug 14 2000 Nalin Dahyabhai <nalin@redhat.com>
433- actually use the right set of translations
434
435* Fri Aug 11 2000 Nalin Dahyabhai <nalin@redhat.com>
436- remove the shutdown command from the list of honored commands
437
438* Wed Aug  9 2000 Nalin Dahyabhai <nalin@redhat.com>
439- merge in updated translations
440- set XAUTHORITY after successful authentication (#11006)
441
442* Wed Aug  2 2000 Nalin Dahyabhai <nalin@redhat.com>
443- install translations
444- fixup a messy text string
445- make "Mount"/"Unmount" translatable
446- stop prompting for passwords to shut down -- we can hit ctrl-alt-del anyway,
447  and gdm users can just shut down without logging in
448
449* Mon Jul 31 2000 Nalin Dahyabhai <nalin@redhat.com>
450- attempt to add i18n support
451
452* Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
453- attempt to get a usable icon for userhelper-wrap (#13616, #13768)
454
455* Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
456- fix them right this time
457
458* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
459- fix verbosity problems
460
461* Mon Jun 19 2000 Nalin Dahyabhai <nalin@redhat.com>
462- strip all binaries by default
463- add the name of the program being run to the userhelper dialog
464- add a graphic to the userhelper-wrap package
465- add a button to jump straight to nonprivileged operation when supported
466
467* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
468- rebuilt to see if we get stripped binaries
469
470* Mon Jun  5 2000 Nalin Dahyabhai <nalin@redhat.com>
471- move man pages to %%{_mandir}
472
473* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
474- modify PAM setup to use system-auth
475- bzip2 compress tarball
476
477* Fri Mar 17 2000 Ngo Than <than@redhat.de>
478- fix problem with LANG and LC_ALL
479- compress source with bzip2
480
481* Thu Mar 09 2000 Nalin Dahyabhai <nalin@redhat.com>
482- fix problem parsing userhelper's -w flag with other args
483
484* Wed Mar 08 2000 Nalin Dahyabhai <nalin@redhat.com>
485- ignore read() == 0 because the child exits
486
487* Tue Mar 07 2000 Nalin Dahyabhai <nalin@redhat.com>
488- queue notice messages until we get prompts in userhelper to fix bug #8745
489
490* Fri Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
491- free trip through the build system
492
493* Tue Jan 11 2000 Nalin Dahyabhai <nalin@redhat.com>
494- grab keyboard input focus for dialogs
495
496* Fri Jan 07 2000 Michael K. Johnson <johnsonm@redhat.com>
497- The root exploit fix created a bug that only showed up in certain
498  circumstances.  Unfortunately, we didn't test in those circumstances...
499
500* Mon Jan 03 2000 Michael K. Johnson <johnsonm@redhat.com>
501- fixed local root exploit
502
503* Thu Sep 30 1999 Michael K. Johnson <johnsonm@redhat.com>
504- fixed old complex broken gecos parsing, replaced with simple working parsing
505- can now blank fields (was broken by previous fix for something else...)
506
507* Tue Sep 21 1999 Michael K. Johnson <johnsonm@redhat.com>
508- FALLBACK/RETRY in consolehelper/userhelper
509- session management fixed for consolehelper/userhelper SESSION=true
510- fix memory leak and failure to close in error condition (#3614)
511- fix various bugs where not all elements in userinfo got set
512
513* Mon Sep 20 1999 Michael K. Johnson <johnsonm@redhat.com>
514- set $HOME when acting as consolehelper
515- rebuild against new pwdb
516
517* Tue Sep 14 1999 Michael K. Johnson <johnsonm@redhat.com>
518- honor "owner" flag to mount
519- ask for passwords with username
520
521* Tue Jul 06 1999 Bill Nottingham <notting@redhat.com>
522- import pam_console wrappers from SysVinit, since they require usermode
523
524* Mon Apr 12 1999 Michael K. Johnson <johnsonm@redhat.com>
525- even better check for X availability
526
527* Wed Apr 07 1999 Michael K. Johnson <johnsonm@redhat.com>
528- better check for X availability
529- center windows to make authentication easier (improve later with
530  transients and embedded windows where possible)
531- applink -> applnk
532- added a little padding, especially important when running without
533  a window manager, as happens when running from session manager at
534  logout time
535
536* Wed Mar 31 1999 Michael K. Johnson <johnsonm@redhat.com>
537- hm, need to be root...
538
539* Fri Mar 19 1999 Michael K. Johnson <johnsonm@redhat.com>
540- updated userhelper.8 man page for consolehelper capabilities
541- moved from wmconfig to desktop entries
542
543* Thu Mar 18 1999 Michael K. Johnson <johnsonm@redhat.com>
544- added consolehelper
545- Changed conversation architecture to follow PAM spec
546
547* Wed Mar 17 1999 Bill Nottingham <notting@redhat.com>
548- remove gdk_input_remove (causing segfaults)
549
550* Tue Jan 12 1999 Michael K. Johnson <johnsonm@redhat.com>
551- fix missing include files
552
553* Mon Oct 12 1998 Cristian Gafton <gafton@redhat.com>
554- strip binaries
555- use defattr
556- fix spec file ( rm -rf $(RPM_BUILD_ROOT) is a stupid thing to do ! )
557
558* Tue Oct 06 1998 Preston Brown <pbrown@redhat.com>
559- fixed so that the close button on window managers quits the program properly
560
561* Thu Apr 16 1998 Erik Troan <ewt@redhat.com>
562- use gtk-config during build
563- added make archive rule to Makefile
564- uses a build root
565
566* Fri Nov  7 1997 Otto Hammersmith <otto@redhat.com>
567- new version that fixed memory leak bug.
568
569* Mon Nov  3 1997 Otto Hammersmith <otto@redhat.com>
570- updated version to fix bugs
571
572* Fri Oct 17 1997 Otto Hammersmith <otto@redhat.com>
573- Wrote man pages for userpasswd and userhelper.
574
575* Tue Oct 14 1997 Otto Hammersmith <otto@redhat.com>
576- Updated the packages... now includes userpasswd for changing passwords
577  and newer versions of usermount and userinfo.  No known bugs or
578  misfeatures.
579- Fixed the file list...
580
581* Mon Oct 6 1997 Otto Hammersmith <otto@redhat.com>
582- Created the spec file.
Note: See TracBrowser for help on using the repository browser.