source: projects/specs/trunk/u/usbmuxd/usbmuxd-vl.spec @ 1253

Revision 1253, 3.5 KB checked in by daisuke, 14 years ago (diff)

usbmuxd: fix owner of the device node

Line 
1Name:           usbmuxd
2Version:        1.0.4
3Release:        2%{?_dist_release}
4Summary:        Daemon for communicating with Apple's iPod Touch and iPhone
5
6Group:          Applications/System
7# All code is dual licenses as GPLv3+ or GPLv2+, except libusbmuxd which is LGPLv2+.
8License:        GPLv3+ or GPLv2+ and LGPLv2+
9URL:            http://marcansoft.com/uploads/
10
11Source0:        http://marcansoft.com/uploads/usbmuxd/%{name}-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildRequires:  libusb1-devel
15BuildRequires:  cmake
16Requires(pre): shadow-utils
17
18%description
19usbmuxd is a daemon used for communicating with Apple's iPod Touch and iPhone
20devices. It allows multiple services on the device to be accessed
21simultaneously.
22
23%package devel
24Summary: Development package for %{name}
25Group: Development/Libraries
26Requires: usbmuxd = %{version}-%{release}
27Requires: pkgconfig
28Requires: libusb1-devel
29
30%description devel
31Files for development with %{name}.
32
33%prep
34%setup -q
35
36# Set the owner of the device node to be usbmuxd
37sed -i.owner 's/ATTR{idVendor}=="05ac"/OWNER="usbmuxd", ATTR{idVendor}=="05ac"/' udev/85-usbmuxd.rules.in
38sed -i.user 's/-U usbmux/-U usbmuxd/' udev/85-usbmuxd.rules.in
39
40%build
41export CMAKE_PREFIX_PATH=/usr
42%{cmake} .
43
44make %{?_smp_mflags}
45
46%install
47export CMAKE_PREFIX_PATH=/usr$RPM_BUILD_ROOT
48rm -rf $RPM_BUILD_ROOT
49make install DESTDIR=$RPM_BUILD_ROOT
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%pre
55getent group usbmuxd >/dev/null || groupadd -r usbmuxd -g 113
56getent passwd usbmuxd >/dev/null || \
57useradd -r -g usbmuxd -d / -s /sbin/nologin \
58        -c "usbmuxd user" -u 113 usbmuxd
59exit 0
60
61%post -p /sbin/ldconfig
62
63%postun -p /sbin/ldconfig
64
65%files
66%defattr(-,root,root,-)
67%doc AUTHORS README COPYING.GPLv2 COPYING.GPLv3 COPYING.LGPLv2.1 README.devel
68/lib/udev/rules.d/85-usbmuxd.rules
69%{_bindir}/iproxy
70%{_sbindir}/usbmuxd
71%{_libdir}/libusbmuxd.so.*
72
73%files devel
74%defattr(-,root,root,-)
75%doc README.devel
76%{_includedir}/*.h
77%{_libdir}/libusbmuxd.so
78%{_libdir}/pkgconfig/libusbmuxd.pc
79
80%changelog
81* Sun Jun 27 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-2
82- set the owner of the device node to be usbmuxd
83
84* Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
85- new upstream release
86
87* Thu Apr 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-1
88- initial build for Vine Linux
89
90* Mon Mar 22 2010 Peter Robinson <pbrobinson@gmail.com> 1.0.3-1
91- New stable 1.0.3 release
92
93* Thu Feb 11 2010 Peter Robinson <pbrobinson@gmail.com> 1.0.2-1
94- New stable 1.0.2 release
95
96* Tue Feb 09 2010 Bastien Nocera <bnocera@redhat.com> 1.0.0-3
97- Use the gid/uid reserved for usbmuxd in setup 2.8.15 and above
98
99* Fri Jan 29 2010 Peter Robinson <pbrobinson@gmail.com> 1.0.0-2
100- Run deamon under the usbmuxd user
101
102* Mon Dec  7 2009 Peter Robinson <pbrobinson@gmail.com> 1.0.0-1
103- New stable 1.0.0 release
104
105* Sat Oct 31 2009 Peter Robinson <pbrobinson@gmail.com> 1.0.0-0.1.rc2
106- New 1.0.0-rc2 test release
107
108* Thu Oct 29 2009 Peter Robinson <pbrobinson@gmail.com> 1.0.0-0.2.rc1
109- Add patch to fix install of 64 bit libs
110
111* Tue Oct 27 2009 Peter Robinson <pbrobinson@gmail.com> 1.0.0-0.1.rc1
112- New 1.0.0-rc1 test release
113
114* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 0.1.4-2
115- Make usbmuxd autostart on newer kernels
116- (Still doesn't exit properly though)
117
118* Mon Aug 10 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.4-1
119- Update to 0.1.4
120
121* Tue Aug  4 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.3-1
122- Update to 0.1.3, review input
123
124* Mon Aug  3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.2-1
125- Update to 0.1.2
126
127* Mon Aug  3 2009 Peter Robinson <pbrobinson@gmail.com> 0.1.1-1
128- Initial packaging
Note: See TracBrowser for help on using the repository browser.