source: projects/specs/trunk/u/usbmanager/usbmanager-vl.spec @ 551

Revision 551, 1.8 KB checked in by kudoh, 14 years ago (diff)
Line 
1Name:           usbmanager
2Version:        1.0.0
3Release:        1%{?_dist_release}
4Summary:        An USB storage management interface written in Python
5Summary(ja):    Python で書かれた USB ストレージ管理インターフェイス
6
7Group:          Applications/System
8License:        LGPLv3
9URL:            https://launchpad.net/usbmanager
10Source0:        %{name}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildArch:      noarch
13
14BuildRequires:  python-devel
15BuildRequires:  python-setuptools
16BuildRequires:  desktop-file-utils
17
18Requires:       python pygtk2
19Requires:       mtools
20Requires:       dbus hal
21
22%description
23USBManager is a simple and intuitive tool developed to help people
24who have hard times managing theirs USB storage devices.
25
26%description -l ja
27USBManager は USB ストレージデバイスの管理に手を焼く人々を
28助けるために開発されたシンプルで直感的なツールです。
29
30%prep
31%setup -q -n %{name}
32
33%build
34python setup.py build
35
36%install
37rm -rf %{buildroot}
38python setup.py install --skip-build --root %{buildroot}
39
40# maybe disued file?
41rm -rf %{buildroot}/root/
42
43%find_lang %{name}
44
45desktop-file-install \
46        --dir $RPM_BUILD_ROOT%{_datadir}/applications data/%{name}.desktop
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%post
52touch --no-create %{_datadir}/icons/hicolor || :
53%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
54update-desktop-database %{_datadir}/applications
55
56%postun
57touch --no-create %{_datadir}/icons/hicolor || :
58%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
59update-desktop-database %{_datadir}/applications
60
61%files -f %{name}.lang
62%defattr(-,root,root,-)
63%doc AUTHORS COPYING ChangeLog NEWS README TODO
64%{_bindir}/%{name}
65%{_libdir}/python2.*/site-packages/*
66%{_datadir}/applications/*.desktop
67%{_datadir}/icons/*
68
69%changelog
70
71* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-1
72- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.