source: projects/specs/trunk/u/usbmanager/usbmanager-vl.spec @ 5787

Revision 5787, 2.5 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild with python-2.7.2

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name: usbmanager
4Version: 1.0.0
5Release: 3%{?_dist_release}
6Summary:        An USB storage management interface written in Python
7Summary(ja): Python で書かれた USB ストレージ管理インターフェイス
8
9Group: Applications/System
10License: LGPLv3
11URL:     https://launchpad.net/usbmanager
12Source0:        %{name}-%{version}.tar.gz
13Source1:        %{name}_ja.po
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildArch: noarch
17
18BuildRequires:  gettext
19BuildRequires:  python-devel
20BuildRequires:  python-setuptools
21BuildRequires:  desktop-file-utils
22
23Requires:       dbus-python
24Requires:       gksu
25Requires:       python pygtk2
26Requires:       mtools
27Requires:       dbus hal
28
29%description
30USBManager is a simple and intuitive tool developed to help people
31who have hard times managing theirs USB storage devices.
32
33%description -l ja
34USBManager は USB ストレージデバイスの管理に手を焼く人々を
35助けるために開発されたシンプルで直感的なツールです。
36
37%prep
38%setup -q -n %{name}
39cp -f %{SOURCE1} locale/ja.po
40
41%build
42# build Japanese language file before setup,
43# if Japanese translation file is merged, this command will delete.
44msgfmt -o locale/ja.mo locale/ja.po
45
46python setup.py build
47
48%install
49rm -rf %{buildroot}
50python setup.py install --skip-build --root %{buildroot}
51
52# maybe disused file?
53rm -rf %{buildroot}/root/
54
55%find_lang %{name}
56
57desktop-file-install \
58        --dir %{buildroot}%{_datadir}/applications data/%{name}.desktop
59
60%clean
61rm -rf %{buildroot}
62
63%post
64touch --no-create %{_datadir}/icons/hicolor || :
65%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
66update-desktop-database %{_datadir}/applications
67
68%postun
69touch --no-create %{_datadir}/icons/hicolor || :
70%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
71update-desktop-database %{_datadir}/applications
72
73%files -f %{name}.lang
74%defattr(-,root,root,-)
75%doc AUTHORS COPYING ChangeLog NEWS README TODO
76%{_bindir}/%{name}
77#%{_libdir}/python2.*/site-packages/*
78%{python_sitelib}/
79%{_datadir}/applications/*.desktop
80%{_datadir}/icons/*
81
82%changelog
83* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-3
84- rebuild with python-2.7.2
85
86* Fri Jan 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-2
87- added source1 to translate Japanese
88- used python macro
89- added BuildRequires: gettext
90- added Requires: dbus-python, gksu
91
92* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-1
93- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.