source: projects/specs/trunk/u/urw-fonts/urw-fonts-vl.spec @ 521

Revision 521, 7.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define filippov_version 1.0.7pre22
2%define fontdir %{_datadir}/fonts/default/Type1
3
4# font manipulation macro
5%define __mkfontscale   umask 133;%{_bindir}/mkfontscale
6%define __mkfontdir     umask 133;%{_bindir}/mkfontdir
7%define __fccache       umask 133;which fc-cache &> /dev/null && fc-cache
8
9Summary: Free versions of the 35 standard PostScript fonts.
10Summary(ja): 35書体のフリーな標準ポストスクリプトフォント
11Name: urw-fonts
12Version: 2.1
13Release: 7%{?_dist_release}
14Source0: ftp://ftp.gnome.ru/fonts/urw/release/urw-fonts-%{filippov_version}.tar.bz2
15Source1: NimbusRomNo9L-Medi.pfb
16Source2: NimbusRomNo9L-Medi.afm
17Source3: NimbusRomNo9L-MediItal.pfb
18SOurce4: NimbusRomNo9L-MediItal.afm
19URL: ftp://ftp.gnome.ru/fonts/urw/release/
20License: GPL, URW holds copyright
21Group: User Interface/X
22BuildRoot: %{_tmppath}/%{name}-root
23BuildArchitectures: noarch
24Requires(post,postun): xorg-x11-font-utils, fontconfig
25
26
27%description
28Free, good quality versions of the 35 standard PostScript(TM) fonts,
29donated under the GPL by URW++ Design and Development GmbH.  The
30fonts.dir file font names match the original Adobe names of the fonts
31(e.g., Times, Helvetica, etc.).
32
33Install the urw-fonts package if you need free versions of standard
34PostScript fonts.
35
36%prep
37%setup -q -c
38
39%install
40rm -rf $RPM_BUILD_ROOT
41
42mkdir -p $RPM_BUILD_ROOT%{fontdir}
43install -m 0644 *.afm *.pfm *.pfb $RPM_BUILD_ROOT%{fontdir}/
44install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{fontdir}/n021004l.pfb
45install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{fontdir}/n021004l.afm
46install -m 0644 %{SOURCE3} $RPM_BUILD_ROOT%{fontdir}/n021024l.pfb
47install -m 0644 %{SOURCE4} $RPM_BUILD_ROOT%{fontdir}/n021024l.afm
48
49# Touch ghosted files
50touch $RPM_BUILD_ROOT%{fontdir}/{fonts.{dir,scale,cache-1},encodings.dir}
51
52%post
53%{__mkfontscale} %{fontdir} ||:
54%{__mkfontdir} %{fontdir} ||:
55%{__fccache} %{_datadir}/fonts ||:
56
57%postun
58if [ "$1" = "0" ]; then
59        %{__fccache} %{_datadir}/fonts ||:
60fi
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(0644,root,root,0755)
67%doc COPYING README README.tweaks TODO
68%dir %{fontdir}
69%ghost %verify(not md5 size mtime) %{fontdir}/fonts.dir
70%ghost %verify(not md5 size mtime) %{fontdir}/fonts.scale
71%ghost %verify(not md5 size mtime) %{fontdir}/fonts.cache-1
72%ghost %verify(not md5 size mtime) %{fontdir}/encodings.dir
73%{fontdir}/*.afm
74%{fontdir}/*.pfm
75%{fontdir}/*.pfb
76
77%changelog
78* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-7
79- spec in utf-8
80
81* Tue Apr 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-6
82- update dependancies to xorg-x11-7.3
83- drop chkfontpath deps
84
85* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-5vl4
86- updated Prereq: XOrg-font-utils XOrg-base-fonts
87
88* Mon Jan 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-5vl3
89- remove unneeded dependency
90
91* Wed Dec 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1-5vl2
92- modified __fccache macro
93
94* Sun Dec 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-5vl1
95- merged with fedora 2.1-5.1
96  * Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
97  - 2.0-12vl1: was ported to Vine
98
99* Fri Aug 29 2003 Owen Taylor <otaylor@redhat.com> 2.1-5.0
100- Add MediItal variant with fixed weight and some of the
101  missing baseline hints (for u,t)
102
103* Mon Jul 21 2003 Owen Taylor <otaylor@redhat.com> 2.1-4.1
104- Bump for rebuild
105
106* Mon Jul 21 2003 Owen Taylor <otaylor@redhat.com> 2.1-4.0
107- Replace the regular not italic bold font with the fixed copy
108
109* Wed Jul  9 2003 Owen Taylor <otaylor@redhat.com> 2.1-3.1
110- Bump for rebuild
111
112* Wed Jul  9 2003 Owen Taylor <otaylor@redhat.com> 2.1-3
113- Add some obvious missing hints that were resulting in
114  very uneven baselines (#97271)
115
116* Fri Jun 20 2003 Than Ngo <than@redhat.com> 2.1-2
117- fix Weight in Nimbus Roman No 9 L (bug #97683)
118
119* Tue Jun 10 2003 Owen Taylor <otaylor@redhat.com> 2.1-1
120- Upgrade to upstream version 1.0.7pre22
121- Massive cleanups to fonts.dir/fonts.scale handling (use mkfontscale
122  instead of fonts.scale from the package, etc.)
123
124* Wed Jan 29 2003 Than Ngo 2.0-29
125- rebuild
126
127* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
128- rebuilt
129
130* Wed Dec 11 2002 Tim Powers <timp@redhat.com> 2.0-27
131- rebuild
132
133* Fri Aug 30 2002 Alexander Larsson <alexl@redhat.com> 2.0-26
134- Call fc-cache from %%post, prereq fontconfig
135
136* Fri Jul 12 2002 Owen Taylor <otaylor@redhat.com>
137- Didn't revert back far enough to fix hints last time; try again.
138
139* Wed Jul 10 2002 Owen Taylor <otaylor@redhat.com>
140- Fix packaging error that lost most of the fonts
141
142* Mon Jul  8 2002 Owen Taylor <otaylor@redhat.com>
143- Go back to 1.0 URW/cyrillic version to avoid hinting problems
144
145* Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
146- Newer upstream version
147- Fix accidental revert of urw-fontspecific => adobe-fontspecific change
148- Tweak hints in "Nimbus Sans Regular L" a bit.
149
150* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
151- automated rebuild
152
153* Wed Jun 12 2002 Than Ngo <than@redhat.com> 2.0-19
154- update urw fonts
155- add missing ZapfDingbats font (bug #65101, #65523)
156- fixed metric troubles (bug #65522)
157
158* Thu May 23 2002 Tim Powers <timp@redhat.com>
159- automated rebuild
160
161* Tue Feb 26 2002 Than Ngo <than@redhat.com> 2.0-17
162- rebuild
163
164* Tue Jan 22 2002 Preston Brown <pbrown@redhat.com>
165- use adobe-fontspecific instead of urw-fontspecific encoding name for
166  symbol font.  Fixes some java issues.
167
168* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
169- automated rebuild
170
171* Thu Dec 13 2001 Than Ngo <than@redhat.com> 2.0-14
172- fixed bug #57306
173
174* Wed Sep 26 2001 Than Ngo <than@redhat.com> 2.0-13
175- Added new fonts with cyrrilic glyphs
176  from ftp://ftp.gnome.ru/fonts/urw/ (bug #52772)
177 
178* Thu Nov 16 2000 Than Ngo <than@redhat.com>
179- zapf dingbats font works now, fixed (Bug #20352)
180
181* Mon Oct 16 2000 Than Ngo <than@redhat.com>
182- added font aliases (Bug #17586)
183- added missing fonts.alias
184
185* Wed Aug 30 2000 Preston Brown <pbrown@redhat.com>
186- enable latin2 encoding
187- alias the Nimbus/Courier font to be monospaced
188- include a Fontmap
189
190* Fri Jul 14 2000 Preston Brown <pbrown@redhat.com>
191- renamed fonts from URW names to Adobe names for better compatibility
192
193* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
194- automatic rebuild
195
196* Sun Jul 09 2000 Than Ngo <than@redhat.de>
197- update gnu-gs-fonts-std-6.0
198- fix Url
199
200* Sat May 27 2000 Ngo Than <than@redhat.de>
201- rebuild for 7.0
202
203* Wed Mar 08 2000 Preston Brown <pbrown@redhat.com>
204- argh! fonts.scale shouldn't have been symlinked to fonts.dir.  fixed.
205
206* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
207- noreplace the fonts.dir config file
208
209* Wed Feb 16 2000 Bill Nottingham <notting@redhat.com>
210- need .pfb files too
211
212* Mon Feb 14 2000 Preston Brown <pbrown@redhat.com>
213- new URW++ fonts that include extra glyphs.
214
215* Thu Jan 13 2000 Preston Brown <pbrown@redhat.com>
216- remove vendor tag.
217
218* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
219- auto rebuild in the new build environment (release 8)
220
221* Tue Mar 09 1999 Preston Brown <pbrown@redhat.com>
222- fixed up chkfontpath stuff
223
224* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
225- Injected new description and group.
226
227* Mon Feb 15 1999 Preston Brown <pbrown@redhat.com>
228- added missing fonts.dir, fonts.scale, %post, %postun using chkfontpath
229- changed foundary from Adobe (which was a lie) to URW.
230
231* Sat Feb 06 1999 Preston Brown <pbrown@redhat.com>
232- fonts now live in /usr/share/fonts/default/Type1
233
234* Fri Nov 13 1998 Preston Brown <pbrown@redhat.com>
235- eliminated section that adds to XF86Config
236- changed fonts to reside in /usr/share/fonts/default/URW, so they can be
237  shared between X and Ghostscript (and other, future programs/applications)
238
239* Fri Sep 11 1998 Preston Brown <pbrown@redhat.com>
240- integrate adding fontdir to XF86Config
241
242* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
243- eliminate %post output
244
245* Wed Jul  8 1998 Jeff Johnson <jbj@redhat.com>
246- create from Stefan Waldherr <swa@cs.cmu.edu> contrib package.
Note: See TracBrowser for help on using the repository browser.