source: projects/specs/trunk/u/urw-fonts/urw-fonts-vl.spec @ 3504

Revision 3504, 7.7 KB checked in by munepi, 13 years ago (diff)

updated urw-fonts-vl.spec

Line 
1%define filippov_version 1.0.7pre44
2%define fontdir %{_datadir}/fonts/default/Type1
3%define catalogue /etc/X11/fontpath.d
4
5# font manipulation macro
6%define __mkfontscale   umask 133;%{_bindir}/mkfontscale
7%define __mkfontdir     umask 133;%{_bindir}/mkfontdir
8%define __fccache       umask 133;which fc-cache &> /dev/null && fc-cache
9
10Summary: Free versions of the 35 standard PostScript fonts.
11Summary(ja): 35書体のフリーな標準ポストスクリプトフォント
12Name: urw-fonts
13Version: 2.4
14Release: 1%{?_dist_release}
15Source: %{name}-%{filippov_version}.tar.bz2
16URL: http://svn.ghostscript.com/ghostscript/tags/urw-fonts-1.0.7pre44/
17# URW holds copyright
18# No version specified
19License: GPL+
20Group: User Interface/X
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildArch: noarch
23Requires(post,postun): xorg-x11-font-utils, fontconfig
24
25
26%description
27Free, good quality versions of the 35 standard PostScript(TM) fonts,
28donated under the GPL by URW++ Design and Development GmbH.  The
29fonts.dir file font names match the original Adobe names of the fonts
30(e.g., Times, Helvetica, etc.).
31
32Install the urw-fonts package if you need free versions of standard
33PostScript fonts.
34
35%prep
36%setup -q -c
37
38%install
39%__rm -rf $RPM_BUILD_ROOT
40
41%__mkdir_p $RPM_BUILD_ROOT%{fontdir}
42%__install -m 0644 *.afm *.pfm *.pfb $RPM_BUILD_ROOT%{fontdir}/
43
44# Touch ghosted files
45touch $RPM_BUILD_ROOT%{fontdir}/{fonts.{dir,scale,cache-1},encodings.dir}
46
47# Install catalogue symlink
48%__mkdir_p $RPM_BUILD_ROOT%{catalogue}
49#%__ln_s -f %{fontdir} $RPM_BUILD_ROOT%{catalogue}/fonts-default
50%__ln_s -f %{fontdir} $RPM_BUILD_ROOT%{catalogue}/default-Type1
51
52%post
53%{__mkfontscale} %{fontdir} ||:
54%{__mkfontdir} %{fontdir} ||:
55%{__fccache} %{_datadir}/fonts ||:
56
57%postun
58if [ "$1" = "0" ]; then
59   %{__fccache} %{_datadir}/fonts ||:
60fi
61
62%clean
63%__rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(0644,root,root,0755)
67%doc COPYING README README.tweaks
68%dir %{fontdir}
69%{catalogue}/default-Type1
70%ghost %verify(not md5 size mtime) %{fontdir}/fonts.dir
71%ghost %verify(not md5 size mtime) %{fontdir}/fonts.scale
72%ghost %verify(not md5 size mtime) %{fontdir}/fonts.cache-1
73%ghost %verify(not md5 size mtime) %{fontdir}/encodings.dir
74%{fontdir}/*.afm
75%{fontdir}/*.pfm
76%{fontdir}/*.pfb
77
78%changelog
79* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.4-1
80- new upstream release
81  - based on urw-fonts-2.4-10 of Fedora rawhide
82
83* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-7
84- spec in utf-8
85
86* Tue Apr 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-6
87- update dependancies to xorg-x11-7.3
88- drop chkfontpath deps
89
90* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-5vl4
91- updated Prereq: XOrg-font-utils XOrg-base-fonts
92
93* Mon Jan 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-5vl3
94- remove unneeded dependency
95
96* Wed Dec 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1-5vl2
97- modified __fccache macro
98
99* Sun Dec 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-5vl1
100- merged with fedora 2.1-5.1
101  * Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
102  - 2.0-12vl1: was ported to Vine
103
104* Fri Aug 29 2003 Owen Taylor <otaylor@redhat.com> 2.1-5.0
105- Add MediItal variant with fixed weight and some of the
106  missing baseline hints (for u,t)
107
108* Mon Jul 21 2003 Owen Taylor <otaylor@redhat.com> 2.1-4.1
109- Bump for rebuild
110
111* Mon Jul 21 2003 Owen Taylor <otaylor@redhat.com> 2.1-4.0
112- Replace the regular not italic bold font with the fixed copy
113
114* Wed Jul  9 2003 Owen Taylor <otaylor@redhat.com> 2.1-3.1
115- Bump for rebuild
116
117* Wed Jul  9 2003 Owen Taylor <otaylor@redhat.com> 2.1-3
118- Add some obvious missing hints that were resulting in
119  very uneven baselines (#97271)
120
121* Fri Jun 20 2003 Than Ngo <than@redhat.com> 2.1-2
122- fix Weight in Nimbus Roman No 9 L (bug #97683)
123
124* Tue Jun 10 2003 Owen Taylor <otaylor@redhat.com> 2.1-1
125- Upgrade to upstream version 1.0.7pre22
126- Massive cleanups to fonts.dir/fonts.scale handling (use mkfontscale
127  instead of fonts.scale from the package, etc.)
128
129* Wed Jan 29 2003 Than Ngo 2.0-29
130- rebuild
131
132* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
133- rebuilt
134
135* Wed Dec 11 2002 Tim Powers <timp@redhat.com> 2.0-27
136- rebuild
137
138* Fri Aug 30 2002 Alexander Larsson <alexl@redhat.com> 2.0-26
139- Call fc-cache from %%post, prereq fontconfig
140
141* Fri Jul 12 2002 Owen Taylor <otaylor@redhat.com>
142- Didn't revert back far enough to fix hints last time; try again.
143
144* Wed Jul 10 2002 Owen Taylor <otaylor@redhat.com>
145- Fix packaging error that lost most of the fonts
146
147* Mon Jul  8 2002 Owen Taylor <otaylor@redhat.com>
148- Go back to 1.0 URW/cyrillic version to avoid hinting problems
149
150* Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
151- Newer upstream version
152- Fix accidental revert of urw-fontspecific => adobe-fontspecific change
153- Tweak hints in "Nimbus Sans Regular L" a bit.
154
155* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
156- automated rebuild
157
158* Wed Jun 12 2002 Than Ngo <than@redhat.com> 2.0-19
159- update urw fonts
160- add missing ZapfDingbats font (bug #65101, #65523)
161- fixed metric troubles (bug #65522)
162
163* Thu May 23 2002 Tim Powers <timp@redhat.com>
164- automated rebuild
165
166* Tue Feb 26 2002 Than Ngo <than@redhat.com> 2.0-17
167- rebuild
168
169* Tue Jan 22 2002 Preston Brown <pbrown@redhat.com>
170- use adobe-fontspecific instead of urw-fontspecific encoding name for
171  symbol font.  Fixes some java issues.
172
173* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
174- automated rebuild
175
176* Thu Dec 13 2001 Than Ngo <than@redhat.com> 2.0-14
177- fixed bug #57306
178
179* Wed Sep 26 2001 Than Ngo <than@redhat.com> 2.0-13
180- Added new fonts with cyrrilic glyphs
181  from ftp://ftp.gnome.ru/fonts/urw/ (bug #52772)
182 
183* Thu Nov 16 2000 Than Ngo <than@redhat.com>
184- zapf dingbats font works now, fixed (Bug #20352)
185
186* Mon Oct 16 2000 Than Ngo <than@redhat.com>
187- added font aliases (Bug #17586)
188- added missing fonts.alias
189
190* Wed Aug 30 2000 Preston Brown <pbrown@redhat.com>
191- enable latin2 encoding
192- alias the Nimbus/Courier font to be monospaced
193- include a Fontmap
194
195* Fri Jul 14 2000 Preston Brown <pbrown@redhat.com>
196- renamed fonts from URW names to Adobe names for better compatibility
197
198* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
199- automatic rebuild
200
201* Sun Jul 09 2000 Than Ngo <than@redhat.de>
202- update gnu-gs-fonts-std-6.0
203- fix Url
204
205* Sat May 27 2000 Ngo Than <than@redhat.de>
206- rebuild for 7.0
207
208* Wed Mar 08 2000 Preston Brown <pbrown@redhat.com>
209- argh! fonts.scale shouldn't have been symlinked to fonts.dir.  fixed.
210
211* Mon Feb 28 2000 Preston Brown <pbrown@redhat.com>
212- noreplace the fonts.dir config file
213
214* Wed Feb 16 2000 Bill Nottingham <notting@redhat.com>
215- need .pfb files too
216
217* Mon Feb 14 2000 Preston Brown <pbrown@redhat.com>
218- new URW++ fonts that include extra glyphs.
219
220* Thu Jan 13 2000 Preston Brown <pbrown@redhat.com>
221- remove vendor tag.
222
223* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
224- auto rebuild in the new build environment (release 8)
225
226* Tue Mar 09 1999 Preston Brown <pbrown@redhat.com>
227- fixed up chkfontpath stuff
228
229* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
230- Injected new description and group.
231
232* Mon Feb 15 1999 Preston Brown <pbrown@redhat.com>
233- added missing fonts.dir, fonts.scale, %post, %postun using chkfontpath
234- changed foundary from Adobe (which was a lie) to URW.
235
236* Sat Feb 06 1999 Preston Brown <pbrown@redhat.com>
237- fonts now live in /usr/share/fonts/default/Type1
238
239* Fri Nov 13 1998 Preston Brown <pbrown@redhat.com>
240- eliminated section that adds to XF86Config
241- changed fonts to reside in /usr/share/fonts/default/URW, so they can be
242  shared between X and Ghostscript (and other, future programs/applications)
243
244* Fri Sep 11 1998 Preston Brown <pbrown@redhat.com>
245- integrate adding fontdir to XF86Config
246
247* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
248- eliminate %post output
249
250* Wed Jul  8 1998 Jeff Johnson <jbj@redhat.com>
251- create from Stefan Waldherr <swa@cs.cmu.edu> contrib package.
Note: See TracBrowser for help on using the repository browser.