source: projects/specs/trunk/u/upstart/upstart-vl.spec @ 8607

Revision 8607, 8.7 KB checked in by Takemikaduchi, 10 years ago (diff)

NEW: eudev
rtmpdump: add R: gmp-devel
gpac: remove Requires
others: rebuild with eudev

Line 
1Name:           upstart
2Version:        1.12.1
3Release:        4%{?_dist_release}
4Summary:        An event-driven init system
5Summary(ja):    イベントドリブン型 init システム
6
7Group:          System Environment/Base
8License:        GPLv2 and LGPLv2+
9URL:            http://launchpad.net/upstart
10
11Source0:        http://launchpad.net/upstart/1.x/%{version}/+download/upstart-%{version}.tar.gz
12Source1:        init-system-dbus.conf
13#Patch1:         upstart-telinit.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16Obsoletes: SysVinit < 2.88
17Provides: SysVinit = 2.88
18BuildRequires:  gettext, audit-libs-devel, expat-devel
19BuildRequires:  dbus-devel >= 1.2.16
20BuildRequires:  libnih-devel >= 1.0.3-2
21BuildRequires:  json-c-devel >= 0.10
22BuildRequires:  eudev-libudev-devel
23BuildRequires:  dconf-devel
24Requires:       initscripts >= 8.90.4
25
26%description
27Upstart is an event-based replacement for the /sbin/init daemon which
28handles starting of tasks and services during boot, stopping them
29during shutdown and supervising them while the system is running.
30
31%description -l ja
32Upstart はイベントドリブン型の /sbin/init デーモンです。OSブート時の
33タスクやサービスの開始やシャットダウン時の終了およびそれらの管理を担
34当します。
35
36%package devel
37Summary: Development files for upstart
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description devel
42Development files for upstart
43
44%package tools
45Summary: Misc tools for upstart
46Group: System Environment/Base
47Requires: %{name} = %{version}-%{release}
48Requires: python3
49Requires: dbus-python3
50
51%description tools
52Misc tools for upstart
53
54%prep
55%setup -q
56#%patch1 -p1 -b .u
57
58%build
59%configure --sbindir=/sbin --libdir=/%{_lib}
60make %{?_smp_mflags}
61
62%install
63rm -rf %{buildroot}
64make install DESTDIR=%{buildroot}
65
66# don't ship default jobs
67rm -f %{buildroot}/%{_sysconfdir}/init/*
68install -m 644 %{SOURCE1} %{buildroot}/%{_sysconfdir}/init/
69
70# install upstart-{socket,udev}-bridge.conf
71install -m 644 extra/conf/*.conf %{buildroot}/%{_sysconfdir}/init/
72
73# remove unneeded files
74rm %{buildroot}/%{_lib}/*.{a,la}
75
76%find_lang %{name}
77
78%check
79#some tests fail in koji while pass in mock and local build
80#to run make check use "--with check"
81%if %{?_with_check:1}%{!?_with_check:0}
82  make check
83%endif
84
85%clean
86rm -rf %{buildroot}
87
88%files -f %{name}.lang
89%defattr(-,root,root,-)
90%doc AUTHORS
91%doc COPYING
92%doc NEWS
93%doc README
94%doc TODO
95%doc HACKING
96%{_sysconfdir}/init/
97%config(noreplace) %{_sysconfdir}/dbus-1/system.d/Upstart.conf
98/%{_lib}/libupstart.so.*
99/sbin/halt
100/sbin/init
101/sbin/initctl
102/sbin/poweroff
103/sbin/reboot
104/sbin/runlevel
105/sbin/shutdown
106/sbin/start
107/sbin/status
108/sbin/stop
109/sbin/restart
110/sbin/telinit
111/sbin/reload
112/sbin/upstart-socket-bridge
113/sbin/upstart-udev-bridge
114/sbin/upstart-dbus-bridge
115/sbin/upstart-dconf-bridge
116/sbin/upstart-event-bridge
117/sbin/upstart-file-bridge
118/sbin/upstart-local-bridge
119%{_bindir}/init-checkconf
120%dir %{_datadir}/upstart
121%dir %{_datadir}/upstart/sessions
122%{_datadir}/upstart/sessions/*
123%{_mandir}/man5/init.5.gz
124%{_mandir}/man5/inittab.5.gz
125%{_mandir}/man7/*.7*
126%{_mandir}/man8/*.8*
127%exclude %{_mandir}/man8/initctl2dot.8*
128%exclude %{_mandir}/man8/upstart-monitor.8*
129
130%files devel
131%defattr(-,root,root,-)
132/%{_lib}/libupstart.so
133%{_includedir}/upstart*
134%{_prefix}/lib/pkgconfig/*.pc
135
136%files tools
137%defattr(-,root,root,-)
138%{_bindir}/upstart-monitor
139%{_bindir}/initctl2dot
140%{_datadir}/applications/*.desktop
141%{_datadir}/icons/hicolor/scalable/apps/*.svg
142%{_datadir}/upstart/icons/*.svg
143%{_mandir}/man8/initctl2dot.8*
144%{_mandir}/man8/upstart-monitor.8*
145
146%changelog
147* Tue Jun 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-4
148- change BuildRequires: eudev-libudev-devel instead of libudev-devel
149
150* Sun Jun 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-3
151- rebuild with libnih-1.0.3-2
152
153* Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-2
154- add -tools subpackage
155- split initctl2dot and upstart-monitor to -tools subpackage
156- add R: dbus-python3 to upstart-tools
157
158* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-1
159- update to 1.12.1
160- add BR: dconf-devel
161- add -devel subpackage
162
163* Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-2
164- install upstart-{socket,udev}-bridge.conf
165
166* Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-1
167- update to 1.6
168- add BR: libudev-devel
169- add BR: json-c-devel >= 0.10
170
171* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
172- new upstream release
173
174* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.7-1
175- new upstream release
176
177* Wed May 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-2
178- add R: initscripts >= 8.90.4
179
180* Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-1
181- initial build for Vine Linux
182
183* Wed Feb 24 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.5-3
184- run "make check" only with --with check
185
186* Fri Feb 19 2010 Casey Dahlin <cdahlin@redhat.com> 0.6.5-2
187- be more specific about which libnih we need.
188
189* Wed Feb 17 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.5-1
190- upgrade to 0.6.5
191
192* Fri Jan 29 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.3-7
193- add SIGUSR1 handler and init-system-dbus.conf (#559660)
194
195* Sun Jan 17 2010 Dennis Gilmore <dennis@ausil.us> - 0.6.3-6
196- add patch from upstream fixing sparc alignment issues
197
198* Mon Jan 11 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.3-5
199- License changed to GPLv2 and LGPLv2+
200
201* Wed Dec 16 2009 Petr Lautrbach <plautrba@redhat.com> 0.6.3-4
202- audit events patch rebased for 0.6 (#470661)
203
204* Thu Dec  3 2009 Bill Nottingham <notting@redhat.com> 0.6.3-3
205- make 'telinit u' a no-op, temporarily
206
207* Fri Nov 27 2009 Petr Lautrbach <plautrba@redhat.com> 0.6.3-2
208- Removed tests which fail in koji
209
210* Fri Nov 20 2009 Casey Dahlin <cdahlin@redhat.com> - 0.6.3-1
211- Upgrade to 0.6.3
212
213* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.3.11-3
214- rebuilt with new audit
215
216* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.11-2
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
218
219* Mon Jun 22 2009 Petr Lautrbach <plautrba@redhat.com> - 0.3.11-1
220- Update to 0.3.11
221
222* Mon Apr 27 2009 Bill Nottingham <notting@redhat.com> - 0.3.9-24
223- Apply the audit patch correctly (#470661)
224
225* Fri Apr 3 2009 Casey Dahlin <cdahlin@redhat.com> - 0.3.9-23
226- Add audit events patch from Steve Grubb <sgrubb@redhat.com> (Bug #470661)
227
228* Fri Jan 23 2009 Casey Dahlin <cdahlin@redhat.com> - 0.3.9-22
229- Re-add 'telinit u' support along with patch to fix it (#450488). Patch due to
230  <pspencer@fields.utoronto.ca>
231
232* Mon Jan 12 2009 Bill Nottingham <notting@redhat.com> - 0.3.9-21
233- Remove 'telinit u' support as it is broken (#450488, <cjdahlin@ncsu.edu>)
234
235* Fri Apr 25 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-19
236- with the merge of event-compat-sysv, move the sysvinit obsoletes/provides here
237
238* Thu Apr 24 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-18
239- fix some man page typos (#444008, <archimerged@gmail.com>)
240
241* Wed Apr 09 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-17
242- Added list of stock events to events(5)
243
244* Tue Apr 08 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-16
245- Add telinit u support
246
247* Fri Apr 04 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-15
248- Add a events(5) manpage that describes event syntax
249
250* Thu Apr 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-14
251- Change bug report email address to fedora-devel-list@redhat.com
252
253* Fri Mar 14 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-13
254- Ignore rpm temporary files of the foo;<somehex> format
255- Make ignores of .rpm{new,orig,save} match only at the end of the name
256
257* Thu Mar 13 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-12
258- forgot about rpmorig too (ugh)
259
260* Thu Mar 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-11
261- Make logd a noreplace
262
263* Thu Mar 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-10
264- Add patch to ignore .rpm{new,save} files
265
266* Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-9
267- Remove automake dependency, build Makefile.in changes into patch
268
269* Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-8
270- Run automake after patching
271
272* Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-7
273- Added BuildRequires: automake
274
275* Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-6
276- Added patch to allow runtime tty changes
277
278* Fri Feb 15 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-5
279- Added patch to imply --force on runlevels 0 and 6
280
281* Wed Feb 06 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-4
282- Patched for GCC 4.3
283
284* Thu Jan 31 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-3
285- Added AUTHORS, COPYING, etc.
286- Made config --libdir option relative
287
288* Mon Jan 21 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-2
289- Remove libnih and libupstart
290
291* Sun Jan 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-1
292- Initial packaging
Note: See TracBrowser for help on using the repository browser.