source: projects/specs/trunk/u/upstart/upstart-vl.spec @ 12005

Revision 12005, 11.8 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

RevLine 
[12005]1%global prepare_systemd 1
2
[2105]3Name:           upstart
[8559]4Version:        1.12.1
[12005]5Release:        6%{?_dist_release}
[2105]6Summary:        An event-driven init system
7Summary(ja):    イベントドリブン型 init システム
8
9Group:          System Environment/Base
10License:        GPLv2 and LGPLv2+
[3371]11URL:            http://launchpad.net/upstart
12
[12005]13Vendor:         Project Vine
14Distribution:   Vine Linux
15
[3371]16Source0:        http://launchpad.net/upstart/1.x/%{version}/+download/upstart-%{version}.tar.gz
[2105]17Source1:        init-system-dbus.conf
[8559]18#Patch1:         upstart-telinit.patch
[3371]19
[2105]20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21Obsoletes: SysVinit < 2.88
22Provides: SysVinit = 2.88
23BuildRequires:  gettext, audit-libs-devel, expat-devel
[7170]24BuildRequires:  dbus-devel >= 1.2.16
[8588]25BuildRequires:  libnih-devel >= 1.0.3-2
[7170]26BuildRequires:  json-c-devel >= 0.10
[8607]27BuildRequires:  eudev-libudev-devel
[8559]28BuildRequires:  dconf-devel
29Requires:       initscripts >= 8.90.4
[12005]30Requires(post,postun): bash
[2105]31
[12005]32Provides: /sbin/halt
33Provides: /sbin/init
34Provides: /sbin/poweroff
35Provides: /sbin/reboot
36Provides: /sbin/runlevel
37Provides: /sbin/shutdown
38Provides: /sbin/telinit
39
[2105]40%description
41Upstart is an event-based replacement for the /sbin/init daemon which
42handles starting of tasks and services during boot, stopping them
43during shutdown and supervising them while the system is running.
44
[3371]45%description -l ja
46Upstart はイベントドリブン型の /sbin/init デーモンです。OSブート時の
47タスクやサービスの開始やシャットダウン時の終了およびそれらの管理を担
48当します。
49
[8559]50%package devel
51Summary: Development files for upstart
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56Development files for upstart
57
[8563]58%package tools
59Summary: Misc tools for upstart
60Group: System Environment/Base
61Requires: %{name} = %{version}-%{release}
62Requires: python3
63Requires: dbus-python3
64
65%description tools
66Misc tools for upstart
67
[2105]68%prep
69%setup -q
[8559]70#%patch1 -p1 -b .u
[2105]71
72%build
73%configure --sbindir=/sbin --libdir=/%{_lib}
74make %{?_smp_mflags}
75
76%install
77rm -rf %{buildroot}
78make install DESTDIR=%{buildroot}
79
80# don't ship default jobs
81rm -f %{buildroot}/%{_sysconfdir}/init/*
82install -m 644 %{SOURCE1} %{buildroot}/%{_sysconfdir}/init/
83
[7172]84# install upstart-{socket,udev}-bridge.conf
85install -m 644 extra/conf/*.conf %{buildroot}/%{_sysconfdir}/init/
86
[8559]87# remove unneeded files
88rm %{buildroot}/%{_lib}/*.{a,la}
89
[2105]90%find_lang %{name}
91
[12005]92# for alternatives
93%if 0%{?prepare_systemd}
94mkdir -p %{buildroot}/%{_lib}/upstart
95for f in init halt poweroff reboot runlevel shutdown telinit; do
96  mv -f %{buildroot}/sbin/$f %{buildroot}/%{_lib}/upstart/
97done
98
99for f in halt poweroff reboot runlevel shutdown telinit; do
100  mv -f %{buildroot}/%{_mandir}/man8/$f.8 \
101        %{buildroot}/%{_mandir}/man8/upstart-$f.8
102done
103%endif
104
[2105]105%check
106#some tests fail in koji while pass in mock and local build
107#to run make check use "--with check"
108%if %{?_with_check:1}%{!?_with_check:0}
109  make check
110%endif
111
[12005]112%if 0%{?prepare_systemd}
113%post
114/sbin/alternatives \
115  --install /sbin/init     init     /%{_lib}/upstart/init 200 \
116    --slave /sbin/halt     halt     /%{_lib}/upstart/halt \
117    --slave /sbin/poweroff poweroff /%{_lib}/upstart/poweroff \
118    --slave /sbin/reboot   reboot   /%{_lib}/upstart/reboot \
119    --slave /sbin/runlevel runlevel /%{_lib}/upstart/runlevel \
120    --slave /sbin/shutdown shutdown /%{_lib}/upstart/shutdown \
121    --slave /sbin/telinit  telinit  /%{_lib}/upstart/telinit \
122    --slave %{_mandir}/man8/halt.8.gz halt.8 %{_mandir}/man8/upstart-halt.8.gz \
123    --slave %{_mandir}/man8/poweroff.8.gz poweroff.8 %{_mandir}/man8/upstart-poweroff.8.gz \
124    --slave %{_mandir}/man8/reboot.8.gz reboot.8 %{_mandir}/man8/upstart-reboot.8.gz \
125    --slave %{_mandir}/man8/runlevel.8.gz runlevel.8 %{_mandir}/man8/upstart-runlevel.8.gz \
126    --slave %{_mandir}/man8/shutdown.8.gz shutdown.8 %{_mandir}/man8/upstart-shutdown.8.gz \
127    --slave %{_mandir}/man8/telinit.8.gz telinit.8 %{_mandir}/man8/upstart-telinit.8.gz
128
129%postun
130if [ "$1" = "0" ]; then
131  /sbin/alternatives --remove init /%{_lib}/upstart/init
132fi
133
134%triggerpostun -- upstart <= 1.12.1-5vl7
135/sbin/alternatives \
136  --install /sbin/init     init     /%{_lib}/upstart/init 200 \
137    --slave /sbin/halt     halt     /%{_lib}/upstart/halt \
138    --slave /sbin/poweroff poweroff /%{_lib}/upstart/poweroff \
139    --slave /sbin/reboot   reboot   /%{_lib}/upstart/reboot \
140    --slave /sbin/runlevel runlevel /%{_lib}/upstart/runlevel \
141    --slave /sbin/shutdown shutdown /%{_lib}/upstart/shutdown \
142    --slave /sbin/telinit  telinit  /%{_lib}/upstart/telinit \
143    --slave %{_mandir}/man8/halt.8.gz halt.8 %{_mandir}/man8/upstart-halt.8.gz \
144    --slave %{_mandir}/man8/poweroff.8.gz poweroff.8 %{_mandir}/man8/upstart-poweroff.8.gz \
145    --slave %{_mandir}/man8/reboot.8.gz reboot.8 %{_mandir}/man8/upstart-reboot.8.gz \
146    --slave %{_mandir}/man8/runlevel.8.gz runlevel.8 %{_mandir}/man8/upstart-runlevel.8.gz \
147    --slave %{_mandir}/man8/shutdown.8.gz shutdown.8 %{_mandir}/man8/upstart-shutdown.8.gz \
148    --slave %{_mandir}/man8/telinit.8.gz telinit.8 %{_mandir}/man8/upstart-telinit.8.gz
149
150%endif
151
[2105]152%clean
153rm -rf %{buildroot}
154
155%files -f %{name}.lang
156%defattr(-,root,root,-)
157%doc AUTHORS
158%doc COPYING
159%doc NEWS
160%doc README
161%doc TODO
162%doc HACKING
163%{_sysconfdir}/init/
164%config(noreplace) %{_sysconfdir}/dbus-1/system.d/Upstart.conf
[8559]165/%{_lib}/libupstart.so.*
[12005]166%if 0%{?prepare_systemd}
167/%{_lib}/upstart
168%else
[2105]169/sbin/halt
170/sbin/init
171/sbin/poweroff
172/sbin/reboot
173/sbin/runlevel
174/sbin/shutdown
[12005]175/sbin/telinit
176%endif
177/sbin/initctl
[2105]178/sbin/start
179/sbin/status
180/sbin/stop
181/sbin/restart
182/sbin/reload
[7170]183/sbin/upstart-socket-bridge
184/sbin/upstart-udev-bridge
[8559]185/sbin/upstart-dbus-bridge
186/sbin/upstart-dconf-bridge
187/sbin/upstart-event-bridge
188/sbin/upstart-file-bridge
189/sbin/upstart-local-bridge
[7170]190%{_bindir}/init-checkconf
[8559]191%dir %{_datadir}/upstart
192%dir %{_datadir}/upstart/sessions
193%{_datadir}/upstart/sessions/*
[2105]194%{_mandir}/man5/init.5.gz
195%{_mandir}/man5/inittab.5.gz
[7170]196%{_mandir}/man7/*.7*
197%{_mandir}/man8/*.8*
[8563]198%exclude %{_mandir}/man8/initctl2dot.8*
199%exclude %{_mandir}/man8/upstart-monitor.8*
[2105]200
[8559]201%files devel
202%defattr(-,root,root,-)
203/%{_lib}/libupstart.so
204%{_includedir}/upstart*
205%{_prefix}/lib/pkgconfig/*.pc
206
[8563]207%files tools
208%defattr(-,root,root,-)
209%{_bindir}/upstart-monitor
210%{_bindir}/initctl2dot
211%{_datadir}/applications/*.desktop
212%{_datadir}/icons/hicolor/scalable/apps/*.svg
213%{_datadir}/upstart/icons/*.svg
214%{_mandir}/man8/initctl2dot.8*
215%{_mandir}/man8/upstart-monitor.8*
216
[2105]217%changelog
[12005]218* Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-6
219- manuals for {halt,poweroff,reboot,runlevel,shutdown,telinit} are alternatives ready.
220
221* Tue Jan 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-5
222- rebuilt with json-c-0.13.
223- /sbin/{init,halt,poweroff,reboot,runlevel,shutdown,telinit} are alternatives ready.
224
[8607]225* Tue Jun 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-4
226- change BuildRequires: eudev-libudev-devel instead of libudev-devel
227
[8588]228* Sun Jun 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-3
229- rebuild with libnih-1.0.3-2
230
[8563]231* Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-2
232- add -tools subpackage
233- split initctl2dot and upstart-monitor to -tools subpackage
234- add R: dbus-python3 to upstart-tools
235
[8559]236* Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-1
237- update to 1.12.1
238- add BR: dconf-devel
[8563]239- add -devel subpackage
[8559]240
[7172]241* Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-2
242- install upstart-{socket,udev}-bridge.conf
243
[7170]244* Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-1
245- update to 1.6
246- add BR: libudev-devel
247- add BR: json-c-devel >= 0.10
248
[3371]249* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
250- new upstream release
251
[2982]252* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.7-1
253- new upstream release
254
[2105]255* Wed May 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-2
256- add R: initscripts >= 8.90.4
257
258* Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-1
259- initial build for Vine Linux
260
261* Wed Feb 24 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.5-3
262- run "make check" only with --with check
263
264* Fri Feb 19 2010 Casey Dahlin <cdahlin@redhat.com> 0.6.5-2
265- be more specific about which libnih we need.
266
267* Wed Feb 17 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.5-1
268- upgrade to 0.6.5
269
270* Fri Jan 29 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.3-7
271- add SIGUSR1 handler and init-system-dbus.conf (#559660)
272
273* Sun Jan 17 2010 Dennis Gilmore <dennis@ausil.us> - 0.6.3-6
274- add patch from upstream fixing sparc alignment issues
275
276* Mon Jan 11 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.3-5
277- License changed to GPLv2 and LGPLv2+
278
279* Wed Dec 16 2009 Petr Lautrbach <plautrba@redhat.com> 0.6.3-4
280- audit events patch rebased for 0.6 (#470661)
281
282* Thu Dec  3 2009 Bill Nottingham <notting@redhat.com> 0.6.3-3
283- make 'telinit u' a no-op, temporarily
284
285* Fri Nov 27 2009 Petr Lautrbach <plautrba@redhat.com> 0.6.3-2
286- Removed tests which fail in koji
287
288* Fri Nov 20 2009 Casey Dahlin <cdahlin@redhat.com> - 0.6.3-1
289- Upgrade to 0.6.3
290
291* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.3.11-3
292- rebuilt with new audit
293
294* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.11-2
295- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
296
297* Mon Jun 22 2009 Petr Lautrbach <plautrba@redhat.com> - 0.3.11-1
298- Update to 0.3.11
299
300* Mon Apr 27 2009 Bill Nottingham <notting@redhat.com> - 0.3.9-24
301- Apply the audit patch correctly (#470661)
302
303* Fri Apr 3 2009 Casey Dahlin <cdahlin@redhat.com> - 0.3.9-23
304- Add audit events patch from Steve Grubb <sgrubb@redhat.com> (Bug #470661)
305
306* Fri Jan 23 2009 Casey Dahlin <cdahlin@redhat.com> - 0.3.9-22
307- Re-add 'telinit u' support along with patch to fix it (#450488). Patch due to
308  <pspencer@fields.utoronto.ca>
309
310* Mon Jan 12 2009 Bill Nottingham <notting@redhat.com> - 0.3.9-21
311- Remove 'telinit u' support as it is broken (#450488, <cjdahlin@ncsu.edu>)
312
313* Fri Apr 25 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-19
314- with the merge of event-compat-sysv, move the sysvinit obsoletes/provides here
315
316* Thu Apr 24 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-18
317- fix some man page typos (#444008, <archimerged@gmail.com>)
318
319* Wed Apr 09 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-17
320- Added list of stock events to events(5)
321
322* Tue Apr 08 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-16
323- Add telinit u support
324
325* Fri Apr 04 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-15
326- Add a events(5) manpage that describes event syntax
327
328* Thu Apr 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-14
329- Change bug report email address to fedora-devel-list@redhat.com
330
[8559]331* Fri Mar 14 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-13
[2105]332- Ignore rpm temporary files of the foo;<somehex> format
333- Make ignores of .rpm{new,orig,save} match only at the end of the name
334
[8559]335* Thu Mar 13 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-12
[2105]336- forgot about rpmorig too (ugh)
337
[8559]338* Thu Mar 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-11
[2105]339- Make logd a noreplace
340
[8559]341* Thu Mar 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-10
[2105]342- Add patch to ignore .rpm{new,save} files
343
[8559]344* Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-9
[2105]345- Remove automake dependency, build Makefile.in changes into patch
346
[8559]347* Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-8
[2105]348- Run automake after patching
349
[8559]350* Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-7
[2105]351- Added BuildRequires: automake
352
[8559]353* Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-6
[2105]354- Added patch to allow runtime tty changes
355
356* Fri Feb 15 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-5
357- Added patch to imply --force on runlevels 0 and 6
358
359* Wed Feb 06 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-4
360- Patched for GCC 4.3
361
362* Thu Jan 31 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-3
363- Added AUTHORS, COPYING, etc.
364- Made config --libdir option relative
365
366* Mon Jan 21 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-2
367- Remove libnih and libupstart
368
369* Sun Jan 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-1
370- Initial packaging
Note: See TracBrowser for help on using the repository browser.