source: projects/specs/trunk/u/update-notifier/update-notifier-vl.spec @ 521

Revision 521, 4.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name    update-notifier
2%define version 0.70.4
3%define release 1%{?_dist_release}
4
5Summary:        Application which notifies about package updates
6Summary(ja):    パッケージの更新を通知するアプリケーション
7Name:           %{name}
8Version:        %{version}
9Release:        %{release}
10Source0:        %{name}_%{version}.tar.gz
11Source1:        apt-check.vine
12Source2:        markupgrade.lua
13Source3:        update-notifier.conf
14Source4:        update-notifier.lua
15Source5:        update-notifier.cron
16Source100:      update-notifier-0.70.4-ja.po
17
18License:        GPL
19Group:          Applications/System
20URL:            https://launchpad.net/ubuntu/+source/update-notifier
21
22Requires:       apt, synaptic, notification-daemon, vixie-cron, anacron
23BuildRequires:  gtk2-devel, libgnomeui-devel, libglade2-devel
24BuildRequires:  GConf2-devel, hal-devel, dbus-glib-devel, libnotify-devel
25BuildRequires:  perl-XML-Parser
26
27Requires(post):   GConf2
28Requires(postun): GConf2
29
30BuildRoot:      %{_tmppath}/%{name}-%{version}-root
31
32%description
33Update Notifier will check for the availability of new packages for your
34system on a daily basis. When it detects new versions of the packages
35installed on the system are available, it will add an icon on the desktop
36notification area.
37
38It will work with any Desktop system that implements the FreeDesktop
39notification area specification, like GNOME, KDE and XFCE.
40
41%description -l ja
42Update Notifier は更新可能なパッケージがないか1日1回自動的にチェックします。
43システムにインストールされたパッケージのより新しいバージョンを検出すると、
44デスクトップの通知エリアにアイコンを表示します。
45
46このアプリケーションは freedesktop.org の notification area speficification
47に準拠しているので、GNOME や KDE、XFCE など、どうようなデスクトップ環境でも
48利用できます。
49
50
51%prep
52%setup -q -n %{name}-%{version}
53%{__cp} %{SOURCE100} po/ja.po
54
55%build
56%configure --disable-schemas-install
57%{__make}
58
59
60%install
61%{__rm} -rf ${RPM_BUILD_ROOT}
62# seems configure option --disable-schemas-install is ignoring...
63export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
64%makeinstall schemadir=${RPM_BUILD_ROOT}/%{_sysconfdir}/gconf/schemas
65unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
66
67%find_lang %{name}
68
69# create local state directory
70%{__install} -d -m755 ${RPM_BUILD_ROOT}/%{_localstatedir}/lib/update-notifier
71%{__install} -d -m755 ${RPM_BUILD_ROOT}/%{_localstatedir}/lib/update-notifier/user.d
72
73# install additional script for vine
74%{__install} -m755 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_libdir}/update-notifier/apt-check
75%{__install} -m755 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_libdir}/update-notifier/markupgrade.lua
76
77%{__install} -d -m755 ${RPM_BUILD_ROOT}/%{_sysconfdir}/apt/apt.conf.d
78%{__install} -m644 %{SOURCE3} ${RPM_BUILD_ROOT}/%{_sysconfdir}/apt/apt.conf.d/update-notifier.conf
79%{__install} -d -m755 ${RPM_BUILD_ROOT}/%{_datadir}/apt/scripts
80%{__install} -m755 %{SOURCE4} ${RPM_BUILD_ROOT}/%{_datadir}/apt/scripts/update-notifier.lua
81
82# install cron script
83%{__install} -d -m755 ${RPM_BUILD_ROOT}/%{_sysconfdir}/cron.daily
84%{__install} -m755 %{SOURCE5} ${RPM_BUILD_ROOT}/%{_sysconfdir}/cron.daily/update-notifier.cron
85
86
87%post
88export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
89gconftool-2 --makefile-install-rule \
90    %{_sysconfdir}/gconf/schemas/update-notifier.schemas > /dev/null;
91
92
93%preun
94export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
95gconftool-2 --makefile-uninstall-rule \
96    %{_sysconfdir}/gconf/schemas/update-notifier.schemas >/dev/null;
97
98
99%clean
100%{__rm} -rf ${RPM_BUILD_ROOT}
101
102
103%files -f %{name}.lang
104%defattr(-,root,root)
105%doc AUTHORS COPYING ChangeLog HOOKS INSTALL NEWS README TODO
106%{_sysconfdir}/apt/apt.conf.d/update-notifier.conf
107%{_sysconfdir}/cron.daily/update-notifier.cron
108%{_sysconfdir}/gconf/schemas/update-notifier.schemas
109%{_sysconfdir}/xdg/autostart/update-notifier.desktop
110%{_bindir}/update-notifier
111%{_datadir}/apt/scripts/update-notifier.lua
112%{_datadir}/icons/hicolor
113%{_datadir}/update-notifier/glade
114%{_datadir}/update-notifier/notify-reboot-required
115%{_libdir}/update-notifier
116%dir %{_localstatedir}/lib/update-notifier
117%dir %{_localstatedir}/lib/update-notifier/user.d
118
119
120%changelog
121* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 0.70.4-1vl5
122- applied new versioning policy, spec in utf-8
123
124* Mon Mar 03 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.70.4-0vl2
125- add Source100 (updated japanese message).
126
127* Sun Feb 24 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.70.4-0vl1
128- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.