source: projects/specs/trunk/u/unzip/unzip-vl.spec @ 8729

Revision 8729, 7.9 KB checked in by daisuke, 10 years ago (diff)

unzip: support ja_JP.utf8 locale

Line 
1%define src_file unzip60
2
3Summary: A utility for unpacking zip files.
4Summary(ja): zip ファイルを展開するユーティリティ
5Name: unzip
6Version: 6.0
7Release: 2%{?_dist_release}
8License: BSD
9Group: Applications/Archiving
10URL: http://www.info-zip.org/UnZip.html
11
12Source: http://downloads.sourceforge.net/infozip/%{src_file}.tar.gz
13
14# Not sent to upstream.
15Patch1: unzip-6.0-bzip2-configure.patch
16# Upstream plans to do this in zip (hopefully also in unzip).
17Patch2: unzip-6.0-exec-shield.patch
18# Upstream plans to do similar thing.
19Patch3: unzip-6.0-close.patch
20# Details in rhbz#532380.
21# Reported to upstream: http://www.info-zip.org/board/board.pl?m-1259575993/
22Patch4: unzip-6.0-attribs-overflow.patch
23# Not sent to upstream, as it's Fedora/RHEL specific.
24# Modify the configure script not to request the strip of binaries.
25Patch5: unzip-6.0-nostrip.patch
26Patch6: unzip-6.0-manpage-fix.patch
27# Update match.c with recmatch() from zip 3.0's util.c
28# This also resolves the license issue in that old function.
29# Original came from here: https://projects.parabolagnulinux.org/abslibre.git/plain/libre/unzip-libre/match.patch
30Patch7: unzip-6.0-fix-recmatch.patch
31# Update process.c
32Patch8: unzip-6.0-symlink.patch
33
34# japanese charset support
35# https://gist.github.com/hamano/573753
36Patch200: unzip-6.0-japanese_charset.patch
37# just ignore -E option, older nls patch use this.
38Patch201: unzip-6.0-ignore-E-option.patch
39# support ja_JP.utf8 locale
40Patch202: unzip-6.0-japanese_charset-utf8.patch
41
42BuildRoot: %{_tmppath}/%{name}-%{version}-root
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: daisuke
47
48%description
49The unzip utility is used to list, test, or extract files from a zip
50archive.  Zip archives are commonly found on MS-DOS systems.  The zip
51utility, included in the zip package, creates zip archives.  Zip and
52unzip are both compatible with archives created by PKWARE(R)'s PKZIP
53for MS-DOS, but the programs' options and default behaviors do differ
54in some respects.
55
56Install the unzip package if you need to list, test or extract files from
57a zip archive.
58
59%description -l ja
60unzip ユーティリティは,zip アーカイブ内のファイルを一覧表示したり,
61テスト/展開する為に使うユーティリティです.zip アーカイブは MS-DOS
62システムで一般的に使われます.
63zip パッケージに含まれる zip プログラムは zip アーカイブを
64作成するのに使います.
65zip と unzip は PKWARE(R) の MS-DOS 用 PKZIP で作成された zip アーカイブに
66対応していますが,デフォルトの動作やプログラムオプション等一部が
67異なります.
68
69
70%prep
71%setup -q -n %{src_file}
72%patch1 -p1 -b .bzip2-configure
73%patch2 -p1 -b .exec-shield
74%patch3 -p1 -b .close
75%patch4 -p1 -b .attribs-overflow
76%patch5 -p1 -b .nostrip
77%patch6 -p1 -b .manpage-fix
78%patch7 -p1 -b .recmatch
79%patch8 -p1 -b .symlink
80
81%patch200 -p1 -b .jp
82%patch201 -p1 -b .ignore-E
83%patch202 -p1 -b .utf8
84
85ln -s unix/Makefile Makefile
86
87%build
88make LOCAL_UNZIP="-D_FILE_OFFSET_BITS=64 -DNO_LCHMOD -D_MBCS -DNO_WORKING_ISPRINT" linux_noasm
89
90%install
91[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
92
93make prefix=$RPM_BUILD_ROOT%{_prefix} MANDIR=$RPM_BUILD_ROOT/%{_mandir}/man1 install LF2=""
94
95
96%clean
97[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
98
99
100%files
101%defattr(-,root,root)
102%doc README BUGS LICENSE INSTALL
103%{_bindir}/*
104%{_mandir}/*/*
105
106
107%changelog
108* Thu Jul 03 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.0-2
109- add patch202 to support ja_JP.utf8
110
111* Thu May 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.0-1
112- update to 6.0
113- replace nls patch.
114
115* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 5.52-3vl6
116- build on current VineSeed
117
118* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.52-2
119- spec in utf-8
120- add NLS patch
121
122* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.52-1
123- new upstream release
124- add patch13 from fc8
125- update patches to fit new release & drop old patches
126- with new versioning polity
127
128* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-11vl4
129- fix changelog typo
130
131* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-10vl4
132- update patch100 to fix ppc issue (it was patch5, from rhel4)
133- renumber patchs
134- add patch 2,3 to support big archive (from rhel4)
135- with new versioning polity
136
137* Fri Mar 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-9vl1.1
138- add patch5 for fix CVE-2005-4667
139- add patch6 for fix CVE-2008-0888
140- add Vendor/Distribution tag
141
142* Tue May 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.51-9vl1
143- new upstream release
144- based on 5.51-9 Fedora development
145  * Thu Feb 10 2005 Ivana Varekova <varekova@redhat.com> 5.51-9
146  - fix the other problem with unpacking zipfiles containing symlinks
147    (bug #134073)
148  * Thu Feb 03 2005 Ivana Varekova <varekova@redhat.com> 5.51-8
149  - fix segfault with unpacking of zipfiles containing dangling symlinks
150    (bug #134073)
151  * Thu Dec 02 2004 Lon Hohberger <lhh@redhat.com> 5.51-5
152  - Fix segfault on extraction of symlinks
153  * Mon Jun 21 2004 Lon Hohberger <lhh@redhat.com> 5.51-4
154  - Extend max file/archive size to 2^32-8193 (4294959103) bytes
155  * Tue Jun 08 2004 Lon Hohberger <lhh@redhat.com> 5.51-1.1
156  - Update to 5.51; remove dotdot patch.
157
158* Tue Sep 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-5vl2
159- merged patch1 from Vine Linux 2.6 updates
160  - Thu Aug 28 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.50-4vl3
161  - replace patch1 from RedHat (RHSA-2003:199-02).
162
163  - Fri Jul 18 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 5.50-4vl2
164  - added patch1 from Redhat (RHSA-2003:199-01)
165
166
167* Sun Dec  1 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.50-5vl1
168- modified changelog section :-P (merge rawhidee changelogs)
169
170  - Sun Dec  1 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-4vl2
171  - rebuild with new toolchains
172
173  - Sun May 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-4vl1
174  - based on 5.50-4 from Rawhide
175  - previous Vine version was 5.41-3vl1:
176
177  - Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
178  - 5.41-3vl1
179  - based on 5.41-3 from Rawhide
180  - added Japanese summary and description
181  - use better macros
182
183* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
184- automated rebuild
185
186* Thu May 23 2002 Tim Powers <timp@redhat.com>
187- automated rebuild
188
189* Thu Apr 25 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-3
190- Rebuild
191
192* Tue Apr  2 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-2
193- Make it not strip
194
195* Wed Mar 13 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-1
196- 5.50
197
198* Thu Feb 21 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.42-3
199- Rebuild
200
201* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
202- automated rebuild
203
204* Mon May 21 2001 Trond Eivind Glomsr︰ <teg@redhat.com>
205- 5.42
206- Don't strip binaries explicitly
207- build without assembly, it doesn't seem to increase performance
208- make it respect RPM_OPT_FLAGS, define _GNU_SOURCE
209- use %%{_tmppath}
210- "License:" replaces "Copyright:"
211- Update URL
212- include zipgrep
213- COPYING doesn't exist anymore, include LICENSE instead
214
215* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
216- automatic rebuild
217
218* Sun Jun 11 2000 BIll Nottingham <notting@redhat.com>
219- rebuild in new env.; FHS fixes.
220
221* Tue Apr 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
222- 4.51 (an acceptable license at last...)
223
224* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
225- handle compressed man pages
226
227* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
228- update to 5.40
229
230* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
231- auto rebuild in the new build environment (release 5)
232
233* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
234- built for 6.0
235
236* Tue Aug 11 1998 Jeff Johnson <jbj@redhat.com>
237- build root
238
239* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
240- translations modified for de, fr, tr
241
242* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
243- builds on non i386 platforms
244
245* Mon Oct 20 1997 Otto Hammersmith <otto@redhat.com>
246- updated the version
247
248* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
249- built against glibc
250
Note: See TracBrowser for help on using the repository browser.