source: projects/specs/trunk/u/unzip/unzip-vl.spec @ 521

Revision 521, 6.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define src_ver 5.52
2%define src_file unzip552
3
4Summary: A utility for unpacking zip files.
5Summary(ja): zip ファイルを展開するユーティリティ
6Name: unzip
7Version: %{src_ver}
8Release: 2%{?_dist_release}
9License: BSD
10Group: Applications/Archiving
11Source: ftp://ftp.info-zip.org/pub/infozip/src/%{src_file}.tar.gz
12Patch0: unzip542-rpmoptflags.patch
13
14Patch1: unzip-5.52-near-4GB.patch
15Patch2: unzip-5.52-near-4GB2.patch
16# Patch3: unzip-5.51-near-4GB3.patch
17Patch10: unzip-5.51-link-segv.patch
18Patch11: unzip-5.51-link-segv2.patch
19# Patch12: unzip-5.51-link-segv3.patch
20Patch13: unzip-5.52-open.patch
21
22Patch100: unzip-5.52_CVE-2005-4667.patch
23Patch110: unzip-5.52-deb-CVE-2008-0888.patch
24
25# http://www.coara.or.jp/~sudakyo/dasworksrpms.html#unzip
26Patch200: unzip-5.52-nls.patch
27
28URL: http://www.info-zip.org/pub/infozip/UnZip.html
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30
31Vendor: Project Vine
32Distribution: Vine Linux
33
34%description
35The unzip utility is used to list, test, or extract files from a zip
36archive.  Zip archives are commonly found on MS-DOS systems.  The zip
37utility, included in the zip package, creates zip archives.  Zip and
38unzip are both compatible with archives created by PKWARE(R)'s PKZIP
39for MS-DOS, but the programs' options and default behaviors do differ
40in some respects.
41
42Install the unzip package if you need to list, test or extract files from
43a zip archive.
44
45%description -l ja
46unzip ユーティリティは,zip アーカイブ内のファイルを一覧表示したり,
47テスト/展開する為に使うユーティリティです.zip アーカイブは MS-DOS
48システムで一般的に使われます.
49zip パッケージに含まれる zip プログラムは zip アーカイブを
50作成するのに使います.
51zip と unzip は PKWARE(R) の MS-DOS 用 PKZIP で作成された zip アーカイブに
52対応していますが,デフォルトの動作やプログラムオプション等一部が
53異なります.
54
55
56%prep
57%setup -q
58%patch0 -p1 -b .rpmo
59%patch1 -p1 -b .4GB
60%patch2 -p1 -b .4GB2
61# %patch3 -p1 -b .4GB3
62
63%patch10 -p1 -b .link-segv
64%patch11 -p1 -b .morn
65# %patch12 -p1 -b .morn2
66%patch13 -p1 -b .open
67
68%patch100 -p1 -b .CVE-2005-4667
69%patch110 -p0 -b .CVE-2008-0888
70
71%patch200 -p1 -b .nls
72
73ln -s unix/Makefile Makefile
74
75%build
76make LOCAL_UNZIP="-DNLS" CFLAGS="-D_LARGEFILE64_SOURCE" linux_noasm LF2=""
77
78
79%install
80[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
81
82make prefix=$RPM_BUILD_ROOT%{_prefix} MANDIR=$RPM_BUILD_ROOT/%{_mandir}/man1 install LF2=""
83
84
85%clean
86[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
87
88
89%files
90%defattr(-,root,root)
91%doc README BUGS LICENSE INSTALL
92%{_bindir}/*
93%{_mandir}/*/*
94
95
96%changelog
97* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.52-2
98- spec in utf-8
99- add NLS patch
100
101* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.52-1
102- new upstream release
103- add patch13 from fc8
104- update patches to fit new release & drop old patches
105- with new versioning polity
106
107* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-11vl4
108- fix changelog typo
109
110* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-10vl4
111- update patch100 to fix ppc issue (it was patch5, from rhel4)
112- renumber patchs
113- add patch 2,3 to support big archive (from rhel4)
114- with new versioning polity
115
116* Fri Mar 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-9vl1.1
117- add patch5 for fix CVE-2005-4667
118- add patch6 for fix CVE-2008-0888
119- add Vendor/Distribution tag
120
121* Tue May 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.51-9vl1
122- new upstream release
123- based on 5.51-9 Fedora development
124  * Thu Feb 10 2005 Ivana Varekova <varekova@redhat.com> 5.51-9
125  - fix the other problem with unpacking zipfiles containing symlinks
126    (bug #134073)
127  * Thu Feb 03 2005 Ivana Varekova <varekova@redhat.com> 5.51-8
128  - fix segfault with unpacking of zipfiles containing dangling symlinks
129    (bug #134073)
130  * Thu Dec 02 2004 Lon Hohberger <lhh@redhat.com> 5.51-5
131  - Fix segfault on extraction of symlinks
132  * Mon Jun 21 2004 Lon Hohberger <lhh@redhat.com> 5.51-4
133  - Extend max file/archive size to 2^32-8193 (4294959103) bytes
134  * Tue Jun 08 2004 Lon Hohberger <lhh@redhat.com> 5.51-1.1
135  - Update to 5.51; remove dotdot patch.
136
137* Tue Sep 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-5vl2
138- merged patch1 from Vine Linux 2.6 updates
139  - Thu Aug 28 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.50-4vl3
140  - replace patch1 from RedHat (RHSA-2003:199-02).
141
142  - Fri Jul 18 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 5.50-4vl2
143  - added patch1 from Redhat (RHSA-2003:199-01)
144
145
146* Sun Dec  1 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.50-5vl1
147- modified changelog section :-P (merge rawhidee changelogs)
148
149  - Sun Dec  1 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-4vl2
150  - rebuild with new toolchains
151
152  - Sun May 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-4vl1
153  - based on 5.50-4 from Rawhide
154  - previous Vine version was 5.41-3vl1:
155
156  - Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
157  - 5.41-3vl1
158  - based on 5.41-3 from Rawhide
159  - added Japanese summary and description
160  - use better macros
161
162* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
163- automated rebuild
164
165* Thu May 23 2002 Tim Powers <timp@redhat.com>
166- automated rebuild
167
168* Thu Apr 25 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-3
169- Rebuild
170
171* Tue Apr  2 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-2
172- Make it not strip
173
174* Wed Mar 13 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-1
175- 5.50
176
177* Thu Feb 21 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.42-3
178- Rebuild
179
180* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
181- automated rebuild
182
183* Mon May 21 2001 Trond Eivind Glomsr︰ <teg@redhat.com>
184- 5.42
185- Don't strip binaries explicitly
186- build without assembly, it doesn't seem to increase performance
187- make it respect RPM_OPT_FLAGS, define _GNU_SOURCE
188- use %%{_tmppath}
189- "License:" replaces "Copyright:"
190- Update URL
191- include zipgrep
192- COPYING doesn't exist anymore, include LICENSE instead
193
194* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
195- automatic rebuild
196
197* Sun Jun 11 2000 BIll Nottingham <notting@redhat.com>
198- rebuild in new env.; FHS fixes.
199
200* Tue Apr 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
201- 4.51 (an acceptable license at last...)
202
203* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
204- handle compressed man pages
205
206* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
207- update to 5.40
208
209* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
210- auto rebuild in the new build environment (release 5)
211
212* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
213- built for 6.0
214
215* Tue Aug 11 1998 Jeff Johnson <jbj@redhat.com>
216- build root
217
218* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
219- translations modified for de, fr, tr
220
221* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
222- builds on non i386 platforms
223
224* Mon Oct 20 1997 Otto Hammersmith <otto@redhat.com>
225- updated the version
226
227* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
228- built against glibc
229
Note: See TracBrowser for help on using the repository browser.