source: projects/specs/trunk/u/unzip/unzip-vl.spec @ 12120

Revision 12120, 9.9 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define src_file unzip60
2
3Summary: A utility for unpacking zip files.
4Summary(ja): zip ファイルを展開するユーティリティ
5Name: unzip
6Version: 6.0
7Release: 5%{?_dist_release}
8License: BSD
9Group: Applications/Archiving
10URL: http://www.info-zip.org/UnZip.html
11
12Source: http://downloads.sourceforge.net/infozip/%{src_file}.tar.gz
13
14# Not sent to upstream.
15Patch1: unzip-6.0-bzip2-configure.patch
16# Upstream plans to do this in zip (hopefully also in unzip).
17Patch2: unzip-6.0-exec-shield.patch
18# Upstream plans to do similar thing.
19Patch3: unzip-6.0-close.patch
20# Details in rhbz#532380.
21# Reported to upstream: http://www.info-zip.org/board/board.pl?m-1259575993/
22Patch4: unzip-6.0-attribs-overflow.patch
23# Not sent to upstream, as it's Fedora/RHEL specific.
24# Modify the configure script not to request the strip of binaries.
25Patch5: unzip-6.0-nostrip.patch
26Patch6: unzip-6.0-manpage-fix.patch
27# Update match.c with recmatch() from zip 3.0's util.c
28# This also resolves the license issue in that old function.
29# Original came from here: https://projects.parabolagnulinux.org/abslibre.git/plain/libre/unzip-libre/match.patch
30Patch7: unzip-6.0-fix-recmatch.patch
31# Update process.c
32Patch8: unzip-6.0-symlink.patch
33# change using of macro "case_map" by "to_up"
34Patch9: unzip-6.0-caseinsensitive.patch
35# downstream fix for "-Werror=format-security"
36# upstream doesn't want hear about this option again
37Patch10: unzip-6.0-format-secure.patch
38Patch11: unzip-6.0-valgrind.patch
39Patch12: unzip-6.0-x-option.patch
40
41# security
42Patch100: unzip-6.0-cve-2014-8139.patch
43Patch110: unzip-6.0-cve-2014-8140.patch
44Patch120: unzip-6.0-cve-2014-8141.patch
45## http://www.openwall.com/lists/oss-security/2014/11/03/10
46Patch130: unzip-6.0-CVE-2014-9636.patch
47
48Patch17: unzip-6.0-overflow-long-fsize.patch
49# Fix heap overflow and infinite loop when invalid input is given (#1260947)
50Patch18: unzip-6.0-heap-overflow-infloop.patch
51
52Patch21: 0001-Fix-CVE-2016-9844-rhbz-1404283.patch
53
54# restore unix timestamp accurately
55Patch22: unzip-6.0-timestamp.patch
56
57# fix possible heap based stack overflow in passwd protected files
58Patch23: unzip-6.0-cve-2018-1000035-heap-based-overflow.patch
59
60Patch24: unzip-6.0-cve-2018-18384.patch
61
62
63# japanese charset support
64# https://gist.github.com/hamano/573753
65Patch200: unzip-6.0-japanese_charset.patch
66# just ignore -E option, older nls patch use this.
67Patch201: unzip-6.0-ignore-E-option.patch
68# support ja_JP.utf8 locale
69Patch202: unzip-6.0-japanese_charset-utf8.patch
70
71BuildRoot: %{_tmppath}/%{name}-%{version}-root
72BuildRequires:  bzip2-devel, gcc
73
74Vendor: Project Vine
75Distribution: Vine Linux
76Packager: daisuke
77
78%description
79The unzip utility is used to list, test, or extract files from a zip
80archive.  Zip archives are commonly found on MS-DOS systems.  The zip
81utility, included in the zip package, creates zip archives.  Zip and
82unzip are both compatible with archives created by PKWARE(R)'s PKZIP
83for MS-DOS, but the programs' options and default behaviors do differ
84in some respects.
85
86Install the unzip package if you need to list, test or extract files from
87a zip archive.
88
89%description -l ja
90unzip ユーティリティは,zip アーカイブ内のファイルを一覧表示したり,
91テスト/展開する為に使うユーティリティです.zip アーカイブは MS-DOS
92システムで一般的に使われます.
93zip パッケージに含まれる zip プログラムは zip アーカイブを
94作成するのに使います.
95zip と unzip は PKWARE(R) の MS-DOS 用 PKZIP で作成された zip アーカイブに
96対応していますが,デフォルトの動作やプログラムオプション等一部が
97異なります.
98
99
100%prep
101%setup -q -n %{src_file}
102%patch1 -p1 -b .bzip2-configure
103%patch2 -p1 -b .exec-shield
104%patch3 -p1 -b .close
105%patch4 -p1 -b .attribs-overflow
106%patch5 -p1 -b .nostrip
107%patch6 -p1 -b .manpage-fix
108%patch7 -p1 -b .recmatch
109%patch8 -p1 -b .symlink
110%patch9 -p1 -b .caseinsensitive
111%patch10 -p1 -b .format-secure
112%patch11 -p1 -b .valgrind
113%patch12 -p1 -b .x-option
114
115# security
116%patch100 -p1 -b .CVE-2014-8139
117%patch110 -p1 -b .CVE-2014-8140
118%patch120 -p1 -b .CVE-2014-8141
119%patch130 -p1 -b .CVE-2014-9636
120
121%patch17 -p1 -b .overflow-long-fsize
122%patch18 -p1 -b .heap-overflow-infloop
123%patch21 -p1 -b .cve-2016-9844
124%patch22 -p1 -b .timestamp
125%patch23 -p1 -b .cve-2018-1000035
126%patch24 -p1 -b .cve-2018-18384
127
128%patch200 -p1 -b .jp
129%patch201 -p1 -b .ignore-E
130%patch202 -p1 -b .utf8
131
132ln -s unix/Makefile Makefile
133
134%build
135make LOCAL_UNZIP="-D_FILE_OFFSET_BITS=64 -DNO_LCHMOD -D_MBCS -DNO_WORKING_ISPRINT" linux_noasm
136
137%install
138[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
139
140make prefix=$RPM_BUILD_ROOT%{_prefix} MANDIR=$RPM_BUILD_ROOT/%{_mandir}/man1 install LF2=""
141
142
143%clean
144[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
145
146
147%files
148%defattr(-,root,root)
149%doc README BUGS LICENSE INSTALL
150%{_bindir}/*
151%{_mandir}/*/*
152
153
154%changelog
155* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0-5
156- imported Patch17-18, 21-24 from rawhide.
157- replaced Patch100-120 to rawhide's one.
158
159* Sun Feb  8 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 6.0-4
160- add Patch130 for CVE-2014-9636 (heap overflow)
161
162* Sun Jan 18 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>  6.0-3
163- add Patch100 for fix CVE-2014-8139 (crc-overflow)
164- add Patch110 for fix CVE-2014-8140 (test-compr-eb)
165- add Patch120 for fix CVE-2014-8141 (getzip64data)
166- add Patch9-12 from fc22
167
168* Thu Jul 03 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.0-2
169- add patch202 to support ja_JP.utf8
170
171* Thu May 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.0-1
172- update to 6.0
173- replace nls patch.
174
175* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 5.52-3vl6
176- build on current VineSeed
177
178* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.52-2
179- spec in utf-8
180- add NLS patch
181
182* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.52-1
183- new upstream release
184- add patch13 from fc8
185- update patches to fit new release & drop old patches
186- with new versioning polity
187
188* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-11vl4
189- fix changelog typo
190
191* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-10vl4
192- update patch100 to fix ppc issue (it was patch5, from rhel4)
193- renumber patchs
194- add patch 2,3 to support big archive (from rhel4)
195- with new versioning polity
196
197* Fri Mar 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-9vl1.1
198- add patch5 for fix CVE-2005-4667
199- add patch6 for fix CVE-2008-0888
200- add Vendor/Distribution tag
201
202* Tue May 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.51-9vl1
203- new upstream release
204- based on 5.51-9 Fedora development
205  * Thu Feb 10 2005 Ivana Varekova <varekova@redhat.com> 5.51-9
206  - fix the other problem with unpacking zipfiles containing symlinks
207    (bug #134073)
208  * Thu Feb 03 2005 Ivana Varekova <varekova@redhat.com> 5.51-8
209  - fix segfault with unpacking of zipfiles containing dangling symlinks
210    (bug #134073)
211  * Thu Dec 02 2004 Lon Hohberger <lhh@redhat.com> 5.51-5
212  - Fix segfault on extraction of symlinks
213  * Mon Jun 21 2004 Lon Hohberger <lhh@redhat.com> 5.51-4
214  - Extend max file/archive size to 2^32-8193 (4294959103) bytes
215  * Tue Jun 08 2004 Lon Hohberger <lhh@redhat.com> 5.51-1.1
216  - Update to 5.51; remove dotdot patch.
217
218* Tue Sep 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-5vl2
219- merged patch1 from Vine Linux 2.6 updates
220  - Thu Aug 28 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.50-4vl3
221  - replace patch1 from RedHat (RHSA-2003:199-02).
222
223  - Fri Jul 18 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 5.50-4vl2
224  - added patch1 from Redhat (RHSA-2003:199-01)
225
226
227* Sun Dec  1 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.50-5vl1
228- modified changelog section :-P (merge rawhidee changelogs)
229
230  - Sun Dec  1 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-4vl2
231  - rebuild with new toolchains
232
233  - Sun May 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-4vl1
234  - based on 5.50-4 from Rawhide
235  - previous Vine version was 5.41-3vl1:
236
237  - Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
238  - 5.41-3vl1
239  - based on 5.41-3 from Rawhide
240  - added Japanese summary and description
241  - use better macros
242
243* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
244- automated rebuild
245
246* Thu May 23 2002 Tim Powers <timp@redhat.com>
247- automated rebuild
248
249* Thu Apr 25 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-3
250- Rebuild
251
252* Tue Apr  2 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-2
253- Make it not strip
254
255* Wed Mar 13 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-1
256- 5.50
257
258* Thu Feb 21 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.42-3
259- Rebuild
260
261* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
262- automated rebuild
263
264* Mon May 21 2001 Trond Eivind Glomsr︰ <teg@redhat.com>
265- 5.42
266- Don't strip binaries explicitly
267- build without assembly, it doesn't seem to increase performance
268- make it respect RPM_OPT_FLAGS, define _GNU_SOURCE
269- use %%{_tmppath}
270- "License:" replaces "Copyright:"
271- Update URL
272- include zipgrep
273- COPYING doesn't exist anymore, include LICENSE instead
274
275* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
276- automatic rebuild
277
278* Sun Jun 11 2000 BIll Nottingham <notting@redhat.com>
279- rebuild in new env.; FHS fixes.
280
281* Tue Apr 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
282- 4.51 (an acceptable license at last...)
283
284* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
285- handle compressed man pages
286
287* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
288- update to 5.40
289
290* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
291- auto rebuild in the new build environment (release 5)
292
293* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
294- built for 6.0
295
296* Tue Aug 11 1998 Jeff Johnson <jbj@redhat.com>
297- build root
298
299* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
300- translations modified for de, fr, tr
301
302* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
303- builds on non i386 platforms
304
305* Mon Oct 20 1997 Otto Hammersmith <otto@redhat.com>
306- updated the version
307
308* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
309- built against glibc
310
Note: See TracBrowser for help on using the repository browser.