source: projects/specs/trunk/u/unzip/unzip-vl.spec @ 9397

Revision 9397, 9.1 KB checked in by iwaim, 9 years ago (diff)

unzip 6.0-4

Line 
1%define src_file unzip60
2
3Summary: A utility for unpacking zip files.
4Summary(ja): zip ファイルを展開するユーティリティ
5Name: unzip
6Version: 6.0
7Release: 4%{?_dist_release}
8License: BSD
9Group: Applications/Archiving
10URL: http://www.info-zip.org/UnZip.html
11
12Source: http://downloads.sourceforge.net/infozip/%{src_file}.tar.gz
13
14# Not sent to upstream.
15Patch1: unzip-6.0-bzip2-configure.patch
16# Upstream plans to do this in zip (hopefully also in unzip).
17Patch2: unzip-6.0-exec-shield.patch
18# Upstream plans to do similar thing.
19Patch3: unzip-6.0-close.patch
20# Details in rhbz#532380.
21# Reported to upstream: http://www.info-zip.org/board/board.pl?m-1259575993/
22Patch4: unzip-6.0-attribs-overflow.patch
23# Not sent to upstream, as it's Fedora/RHEL specific.
24# Modify the configure script not to request the strip of binaries.
25Patch5: unzip-6.0-nostrip.patch
26Patch6: unzip-6.0-manpage-fix.patch
27# Update match.c with recmatch() from zip 3.0's util.c
28# This also resolves the license issue in that old function.
29# Original came from here: https://projects.parabolagnulinux.org/abslibre.git/plain/libre/unzip-libre/match.patch
30Patch7: unzip-6.0-fix-recmatch.patch
31# Update process.c
32Patch8: unzip-6.0-symlink.patch
33# change using of macro "case_map" by "to_up"
34Patch9: unzip-6.0-caseinsensitive.patch
35# downstream fix for "-Werror=format-security"
36# upstream doesn't want hear about this option again
37Patch10: unzip-6.0-format-secure.patch
38Patch11: unzip-6.0-valgrind.patch
39Patch12: unzip-6.0-x-option.patch
40
41# security
42Patch100: unzip-6.0-CVE-2014-8139.patch
43Patch110: unzip-6.0-CVE-2014-8140.patch
44Patch120: unzip-6.0-CVE-2014-8141.patch
45## http://www.openwall.com/lists/oss-security/2014/11/03/10
46Patch130: unzip-6.0-CVE-2014-9636.patch
47
48# japanese charset support
49# https://gist.github.com/hamano/573753
50Patch200: unzip-6.0-japanese_charset.patch
51# just ignore -E option, older nls patch use this.
52Patch201: unzip-6.0-ignore-E-option.patch
53# support ja_JP.utf8 locale
54Patch202: unzip-6.0-japanese_charset-utf8.patch
55
56BuildRoot: %{_tmppath}/%{name}-%{version}-root
57
58Vendor: Project Vine
59Distribution: Vine Linux
60Packager: daisuke
61
62%description
63The unzip utility is used to list, test, or extract files from a zip
64archive.  Zip archives are commonly found on MS-DOS systems.  The zip
65utility, included in the zip package, creates zip archives.  Zip and
66unzip are both compatible with archives created by PKWARE(R)'s PKZIP
67for MS-DOS, but the programs' options and default behaviors do differ
68in some respects.
69
70Install the unzip package if you need to list, test or extract files from
71a zip archive.
72
73%description -l ja
74unzip ユーティリティは,zip アーカイブ内のファイルを一覧表示したり,
75テスト/展開する為に使うユーティリティです.zip アーカイブは MS-DOS
76システムで一般的に使われます.
77zip パッケージに含まれる zip プログラムは zip アーカイブを
78作成するのに使います.
79zip と unzip は PKWARE(R) の MS-DOS 用 PKZIP で作成された zip アーカイブに
80対応していますが,デフォルトの動作やプログラムオプション等一部が
81異なります.
82
83
84%prep
85%setup -q -n %{src_file}
86%patch1 -p1 -b .bzip2-configure
87%patch2 -p1 -b .exec-shield
88%patch3 -p1 -b .close
89%patch4 -p1 -b .attribs-overflow
90%patch5 -p1 -b .nostrip
91%patch6 -p1 -b .manpage-fix
92%patch7 -p1 -b .recmatch
93%patch8 -p1 -b .symlink
94%patch9 -p1 -b .caseinsensitive
95%patch10 -p1 -b .format-secure
96%patch11 -p1 -b .valgrind
97%patch12 -p1 -b .x-option
98
99# security
100%patch100 -p1 -b .CVE-2014-8139
101%patch110 -p1 -b .CVE-2014-8140
102%patch120 -p1 -b .CVE-2014-8141
103%patch130 -p1 -b .CVE-2014-9636
104
105%patch200 -p1 -b .jp
106%patch201 -p1 -b .ignore-E
107%patch202 -p1 -b .utf8
108
109ln -s unix/Makefile Makefile
110
111%build
112make LOCAL_UNZIP="-D_FILE_OFFSET_BITS=64 -DNO_LCHMOD -D_MBCS -DNO_WORKING_ISPRINT" linux_noasm
113
114%install
115[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
116
117make prefix=$RPM_BUILD_ROOT%{_prefix} MANDIR=$RPM_BUILD_ROOT/%{_mandir}/man1 install LF2=""
118
119
120%clean
121[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
122
123
124%files
125%defattr(-,root,root)
126%doc README BUGS LICENSE INSTALL
127%{_bindir}/*
128%{_mandir}/*/*
129
130
131%changelog
132* Sun Feb  8 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 6.0-4
133- add Patch130 for CVE-2014-9636 (heap overflow)
134
135* Sun Jan 18 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>  6.0-3
136- add Patch100 for fix CVE-2014-8139 (crc-overflow)
137- add Patch110 for fix CVE-2014-8140 (test-compr-eb)
138- add Patch120 for fix CVE-2014-8141 (getzip64data)
139- add Patch9-12 from fc22
140
141* Thu Jul 03 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.0-2
142- add patch202 to support ja_JP.utf8
143
144* Thu May 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.0-1
145- update to 6.0
146- replace nls patch.
147
148* Tue Apr  5 2011 IWAI, Masaharu <iwai@alib.jp> 5.52-3vl6
149- build on current VineSeed
150
151* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.52-2
152- spec in utf-8
153- add NLS patch
154
155* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.52-1
156- new upstream release
157- add patch13 from fc8
158- update patches to fit new release & drop old patches
159- with new versioning polity
160
161* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-11vl4
162- fix changelog typo
163
164* Wed Apr 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-10vl4
165- update patch100 to fix ppc issue (it was patch5, from rhel4)
166- renumber patchs
167- add patch 2,3 to support big archive (from rhel4)
168- with new versioning polity
169
170* Fri Mar 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.51-9vl1.1
171- add patch5 for fix CVE-2005-4667
172- add patch6 for fix CVE-2008-0888
173- add Vendor/Distribution tag
174
175* Tue May 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.51-9vl1
176- new upstream release
177- based on 5.51-9 Fedora development
178  * Thu Feb 10 2005 Ivana Varekova <varekova@redhat.com> 5.51-9
179  - fix the other problem with unpacking zipfiles containing symlinks
180    (bug #134073)
181  * Thu Feb 03 2005 Ivana Varekova <varekova@redhat.com> 5.51-8
182  - fix segfault with unpacking of zipfiles containing dangling symlinks
183    (bug #134073)
184  * Thu Dec 02 2004 Lon Hohberger <lhh@redhat.com> 5.51-5
185  - Fix segfault on extraction of symlinks
186  * Mon Jun 21 2004 Lon Hohberger <lhh@redhat.com> 5.51-4
187  - Extend max file/archive size to 2^32-8193 (4294959103) bytes
188  * Tue Jun 08 2004 Lon Hohberger <lhh@redhat.com> 5.51-1.1
189  - Update to 5.51; remove dotdot patch.
190
191* Tue Sep 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-5vl2
192- merged patch1 from Vine Linux 2.6 updates
193  - Thu Aug 28 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.50-4vl3
194  - replace patch1 from RedHat (RHSA-2003:199-02).
195
196  - Fri Jul 18 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 5.50-4vl2
197  - added patch1 from Redhat (RHSA-2003:199-01)
198
199
200* Sun Dec  1 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.50-5vl1
201- modified changelog section :-P (merge rawhidee changelogs)
202
203  - Sun Dec  1 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-4vl2
204  - rebuild with new toolchains
205
206  - Sun May 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.50-4vl1
207  - based on 5.50-4 from Rawhide
208  - previous Vine version was 5.41-3vl1:
209
210  - Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
211  - 5.41-3vl1
212  - based on 5.41-3 from Rawhide
213  - added Japanese summary and description
214  - use better macros
215
216* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
217- automated rebuild
218
219* Thu May 23 2002 Tim Powers <timp@redhat.com>
220- automated rebuild
221
222* Thu Apr 25 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-3
223- Rebuild
224
225* Tue Apr  2 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-2
226- Make it not strip
227
228* Wed Mar 13 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.50-1
229- 5.50
230
231* Thu Feb 21 2002 Trond Eivind Glomsr︰ <teg@redhat.com> 5.42-3
232- Rebuild
233
234* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
235- automated rebuild
236
237* Mon May 21 2001 Trond Eivind Glomsr︰ <teg@redhat.com>
238- 5.42
239- Don't strip binaries explicitly
240- build without assembly, it doesn't seem to increase performance
241- make it respect RPM_OPT_FLAGS, define _GNU_SOURCE
242- use %%{_tmppath}
243- "License:" replaces "Copyright:"
244- Update URL
245- include zipgrep
246- COPYING doesn't exist anymore, include LICENSE instead
247
248* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
249- automatic rebuild
250
251* Sun Jun 11 2000 BIll Nottingham <notting@redhat.com>
252- rebuild in new env.; FHS fixes.
253
254* Tue Apr 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
255- 4.51 (an acceptable license at last...)
256
257* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
258- handle compressed man pages
259
260* Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
261- update to 5.40
262
263* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
264- auto rebuild in the new build environment (release 5)
265
266* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
267- built for 6.0
268
269* Tue Aug 11 1998 Jeff Johnson <jbj@redhat.com>
270- build root
271
272* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
273- translations modified for de, fr, tr
274
275* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
276- builds on non i386 platforms
277
278* Mon Oct 20 1997 Otto Hammersmith <otto@redhat.com>
279- updated the version
280
281* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
282- built against glibc
283
Note: See TracBrowser for help on using the repository browser.