source: projects/specs/trunk/u/unixODBC/unixODBC-vl.spec @ 12141

Revision 12141, 9.2 KB checked in by ara_t, 5 years ago (diff)

unixODBC: rebuild with readline-8.0

Line 
1Name: unixODBC
2Version: 2.3.7
3Release: 2%{?_dist_release}
4Summary: A complete ODBC Driver Manager for Linux
5Summary(ja): Linux 用 ODBC ドライバマネージャー
6
7Group: System Environment/Libraries
8# Programs are GPL, libraries are LGPL, except News Server library is GPL.
9License: GPLv2+ and LGPLv2+
10URL: http://www.unixODBC.org/
11
12Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
13Source1: odbcinst.ini
14Source4: conffile.h
15Source5: README.dist
16
17Patch8: so-version-bump.patch
18Patch9: keep-typedefs.patch
19
20Conflicts: iodbc
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
24BuildRequires: readline-devel
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30Install unixODBC if you want to access databases through ODBC.
31You will also need the mysql-connector-odbc package if you want to access
32a MySQL database, and/or the postgresql-odbc package for PostgreSQL.
33
34%package devel
35Summary: Development files for programs which will use the unixODBC library.
36Summary(ja): unixODBC ライブラリを用いるプログラムのための開発用ファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description devel
41The unixODBC package can be used to access databases through ODBC
42drivers. If you want to develop programs that will access data through
43ODBC, you need to install this package.
44
45%prep
46%setup -q
47%patch8 -p1
48%patch9 -p1
49
50chmod 0644 Drivers/MiniSQL/*.c
51chmod 0644 Drivers/nn/*.c
52chmod 0644 Drivers/template/*.c
53chmod 0644 doc/ProgrammerManual/Tutorial/*.html
54chmod 0644 doc/lst/*
55chmod 0644 include/odbcinst.h
56
57%build
58autoreconf -ivf
59
60# unixODBC 2.2.14 is not aliasing-safe
61CFLAGS="%{optflags} -fno-strict-aliasing"
62CXXFLAGS="$CFLAGS"
63export CFLAGS CXXFLAGS
64
65%configure --with-gnu-ld=yes --enable-threads=yes \
66        --enable-drivers=yes --enable-driverc=yes --enable-ltdllib
67
68# Get rid of the rpaths
69sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
70sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
71
72make all
73
74%install
75rm -rf $RPM_BUILD_ROOT
76make DESTDIR=$RPM_BUILD_ROOT install
77install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
78
79# multilib header hacks
80# we only apply this to known Red Hat multilib arches, per bug #181335
81case `uname -i` in
82  i386 | x86_64 | ia64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
83    mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
84    rm -f unixodbc_conf.h
85    sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
86    install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
87    ;;
88  *)
89    ;;
90esac
91
92# add some explanatory documentation
93cp %{SOURCE5} README.dist
94
95# remove obsolete Postgres drivers from the package (but not the setup code)
96rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
97
98# copy text driver documentation into main doc directory
99# currently disabled because upstream no longer includes text driver
100# mkdir -p doc/Drivers/txt
101# cp -pr Drivers/txt/doc/* doc/Drivers/txt
102
103# don't want to install doc Makefiles as docs
104find doc -name 'Makefile*' | xargs rm
105
106# we do not want to ship static libraries
107rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
108
109# remove unpackaged files from the buildroot
110rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
111rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
112rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
113
114# initialize lists of .so files
115find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
116find $RPM_BUILD_ROOT%{_libdir} -name "*.so"   | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
117
118# move these to main package, they're often dlopened...
119for lib in libodbc.so libodbcinst.so libodbcpsqlS.so libodbcmyS.so
120do
121    echo "%{_libdir}/$lib" >> base-so-list
122    grep -v "/$lib$" devel-so-list > devel-so-list.x
123    mv -f devel-so-list.x devel-so-list
124done
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
133%files -f base-so-list
134%doc README COPYING AUTHORS ChangeLog NEWS doc
135%doc README.dist
136%config(noreplace) %{_sysconfdir}/odbc*
137%{_bindir}/odbcinst
138%{_bindir}/isql
139%{_bindir}/dltest
140%{_bindir}/iusql
141%{_bindir}/odbc_config
142%{_bindir}/slencheck
143%{_mandir}/man*/*
144
145%files devel -f devel-so-list
146%{_includedir}/*
147%{_libdir}/pkgconfig/*.pc
148
149%changelog
150* Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 2.3.7-2
151- rebuild with readline-8.0
152
153* Wed Dec 12 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.7-1
154- new upstream release.
155- dropped Patch6: fixed in upstream.
156
157* Sat Jan 20 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.5-1
158- new upstream release.
159
160* Tue Jan  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
161- new upstream release.
162
163* Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
164- rebuilt with readline 6.3
165- removed kde-subpackage-related BuildRequires
166- added Japanese summary
167
168* Tue Jul  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
169- new upstream release.
170- gui was discontinued in upstream.
171
172* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
173- rebuild with VineSeed environment
174
175* Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
176- add --with-qt-includes option for configure
177
178* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
179- updated to 2.2.14
180
181* Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
182- applied new versioning policy
183- removed *.la files from devel package
184
185* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
186- updated to 2.2.12
187- rebuilt with new toolchain
188
189* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
190- use installed libltdl
191- added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
192
193* Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
194- rebuilt with readline 5.1
195
196* Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
197- updated to 2.2.11
198- not libtoolize
199
200* Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
201- added Patch100 to fix typo in doc/Makefile.am from failure on compiling
202
203* Fri Jun  6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
204- source upgrade
205- remove patch (no need)
206- run libtoolize etc for VineSeed
207
208* Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
209- enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
210
211* Sun Feb  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
212- source upgrade
213- change spec to build both VineSeed and Vine2.5/2.6
214- add patch from rawhide 2.2.3-6
215
216* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
217- Requires: libjpeg (not libjpeg-6b)
218
219* Sun Oct  6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
220- source upgrade
221- add BuildPrereq: autoconf253 automake15
222- add PreReq: ldconfig
223- fix %files section and clean up spec
224- for unixODBC-kde package
225  - add Requires: unixODBC = %{version}
226  - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
227  - delete .desktop files
228
229* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
230- rebuild with KDE3
231
232* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
233- updated unixODBC-2.2.0
234- fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
235
236* Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
237- remove -kde package on alpha
238
239* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
240- Rebuild for Vine.
241
242* Sun Jun 24 2001 Than Ngo <than@redhat.com>
243- rebuild against qt-2.3.1, kde-2.1.x
244
245* Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
246- Better default odbcinst.ini
247- Minor cleanups
248
249* Wed Jun  6 2001 Trond Eivind Glomsrød <teg@redhat.com>
250- 2.0.7
251
252* Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
253- Fix for isql segfault on EOF/ctrl-d exit
254
255* Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
256- 2.0.6
257- add patch for 64 bit archs (dword shouldn't be "long int")
258
259* Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
260- rebuild
261
262* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
263- 1.8.13
264
265* Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
266- enable GUI now that we have KDE compiled with the standard
267  compiler
268- move the applnk entries to the KDE package
269
270* Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
271- add the missing shared libs to the non-devel package
272
273* Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
274- 1.8.12 fixes problems with the postgresql driver
275
276* Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
277- disable KDE subpackage to avoid the mess that is C++ binary
278  compatibility
279
280* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
281- automatic rebuild
282
283* Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
284- improved QTDIR detection
285
286* Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
287- 1.8.10
288- use %%{_tmppath}
289- update URL
290- including two missing libraries
291
292* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
293- 1.8.9
294
295* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
296- adopted for Winston, changed to Red Hat packaging standards
297
298* Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
299- added a unixODBC-devel RPM to the group, added KDE links and icons to system
300- all of which came from recommendations from Fredrick Meunier
301- <Fredrick.Meunier@computershare.com.au>
302
303* Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
304- unixODBC-1.8.7
305- moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.
306
307
Note: See TracBrowser for help on using the repository browser.