source: projects/specs/trunk/u/unbound/unbound-vl.spec @ 7230

Revision 7230, 14.8 KB checked in by iwaim, 11 years ago (diff)

unbound 1.4.19-1

Line 
1%global with_munin 1
2
3# not ready yet
4%{?!with_python:      %global with_python      0}
5%{?!enable_gost:      %global enable_gost      0}
6
7%if %{with_python}
8%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
9%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
10%endif
11
12Summary: Validating, recursive, and caching DNS(SEC) resolver
13Name: unbound
14Version: 1.4.19
15Release: 1%{?_dist_release}
16License: BSD
17Url: http://www.unbound.net/
18Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
19Source1: unbound.init
20Source2: unbound.conf
21Source3: unbound.munin
22Source4: dlv.isc.org.key
23Source5: root.key
24
25Group: System Environment/Daemons
26BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
27BuildRequires: flex, ldns-devel >= 1.6.13,
28BuildRequires: libevent-devel
29BuildRequires: expat-devel
30%if %{with_python}
31BuildRequires:  python-devel swig
32%endif
33%if %{enable_gost}
34BuildRequires: openssl-devel >= 1.0.0
35%else
36BuildRequires: openssl-devel
37%endif
38# Required for SVN versions
39#BuildRequires: bison
40
41
42Requires(post): chkconfig
43Requires(preun): chkconfig
44Requires(preun): initscripts
45Requires(postun): initscripts
46Requires: ldns >= 1.5.0
47Requires(pre): shadow-utils
48
49Distribution: Vine Linux
50Vendor: Project Vine
51Packager: iwaim, daisuke
52
53%description
54Unbound is a validating, recursive, and caching DNS(SEC) resolver.
55
56The C implementation of Unbound is developed and maintained by NLnet
57Labs. It is based on ideas and algorithms taken from a java prototype
58developed by Verisign labs, Nominet, Kirei and ep.net.
59
60Unbound is designed as a set of modular components, so that also
61DNSSEC (secure DNS) validation and stub-resolvers (that do not run
62as a server, but are linked into an application) are easily possible.
63
64%if %{with_munin}
65%package munin
66Summary: Plugin for the munin / munin-node monitoring package
67Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
68Group:     System Environment/Daemons
69Requires: munin-node
70Requires: %{name} = %{version}-%{release}, bc
71
72%description munin
73Plugin for the munin / munin-node monitoring package
74%endif
75
76%package devel
77Summary: Development package that includes the unbound header files
78Group: Development/Libraries
79Requires: %{name}-libs = %{version}-%{release}, openssl-devel, ldns-devel
80
81%description devel
82The devel package contains the unbound library and the include files
83
84%package libs
85Summary: Libraries used by the unbound server and client applications
86Group: Applications/System
87Requires(post): /sbin/ldconfig
88Requires(postun): /sbin/ldconfig
89Requires: openssl >= 0.9.8g-12
90
91%description libs
92Contains libraries used by the unbound server and client applications
93
94%if %{with_python}
95%package python
96Summary: Python modules and extensions for unbound
97Group: Applications/System
98Requires: %{name}-libs = %{version}-%{release}
99
100%description python
101Python modules and extensions for unbound
102%endif
103
104%prep
105%setup -q
106
107%build
108%configure  --with-ldns= --with-libevent --with-pthreads --with-ssl \
109            --disable-rpath --enable-debug --disable-static \
110            --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
111            --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
112%if %{with_python}
113            --with-pythonmodule --with-pyunbound \
114%endif
115%if !%{enable_gost}
116            --disable-gost \
117%endif
118            --enable-sha2
119%{__make} %{?_smp_mflags}
120
121%install
122rm -rf %{buildroot}
123%{__make} DESTDIR=%{buildroot} install
124install -d 0755 %{buildroot}%{_initrddir}
125install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
126install -m 0755 %{SOURCE2} %{buildroot}%{_sysconfdir}/unbound
127%if %{with_munin}
128# Install munin plugin and its softlinks
129install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
130install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
131install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
132install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
133for plugin in unbound_munin_hits unbound_munin_queue unbound_munin_memory unbound_munin_by_type unbound_munin_by_class unbound_munin_by_opcode unbound_munin_by_rcode unbound_munin_by_flags unbound_munin_histogram; do
134    ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
135done
136%endif
137
138# install root and DLV key
139install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
140
141# remove static library from install (fedora packaging guidelines)
142rm -rf %{buildroot}%{_libdir}/*.la
143%if %{with_python}
144rm -rf %{buildroot}%{python_sitelib}/*/*.la
145%endif
146
147mkdir -p %{buildroot}%{_localstatedir}/run/unbound
148
149%clean
150rm -rf ${RPM_BUILD_ROOT}
151
152%files
153%defattr(-,root,root,-)
154%doc doc/README doc/CREDITS doc/LICENSE doc/FEATURES
155%attr(0755,root,root) %{_initrddir}/%{name}
156%attr(0755,root,root) %dir %{_sysconfdir}/%{name}
157%attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
158%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
159%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
160%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
161%{_sbindir}/*
162%{_mandir}/*/*
163
164%if %{with_python}
165%files python
166%{python_sitelib}/*
167%endif
168
169%if %{with_munin}
170%files munin
171%defattr(-,root,root,-)
172%config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
173%{_datadir}/munin/plugins/unbound*
174%endif
175
176%files devel
177%defattr(-,root,root,-)
178%{_libdir}/libunbound.so
179%{_includedir}/unbound.h
180%doc README
181
182%files libs
183%defattr(-,root,root,-)
184%{_libdir}/libunbound.so.*
185%doc doc/README doc/LICENSE
186
187%pre
188getent group unbound >/dev/null || groupadd -r unbound
189getent passwd unbound >/dev/null || \
190useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
191-c "Unbound DNS resolver" unbound
192exit 0
193
194%post
195/sbin/chkconfig --add %{name}
196# dnssec-conf used to contain our DLV key, but now we include it via unbound
197# If unbound had previously been configured with dnssec-configure, we need
198# to migrate the location of the DLV key file (to keep DLV enabled, and because
199# unbound won't start with a bad location for a DLV key file.
200sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
201
202%post libs -p /sbin/ldconfig
203
204%preun
205if [ "$1" -eq 0 ]; then
206        /sbin/service %{name} stop >/dev/null 2>&1
207        /sbin/chkconfig --del %{name}
208fi
209
210%postun
211if [ "$1" -ge "1" ]; then
212  /sbin/service %{name} condrestart >/dev/null 2>&1 || :
213fi
214
215%postun libs -p /sbin/ldconfig
216
217%changelog
218* Thu Dec 13 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.19-1
219- new upstream release
220- drop glob patch (Patch1): upstream merged
221
222* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
223- new upstream release
224
225* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
226- update to 1.4.17
227- add root.key for DNSSEC
228- enable munin subpackage by default
229- buildrequire ldns-devel >= 1.6.13
230
231* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
232- rebuild with python-2.7.2
233
234* Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
235- new upstream release
236
237* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
238- new upstream release
239
240* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
241- new upstream releas
242
243* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
244- new upstream release
245
246* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
247- new upstream release
248
249* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
250- rebuilt with libevent-2.0.10
251
252* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
253- new upstream release
254- add enable_gost flag: default disable
255- add BuildRequires: expat-devel
256
257* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
258- new upstream release
259
260* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
261- new upstream release
262
263* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
264- initial build for Vine Linux: based Fedora 1.4.3-1.fc14
265 - update to 1.4.4
266 - build without munin
267
268* Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
269- Update to 1.4.3 that fixes 64bit crasher
270
271* Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
272- Updated to 1.4.2
273- Updated unbound.conf with new options
274- Enabled pre-fetching DNSKEY records (DNSSEC speedup)
275- Enabled re-fetching popular records before they expire
276- Enabled logging of DNSSEC validation errors
277
278* Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
279- Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
280  with pthreads
281
282* Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
283- Change make/configure lines to attempt to fix -lphtread linking issue
284
285* Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
286- Removed dependancy for dnssec-conf
287- Added ISC DLV key (formerly in dnssec-conf)
288- Fixup old DLV locations in unbound.conf file via %%post
289- Fix parent child disagreement handling and no-ipv6 present [svn r1953]
290
291* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
292- Updated to 1.4.1
293- Changed %%define to %%global
294
295* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
296- Bump version
297
298* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
299- Upgraded to 1.3.4. Security fix with validating NSEC3 records
300
301* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
302- rebuilt with new openssl
303
304* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
305- Updated to 1.3.3
306
307* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
308- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
309
310* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
311- Added missing glob patch to cvs
312- Place python macros within the %%with_python check
313
314* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
315- Updated to 1.3.0
316- Added unbound-python sub package. disabled for now
317- Patch from svn to fix DLV lookups
318- Patches from svn to detect wrong truncated response from BIND 9.6.1 with
319  minimal-responses)
320- Added Default-Start and Default-Stop to unbound.init
321- Re-enabled --enable-sha2
322- Re-enabled glob.patch
323
324* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
325- unbound-iterator.patch was not commited
326
327* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
328- Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
329
330* Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
331- Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
332
333* Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
334- enable DNSSEC only if it is enabled in sysconfig/dnssec
335
336* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
337- add DNSSEC support to initscript and enabled it per default
338- add requires dnssec-conf
339
340* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
341- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
342
343* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
344- updated to 1.2.1
345
346* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
347- rebuild with new openssl
348
349* Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
350- Updated to 1.2.0
351- Added dependancy on minimum SSL for CVE-2008-5077
352- Added dependancy on bc for unbound-munin
353- Added minimum requirement of libevent 1.4.5. Crashes with older versions
354  (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
355- Removed dependancy on selinux-policy (will get used when available)
356- Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
357- Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
358- Enable val-clean-additional to drop addition unsigned data from signed
359  response.
360- Removed patches (got merged into upstream)
361
362* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
363- Modified scandir patch to silently fail when wildcard matches nothing
364- Patch to allow unbound-checkconf to find empty wildcard matches
365
366* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
367- Added scandir patch for trusted-keys-file: option, which
368  is used to load multiple dnssec keys in bind file format
369
370* Mon Dec  8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
371- Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
372
373* Mon Dec  1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
374- We did not own the /etc/unbound directory (#474020)
375- Fixed cvs anomalies
376
377* Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
378- removed all obsolete chroot related stuff
379- label control certs after generation correctly
380
381* Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
382- Updated to unbound 1.1.1 which fixes a crasher and
383  addresses nlnetlabs bug #219
384
385* Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
386- Remove the chroot, obsoleted by SElinux
387- Add additional munin plugin links supported by unbound plugin
388- Move configuration directory from /var/lib/unbound to /etc/unbound
389- Modified unbound.init and unbound.conf to account for chroot changes
390- Updated unbound.conf with new available options
391- Enabled dns-0x20 protection per default
392
393* Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
394- unbound-1.1.0-log_open.patch
395  - make sure log is opened before chroot call
396  - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
397- removed /dev/log and /var/run/unbound and /etc/resolv.conf from
398  chroot, not needed
399- don't mount files in chroot, it causes problems during updates
400- fixed typo in default config file
401
402* Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
403- Updated to version 1.1.0
404- Updated unbound.conf's statistics options and remote-control
405  to work properly for munin
406- Added unbound-munin package
407- Generate unbound remote-control  key/certs on first startup
408- Required ldns is now 1.4.0
409
410* Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
411- Only call ldconfig in -libs package
412- Move configure into build section
413- devel subpackage should only depend on libs subpackage
414
415* Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
416- Fix CFLAGS getting lost in build
417- Don't enable interface-automatic:yes because that
418  causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
419
420* Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
421- Split off unbound-libs, make build verbose
422
423* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
424- FSB compliance, chroot fixes, initscript fixes
425
426* Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
427- Upgraded to 1.0.2
428
429* Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
430- upgraded to new release
431
432* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
433- Build against ldns-1.3.0
434
435* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
436- Split of -devel package, fixed dependancies, make rpmlint happy
437
438* Thu Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
439- Using parts from ports collection entry by Jaap Akkerhuis.
440- Using Fedoraproject wiki guidelines.
441
442* Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
443- Initial version.
Note: See TracBrowser for help on using the repository browser.