source: projects/specs/trunk/u/unbound/unbound-vl.spec @ 7215

Revision 7215, 14.7 KB checked in by iwaim, 11 years ago (diff)

unbound 1.4.18-1

Line 
1%global with_munin 1
2
3# not ready yet
4%{?!with_python:      %global with_python      0}
5%{?!enable_gost:      %global enable_gost      0}
6
7%if %{with_python}
8%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
9%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
10%endif
11
12Summary: Validating, recursive, and caching DNS(SEC) resolver
13Name: unbound
14Version: 1.4.18
15Release: 1%{?_dist_release}
16License: BSD
17Url: http://www.unbound.net/
18Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
19Source1: unbound.init
20Source2: unbound.conf
21Source3: unbound.munin
22Source4: dlv.isc.org.key
23Source5: root.key
24Patch1: unbound-1.2-glob.patch
25
26Group: System Environment/Daemons
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
28BuildRequires: flex, ldns-devel >= 1.6.13,
29BuildRequires: libevent-devel
30BuildRequires: expat-devel
31%if %{with_python}
32BuildRequires:  python-devel swig
33%endif
34%if %{enable_gost}
35BuildRequires: openssl-devel >= 1.0.0
36%else
37BuildRequires: openssl-devel
38%endif
39# Required for SVN versions
40#BuildRequires: bison
41
42
43Requires(post): chkconfig
44Requires(preun): chkconfig
45Requires(preun): initscripts
46Requires(postun): initscripts
47Requires: ldns >= 1.5.0
48Requires(pre): shadow-utils
49
50Distribution: Vine Linux
51Vendor: Project Vine
52Packager: iwaim, daisuke
53
54%description
55Unbound is a validating, recursive, and caching DNS(SEC) resolver.
56
57The C implementation of Unbound is developed and maintained by NLnet
58Labs. It is based on ideas and algorithms taken from a java prototype
59developed by Verisign labs, Nominet, Kirei and ep.net.
60
61Unbound is designed as a set of modular components, so that also
62DNSSEC (secure DNS) validation and stub-resolvers (that do not run
63as a server, but are linked into an application) are easily possible.
64
65%if %{with_munin}
66%package munin
67Summary: Plugin for the munin / munin-node monitoring package
68Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
69Group:     System Environment/Daemons
70Requires: munin-node
71Requires: %{name} = %{version}-%{release}, bc
72
73%description munin
74Plugin for the munin / munin-node monitoring package
75%endif
76
77%package devel
78Summary: Development package that includes the unbound header files
79Group: Development/Libraries
80Requires: %{name}-libs = %{version}-%{release}, openssl-devel, ldns-devel
81
82%description devel
83The devel package contains the unbound library and the include files
84
85%package libs
86Summary: Libraries used by the unbound server and client applications
87Group: Applications/System
88Requires(post): /sbin/ldconfig
89Requires(postun): /sbin/ldconfig
90Requires: openssl >= 0.9.8g-12
91
92%description libs
93Contains libraries used by the unbound server and client applications
94
95%if %{with_python}
96%package python
97Summary: Python modules and extensions for unbound
98Group: Applications/System
99Requires: %{name}-libs = %{version}-%{release}
100
101%description python
102Python modules and extensions for unbound
103%endif
104
105%prep
106%setup -q
107%patch1 -p1
108
109%build
110%configure  --with-ldns= --with-libevent --with-pthreads --with-ssl \
111            --disable-rpath --enable-debug --disable-static \
112            --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
113            --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
114%if %{with_python}
115            --with-pythonmodule --with-pyunbound \
116%endif
117%if !%{enable_gost}
118            --disable-gost \
119%endif
120            --enable-sha2
121%{__make} %{?_smp_mflags}
122
123%install
124rm -rf %{buildroot}
125%{__make} DESTDIR=%{buildroot} install
126install -d 0755 %{buildroot}%{_initrddir}
127install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
128install -m 0755 %{SOURCE2} %{buildroot}%{_sysconfdir}/unbound
129%if %{with_munin}
130# Install munin plugin and its softlinks
131install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
132install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
133install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
134install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
135for plugin in unbound_munin_hits unbound_munin_queue unbound_munin_memory unbound_munin_by_type unbound_munin_by_class unbound_munin_by_opcode unbound_munin_by_rcode unbound_munin_by_flags unbound_munin_histogram; do
136    ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
137done
138%endif
139
140# install root and DLV key
141install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
142
143# remove static library from install (fedora packaging guidelines)
144rm -rf %{buildroot}%{_libdir}/*.la
145%if %{with_python}
146rm -rf %{buildroot}%{python_sitelib}/*/*.la
147%endif
148
149mkdir -p %{buildroot}%{_localstatedir}/run/unbound
150
151%clean
152rm -rf ${RPM_BUILD_ROOT}
153
154%files
155%defattr(-,root,root,-)
156%doc doc/README doc/CREDITS doc/LICENSE doc/FEATURES
157%attr(0755,root,root) %{_initrddir}/%{name}
158%attr(0755,root,root) %dir %{_sysconfdir}/%{name}
159%attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
160%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
161%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
162%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
163%{_sbindir}/*
164%{_mandir}/*/*
165
166%if %{with_python}
167%files python
168%{python_sitelib}/*
169%endif
170
171%if %{with_munin}
172%files munin
173%defattr(-,root,root,-)
174%config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
175%{_datadir}/munin/plugins/unbound*
176%endif
177
178%files devel
179%defattr(-,root,root,-)
180%{_libdir}/libunbound.so
181%{_includedir}/unbound.h
182%doc README
183
184%files libs
185%defattr(-,root,root,-)
186%{_libdir}/libunbound.so.*
187%doc doc/README doc/LICENSE
188
189%pre
190getent group unbound >/dev/null || groupadd -r unbound
191getent passwd unbound >/dev/null || \
192useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
193-c "Unbound DNS resolver" unbound
194exit 0
195
196%post
197/sbin/chkconfig --add %{name}
198# dnssec-conf used to contain our DLV key, but now we include it via unbound
199# If unbound had previously been configured with dnssec-configure, we need
200# to migrate the location of the DLV key file (to keep DLV enabled, and because
201# unbound won't start with a bad location for a DLV key file.
202sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
203
204%post libs -p /sbin/ldconfig
205
206%preun
207if [ "$1" -eq 0 ]; then
208        /sbin/service %{name} stop >/dev/null 2>&1
209        /sbin/chkconfig --del %{name}
210fi
211
212%postun
213if [ "$1" -ge "1" ]; then
214  /sbin/service %{name} condrestart >/dev/null 2>&1 || :
215fi
216
217%postun libs -p /sbin/ldconfig
218
219%changelog
220* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
221- new upstream release
222
223* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
224- update to 1.4.17
225- add root.key for DNSSEC
226- enable munin subpackage by default
227- buildrequire ldns-devel >= 1.6.13
228
229* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
230- rebuild with python-2.7.2
231
232* Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
233- new upstream release
234
235* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
236- new upstream release
237
238* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
239- new upstream releas
240
241* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
242- new upstream release
243
244* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
245- new upstream release
246
247* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
248- rebuilt with libevent-2.0.10
249
250* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
251- new upstream release
252- add enable_gost flag: default disable
253- add BuildRequires: expat-devel
254
255* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
256- new upstream release
257
258* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
259- new upstream release
260
261* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
262- initial build for Vine Linux: based Fedora 1.4.3-1.fc14
263 - update to 1.4.4
264 - build without munin
265
266* Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
267- Update to 1.4.3 that fixes 64bit crasher
268
269* Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
270- Updated to 1.4.2
271- Updated unbound.conf with new options
272- Enabled pre-fetching DNSKEY records (DNSSEC speedup)
273- Enabled re-fetching popular records before they expire
274- Enabled logging of DNSSEC validation errors
275
276* Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
277- Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
278  with pthreads
279
280* Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
281- Change make/configure lines to attempt to fix -lphtread linking issue
282
283* Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
284- Removed dependancy for dnssec-conf
285- Added ISC DLV key (formerly in dnssec-conf)
286- Fixup old DLV locations in unbound.conf file via %%post
287- Fix parent child disagreement handling and no-ipv6 present [svn r1953]
288
289* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
290- Updated to 1.4.1
291- Changed %%define to %%global
292
293* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
294- Bump version
295
296* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
297- Upgraded to 1.3.4. Security fix with validating NSEC3 records
298
299* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
300- rebuilt with new openssl
301
302* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
303- Updated to 1.3.3
304
305* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
306- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
307
308* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
309- Added missing glob patch to cvs
310- Place python macros within the %%with_python check
311
312* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
313- Updated to 1.3.0
314- Added unbound-python sub package. disabled for now
315- Patch from svn to fix DLV lookups
316- Patches from svn to detect wrong truncated response from BIND 9.6.1 with
317  minimal-responses)
318- Added Default-Start and Default-Stop to unbound.init
319- Re-enabled --enable-sha2
320- Re-enabled glob.patch
321
322* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
323- unbound-iterator.patch was not commited
324
325* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
326- Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
327
328* Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
329- Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
330
331* Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
332- enable DNSSEC only if it is enabled in sysconfig/dnssec
333
334* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
335- add DNSSEC support to initscript and enabled it per default
336- add requires dnssec-conf
337
338* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
339- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
340
341* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
342- updated to 1.2.1
343
344* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
345- rebuild with new openssl
346
347* Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
348- Updated to 1.2.0
349- Added dependancy on minimum SSL for CVE-2008-5077
350- Added dependancy on bc for unbound-munin
351- Added minimum requirement of libevent 1.4.5. Crashes with older versions
352  (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
353- Removed dependancy on selinux-policy (will get used when available)
354- Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
355- Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
356- Enable val-clean-additional to drop addition unsigned data from signed
357  response.
358- Removed patches (got merged into upstream)
359
360* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
361- Modified scandir patch to silently fail when wildcard matches nothing
362- Patch to allow unbound-checkconf to find empty wildcard matches
363
364* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
365- Added scandir patch for trusted-keys-file: option, which
366  is used to load multiple dnssec keys in bind file format
367
368* Mon Dec  8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
369- Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
370
371* Mon Dec  1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
372- We did not own the /etc/unbound directory (#474020)
373- Fixed cvs anomalies
374
375* Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
376- removed all obsolete chroot related stuff
377- label control certs after generation correctly
378
379* Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
380- Updated to unbound 1.1.1 which fixes a crasher and
381  addresses nlnetlabs bug #219
382
383* Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
384- Remove the chroot, obsoleted by SElinux
385- Add additional munin plugin links supported by unbound plugin
386- Move configuration directory from /var/lib/unbound to /etc/unbound
387- Modified unbound.init and unbound.conf to account for chroot changes
388- Updated unbound.conf with new available options
389- Enabled dns-0x20 protection per default
390
391* Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
392- unbound-1.1.0-log_open.patch
393  - make sure log is opened before chroot call
394  - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
395- removed /dev/log and /var/run/unbound and /etc/resolv.conf from
396  chroot, not needed
397- don't mount files in chroot, it causes problems during updates
398- fixed typo in default config file
399
400* Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
401- Updated to version 1.1.0
402- Updated unbound.conf's statistics options and remote-control
403  to work properly for munin
404- Added unbound-munin package
405- Generate unbound remote-control  key/certs on first startup
406- Required ldns is now 1.4.0
407
408* Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
409- Only call ldconfig in -libs package
410- Move configure into build section
411- devel subpackage should only depend on libs subpackage
412
413* Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
414- Fix CFLAGS getting lost in build
415- Don't enable interface-automatic:yes because that
416  causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
417
418* Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
419- Split off unbound-libs, make build verbose
420
421* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
422- FSB compliance, chroot fixes, initscript fixes
423
424* Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
425- Upgraded to 1.0.2
426
427* Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
428- upgraded to new release
429
430* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
431- Build against ldns-1.3.0
432
433* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
434- Split of -devel package, fixed dependancies, make rpmlint happy
435
436* Thu Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
437- Using parts from ports collection entry by Jaap Akkerhuis.
438- Using Fedoraproject wiki guidelines.
439
440* Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
441- Initial version.
Note: See TracBrowser for help on using the repository browser.