source: projects/specs/trunk/u/unbound/unbound-vl.spec @ 1800

Revision 1800, 13.3 KB checked in by iwaim, 14 years ago (diff)

unbound: 1.4.6-1

Line 
1%{?!with_munin:      %global with_munin      0}
2
3# not ready yet
4%{?!with_python:      %global with_python      0}
5
6%if %{with_python}
7%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
9%endif
10
11Summary: Validating, recursive, and caching DNS(SEC) resolver
12Name: unbound
13Version: 1.4.6
14Release: 1%{?_dist_release}
15License: BSD
16Url: http://www.unbound.net/
17Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
18Source1: unbound.init
19Source2: unbound.conf
20Source3: unbound.munin
21Source4: dlv.isc.org.key
22Patch1: unbound-1.2-glob.patch
23
24Group: System Environment/Daemons
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
26BuildRequires: flex, openssl-devel , ldns-devel >= 1.5.0,
27BuildRequires: libevent-devel
28%if %{with_python}
29BuildRequires:  python-devel swig
30%endif
31# Required for SVN versions
32#BuildRequires: bison
33
34
35Requires(post): chkconfig
36Requires(preun): chkconfig
37Requires(preun): initscripts
38Requires(postun): initscripts
39Requires: ldns >= 1.5.0
40Requires(pre): shadow-utils
41
42Distribution: Vine Linux
43Vendor: Project Vine
44Packager: iwaim
45
46%description
47Unbound is a validating, recursive, and caching DNS(SEC) resolver.
48
49The C implementation of Unbound is developed and maintained by NLnet
50Labs. It is based on ideas and algorithms taken from a java prototype
51developed by Verisign labs, Nominet, Kirei and ep.net.
52
53Unbound is designed as a set of modular components, so that also
54DNSSEC (secure DNS) validation and stub-resolvers (that do not run
55as a server, but are linked into an application) are easily possible.
56
57%if %{with_munin}
58%package munin
59Summary: Plugin for the munin / munin-node monitoring package
60Group:     System Environment/Daemons
61Requires: munin-node
62Requires: %{name} = %{version}-%{release}, bc
63
64%description munin
65Plugin for the munin / munin-node monitoring package
66%endif
67
68%package devel
69Summary: Development package that includes the unbound header files
70Group: Development/Libraries
71Requires: %{name}-libs = %{version}-%{release}, openssl-devel, ldns-devel
72
73%description devel
74The devel package contains the unbound library and the include files
75
76%package libs
77Summary: Libraries used by the unbound server and client applications
78Group: Applications/System
79Requires(post): /sbin/ldconfig
80Requires(postun): /sbin/ldconfig
81Requires: openssl >= 0.9.8g-12
82
83%description libs
84Contains libraries used by the unbound server and client applications
85
86%if %{with_python}
87%package python
88Summary: Python modules and extensions for unbound
89Group: Applications/System
90Requires: %{name}-libs = %{version}-%{release}
91
92%description python
93Python modules and extensions for unbound
94%endif
95
96%prep
97%setup -q
98%patch1 -p1
99
100%build
101%configure  --with-ldns= --with-libevent --with-pthreads --with-ssl \
102            --disable-rpath --enable-debug --disable-static \
103            --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
104            --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
105%if %{with_python}
106            --with-pythonmodule --with-pyunbound \
107%endif
108            --enable-sha2
109%{__make} %{?_smp_mflags}
110
111%install
112rm -rf %{buildroot}
113%{__make} DESTDIR=%{buildroot} install
114install -d 0755 %{buildroot}%{_initrddir}
115install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
116install -m 0755 %{SOURCE2} %{buildroot}%{_sysconfdir}/unbound
117%if %{with_munin}
118# Install munin plugin and its softlinks
119install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
120install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
121install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
122install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
123for plugin in unbound_munin_hits unbound_munin_queue unbound_munin_memory unbound_munin_by_type unbound_munin_by_class unbound_munin_by_opcode unbound_munin_by_rcode unbound_munin_by_flags unbound_munin_histogram; do
124    ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
125done
126%endif
127
128# install DLV key
129install -m 0644 %{SOURCE4} %{buildroot}%{_sysconfdir}/unbound/
130
131# remove static library from install (fedora packaging guidelines)
132rm -rf %{buildroot}%{_libdir}/*.la
133%if %{with_python}
134rm -rf %{buildroot}%{python_sitelib}/*/*.la
135%endif
136
137mkdir -p %{buildroot}%{_localstatedir}/run/unbound
138
139%clean
140rm -rf ${RPM_BUILD_ROOT}
141
142%files
143%defattr(-,root,root,-)
144%doc doc/README doc/CREDITS doc/LICENSE doc/FEATURES
145%attr(0755,root,root) %{_initrddir}/%{name}
146%attr(0755,root,root) %dir %{_sysconfdir}/%{name}
147%attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
148%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
149%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
150%{_sbindir}/*
151%{_mandir}/*/*
152
153%if %{with_python}
154%files python
155%{python_sitelib}/*
156%endif
157
158%if %{with_munin}
159%files munin
160%defattr(-,root,root,-)
161%config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
162%{_datadir}/munin/plugins/unbound*
163%endif
164
165%files devel
166%defattr(-,root,root,-)
167%{_libdir}/libunbound.so
168%{_includedir}/unbound.h
169%doc README
170
171%files libs
172%defattr(-,root,root,-)
173%{_libdir}/libunbound.so.*
174%doc doc/README doc/LICENSE
175
176%pre
177getent group unbound >/dev/null || groupadd -r unbound
178getent passwd unbound >/dev/null || \
179useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
180-c "Unbound DNS resolver" unbound
181exit 0
182
183%post
184/sbin/chkconfig --add %{name}
185# dnssec-conf used to contain our DLV key, but now we include it via unbound
186# If unbound had previously been configured with dnssec-configure, we need
187# to migrate the location of the DLV key file (to keep DLV enabled, and because
188# unbound won't start with a bad location for a DLV key file.
189sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
190
191%post libs -p /sbin/ldconfig
192
193%preun
194if [ "$1" -eq 0 ]; then
195        /sbin/service %{name} stop >/dev/null 2>&1
196        /sbin/chkconfig --del %{name}
197fi
198
199%postun
200if [ "$1" -ge "1" ]; then
201  /sbin/service %{name} condrestart >/dev/null 2>&1 || :
202fi
203
204%postun libs -p /sbin/ldconfig
205
206%changelog
207* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
208- new upstream release
209
210* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
211- new upstream release
212
213* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
214- initial build for Vine Linux: based Fedora 1.4.3-1.fc14
215 - update to 1.4.4
216 - build without munin
217
218* Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
219- Update to 1.4.3 that fixes 64bit crasher
220
221* Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
222- Updated to 1.4.2
223- Updated unbound.conf with new options
224- Enabled pre-fetching DNSKEY records (DNSSEC speedup)
225- Enabled re-fetching popular records before they expire
226- Enabled logging of DNSSEC validation errors
227
228* Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
229- Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
230  with pthreads
231
232* Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
233- Change make/configure lines to attempt to fix -lphtread linking issue
234
235* Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
236- Removed dependancy for dnssec-conf
237- Added ISC DLV key (formerly in dnssec-conf)
238- Fixup old DLV locations in unbound.conf file via %%post
239- Fix parent child disagreement handling and no-ipv6 present [svn r1953]
240
241* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
242- Updated to 1.4.1
243- Changed %%define to %%global
244
245* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
246- Bump version
247
248* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
249- Upgraded to 1.3.4. Security fix with validating NSEC3 records
250
251* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
252- rebuilt with new openssl
253
254* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
255- Updated to 1.3.3
256
257* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
258- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
259
260* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
261- Added missing glob patch to cvs
262- Place python macros within the %%with_python check
263
264* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
265- Updated to 1.3.0
266- Added unbound-python sub package. disabled for now
267- Patch from svn to fix DLV lookups
268- Patches from svn to detect wrong truncated response from BIND 9.6.1 with
269  minimal-responses)
270- Added Default-Start and Default-Stop to unbound.init
271- Re-enabled --enable-sha2
272- Re-enabled glob.patch
273
274* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
275- unbound-iterator.patch was not commited
276
277* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
278- Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
279
280* Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
281- Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
282
283* Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
284- enable DNSSEC only if it is enabled in sysconfig/dnssec
285
286* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
287- add DNSSEC support to initscript and enabled it per default
288- add requires dnssec-conf
289
290* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
291- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
292
293* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
294- updated to 1.2.1
295
296* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
297- rebuild with new openssl
298
299* Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
300- Updated to 1.2.0
301- Added dependancy on minimum SSL for CVE-2008-5077
302- Added dependancy on bc for unbound-munin
303- Added minimum requirement of libevent 1.4.5. Crashes with older versions
304  (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
305- Removed dependancy on selinux-policy (will get used when available)
306- Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
307- Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
308- Enable val-clean-additional to drop addition unsigned data from signed
309  response.
310- Removed patches (got merged into upstream)
311
312* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
313- Modified scandir patch to silently fail when wildcard matches nothing
314- Patch to allow unbound-checkconf to find empty wildcard matches
315
316* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
317- Added scandir patch for trusted-keys-file: option, which
318  is used to load multiple dnssec keys in bind file format
319
320* Mon Dec  8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
321- Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
322
323* Mon Dec  1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
324- We did not own the /etc/unbound directory (#474020)
325- Fixed cvs anomalies
326
327* Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
328- removed all obsolete chroot related stuff
329- label control certs after generation correctly
330
331* Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
332- Updated to unbound 1.1.1 which fixes a crasher and
333  addresses nlnetlabs bug #219
334
335* Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
336- Remove the chroot, obsoleted by SElinux
337- Add additional munin plugin links supported by unbound plugin
338- Move configuration directory from /var/lib/unbound to /etc/unbound
339- Modified unbound.init and unbound.conf to account for chroot changes
340- Updated unbound.conf with new available options
341- Enabled dns-0x20 protection per default
342
343* Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
344- unbound-1.1.0-log_open.patch
345  - make sure log is opened before chroot call
346  - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
347- removed /dev/log and /var/run/unbound and /etc/resolv.conf from
348  chroot, not needed
349- don't mount files in chroot, it causes problems during updates
350- fixed typo in default config file
351
352* Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
353- Updated to version 1.1.0
354- Updated unbound.conf's statistics options and remote-control
355  to work properly for munin
356- Added unbound-munin package
357- Generate unbound remote-control  key/certs on first startup
358- Required ldns is now 1.4.0
359
360* Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
361- Only call ldconfig in -libs package
362- Move configure into build section
363- devel subpackage should only depend on libs subpackage
364
365* Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
366- Fix CFLAGS getting lost in build
367- Don't enable interface-automatic:yes because that
368  causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
369
370* Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
371- Split off unbound-libs, make build verbose
372
373* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
374- FSB compliance, chroot fixes, initscript fixes
375
376* Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
377- Upgraded to 1.0.2
378
379* Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
380- upgraded to new release
381
382* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
383- Build against ldns-1.3.0
384
385* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
386- Split of -devel package, fixed dependancies, make rpmlint happy
387
388* Thu Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
389- Using parts from ports collection entry by Jaap Akkerhuis.
390- Using Fedoraproject wiki guidelines.
391
392* Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
393- Initial version.
Note: See TracBrowser for help on using the repository browser.