source: projects/specs/trunk/u/unbound/unbound-vl.spec @ 12508

Revision 12508, 22.8 KB checked in by tomop, 3 years ago (diff)

updated 14 packages

cups-2.3.3-1

firefox-78.5.0-1

golang-1.15.5-1

kernel-5.4.80-1

krb5-1.18.3-1

mariadb-10.5.8-1

nsd-4.3.4-1

php74-7.4.13-1

postfix-3.5.8-1

postgresql-13.1-1

thunderbird-78.5.1-1

tmux-3.1c-1

unbound-1.13.0-1

webkitgtk4-2.30.3-1

Line 
1%bcond_with systemd
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4%global with_munin 0
5%{?!enable_gost:      %global enable_gost      1}
6
7# not ready yet
8%{?!with_python:      %global with_python      0}
9
10%define _sharedstatedir /var/lib
11
12Summary: Validating, recursive, and caching DNS(SEC) resolver
13Name: unbound
14Version: 1.13.0
15Release: 1%{?_dist_release}%{?with_systemd:.systemd}
16Group: servers
17Distribution: Vine Linux
18Vendor: Project Vine
19Packager: iwaim, daisuke
20
21License: BSD
22Url: http://www.unbound.net/
23Source: https://nlnetlabs.nl/downloads/unbound/%{name}-%{version}.tar.gz
24Source1: unbound.init
25Source3: unbound.munin
26Source4: dlv.isc.org.key
27Source5: root.key
28Source6: root.anchor
29Source7: icannbundle.pem
30Source8: unbound.cron
31Source9: example.com.key
32Source10: example.com.conf
33Source11: block-example.com.conf
34
35Source100: unbound.service
36Source101: unbound-keygen.service
37Source102: unbound-anchor.service
38Source103: unbound-anchor.timer
39Source104: tmpfiles-unbound.conf
40Source105: unbound.sysconfig
41
42BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
43BuildRequires: flex
44BuildRequires: libevent-devel
45BuildRequires: expat-devel
46%if %{with_python}
47BuildRequires:  python3-devel python3-rpm-macros swig
48%endif
49%if %{enable_gost}
50BuildRequires: openssl-devel >= 1.0.0
51%else
52BuildRequires: openssl-devel
53%endif
54BuildRequires: libnghttp2-devel
55# Required for SVN versions
56#BuildRequires: bison
57
58%if %{with systemd}
59%global piddir /run/%{name}
60BuildRequires: systemd
61%{?systemd_requires}
62%else
63%global piddir %{_localstatedir}/run/%{name}
64Requires(post): chkconfig
65Requires(preun): chkconfig
66Requires(preun): initscripts
67Requires(postun): initscripts
68%endif
69Requires(pre): shadow-utils
70
71
72%description
73Unbound is a validating, recursive, and caching DNS(SEC) resolver.
74
75The C implementation of Unbound is developed and maintained by NLnet
76Labs. It is based on ideas and algorithms taken from a java prototype
77developed by Verisign labs, Nominet, Kirei and ep.net.
78
79Unbound is designed as a set of modular components, so that also
80DNSSEC (secure DNS) validation and stub-resolvers (that do not run
81as a server, but are linked into an application) are easily possible.
82
83
84%if %{with_munin}
85%package munin
86Summary: Plugin for the munin / munin-node monitoring package
87Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
88Group: servers
89Requires: munin-node
90Requires: %{name} = %{version}-%{release}, bc
91
92%description munin
93Plugin for the munin / munin-node monitoring package
94%endif
95
96
97%package devel
98Summary: Development package that includes the unbound header files
99Group: programming
100Requires: %{name}-libs = %{version}-%{release}, openssl-devel
101
102%description devel
103The devel package contains the unbound library and the include files
104
105
106%package libs
107Summary: Libraries used by the unbound server and client applications
108Group: system
109Requires(post): /sbin/ldconfig
110Requires(postun): /sbin/ldconfig
111Requires: openssl >= 0.9.8g-12
112
113%description libs
114Contains libraries used by the unbound server and client applications
115
116
117%if %{with_python}
118%package python
119Summary: Python modules and extensions for unbound
120Group: programming
121Requires: %{name}-libs = %{version}-%{release}
122
123%description python
124Python modules and extensions for unbound
125%endif
126
127
128%package -n compat32-%{name}-libs
129Summary: Libraries used by the unbound server and client applications
130Group: system
131Requires: %{name}-libs = %{version}-%{release}
132Requires(post): /sbin/ldconfig
133Requires(postun): /sbin/ldconfig
134Requires: openssl >= 0.9.8g-12
135
136%description -n compat32-%{name}-libs
137Contains libraries used by the unbound server and client applications
138
139
140%debug_package
141
142
143%prep
144%setup -q
145
146
147%build
148%configure  --with-libevent --with-pthreads --with-ssl \
149            --disable-rpath --enable-debug --disable-static \
150            --enable-relro-now --enable-pie \
151            --enable-subnet --enable-ipsecmod \
152            --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
153            --with-pidfile=%{piddir}/%{name}.pid \
154%if %{with_python}
155            --with-pythonmodule --with-pyunbound \
156%endif
157%if !%{enable_gost}
158            --disable-gost \
159%endif
160            --enable-sha2 \
161            --disable-sha1 \
162            --with-libnghttp2 \
163            --with-rootkey-file=%{_sharedstatedir}/unbound/root.key
164
165%{__make} %{?_smp_mflags}
166
167
168%install
169rm -rf %{buildroot}
170%{__make} DESTDIR=%{buildroot} install
171install -d 0755 %{buildroot}%{_initrddir}
172
173%if %{with systemd}
174install -d -m 0755 %{buildroot}%{_unitdir} %{buildroot}%{_sysconfdir}/sysconfig
175install -p -m 0644 %{SOURCE100} %{buildroot}%{_unitdir}/unbound.service
176install -p -m 0644 %{SOURCE101} %{buildroot}%{_unitdir}/unbound-keygen.service
177install -p -m 0644 %{SOURCE103} %{buildroot}%{_unitdir}/unbound-anchor.timer
178install -p -m 0644 %{SOURCE102} %{buildroot}%{_unitdir}/unbound-anchor.service
179install -p -m 0644 %{SOURCE105} %{buildroot}%{_sysconfdir}/sysconfig/unbound
180# Install tmpfiles.d config
181install -d -m 0755 %{buildroot}%{_tmpfilesdir} %{buildroot}%{_sharedstatedir}/unbound
182install -m 0644 %{SOURCE104} %{buildroot}%{_tmpfilesdir}/unbound.conf
183%else
184install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
185install -d 0755 %{buildroot}%{_sysconfdir}/cron.d
186install -p -m 0644 %{SOURCE8} %{buildroot}%{_sysconfdir}/cron.d/unbound-anchor
187%endif
188
189install -m 0644 %{SOURCE7} %{buildroot}%{_sysconfdir}/unbound
190
191echo "include: %{_sysconfdir}/unbound/conf.d/*.conf" >> %{buildroot}%{_sysconfdir}/unbound/unbound.conf
192
193%if %{with_munin}
194# Install munin plugin and its softlinks
195install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
196install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
197install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
198install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
199for plugin in unbound_munin_hits unbound_munin_queue \
200              unbound_munin_memory unbound_munin_by_type \
201              unbound_munin_by_class unbound_munin_by_opcode \
202              unbound_munin_by_rcode unbound_munin_by_flags \
203              unbound_munin_histogram; do
204    ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
205done
206%endif
207
208# install root and DLV key
209install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
210install -d -m 0755 %{buildroot}%{_sharedstatedir}/unbound
211install -m 0644 %{SOURCE6} %{buildroot}%{_sharedstatedir}/unbound/root.key
212
213# remove static library from install (fedora packaging guidelines)
214rm -rf %{buildroot}%{_libdir}/*.la
215%if %{with_python}
216rm -rf %{buildroot}%{python_sitelib}/*/*.la
217%endif
218
219mkdir -p %{buildroot}%{_localstatedir}/run/unbound
220
221# Install directories for easier config file drop in
222install -d -m 0755 %{buildroot}%{_sysconfdir}/unbound/{keys.d,local.d,conf.d}
223install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/unbound/keys.d/
224install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/unbound/conf.d/
225install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/unbound/local.d/
226
227
228%clean
229rm -rf ${RPM_BUILD_ROOT}
230
231
232%files
233%defattr(-,root,root,-)
234%license doc/LICENSE
235%doc doc/README doc/CREDITS doc/FEATURES
236%if %{with systemd}
237%attr(0644,root,root) %{_tmpfilesdir}/unbound.conf
238%{_unitdir}/%{name}.service
239%{_unitdir}/%{name}-keygen.service
240%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
241%else
242%attr(0755,root,root) %{_initrddir}/%{name}
243%endif
244%attr(0755,root,root) %dir %{_sysconfdir}/%{name}
245%attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
246%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
247%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/keys.d
248%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/keys.d/*.key
249%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/conf.d
250%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/conf.d/*.conf
251%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/local.d
252%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/local.d/*.conf
253%{_sbindir}/*
254%exclude %{_sbindir}/unbound-anchor
255%{_mandir}/*/*
256
257%if %{with_python}
258%files python
259%{python3_sitelib}/*
260%endif
261
262%if %{with_munin}
263%files munin
264%defattr(-,root,root,-)
265%config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
266%{_datadir}/munin/plugins/unbound*
267%endif
268
269%files devel
270%defattr(-,root,root,-)
271%{_libdir}/libunbound.so
272%{_includedir}/unbound.h
273%{_libdir}/pkgconfig/libunbound.pc
274%doc README
275
276%files libs
277%defattr(-,root,root,-)
278%license doc/LICENSE
279%doc doc/README
280%{_sbindir}/unbound-anchor
281%{_libdir}/libunbound.so.*
282%{_sysconfdir}/%{name}/icannbundle.pem
283%dir %attr(0755,unbound,unbound) %{_sharedstatedir}/%{name}
284%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
285%attr(0644,unbound,unbound) %config(noreplace) %{_sharedstatedir}/%{name}/root.key
286%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
287%if %{with systemd}
288%{_unitdir}/unbound-anchor.timer
289%{_unitdir}/unbound-anchor.service
290%else
291%attr(0644,root,root) %{_sysconfdir}/cron.d/unbound-anchor
292%endif
293
294%if %{build_compat32}
295%files -n compat32-%{name}-libs
296%defattr(-,root,root,-)
297%{_libdir}/libunbound.so.*
298%endif
299
300
301%pre libs
302getent group unbound >/dev/null || groupadd -r unbound
303getent passwd unbound >/dev/null || \
304useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
305-c "Unbound DNS resolver" unbound
306exit 0
307
308%post libs
309/sbin/ldconfig
310/sbin/runuser  --command="%{_sbindir}/unbound-anchor -a %{_sharedstatedir}/unbound/root.key -c %{_sysconfdir}/unbound/icannbundle.pem"  --shell /bin/sh unbound ||:
311%if %{with systemd}
312%systemd_post unbound-anchor.timer
313# start the timer only if installing the package to prevent starting it, if it was stopped on purpose
314if [ "$1" -eq 1 ]; then
315    # the Unit is in presets, but would be started after reboot
316    /bin/systemctl start unbound-anchor.timer >/dev/null 2>&1 || :
317fi
318%endif
319
320%if %{with systemd}
321%preun libs
322%systemd_preun unbound-anchor.timer
323%endif
324
325%postun libs
326/sbin/ldconfig
327%if %{with systemd}
328%systemd_postun_with_restart unbound-anchor.timer
329%endif
330
331%post
332%if %{with systemd}
333%systemd_post unbound.service
334%systemd_post unbound-keygen.service
335%else
336/sbin/chkconfig --add %{name}
337%endif
338# dnssec-conf used to contain our DLV key, but now we include it via unbound
339# If unbound had previously been configured with dnssec-configure, we need
340# to migrate the location of the DLV key file (to keep DLV enabled, and because
341# unbound won't start with a bad location for a DLV key file.
342sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
343
344%preun
345%if %{with systemd}
346%systemd_preun unbound.service
347%systemd_preun unbound-keygen.service
348%else
349if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
350  /sbin/service %{name} stop >/dev/null 2>&1
351  /sbin/chkconfig --del %{name}
352fi
353%endif
354
355%postun
356%if %{with systemd}
357%systemd_postun_with_restart unbound.service
358%systemd_postun unbound-keygen.service
359%else
360if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
361  /sbin/service %{name} condrestart >/dev/null 2>&1 || :
362fi
363%endif
364
365%post -n compat32-%{name}-libs
366/sbin/ldconfig
367
368%postun -n compat32-%{name}-libs
369/sbin/ldconfig
370
371
372%changelog
373* Thu Dec 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.0-1
374- updated to 1.13.0.
375
376* Thu Oct 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
377- updated to 1.12.0.
378
379* Mon Jul 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.0-1
380- updated to 1.11.1.
381
382* Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
383- updated to 1.10.1.
384
385* Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-2
386- rebuilt with libevent-2.1.11.
387
388* Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-1
389- updated to 1.10.0.
390- added systemd support (disabled as default).
391- disabled munin.
392
393* Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.6-1
394- updated to 1.9.6.
395
396* Fri Oct 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.4-1
397- updated to 1.9.4.
398
399* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.3-1
400- updated to 1.9.3.
401
402* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-1
403- updated to 1.9.2.
404
405* Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-2
406- added a subpackage 'compat32-unbound-libs'.
407
408* Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-1
409- updated to 1.8.1.
410- rebuilt with openssl-1.1.1 and libevent-2.1.8.
411- updated root.key and root.anchor.
412
413* Thu Oct  4 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.0-1
414- update to 1.8.0
415- drop mesh patch (Patch0): upstream fixed
416
417* Thu May 24 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-3
418- Fix mesh state assertion failure due to callback removal. (Patch0)
419
420* Sun May  6 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-2
421- enable ECDSA support
422- enable GOST support
423
424* Sat May  5 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-1
425- update to 1.7.1
426- add pkgconfig file in devel sub package
427
428* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.7-1
429- updated to 1.6.7.
430
431* Mon Jul 31 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.4-1
432- update to 1.6.4
433
434* Sat Jun 24 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.3-1
435- update to 1.6.3
436
437* Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.2-1
438- update to 1.6.2
439- disables SHA1 support
440
441* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.1-1
442- update to 1.6.1
443
444* Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-2
445- fix Requires and BuildRequres
446 - drop ldns
447
448* Thu Dec 29 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-1
449- update to 1.6.0
450
451* Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.9-1
452- new upstream release.
453
454* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.8-1
455- new upstream release.
456
457* Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.7-1
458- new upstream release.
459
460* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-1
461- new upstream release.
462
463* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.5.3-1
464- update to 1.5.3
465
466* Tue Dec 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.1-1
467- update to 1.5.1
468
469* Tue Jun 17 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-3
470- move create user script to libs subpackage
471
472* Wed Jun 11 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-2
473- add {B,C}.ROOT-SERVERS.NET. IPv6 address
474
475* Wed Apr 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
476- update to 1.4.22
477- move root.key to /var/lib/unbound
478- add icannbundle.pem from http://data.iana.org/root-anchors/icannbundle.pem
479- add unbound.cron
480- move keys and unbound-anchor to libs subpackage
481
482* Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.21-1
483- new upstream release
484
485* Tue Mar 26 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.20-1
486- new upstream release
487
488* Thu Dec 13 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.19-1
489- new upstream release
490- drop glob patch (Patch1): upstream merged
491
492* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
493- new upstream release
494
495* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
496- update to 1.4.17
497- add root.key for DNSSEC
498- enable munin subpackage by default
499- buildrequire ldns-devel >= 1.6.13
500
501* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
502- rebuild with python-2.7.2
503
504* Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
505- new upstream release
506
507* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
508- new upstream release
509
510* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
511- new upstream releas
512
513* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
514- new upstream release
515
516* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
517- new upstream release
518
519* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
520- rebuilt with libevent-2.0.10
521
522* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
523- new upstream release
524- add enable_gost flag: default disable
525- add BuildRequires: expat-devel
526
527* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
528- new upstream release
529
530* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
531- new upstream release
532
533* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
534- initial build for Vine Linux: based Fedora 1.4.3-1.fc14
535 - update to 1.4.4
536 - build without munin
537
538* Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
539- Update to 1.4.3 that fixes 64bit crasher
540
541* Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
542- Updated to 1.4.2
543- Updated unbound.conf with new options
544- Enabled pre-fetching DNSKEY records (DNSSEC speedup)
545- Enabled re-fetching popular records before they expire
546- Enabled logging of DNSSEC validation errors
547
548* Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
549- Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
550  with pthreads
551
552* Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
553- Change make/configure lines to attempt to fix -lphtread linking issue
554
555* Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
556- Removed dependancy for dnssec-conf
557- Added ISC DLV key (formerly in dnssec-conf)
558- Fixup old DLV locations in unbound.conf file via %%post
559- Fix parent child disagreement handling and no-ipv6 present [svn r1953]
560
561* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
562- Updated to 1.4.1
563- Changed %%define to %%global
564
565* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
566- Bump version
567
568* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
569- Upgraded to 1.3.4. Security fix with validating NSEC3 records
570
571* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
572- rebuilt with new openssl
573
574* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
575- Updated to 1.3.3
576
577* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
578- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
579
580* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
581- Added missing glob patch to cvs
582- Place python macros within the %%with_python check
583
584* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
585- Updated to 1.3.0
586- Added unbound-python sub package. disabled for now
587- Patch from svn to fix DLV lookups
588- Patches from svn to detect wrong truncated response from BIND 9.6.1 with
589  minimal-responses)
590- Added Default-Start and Default-Stop to unbound.init
591- Re-enabled --enable-sha2
592- Re-enabled glob.patch
593
594* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
595- unbound-iterator.patch was not commited
596
597* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
598- Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
599
600* Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
601- Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
602
603* Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
604- enable DNSSEC only if it is enabled in sysconfig/dnssec
605
606* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
607- add DNSSEC support to initscript and enabled it per default
608- add requires dnssec-conf
609
610* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
611- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
612
613* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
614- updated to 1.2.1
615
616* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
617- rebuild with new openssl
618
619* Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
620- Updated to 1.2.0
621- Added dependancy on minimum SSL for CVE-2008-5077
622- Added dependancy on bc for unbound-munin
623- Added minimum requirement of libevent 1.4.5. Crashes with older versions
624  (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
625- Removed dependancy on selinux-policy (will get used when available)
626- Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
627- Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
628- Enable val-clean-additional to drop addition unsigned data from signed
629  response.
630- Removed patches (got merged into upstream)
631
632* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
633- Modified scandir patch to silently fail when wildcard matches nothing
634- Patch to allow unbound-checkconf to find empty wildcard matches
635
636* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
637- Added scandir patch for trusted-keys-file: option, which
638  is used to load multiple dnssec keys in bind file format
639
640* Mon Dec  8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
641- Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
642
643* Mon Dec  1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
644- We did not own the /etc/unbound directory (#474020)
645- Fixed cvs anomalies
646
647* Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
648- removed all obsolete chroot related stuff
649- label control certs after generation correctly
650
651* Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
652- Updated to unbound 1.1.1 which fixes a crasher and
653  addresses nlnetlabs bug #219
654
655* Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
656- Remove the chroot, obsoleted by SElinux
657- Add additional munin plugin links supported by unbound plugin
658- Move configuration directory from /var/lib/unbound to /etc/unbound
659- Modified unbound.init and unbound.conf to account for chroot changes
660- Updated unbound.conf with new available options
661- Enabled dns-0x20 protection per default
662
663* Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
664- unbound-1.1.0-log_open.patch
665  - make sure log is opened before chroot call
666  - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
667- removed /dev/log and /var/run/unbound and /etc/resolv.conf from
668  chroot, not needed
669- don't mount files in chroot, it causes problems during updates
670- fixed typo in default config file
671
672* Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
673- Updated to version 1.1.0
674- Updated unbound.conf's statistics options and remote-control
675  to work properly for munin
676- Added unbound-munin package
677- Generate unbound remote-control  key/certs on first startup
678- Required ldns is now 1.4.0
679
680* Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
681- Only call ldconfig in -libs package
682- Move configure into build section
683- devel subpackage should only depend on libs subpackage
684
685* Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
686- Fix CFLAGS getting lost in build
687- Don't enable interface-automatic:yes because that
688  causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
689
690* Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
691- Split off unbound-libs, make build verbose
692
693* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
694- FSB compliance, chroot fixes, initscript fixes
695
696* Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
697- Upgraded to 1.0.2
698
699* Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
700- upgraded to new release
701
702* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
703- Build against ldns-1.3.0
704
705* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
706- Split of -devel package, fixed dependancies, make rpmlint happy
707
708* Fri Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
709- Using parts from ports collection entry by Jaap Akkerhuis.
710- Using Fedoraproject wiki guidelines.
711
712* Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
713- Initial version.
Note: See TracBrowser for help on using the repository browser.