source: projects/specs/trunk/u/unbound/unbound-vl.spec @ 974

Revision 974, 13.2 KB checked in by iwaim, 14 years ago (diff)

unbound: 1.4.4-1

Line 
1%{?!with_munin:      %global with_munin      0}
2
3# not ready yet
4%{?!with_python:      %global with_python      0}
5
6%if %{with_python}
7%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
8%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
9%endif
10
11Summary: Validating, recursive, and caching DNS(SEC) resolver
12Name: unbound
13Version: 1.4.4
14Release: 1%{?_dist_release}
15License: BSD
16Url: http://www.unbound.net/
17Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
18Source1: unbound.init
19Source2: unbound.conf
20Source3: unbound.munin
21Source4: dlv.isc.org.key
22Patch1: unbound-1.2-glob.patch
23
24Group: System Environment/Daemons
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
26BuildRequires: flex, openssl-devel , ldns-devel >= 1.5.0,
27BuildRequires: libevent-devel
28%if %{with_python}
29BuildRequires:  python-devel swig
30%endif
31# Required for SVN versions
32#BuildRequires: bison
33
34
35Requires(post): chkconfig
36Requires(preun): chkconfig
37Requires(preun): initscripts
38Requires(postun): initscripts
39Requires: ldns >= 1.5.0
40Requires(pre): shadow-utils
41
42Distribution: Vine Linux
43Vendor: Project Vine
44Packager: iwaim
45
46%description
47Unbound is a validating, recursive, and caching DNS(SEC) resolver.
48
49The C implementation of Unbound is developed and maintained by NLnet
50Labs. It is based on ideas and algorithms taken from a java prototype
51developed by Verisign labs, Nominet, Kirei and ep.net.
52
53Unbound is designed as a set of modular components, so that also
54DNSSEC (secure DNS) validation and stub-resolvers (that do not run
55as a server, but are linked into an application) are easily possible.
56
57%if %{with_munin}
58%package munin
59Summary: Plugin for the munin / munin-node monitoring package
60Group:     System Environment/Daemons
61Requires: munin-node
62Requires: %{name} = %{version}-%{release}, bc
63
64%description munin
65Plugin for the munin / munin-node monitoring package
66%endif
67
68%package devel
69Summary: Development package that includes the unbound header files
70Group: Development/Libraries
71Requires: %{name}-libs = %{version}-%{release}, openssl-devel, ldns-devel
72
73%description devel
74The devel package contains the unbound library and the include files
75
76%package libs
77Summary: Libraries used by the unbound server and client applications
78Group: Applications/System
79Requires(post): /sbin/ldconfig
80Requires(postun): /sbin/ldconfig
81Requires: openssl >= 0.9.8g-12
82
83%description libs
84Contains libraries used by the unbound server and client applications
85
86%if %{with_python}
87%package python
88Summary: Python modules and extensions for unbound
89Group: Applications/System
90Requires: %{name}-libs = %{version}-%{release}
91
92%description python
93Python modules and extensions for unbound
94%endif
95
96%prep
97%setup -q
98%patch1 -p1
99
100%build
101%configure  --with-ldns= --with-libevent --with-pthreads --with-ssl \
102            --disable-rpath --enable-debug --disable-static \
103            --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
104            --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
105%if %{with_python}
106            --with-pythonmodule --with-pyunbound \
107%endif
108            --enable-sha2
109%{__make} %{?_smp_mflags}
110
111%install
112rm -rf %{buildroot}
113%{__make} DESTDIR=%{buildroot} install
114install -d 0755 %{buildroot}%{_initrddir}
115install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
116install -m 0755 %{SOURCE2} %{buildroot}%{_sysconfdir}/unbound
117%if %{with_munin}
118# Install munin plugin and its softlinks
119install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
120install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
121install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
122install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
123for plugin in unbound_munin_hits unbound_munin_queue unbound_munin_memory unbound_munin_by_type unbound_munin_by_class unbound_munin_by_opcode unbound_munin_by_rcode unbound_munin_by_flags unbound_munin_histogram; do
124    ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
125done
126%endif
127
128# install DLV key
129install -m 0644 %{SOURCE4} %{buildroot}%{_sysconfdir}/unbound/
130
131# remove static library from install (fedora packaging guidelines)
132rm -rf %{buildroot}%{_libdir}/*.la
133%if %{with_python}
134rm -rf %{buildroot}%{python_sitelib}/*/*.la
135%endif
136
137mkdir -p %{buildroot}%{_localstatedir}/run/unbound
138
139%clean
140rm -rf ${RPM_BUILD_ROOT}
141
142%files
143%defattr(-,root,root,-)
144%doc doc/README doc/CREDITS doc/LICENSE doc/FEATURES
145%attr(0755,root,root) %{_initrddir}/%{name}
146%attr(0755,root,root) %dir %{_sysconfdir}/%{name}
147%attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
148%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
149%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
150%{_sbindir}/*
151%{_mandir}/*/*
152
153%if %{with_python}
154%files python
155%{python_sitelib}/*
156%endif
157
158%if %{with_munin}
159%files munin
160%defattr(-,root,root,-)
161%config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
162%{_datadir}/munin/plugins/unbound*
163%endif
164
165%files devel
166%defattr(-,root,root,-)
167%{_libdir}/libunbound.so
168%{_includedir}/unbound.h
169%doc README
170
171%files libs
172%defattr(-,root,root,-)
173%{_libdir}/libunbound.so.*
174%doc doc/README doc/LICENSE
175
176%pre
177getent group unbound >/dev/null || groupadd -r unbound
178getent passwd unbound >/dev/null || \
179useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
180-c "Unbound DNS resolver" unbound
181exit 0
182
183%post
184/sbin/chkconfig --add %{name}
185# dnssec-conf used to contain our DLV key, but now we include it via unbound
186# If unbound had previously been configured with dnssec-configure, we need
187# to migrate the location of the DLV key file (to keep DLV enabled, and because
188# unbound won't start with a bad location for a DLV key file.
189sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
190
191%post libs -p /sbin/ldconfig
192
193%preun
194if [ "$1" -eq 0 ]; then
195        /sbin/service %{name} stop >/dev/null 2>&1
196        /sbin/chkconfig --del %{name}
197fi
198
199%postun
200if [ "$1" -ge "1" ]; then
201  /sbin/service %{name} condrestart >/dev/null 2>&1 || :
202fi
203
204%postun libs -p /sbin/ldconfig
205
206%changelog
207* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
208- initial build for Vine Linux: based Fedora 1.4.3-1.fc14
209 - update to 1.4.4
210 - build without munin
211
212* Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
213- Update to 1.4.3 that fixes 64bit crasher
214
215* Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
216- Updated to 1.4.2
217- Updated unbound.conf with new options
218- Enabled pre-fetching DNSKEY records (DNSSEC speedup)
219- Enabled re-fetching popular records before they expire
220- Enabled logging of DNSSEC validation errors
221
222* Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
223- Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
224  with pthreads
225
226* Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
227- Change make/configure lines to attempt to fix -lphtread linking issue
228
229* Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
230- Removed dependancy for dnssec-conf
231- Added ISC DLV key (formerly in dnssec-conf)
232- Fixup old DLV locations in unbound.conf file via %%post
233- Fix parent child disagreement handling and no-ipv6 present [svn r1953]
234
235* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
236- Updated to 1.4.1
237- Changed %%define to %%global
238
239* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
240- Bump version
241
242* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
243- Upgraded to 1.3.4. Security fix with validating NSEC3 records
244
245* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
246- rebuilt with new openssl
247
248* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
249- Updated to 1.3.3
250
251* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
252- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
253
254* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
255- Added missing glob patch to cvs
256- Place python macros within the %%with_python check
257
258* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
259- Updated to 1.3.0
260- Added unbound-python sub package. disabled for now
261- Patch from svn to fix DLV lookups
262- Patches from svn to detect wrong truncated response from BIND 9.6.1 with
263  minimal-responses)
264- Added Default-Start and Default-Stop to unbound.init
265- Re-enabled --enable-sha2
266- Re-enabled glob.patch
267
268* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
269- unbound-iterator.patch was not commited
270
271* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
272- Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
273
274* Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
275- Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
276
277* Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
278- enable DNSSEC only if it is enabled in sysconfig/dnssec
279
280* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
281- add DNSSEC support to initscript and enabled it per default
282- add requires dnssec-conf
283
284* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
285- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
286
287* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
288- updated to 1.2.1
289
290* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
291- rebuild with new openssl
292
293* Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
294- Updated to 1.2.0
295- Added dependancy on minimum SSL for CVE-2008-5077
296- Added dependancy on bc for unbound-munin
297- Added minimum requirement of libevent 1.4.5. Crashes with older versions
298  (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
299- Removed dependancy on selinux-policy (will get used when available)
300- Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
301- Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
302- Enable val-clean-additional to drop addition unsigned data from signed
303  response.
304- Removed patches (got merged into upstream)
305
306* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
307- Modified scandir patch to silently fail when wildcard matches nothing
308- Patch to allow unbound-checkconf to find empty wildcard matches
309
310* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
311- Added scandir patch for trusted-keys-file: option, which
312  is used to load multiple dnssec keys in bind file format
313
314* Mon Dec  8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
315- Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
316
317* Mon Dec  1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
318- We did not own the /etc/unbound directory (#474020)
319- Fixed cvs anomalies
320
321* Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
322- removed all obsolete chroot related stuff
323- label control certs after generation correctly
324
325* Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
326- Updated to unbound 1.1.1 which fixes a crasher and
327  addresses nlnetlabs bug #219
328
329* Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
330- Remove the chroot, obsoleted by SElinux
331- Add additional munin plugin links supported by unbound plugin
332- Move configuration directory from /var/lib/unbound to /etc/unbound
333- Modified unbound.init and unbound.conf to account for chroot changes
334- Updated unbound.conf with new available options
335- Enabled dns-0x20 protection per default
336
337* Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
338- unbound-1.1.0-log_open.patch
339  - make sure log is opened before chroot call
340  - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
341- removed /dev/log and /var/run/unbound and /etc/resolv.conf from
342  chroot, not needed
343- don't mount files in chroot, it causes problems during updates
344- fixed typo in default config file
345
346* Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
347- Updated to version 1.1.0
348- Updated unbound.conf's statistics options and remote-control
349  to work properly for munin
350- Added unbound-munin package
351- Generate unbound remote-control  key/certs on first startup
352- Required ldns is now 1.4.0
353
354* Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
355- Only call ldconfig in -libs package
356- Move configure into build section
357- devel subpackage should only depend on libs subpackage
358
359* Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
360- Fix CFLAGS getting lost in build
361- Don't enable interface-automatic:yes because that
362  causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
363
364* Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
365- Split off unbound-libs, make build verbose
366
367* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
368- FSB compliance, chroot fixes, initscript fixes
369
370* Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
371- Upgraded to 1.0.2
372
373* Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
374- upgraded to new release
375
376* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
377- Build against ldns-1.3.0
378
379* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
380- Split of -devel package, fixed dependancies, make rpmlint happy
381
382* Thu Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
383- Using parts from ports collection entry by Jaap Akkerhuis.
384- Using Fedoraproject wiki guidelines.
385
386* Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
387- Initial version.
Note: See TracBrowser for help on using the repository browser.