source: projects/specs/trunk/u/unbound/unbound-vl.spec @ 11093

Revision 11093, 18.1 KB checked in by iwaim, 7 years ago (diff)

unbound 1.6.2-1

Line 
1%global with_munin 1
2
3# not ready yet
4%{?!with_python:      %global with_python      0}
5%{?!enable_gost:      %global enable_gost      0}
6
7%if %{with_python}
8%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
9%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
10%endif
11
12%define _sharedstatedir /var/lib
13
14Summary: Validating, recursive, and caching DNS(SEC) resolver
15Name: unbound
16Version: 1.6.2
17Release: 1%{?_dist_release}
18License: BSD
19Url: http://www.unbound.net/
20Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
21Source1: unbound.init
22Source2: unbound.conf
23Source3: unbound.munin
24Source4: dlv.isc.org.key
25Source5: root.key
26Source6: root.anchor
27Source7: icannbundle.pem
28Source8: unbound.cron
29Source9: example.com.key
30Source10: example.com.conf
31Source11: block-example.com.conf
32
33Group: System Environment/Daemons
34BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
35BuildRequires: flex
36BuildRequires: libevent-devel
37BuildRequires: expat-devel
38%if %{with_python}
39BuildRequires:  python-devel swig
40%endif
41%if %{enable_gost}
42BuildRequires: openssl-devel >= 1.0.0
43%else
44BuildRequires: openssl-devel
45%endif
46# Required for SVN versions
47#BuildRequires: bison
48
49
50Requires(post): chkconfig
51Requires(preun): chkconfig
52Requires(preun): initscripts
53Requires(postun): initscripts
54Requires(pre): shadow-utils
55
56Distribution: Vine Linux
57Vendor: Project Vine
58Packager: iwaim, daisuke
59
60%description
61Unbound is a validating, recursive, and caching DNS(SEC) resolver.
62
63The C implementation of Unbound is developed and maintained by NLnet
64Labs. It is based on ideas and algorithms taken from a java prototype
65developed by Verisign labs, Nominet, Kirei and ep.net.
66
67Unbound is designed as a set of modular components, so that also
68DNSSEC (secure DNS) validation and stub-resolvers (that do not run
69as a server, but are linked into an application) are easily possible.
70
71%if %{with_munin}
72%package munin
73Summary: Plugin for the munin / munin-node monitoring package
74Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
75Group:     System Environment/Daemons
76Requires: munin-node
77Requires: %{name} = %{version}-%{release}, bc
78
79%description munin
80Plugin for the munin / munin-node monitoring package
81%endif
82
83%package devel
84Summary: Development package that includes the unbound header files
85Group: Development/Libraries
86Requires: %{name}-libs = %{version}-%{release}, openssl-devel
87
88%description devel
89The devel package contains the unbound library and the include files
90
91%package libs
92Summary: Libraries used by the unbound server and client applications
93Group: Applications/System
94Requires(post): /sbin/ldconfig
95Requires(postun): /sbin/ldconfig
96Requires: openssl >= 0.9.8g-12
97
98%description libs
99Contains libraries used by the unbound server and client applications
100
101%if %{with_python}
102%package python
103Summary: Python modules and extensions for unbound
104Group: Applications/System
105Requires: %{name}-libs = %{version}-%{release}
106
107%description python
108Python modules and extensions for unbound
109%endif
110
111%prep
112%setup -q
113
114%build
115%configure  --with-libevent --with-pthreads --with-ssl \
116            --disable-rpath --enable-debug --disable-static \
117            --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
118            --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
119%if %{with_python}
120            --with-pythonmodule --with-pyunbound \
121%endif
122%if !%{enable_gost}
123            --disable-gost \
124%endif
125            --enable-sha2 --disable-ecdsa \
126            --disable-sha1 \
127            --with-rootkey-file=%{_sharedstatedir}/unbound/root.key
128
129%{__make} %{?_smp_mflags}
130
131%install
132rm -rf %{buildroot}
133%{__make} DESTDIR=%{buildroot} install
134install -d 0755 %{buildroot}%{_initrddir}
135install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
136install -m 0755 %{SOURCE2} %{buildroot}%{_sysconfdir}/unbound
137install -m 0755 %{SOURCE7} %{buildroot}%{_sysconfdir}/unbound
138install -d 0755 %{buildroot}%{_sysconfdir}/cron.d
139install -p -m 0644 %{SOURCE8} %{buildroot}%{_sysconfdir}/cron.d/unbound-anchor
140
141%if %{with_munin}
142# Install munin plugin and its softlinks
143install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
144install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
145install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
146install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
147for plugin in unbound_munin_hits unbound_munin_queue \
148              unbound_munin_memory unbound_munin_by_type \
149              unbound_munin_by_class unbound_munin_by_opcode \
150              unbound_munin_by_rcode unbound_munin_by_flags \
151              unbound_munin_histogram; do
152    ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
153done
154%endif
155
156# install root and DLV key
157install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
158install -d -m 0755 %{buildroot}%{_sharedstatedir}/unbound
159install -m 0644 %{SOURCE6} %{buildroot}%{_sharedstatedir}/unbound/root.key
160
161# remove static library from install (fedora packaging guidelines)
162rm -rf %{buildroot}%{_libdir}/*.la
163%if %{with_python}
164rm -rf %{buildroot}%{python_sitelib}/*/*.la
165%endif
166
167mkdir -p %{buildroot}%{_localstatedir}/run/unbound
168
169# Install directories for easier config file drop in
170install -d -m 0755 %{buildroot}%{_sysconfdir}/unbound/{keys.d,local.d,conf.d}
171install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/unbound/keys.d/
172install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/unbound/conf.d/
173install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/unbound/local.d/
174
175
176%clean
177rm -rf ${RPM_BUILD_ROOT}
178
179%files
180%defattr(-,root,root,-)
181%doc doc/README doc/CREDITS doc/LICENSE doc/FEATURES
182%attr(0755,root,root) %{_initrddir}/%{name}
183%attr(0755,root,root) %dir %{_sysconfdir}/%{name}
184%attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
185%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
186%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/keys.d
187%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/keys.d/*.key
188%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/conf.d
189%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/conf.d/*.conf
190%dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/local.d
191%attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/local.d/*.conf
192%{_sbindir}/*
193%exclude %{_sbindir}/unbound-anchor
194%{_mandir}/*/*
195
196%if %{with_python}
197%files python
198%{python_sitelib}/*
199%endif
200
201%if %{with_munin}
202%files munin
203%defattr(-,root,root,-)
204%config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
205%{_datadir}/munin/plugins/unbound*
206%endif
207
208%files devel
209%defattr(-,root,root,-)
210%{_libdir}/libunbound.so
211%{_includedir}/unbound.h
212%doc README
213
214%files libs
215%defattr(-,root,root,-)
216%doc doc/README doc/LICENSE
217%{_sbindir}/unbound-anchor
218%{_libdir}/libunbound.so.*
219%{_sysconfdir}/%{name}/icannbundle.pem
220%attr(0644,root,root) %{_sysconfdir}/cron.d/unbound-anchor
221%dir %attr(0755,unbound,unbound) %{_sharedstatedir}/%{name}
222%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
223%attr(0644,unbound,unbound) %config(noreplace) %{_sharedstatedir}/%{name}/root.key
224%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
225
226%pre libs
227getent group unbound >/dev/null || groupadd -r unbound
228getent passwd unbound >/dev/null || \
229useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
230-c "Unbound DNS resolver" unbound
231exit 0
232
233%post
234/sbin/chkconfig --add %{name}
235# dnssec-conf used to contain our DLV key, but now we include it via unbound
236# If unbound had previously been configured with dnssec-configure, we need
237# to migrate the location of the DLV key file (to keep DLV enabled, and because
238# unbound won't start with a bad location for a DLV key file.
239sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
240
241%post libs
242/sbin/ldconfig
243/sbin/runuser  --command="%{_sbindir}/unbound-anchor -a %{_sharedstatedir}/unbound/root.key -c %{_sysconfdir}/unbound/icannbundle.pem"  --shell /bin/sh unbound ||:
244
245%preun
246if [ "$1" -eq 0 ]; then
247        /sbin/service %{name} stop >/dev/null 2>&1
248        /sbin/chkconfig --del %{name}
249fi
250
251%postun
252if [ "$1" -ge "1" ]; then
253  /sbin/service %{name} condrestart >/dev/null 2>&1 || :
254fi
255
256%postun libs
257/sbin/ldconfig
258
259%changelog
260* Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.2-1
261- update to 1.6.2
262- disables SHA1 support
263
264* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.1-1
265- update to 1.6.1
266
267* Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-2
268- fix Requires and BuildRequres
269 - drop ldns
270
271* Thu Dec 29 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-1
272- update to 1.6.0
273
274* Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.9-1
275- new upstream release.
276
277* Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.8-1
278- new upstream release.
279
280* Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.7-1
281- new upstream release.
282
283* Tue Nov  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-1
284- new upstream release.
285
286* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.5.3-1
287- update to 1.5.3
288
289* Tue Dec 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.1-1
290- update to 1.5.1
291
292* Tue Jun 17 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-3
293- move create user script to libs subpackage
294
295* Wed Jun 11 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-2
296- add {B,C}.ROOT-SERVERS.NET. IPv6 address
297
298* Wed Apr 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
299- update to 1.4.22
300- move root.key to /var/lib/unbound
301- add icannbundle.pem from http://data.iana.org/root-anchors/icannbundle.pem
302- add unbound.cron
303- move keys and unbound-anchor to libs subpackage
304
305* Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.21-1
306- new upstream release
307
308* Tue Mar 26 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.20-1
309- new upstream release
310
311* Thu Dec 13 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.19-1
312- new upstream release
313- drop glob patch (Patch1): upstream merged
314
315* Wed Dec  5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
316- new upstream release
317
318* Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
319- update to 1.4.17
320- add root.key for DNSSEC
321- enable munin subpackage by default
322- buildrequire ldns-devel >= 1.6.13
323
324* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
325- rebuild with python-2.7.2
326
327* Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
328- new upstream release
329
330* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
331- new upstream release
332
333* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
334- new upstream releas
335
336* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
337- new upstream release
338
339* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
340- new upstream release
341
342* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
343- rebuilt with libevent-2.0.10
344
345* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
346- new upstream release
347- add enable_gost flag: default disable
348- add BuildRequires: expat-devel
349
350* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
351- new upstream release
352
353* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
354- new upstream release
355
356* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
357- initial build for Vine Linux: based Fedora 1.4.3-1.fc14
358 - update to 1.4.4
359 - build without munin
360
361* Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
362- Update to 1.4.3 that fixes 64bit crasher
363
364* Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
365- Updated to 1.4.2
366- Updated unbound.conf with new options
367- Enabled pre-fetching DNSKEY records (DNSSEC speedup)
368- Enabled re-fetching popular records before they expire
369- Enabled logging of DNSSEC validation errors
370
371* Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
372- Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
373  with pthreads
374
375* Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
376- Change make/configure lines to attempt to fix -lphtread linking issue
377
378* Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
379- Removed dependancy for dnssec-conf
380- Added ISC DLV key (formerly in dnssec-conf)
381- Fixup old DLV locations in unbound.conf file via %%post
382- Fix parent child disagreement handling and no-ipv6 present [svn r1953]
383
384* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
385- Updated to 1.4.1
386- Changed %%define to %%global
387
388* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
389- Bump version
390
391* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
392- Upgraded to 1.3.4. Security fix with validating NSEC3 records
393
394* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
395- rebuilt with new openssl
396
397* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
398- Updated to 1.3.3
399
400* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
401- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
402
403* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
404- Added missing glob patch to cvs
405- Place python macros within the %%with_python check
406
407* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
408- Updated to 1.3.0
409- Added unbound-python sub package. disabled for now
410- Patch from svn to fix DLV lookups
411- Patches from svn to detect wrong truncated response from BIND 9.6.1 with
412  minimal-responses)
413- Added Default-Start and Default-Stop to unbound.init
414- Re-enabled --enable-sha2
415- Re-enabled glob.patch
416
417* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
418- unbound-iterator.patch was not commited
419
420* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
421- Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
422
423* Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
424- Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
425
426* Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
427- enable DNSSEC only if it is enabled in sysconfig/dnssec
428
429* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
430- add DNSSEC support to initscript and enabled it per default
431- add requires dnssec-conf
432
433* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
434- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
435
436* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
437- updated to 1.2.1
438
439* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
440- rebuild with new openssl
441
442* Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
443- Updated to 1.2.0
444- Added dependancy on minimum SSL for CVE-2008-5077
445- Added dependancy on bc for unbound-munin
446- Added minimum requirement of libevent 1.4.5. Crashes with older versions
447  (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
448- Removed dependancy on selinux-policy (will get used when available)
449- Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
450- Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
451- Enable val-clean-additional to drop addition unsigned data from signed
452  response.
453- Removed patches (got merged into upstream)
454
455* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
456- Modified scandir patch to silently fail when wildcard matches nothing
457- Patch to allow unbound-checkconf to find empty wildcard matches
458
459* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
460- Added scandir patch for trusted-keys-file: option, which
461  is used to load multiple dnssec keys in bind file format
462
463* Mon Dec  8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
464- Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
465
466* Mon Dec  1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
467- We did not own the /etc/unbound directory (#474020)
468- Fixed cvs anomalies
469
470* Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
471- removed all obsolete chroot related stuff
472- label control certs after generation correctly
473
474* Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
475- Updated to unbound 1.1.1 which fixes a crasher and
476  addresses nlnetlabs bug #219
477
478* Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
479- Remove the chroot, obsoleted by SElinux
480- Add additional munin plugin links supported by unbound plugin
481- Move configuration directory from /var/lib/unbound to /etc/unbound
482- Modified unbound.init and unbound.conf to account for chroot changes
483- Updated unbound.conf with new available options
484- Enabled dns-0x20 protection per default
485
486* Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
487- unbound-1.1.0-log_open.patch
488  - make sure log is opened before chroot call
489  - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
490- removed /dev/log and /var/run/unbound and /etc/resolv.conf from
491  chroot, not needed
492- don't mount files in chroot, it causes problems during updates
493- fixed typo in default config file
494
495* Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
496- Updated to version 1.1.0
497- Updated unbound.conf's statistics options and remote-control
498  to work properly for munin
499- Added unbound-munin package
500- Generate unbound remote-control  key/certs on first startup
501- Required ldns is now 1.4.0
502
503* Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
504- Only call ldconfig in -libs package
505- Move configure into build section
506- devel subpackage should only depend on libs subpackage
507
508* Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
509- Fix CFLAGS getting lost in build
510- Don't enable interface-automatic:yes because that
511  causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
512
513* Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
514- Split off unbound-libs, make build verbose
515
516* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
517- FSB compliance, chroot fixes, initscript fixes
518
519* Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
520- Upgraded to 1.0.2
521
522* Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
523- upgraded to new release
524
525* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
526- Build against ldns-1.3.0
527
528* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
529- Split of -devel package, fixed dependancies, make rpmlint happy
530
531* Fri Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
532- Using parts from ports collection entry by Jaap Akkerhuis.
533- Using Fedoraproject wiki guidelines.
534
535* Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
536- Initial version.
Note: See TracBrowser for help on using the repository browser.