source: projects/specs/trunk/u/unbound/unbound-vl.spec @ 5787

Revision 5787, 14.3 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild with python-2.7.2

Line 
1%{?!with_munin:      %global with_munin      0}
2
3# not ready yet
4%{?!with_python:      %global with_python      0}
5%{?!enable_gost:      %global enable_gost      0}
6
7%if %{with_python}
8%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
9%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
10%endif
11
12Summary: Validating, recursive, and caching DNS(SEC) resolver
13Name: unbound
14Version: 1.4.14
15Release: 2%{?_dist_release}
16License: BSD
17Url: http://www.unbound.net/
18Source: http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
19Source1: unbound.init
20Source2: unbound.conf
21Source3: unbound.munin
22Source4: dlv.isc.org.key
23Patch1: unbound-1.2-glob.patch
24
25Group: System Environment/Daemons
26BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
27BuildRequires: flex, ldns-devel >= 1.5.0,
28BuildRequires: libevent-devel
29BuildRequires: expat-devel
30%if %{with_python}
31BuildRequires:  python-devel swig
32%endif
33%if %{enable_gost}
34BuildRequires: openssl-devel >= 1.0.0
35%else
36BuildRequires: openssl-devel
37%endif
38# Required for SVN versions
39#BuildRequires: bison
40
41
42Requires(post): chkconfig
43Requires(preun): chkconfig
44Requires(preun): initscripts
45Requires(postun): initscripts
46Requires: ldns >= 1.5.0
47Requires(pre): shadow-utils
48
49Distribution: Vine Linux
50Vendor: Project Vine
51Packager: iwaim
52
53%description
54Unbound is a validating, recursive, and caching DNS(SEC) resolver.
55
56The C implementation of Unbound is developed and maintained by NLnet
57Labs. It is based on ideas and algorithms taken from a java prototype
58developed by Verisign labs, Nominet, Kirei and ep.net.
59
60Unbound is designed as a set of modular components, so that also
61DNSSEC (secure DNS) validation and stub-resolvers (that do not run
62as a server, but are linked into an application) are easily possible.
63
64%if %{with_munin}
65%package munin
66Summary: Plugin for the munin / munin-node monitoring package
67Group:     System Environment/Daemons
68Requires: munin-node
69Requires: %{name} = %{version}-%{release}, bc
70
71%description munin
72Plugin for the munin / munin-node monitoring package
73%endif
74
75%package devel
76Summary: Development package that includes the unbound header files
77Group: Development/Libraries
78Requires: %{name}-libs = %{version}-%{release}, openssl-devel, ldns-devel
79
80%description devel
81The devel package contains the unbound library and the include files
82
83%package libs
84Summary: Libraries used by the unbound server and client applications
85Group: Applications/System
86Requires(post): /sbin/ldconfig
87Requires(postun): /sbin/ldconfig
88Requires: openssl >= 0.9.8g-12
89
90%description libs
91Contains libraries used by the unbound server and client applications
92
93%if %{with_python}
94%package python
95Summary: Python modules and extensions for unbound
96Group: Applications/System
97Requires: %{name}-libs = %{version}-%{release}
98
99%description python
100Python modules and extensions for unbound
101%endif
102
103%prep
104%setup -q
105%patch1 -p1
106
107%build
108%configure  --with-ldns= --with-libevent --with-pthreads --with-ssl \
109            --disable-rpath --enable-debug --disable-static \
110            --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
111            --with-pidfile=%{_localstatedir}/run/%{name}/%{name}.pid \
112%if %{with_python}
113            --with-pythonmodule --with-pyunbound \
114%endif
115%if !%{enable_gost}
116            --disable-gost \
117%endif
118            --enable-sha2
119%{__make} %{?_smp_mflags}
120
121%install
122rm -rf %{buildroot}
123%{__make} DESTDIR=%{buildroot} install
124install -d 0755 %{buildroot}%{_initrddir}
125install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
126install -m 0755 %{SOURCE2} %{buildroot}%{_sysconfdir}/unbound
127%if %{with_munin}
128# Install munin plugin and its softlinks
129install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
130install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
131install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
132install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
133for plugin in unbound_munin_hits unbound_munin_queue unbound_munin_memory unbound_munin_by_type unbound_munin_by_class unbound_munin_by_opcode unbound_munin_by_rcode unbound_munin_by_flags unbound_munin_histogram; do
134    ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
135done
136%endif
137
138# install DLV key
139install -m 0644 %{SOURCE4} %{buildroot}%{_sysconfdir}/unbound/
140
141# remove static library from install (fedora packaging guidelines)
142rm -rf %{buildroot}%{_libdir}/*.la
143%if %{with_python}
144rm -rf %{buildroot}%{python_sitelib}/*/*.la
145%endif
146
147mkdir -p %{buildroot}%{_localstatedir}/run/unbound
148
149%clean
150rm -rf ${RPM_BUILD_ROOT}
151
152%files
153%defattr(-,root,root,-)
154%doc doc/README doc/CREDITS doc/LICENSE doc/FEATURES
155%attr(0755,root,root) %{_initrddir}/%{name}
156%attr(0755,root,root) %dir %{_sysconfdir}/%{name}
157%attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
158%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
159%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
160%{_sbindir}/*
161%{_mandir}/*/*
162
163%if %{with_python}
164%files python
165%{python_sitelib}/*
166%endif
167
168%if %{with_munin}
169%files munin
170%defattr(-,root,root,-)
171%config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
172%{_datadir}/munin/plugins/unbound*
173%endif
174
175%files devel
176%defattr(-,root,root,-)
177%{_libdir}/libunbound.so
178%{_includedir}/unbound.h
179%doc README
180
181%files libs
182%defattr(-,root,root,-)
183%{_libdir}/libunbound.so.*
184%doc doc/README doc/LICENSE
185
186%pre
187getent group unbound >/dev/null || groupadd -r unbound
188getent passwd unbound >/dev/null || \
189useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
190-c "Unbound DNS resolver" unbound
191exit 0
192
193%post
194/sbin/chkconfig --add %{name}
195# dnssec-conf used to contain our DLV key, but now we include it via unbound
196# If unbound had previously been configured with dnssec-configure, we need
197# to migrate the location of the DLV key file (to keep DLV enabled, and because
198# unbound won't start with a bad location for a DLV key file.
199sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
200
201%post libs -p /sbin/ldconfig
202
203%preun
204if [ "$1" -eq 0 ]; then
205        /sbin/service %{name} stop >/dev/null 2>&1
206        /sbin/chkconfig --del %{name}
207fi
208
209%postun
210if [ "$1" -ge "1" ]; then
211  /sbin/service %{name} condrestart >/dev/null 2>&1 || :
212fi
213
214%postun libs -p /sbin/ldconfig
215
216%changelog
217* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
218- rebuild with python-2.7.2
219
220* Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
221- new upstream release
222
223* Sat Sep  3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
224- new upstream release
225
226* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
227- new upstream releas
228
229* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
230- new upstream release
231
232* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
233- new upstream release
234
235* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
236- rebuilt with libevent-2.0.10
237
238* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
239- new upstream release
240- add enable_gost flag: default disable
241- add BuildRequires: expat-devel
242
243* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
244- new upstream release
245
246* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
247- new upstream release
248
249* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
250- initial build for Vine Linux: based Fedora 1.4.3-1.fc14
251 - update to 1.4.4
252 - build without munin
253
254* Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
255- Update to 1.4.3 that fixes 64bit crasher
256
257* Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
258- Updated to 1.4.2
259- Updated unbound.conf with new options
260- Enabled pre-fetching DNSKEY records (DNSSEC speedup)
261- Enabled re-fetching popular records before they expire
262- Enabled logging of DNSSEC validation errors
263
264* Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
265- Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
266  with pthreads
267
268* Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
269- Change make/configure lines to attempt to fix -lphtread linking issue
270
271* Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
272- Removed dependancy for dnssec-conf
273- Added ISC DLV key (formerly in dnssec-conf)
274- Fixup old DLV locations in unbound.conf file via %%post
275- Fix parent child disagreement handling and no-ipv6 present [svn r1953]
276
277* Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
278- Updated to 1.4.1
279- Changed %%define to %%global
280
281* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
282- Bump version
283
284* Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
285- Upgraded to 1.3.4. Security fix with validating NSEC3 records
286
287* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
288- rebuilt with new openssl
289
290* Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
291- Updated to 1.3.3
292
293* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
294- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
295
296* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
297- Added missing glob patch to cvs
298- Place python macros within the %%with_python check
299
300* Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
301- Updated to 1.3.0
302- Added unbound-python sub package. disabled for now
303- Patch from svn to fix DLV lookups
304- Patches from svn to detect wrong truncated response from BIND 9.6.1 with
305  minimal-responses)
306- Added Default-Start and Default-Stop to unbound.init
307- Re-enabled --enable-sha2
308- Re-enabled glob.patch
309
310* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
311- unbound-iterator.patch was not commited
312
313* Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
314- Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
315
316* Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
317- Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
318
319* Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
320- enable DNSSEC only if it is enabled in sysconfig/dnssec
321
322* Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
323- add DNSSEC support to initscript and enabled it per default
324- add requires dnssec-conf
325
326* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
327- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
328
329* Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
330- updated to 1.2.1
331
332* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
333- rebuild with new openssl
334
335* Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
336- Updated to 1.2.0
337- Added dependancy on minimum SSL for CVE-2008-5077
338- Added dependancy on bc for unbound-munin
339- Added minimum requirement of libevent 1.4.5. Crashes with older versions
340  (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
341- Removed dependancy on selinux-policy (will get used when available)
342- Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
343- Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
344- Enable val-clean-additional to drop addition unsigned data from signed
345  response.
346- Removed patches (got merged into upstream)
347
348* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
349- Modified scandir patch to silently fail when wildcard matches nothing
350- Patch to allow unbound-checkconf to find empty wildcard matches
351
352* Mon Jan  5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
353- Added scandir patch for trusted-keys-file: option, which
354  is used to load multiple dnssec keys in bind file format
355
356* Mon Dec  8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
357- Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
358
359* Mon Dec  1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
360- We did not own the /etc/unbound directory (#474020)
361- Fixed cvs anomalies
362
363* Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
364- removed all obsolete chroot related stuff
365- label control certs after generation correctly
366
367* Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
368- Updated to unbound 1.1.1 which fixes a crasher and
369  addresses nlnetlabs bug #219
370
371* Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
372- Remove the chroot, obsoleted by SElinux
373- Add additional munin plugin links supported by unbound plugin
374- Move configuration directory from /var/lib/unbound to /etc/unbound
375- Modified unbound.init and unbound.conf to account for chroot changes
376- Updated unbound.conf with new available options
377- Enabled dns-0x20 protection per default
378
379* Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
380- unbound-1.1.0-log_open.patch
381  - make sure log is opened before chroot call
382  - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
383- removed /dev/log and /var/run/unbound and /etc/resolv.conf from
384  chroot, not needed
385- don't mount files in chroot, it causes problems during updates
386- fixed typo in default config file
387
388* Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
389- Updated to version 1.1.0
390- Updated unbound.conf's statistics options and remote-control
391  to work properly for munin
392- Added unbound-munin package
393- Generate unbound remote-control  key/certs on first startup
394- Required ldns is now 1.4.0
395
396* Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
397- Only call ldconfig in -libs package
398- Move configure into build section
399- devel subpackage should only depend on libs subpackage
400
401* Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
402- Fix CFLAGS getting lost in build
403- Don't enable interface-automatic:yes because that
404  causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
405
406* Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
407- Split off unbound-libs, make build verbose
408
409* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
410- FSB compliance, chroot fixes, initscript fixes
411
412* Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
413- Upgraded to 1.0.2
414
415* Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
416- upgraded to new release
417
418* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
419- Build against ldns-1.3.0
420
421* Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
422- Split of -devel package, fixed dependancies, make rpmlint happy
423
424* Thu Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
425- Using parts from ports collection entry by Jaap Akkerhuis.
426- Using Fedoraproject wiki guidelines.
427
428* Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
429- Initial version.
Note: See TracBrowser for help on using the repository browser.