source: projects/specs/trunk/u/umb-scheme/umb-scheme-vl.spec @ 3754

Revision 3754, 4.9 KB checked in by inagaki, 13 years ago (diff)

update: umb-scheme

Line 
1Summary: An implementation of the Scheme programming language.
2Summary(ja): Scheme プログラミング言語の実装
3Name: umb-scheme
4Version: 3.2
5Release: 31%{?_dist_release}
6
7License: distributable
8Group: Development/Languages
9
10Source: ftp://ftp.cs.umb.edu/pub/scheme/umb-scheme-3.2.tar.gz
11Source1: http://groups.csail.mit.edu/mac/ftpdir/scm/slib-3b3.zip
12Source2: slibcat
13Patch0: umb-scheme-3.2-misc.patch
14Patch1: umb-scheme-3.2-texinfo.patch
15Patch2: umb-scheme-3.2-config.patch
16Patch3: umb-scheme-3.2-man.patch
17Patch4: umb-scheme-3.2-chapter.patch
18Patch5: umb-scheme-3.2-slib2c7.patch
19Patch6: umb-scheme-3.2-share.patch
20Patch7: umb-scheme-3.2-vi.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: texinfo
24Requires(post): /sbin/install-info
25Requires(preun): /sbin/install-info
26
27%description
28UMB Scheme is a public domain implementation of the Scheme programming
29language.  Scheme is a statically scoped and properly tail-recursive
30dialect of the Lisp programming language, designed with clear and
31simple semantics and a minimal number of ways to form expressions.
32
33Install the umb-scheme package if you need an implementation of the
34Scheme programming language.
35
36
37%prep
38%setup -q -n scheme-3.2
39rm -fr slib
40unzip -q -o %{SOURCE1}
41%patch0 -p1
42%patch1 -p1
43%patch2 -p1
44%patch3 -p1
45%patch4 -p1
46%patch5 -p1
47%patch6 -p1
48%patch7 -p1
49
50%build
51make "RPM_OPT_FLAGS=$RPM_OPT_FLAGS"
52makeinfo scheme.texinfo
53
54
55%install
56[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
57mkdir -p $RPM_BUILD_ROOT{%{_bindir},%{_infodir},%{_datadir}/umb-scheme,%{_mandir}/man1}
58
59install -s -m755 scheme $RPM_BUILD_ROOT%{_bindir}/umb-scheme
60install -m755 scheme.1 $RPM_BUILD_ROOT%{_mandir}/man1/umb-scheme.1
61install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/umb-scheme/slibcat
62
63find slib | cpio -pdm $RPM_BUILD_ROOT%{_datadir}/umb-scheme
64install -m644 prelude.scheme $RPM_BUILD_ROOT%{_datadir}/umb-scheme
65
66install -m644 scheme.info $RPM_BUILD_ROOT%{_infodir}/umb-scheme.info
67gzip -9nf $RPM_BUILD_ROOT%{_infodir}/umb-scheme.info
68
69chmod -x $RPM_BUILD_ROOT%{_mandir}/*/*
70
71
72%clean
73[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
74
75
76%post
77/sbin/install-info %{_infodir}/umb-scheme.info.gz %{_infodir}/dir \
78  --entry="* umb-scheme: (umb-scheme).                     UMB Scheme Interpreter."
79
80
81%preun
82if [ "$1" = 0 ]; then
83    /sbin/install-info --delete %{_infodir}/umb-scheme.info.gz %{_infodir}/dir \
84      --entry="* umb-scheme: (umb-scheme).                     UMB Scheme Interpreter."
85fi
86
87
88%files
89%defattr(-,root,root)
90%doc slib/ANNOUNCE slib/FAQ slib/README
91%attr(0755,root,root) %{_bindir}/umb-scheme
92%attr(0755,root,root) %dir %{_datadir}/umb-scheme
93%attr(0644,root,root) %{_datadir}/umb-scheme/prelude.scheme
94%attr(0644,root,root) %{_datadir}/umb-scheme/slibcat
95%attr(0755,root,root) %dir %{_datadir}/umb-scheme/slib
96%attr(0644,root,root) %{_datadir}/umb-scheme/slib/*
97%{_mandir}/man1/umb-scheme.1*
98%{_infodir}/umb-scheme.info.gz
99
100
101%changelog
102* Sun May  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-31
103- rebuilt with current VineSeed
104- updated slib to 3b3
105- updated Patch6
106- s/BuildPrereq/BuildRequires/g
107- s/Prereq/Requires(post,preun)/g
108
109* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-30vl5
110- applied new versioning policy, spec in utf-8
111
112* Tue Oct 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-29vl2
113- updated slib to 3a1
114- added Prereq: and BuildPrereq:
115
116* Thu Feb 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-29vl1
117- based on 3.2-29 from Rawhide
118  - Added new slib library (#76693).
119  - Updated slibcat as well.
120  - Fixed unset EDITOR vi location (#76692).
121  - Fixed Copyright: to License:.
122  - Fixed problem with read-only /usr pollution of
123    /usr/share/umb-scheme/slibcat(#52742)
124  - Fixed wrong slibcat version (#40395)
125
126* Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
127- 3.2-17vl1
128- based on 3.2-17 from Rawhide
129- added Japanese summary
130
131* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
132- rebuild
133
134* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
135- automatic rebuild
136
137* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
138- update to slib 2c8
139
140* Sat Jun 10 2000 Nalin Dahyabhai <nalin@redhat.com>
141- fix wacky permissions in slib directory (bug #11871)
142
143* Sun Jun  4 2000 Nalin Dahyabhai <nalin@redhat.com>
144- FHS fixes
145- move slib to %%{_datadir}
146
147* Tue Feb  8 2000 Nalin Dahyabhai <nalin@redhat.com>
148- update slib to version 2c7
149- generate new catalog for slib and include it
150
151* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
152- remove executable bit from man page (Bug #9035)
153- deal with RPM compressing man pages
154
155* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
156- auto rebuild in the new build environment (release 9)
157
158* Tue Aug 11 1998 Jeff Johnson <jbj@redhat.com>
159- build root
160
161* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
162- translations modified for de, fr, tr
163
164* Fri Oct 24 1997 Marc Ewing <marc@redhat.com>
165- install-info
166
167* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
168- built against glibc
Note: See TracBrowser for help on using the repository browser.