source: projects/specs/trunk/u/ulogd/ulogd-vl.spec @ 8860

Revision 8860, 10.1 KB checked in by tomop, 10 years ago (diff)

ulogd-2.0.4-2

Line 
1Summary: Userspace logging daemon for netfilter
2Name: ulogd
3Version: 2.0.4
4Release: 2%{?_dist_release}
5License: GPLv2+
6Group: System Environment/Daemons
7URL: http://www.netfilter.org/projects/%{name}/
8Source0: http://ftp.netfilter.org/pub/%{name}/%{name}-%{version}.tar.bz2
9Source1: %{name}.init
10
11BuildRequires: libnetfilter_conntrack-devel >= 0.0.95
12BuildRequires: libnetfilter_log-devel >= 1.0.0
13BuildRequires: libnfnetlink-devel >= 0.0.39
14BuildRequires: libnetfilter_acct-devel >= 1.0.1
15BuildRequires: libmnl-devel
16BuildRequires: linuxdoc-tools
17BuildRequires: texlive-collection-fontsrecommended
18
19Requires(post): /sbin/service
20Requires(post): /sbin/chkconfig
21Requires(preun): /sbin/chkconfig
22Requires(preun): /sbin/service
23Requires(postun): /sbin/service
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: tomop
28
29%description
30%{name} is a logging daemon that reads event messages coming from the Netfilter
31connection tracking and the Netfilter packet logging subsystem. You have to
32enable support for connection tracking event delivery; ctnetlink and the NFLOG
33target in your Linux kernel 2.6.x or load their respective modules. The
34deprecated ULOG target (which has been superseded by NFLOG) is also supported.
35
36%package libdbi
37Summary: Libdbi framework output plugin for %{name}
38Group: System Environment/Daemons
39BuildRequires: libdbi-devel
40Requires: %{name} = %{version}
41%description libdbi
42%{name}-libdbi is a libdbi output plugin for %{name}. It enables logging of
43firewall information through a libdbi interface.
44
45%package mysql
46Summary: MySQL output plugin for %{name}
47Group: System Environment/Daemons
48BuildRequires: libmysqlclient-devel
49Requires: %{name} = %{version}
50%description mysql
51%{name}-mysql is a MySQL output plugin for %{name}. It enables logging of
52firewall information into a MySQL database.
53
54%package pgsql
55Summary: PostgreSQL output plugin for %{name}
56Group: System Environment/Daemons
57BuildRequires: libpq-devel
58Requires: %{name} = %{version}
59%description pgsql
60%{name}-pgsql is a PostgreSQL output plugin for %{name}. It enables logging of
61firewall information into a PostgreSQL database.
62
63%package pcap
64Summary: PCAP output plugin for %{name}
65Group: System Environment/Daemons
66BuildRequires: libpcap-devel
67Requires: %{name} = %{version}
68%description pcap
69%{name}-pcap is a output plugin for %{name} that saves packet logs as PCAP
70file. PCAP is a standard format that can be later analyzed by a lot of tools
71such as tcpdump and wireshark.
72
73%package sqlite
74Summary: SQLITE output plugin for %{name}
75Group: System Environment/Daemons
76BuildRequires: sqlite3-devel
77Requires: %{name} = %{version}
78%description sqlite
79%{name}-sqlite is a SQLITE output plugin for %{name}. It enables logging of
80firewall information into an SQLITE database.
81
82%prep
83%setup -q
84
85%{__sed} -i -e 's|/var/log/|%{_localstatedir}/log/%{name}/|g' %{name}.conf.in
86
87%{__sed} -i -e 's|/var/log/|%{_localstatedir}/log/%{name}/|g' %{name}.logrotate
88%{__sed} -i -e 's|/bin/killall|%{_bindir}/killall|g' %{name}.logrotate
89
90%build
91%configure \
92   --disable-static \
93   --enable-shared \
94   --with-dbi-lib=%{_libdir} \
95   --with-pcap-lib=%{_libdir} \
96   --with-sqlite3-lib=%{_libdir}
97
98%{__make} %{?_smp_mflags}
99%{__make} %{?_smp_mflags} -C doc
100
101%install
102%{__rm} -rf %{buildroot}
103%{__make} DESTDIR=%{buildroot} install
104
105%{__mkdir_p} -m 0755 %{buildroot}%{_localstatedir}/log/%{name}/
106
107%{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/
108%{__install} -m 0644 %{name}.conf %{buildroot}%{_sysconfdir}/
109
110%{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/logrotate.d/
111%{__install} -m 0644 %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
112
113%{__mkdir_p} -m 0755 %{buildroot}%{_initrddir}/
114%{__install} -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
115
116%post
117/sbin/chkconfig --add %{name}
118/sbin/service %{name} condrestart >/dev/null 2>&1 || :
119
120%preun
121# if we are uninstalling...
122if [ "$1" = 0 ]; then
123   /sbin/service %{name} stop > /dev/null 2>&1 ||:
124   /sbin/chkconfig --del %{name}
125fi
126
127%postun
128# if we are upgrading...
129if [ "$1" -ge "1" ]; then
130   /sbin/service %{name} condrestart >/dev/null 2>&1 || :
131fi
132
133%check
134%{__make} %{?_smp_mflags} check
135
136%clean
137%{__rm} -rf %{buildroot}
138
139%files
140%defattr(0755,root,root,0755)
141%{_sbindir}/%{name}
142%{_initrddir}/%{name}
143%{_libdir}/%{name}
144%defattr(0644,root,root,0755)
145%doc COPYING
146%doc AUTHORS README
147%doc doc/%{name}.txt doc/%{name}.ps doc/%{name}.html
148%doc %{_mandir}/man?/*
149%config(noreplace) %{_sysconfdir}/%{name}.conf
150%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
151%dir %{_localstatedir}/log/%{name}
152%exclude %{_libdir}/%{name}/*.la
153%exclude %{_libdir}/%{name}/%{name}_output_DBI.so
154%exclude %{_libdir}/%{name}/%{name}_output_MYSQL.so
155%exclude %{_libdir}/%{name}/%{name}_output_PGSQL.so
156%exclude %{_libdir}/%{name}/%{name}_output_PCAP.so
157%exclude %{_libdir}/%{name}/%{name}_output_SQLITE3.so
158
159%files libdbi
160%defattr(0755,root,root,0755)
161%{_libdir}/%{name}/%{name}_output_DBI.so
162%defattr(0644,root,root,0755)
163%doc COPYING
164
165%files mysql
166%defattr(0755,root,root,0755)
167%{_libdir}/%{name}/%{name}_output_MYSQL.so
168%defattr(0644,root,root,0755)
169%doc COPYING
170
171%files pgsql
172%defattr(0755,root,root,0755)
173%{_libdir}/%{name}/%{name}_output_PGSQL.so
174%defattr(0644,root,root,0755)
175%doc COPYING
176
177%files pcap
178%defattr(0755,root,root,0755)
179%{_libdir}/%{name}/%{name}_output_PCAP.so
180%defattr(0644,root,root,0755)
181%doc COPYING
182
183%files sqlite
184%defattr(0755,root,root,0755)
185%{_libdir}/%{name}/%{name}_output_SQLITE3.so
186%defattr(0644,root,root,0755)
187%doc COPYING
188
189%changelog
190* Mon Jul 14 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-2
191- fixed configuration for logrotate.
192
193* Sun Jun 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
194- new upstream release.
195- initial build for Vine Linux.
196
197* Tue Sep 24 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-2
198- added accidentaly removed dist suffix in release
199- fixed up bogus dates in changelog
200
201* Mon Sep 09 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-1
202- update version
203
204* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-5.beta4
205- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
206
207* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4.beta4
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
209
210* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-3.beta4
211- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
212
213* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-2.beta4
214- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
215
216* Wed Nov 23 2011 Stephen Beahm <stephenbeahm@comcast.net> - 2.0.0-1.beta4
217- update version.
218- spec review.
219- (rebased on top of the remaining 1.24 changes, original date was Nov 16 2010)
220
221* Wed Mar 23 2011 Dan Horák <dan@danny.cz> - 1.24-15
222- rebuilt for mysql 5.5.10 (soname bump in libmysqlclient)
223
224* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-14
225- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
226
227* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.24-13
228- rebuilt with new openssl
229
230* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-12
231- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
232
233* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-11
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
235
236* Sat Jan 24 2009 Aurelien Bompard <abompard@fedoraproject.org> 1.24-10
237- rebuild for mysql
238
239* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.24-9
240- Autorebuild for GCC 4.3
241
242* Wed Jan 9 2008 Leopold Aichinger <linuxtrainer@gmx.at> 1.24-8
243- Support for libpcap added
244
245* Thu Dec 06 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.24-7
246- Rebuild for deps
247
248* Tue Aug 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-5
249- Fix the deprecated way of getting the DSO initializers run, causing
250  builds to fails with rpm-build > 4.4.2.1-3 (new find-debuginfo.sh script)
251
252* Sat Jul 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-4
253- add patch to fix bug 247345
254- update URL
255- fix initscript (bug 247083)
256- unmark init script as %%config (Fedora policy)
257
258* Sat Dec 09 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-3
259- rebuild
260
261* Thu Aug 31 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-2
262- rebuild
263
264* Wed Feb 22 2006 Aurelien Bompard <gauret[AT]free.fr> 1.24-1
265- version 1.24
266- drop patch3 (applied upstream)
267- drop patch4 (upstream uses mysql-config to detect libdir now)
268- drop patch5 (applied upstream)
269
270* Tue Feb 21 2006 Aurelien Bompard <gauret[AT]free.fr> 1.23-3
271- rebuild for FC5
272
273* Sun Jul 24 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-2
274- compress rotated logs
275- start after mysql in the init process
276- use dist tag
277
278* Tue Apr 19 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-1.fc4
279- version 1.23
280- change release tag for FC4
281- add patch for GCC4 (upstream bug #323)
282
283* Thu Apr 07 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
284- rebuilt
285
286* Wed Mar 09 2005 Aurelien Bompard <gauret[AT]free.fr> 1.22-1
287- version 1.22
288- add gpg signature to sources
289
290* Sun Feb 20 2005 Aurelien Bompard <gauret[AT]free.fr> 1.21-1
291- version 1.21
292
293* Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-8
294- revise x86_64 patch to remove more hardcoded /lib badness
295
296* Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-7
297- x86_64, patch configure to look for mysql/pgsql below %%_libdir.
298- delete undefined %%epoch in mysql/pgsql sub package dep.
299
300* Sun Oct 31 2004 Aurelien Bompard <gauret[AT]free.fr> 1.02-6
301- apply Michael Schwendt's suggestions in bug 1598
302
303* Wed Oct 20 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.5
304- enable MySQL and PostgreSQL in subpackages
305- add man page from Debian
306
307* Wed Oct 06 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.4
308- apply QA suggestions (bug 1598)
309
310* Sat Jul 10 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.3
311- disable parallel builds
312- add chkconfig to Requires(pre,post)
313- set the right mode for /etc/logrotate.d/ulogd
314- rotate weekly
315
316* Sun May 16 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.2
317- Add Epoch: 0
Note: See TracBrowser for help on using the repository browser.