source: projects/specs/trunk/u/ulogd/ulogd-vl.spec @ 8624

Revision 8624, 9.8 KB checked in by tomop, 10 years ago (diff)

ulogd-2.0.4-1

Line 
1Summary: Userspace logging daemon for netfilter
2Name: ulogd
3Version: 2.0.4
4Release: 1%{?_dist_release}
5License: GPLv2+
6Group: System Environment/Daemons
7URL: http://www.netfilter.org/projects/%{name}/
8Source0: http://ftp.netfilter.org/pub/%{name}/%{name}-%{version}.tar.bz2
9Source1: %{name}.init
10
11BuildRequires: libnetfilter_conntrack-devel >= 0.0.95
12BuildRequires: libnetfilter_log-devel >= 1.0.0
13BuildRequires: libnfnetlink-devel >= 0.0.39
14BuildRequires: libnetfilter_acct-devel >= 1.0.1
15BuildRequires: libmnl-devel
16BuildRequires: linuxdoc-tools
17BuildRequires: texlive-collection-fontsrecommended
18
19Requires(post): /sbin/service
20Requires(post): /sbin/chkconfig
21Requires(preun): /sbin/chkconfig
22Requires(preun): /sbin/service
23Requires(postun): /sbin/service
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: tomop
28
29%description
30%{name} is a logging daemon that reads event messages coming from the Netfilter
31connection tracking and the Netfilter packet logging subsystem. You have to
32enable support for connection tracking event delivery; ctnetlink and the NFLOG
33target in your Linux kernel 2.6.x or load their respective modules. The
34deprecated ULOG target (which has been superseded by NFLOG) is also supported.
35
36%package libdbi
37Summary: Libdbi framework output plugin for %{name}
38Group: System Environment/Daemons
39BuildRequires: libdbi-devel
40Requires: %{name} = %{version}
41%description libdbi
42%{name}-libdbi is a libdbi output plugin for %{name}. It enables logging of
43firewall information through a libdbi interface.
44
45%package mysql
46Summary: MySQL output plugin for %{name}
47Group: System Environment/Daemons
48BuildRequires: libmysqlclient-devel
49Requires: %{name} = %{version}
50%description mysql
51%{name}-mysql is a MySQL output plugin for %{name}. It enables logging of
52firewall information into a MySQL database.
53
54%package pgsql
55Summary: PostgreSQL output plugin for %{name}
56Group: System Environment/Daemons
57BuildRequires: libpq-devel
58Requires: %{name} = %{version}
59%description pgsql
60%{name}-pgsql is a PostgreSQL output plugin for %{name}. It enables logging of
61firewall information into a PostgreSQL database.
62
63%package pcap
64Summary: PCAP output plugin for %{name}
65Group: System Environment/Daemons
66BuildRequires: libpcap-devel
67Requires: %{name} = %{version}
68%description pcap
69%{name}-pcap is a output plugin for %{name} that saves packet logs as PCAP
70file. PCAP is a standard format that can be later analyzed by a lot of tools
71such as tcpdump and wireshark.
72
73%package sqlite
74Summary: SQLITE output plugin for %{name}
75Group: System Environment/Daemons
76BuildRequires: sqlite3-devel
77Requires: %{name} = %{version}
78%description sqlite
79%{name}-sqlite is a SQLITE output plugin for %{name}. It enables logging of
80firewall information into an SQLITE database.
81
82%prep
83%setup -q
84
85%{__sed} -i -e 's|/var/log/|%{_localstatedir}/log/%{name}/|g' %{name}.conf.in
86
87%build
88%configure \
89   --disable-static \
90   --enable-shared \
91   --with-dbi-lib=%{_libdir} \
92   --with-pcap-lib=%{_libdir} \
93   --with-sqlite3-lib=%{_libdir}
94
95%{__make} %{?_smp_mflags}
96%{__make} %{?_smp_mflags} -C doc
97
98%install
99%{__rm} -rf %{buildroot}
100%{__make} DESTDIR=%{buildroot} install
101
102%{__mkdir_p} -m 0755 %{buildroot}%{_localstatedir}/log/%{name}/
103
104%{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/
105%{__install} -m 0644 %{name}.conf %{buildroot}%{_sysconfdir}/
106
107%{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/logrotate.d/
108%{__install} -m 0644 %{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
109
110%{__mkdir_p} -m 0755 %{buildroot}%{_initrddir}/
111%{__install} -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
112
113%post
114/sbin/chkconfig --add %{name}
115/sbin/service %{name} condrestart >/dev/null 2>&1 || :
116
117%preun
118# if we are uninstalling...
119if [ "$1" = 0 ]; then
120   /sbin/service %{name} stop > /dev/null 2>&1 ||:
121   /sbin/chkconfig --del %{name}
122fi
123
124%postun
125# if we are upgrading...
126if [ "$1" -ge "1" ]; then
127   /sbin/service %{name} condrestart >/dev/null 2>&1 || :
128fi
129
130%check
131%{__make} %{?_smp_mflags} check
132
133%clean
134%{__rm} -rf %{buildroot}
135
136%files
137%defattr(0755,root,root,0755)
138%{_sbindir}/%{name}
139%{_initrddir}/%{name}
140%{_libdir}/%{name}
141%defattr(0644,root,root,0755)
142%doc COPYING
143%doc AUTHORS README
144%doc doc/%{name}.txt doc/%{name}.ps doc/%{name}.html
145%doc %{_mandir}/man?/*
146%config(noreplace) %{_sysconfdir}/%{name}.conf
147%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
148%dir %{_localstatedir}/log/%{name}
149%exclude %{_libdir}/%{name}/*.la
150%exclude %{_libdir}/%{name}/%{name}_output_DBI.so
151%exclude %{_libdir}/%{name}/%{name}_output_MYSQL.so
152%exclude %{_libdir}/%{name}/%{name}_output_PGSQL.so
153%exclude %{_libdir}/%{name}/%{name}_output_PCAP.so
154%exclude %{_libdir}/%{name}/%{name}_output_SQLITE3.so
155
156%files libdbi
157%defattr(0755,root,root,0755)
158%{_libdir}/%{name}/%{name}_output_DBI.so
159%defattr(0644,root,root,0755)
160%doc COPYING
161
162%files mysql
163%defattr(0755,root,root,0755)
164%{_libdir}/%{name}/%{name}_output_MYSQL.so
165%defattr(0644,root,root,0755)
166%doc COPYING
167
168%files pgsql
169%defattr(0755,root,root,0755)
170%{_libdir}/%{name}/%{name}_output_PGSQL.so
171%defattr(0644,root,root,0755)
172%doc COPYING
173
174%files pcap
175%defattr(0755,root,root,0755)
176%{_libdir}/%{name}/%{name}_output_PCAP.so
177%defattr(0644,root,root,0755)
178%doc COPYING
179
180%files sqlite
181%defattr(0755,root,root,0755)
182%{_libdir}/%{name}/%{name}_output_SQLITE3.so
183%defattr(0644,root,root,0755)
184%doc COPYING
185
186%changelog
187* Sun Jun 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
188- new upstream release.
189- initial build for Vine Linux.
190
191* Tue Sep 24 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-2
192- added accidentaly removed dist suffix in release
193- fixed up bogus dates in changelog
194
195* Mon Sep 09 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-1
196- update version
197
198* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-5.beta4
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
200
201* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4.beta4
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
203
204* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-3.beta4
205- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
206
207* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-2.beta4
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
209
210* Wed Nov 23 2011 Stephen Beahm <stephenbeahm@comcast.net> - 2.0.0-1.beta4
211- update version.
212- spec review.
213- (rebased on top of the remaining 1.24 changes, original date was Nov 16 2010)
214
215* Wed Mar 23 2011 Dan Horák <dan@danny.cz> - 1.24-15
216- rebuilt for mysql 5.5.10 (soname bump in libmysqlclient)
217
218* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-14
219- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
220
221* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.24-13
222- rebuilt with new openssl
223
224* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-12
225- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
226
227* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-11
228- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
229
230* Sat Jan 24 2009 Aurelien Bompard <abompard@fedoraproject.org> 1.24-10
231- rebuild for mysql
232
233* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.24-9
234- Autorebuild for GCC 4.3
235
236* Wed Jan 9 2008 Leopold Aichinger <linuxtrainer@gmx.at> 1.24-8
237- Support for libpcap added
238
239* Thu Dec 06 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.24-7
240- Rebuild for deps
241
242* Tue Aug 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-5
243- Fix the deprecated way of getting the DSO initializers run, causing
244  builds to fails with rpm-build > 4.4.2.1-3 (new find-debuginfo.sh script)
245
246* Sat Jul 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-4
247- add patch to fix bug 247345
248- update URL
249- fix initscript (bug 247083)
250- unmark init script as %%config (Fedora policy)
251
252* Sat Dec 09 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-3
253- rebuild
254
255* Thu Aug 31 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-2
256- rebuild
257
258* Wed Feb 22 2006 Aurelien Bompard <gauret[AT]free.fr> 1.24-1
259- version 1.24
260- drop patch3 (applied upstream)
261- drop patch4 (upstream uses mysql-config to detect libdir now)
262- drop patch5 (applied upstream)
263
264* Tue Feb 21 2006 Aurelien Bompard <gauret[AT]free.fr> 1.23-3
265- rebuild for FC5
266
267* Sun Jul 24 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-2
268- compress rotated logs
269- start after mysql in the init process
270- use dist tag
271
272* Tue Apr 19 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-1.fc4
273- version 1.23
274- change release tag for FC4
275- add patch for GCC4 (upstream bug #323)
276
277* Thu Apr 07 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
278- rebuilt
279
280* Wed Mar 09 2005 Aurelien Bompard <gauret[AT]free.fr> 1.22-1
281- version 1.22
282- add gpg signature to sources
283
284* Sun Feb 20 2005 Aurelien Bompard <gauret[AT]free.fr> 1.21-1
285- version 1.21
286
287* Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-8
288- revise x86_64 patch to remove more hardcoded /lib badness
289
290* Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-7
291- x86_64, patch configure to look for mysql/pgsql below %%_libdir.
292- delete undefined %%epoch in mysql/pgsql sub package dep.
293
294* Sun Oct 31 2004 Aurelien Bompard <gauret[AT]free.fr> 1.02-6
295- apply Michael Schwendt's suggestions in bug 1598
296
297* Wed Oct 20 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.5
298- enable MySQL and PostgreSQL in subpackages
299- add man page from Debian
300
301* Wed Oct 06 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.4
302- apply QA suggestions (bug 1598)
303
304* Sat Jul 10 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.3
305- disable parallel builds
306- add chkconfig to Requires(pre,post)
307- set the right mode for /etc/logrotate.d/ulogd
308- rotate weekly
309
310* Sun May 16 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.2
311- Add Epoch: 0
Note: See TracBrowser for help on using the repository browser.