source: projects/specs/trunk/u/ulogd/ulogd-vl.spec @ 12121

Revision 12121, 10.4 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%bcond_with doc
2
3Summary: Userspace logging daemon for netfilter
4Name: ulogd
5Version: 2.0.7
6Release: 1%{?_dist_release}
7License: GPLv2+
8Group: System Environment/Daemons
9URL: http://www.netfilter.org/projects/%{name}/
10Source0: http://ftp.netfilter.org/pub/%{name}/%{name}-%{version}.tar.bz2
11Source1: %{name}.init
12Source2: %{name}.logrotate
13
14BuildRequires: libnetfilter_conntrack-devel >= 0.0.95
15BuildRequires: libnetfilter_log-devel >= 1.0.0
16BuildRequires: libnfnetlink-devel >= 0.0.39
17BuildRequires: libnetfilter_acct-devel >= 1.0.1
18BuildRequires: libmnl-devel
19%if %{with doc}
20BuildRequires: linuxdoc-tools
21BuildRequires: texlive-collection-fontsrecommended
22%endif
23
24Requires(post): /sbin/service
25Requires(post): /sbin/chkconfig
26Requires(preun): /sbin/chkconfig
27Requires(preun): /sbin/service
28Requires(postun): /sbin/service
29
30Vendor: Project Vine
31Distribution: Vine Linux
32Packager: tomop
33
34%description
35%{name} is a logging daemon that reads event messages coming from the Netfilter
36connection tracking and the Netfilter packet logging subsystem. You have to
37enable support for connection tracking event delivery; ctnetlink and the NFLOG
38target in your Linux kernel 2.6.x or load their respective modules. The
39deprecated ULOG target (which has been superseded by NFLOG) is also supported.
40
41%package libdbi
42Summary: Libdbi framework output plugin for %{name}
43Group: System Environment/Daemons
44BuildRequires: libdbi-devel
45Requires: %{name} = %{version}
46%description libdbi
47%{name}-libdbi is a libdbi output plugin for %{name}. It enables logging of
48firewall information through a libdbi interface.
49
50%package mysql
51Summary: MySQL output plugin for %{name}
52Group: System Environment/Daemons
53BuildRequires: libmariadb-devel
54Requires: %{name} = %{version}
55%description mysql
56%{name}-mysql is a MySQL output plugin for %{name}. It enables logging of
57firewall information into a MySQL database.
58
59%package pgsql
60Summary: PostgreSQL output plugin for %{name}
61Group: System Environment/Daemons
62BuildRequires: libpq-devel
63Requires: %{name} = %{version}
64%description pgsql
65%{name}-pgsql is a PostgreSQL output plugin for %{name}. It enables logging of
66firewall information into a PostgreSQL database.
67
68%package pcap
69Summary: PCAP output plugin for %{name}
70Group: System Environment/Daemons
71BuildRequires: libpcap-devel
72Requires: %{name} = %{version}
73%description pcap
74%{name}-pcap is a output plugin for %{name} that saves packet logs as PCAP
75file. PCAP is a standard format that can be later analyzed by a lot of tools
76such as tcpdump and wireshark.
77
78%package sqlite
79Summary: SQLITE output plugin for %{name}
80Group: System Environment/Daemons
81BuildRequires: sqlite3-devel
82Requires: %{name} = %{version}
83%description sqlite
84%{name}-sqlite is a SQLITE output plugin for %{name}. It enables logging of
85firewall information into an SQLITE database.
86
87%prep
88%setup -q
89
90%{__sed} -i -e 's|/var/log/|%{_localstatedir}/log/%{name}/|g' %{name}.conf.in
91
92%build
93%configure \
94   --disable-static \
95   --enable-shared \
96   --with-dbi-lib=%{_libdir} \
97   --with-pcap-lib=%{_libdir} \
98   --with-sqlite3-lib=%{_libdir}
99
100%{__make} %{?_smp_mflags}
101%if %{with doc}
102%{__make} %{?_smp_mflags} -C doc
103%endif
104
105%install
106%{__rm} -rf %{buildroot}
107%{__make} DESTDIR=%{buildroot} install
108
109%{__mkdir_p} -m 0755 %{buildroot}%{_localstatedir}/log/%{name}/
110
111%{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/
112%{__install} -m 0644 %{name}.conf %{buildroot}%{_sysconfdir}/
113
114%{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/logrotate.d/
115%{__install} -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
116
117%{__mkdir_p} -m 0755 %{buildroot}%{_initrddir}/
118%{__install} -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
119
120%post
121/sbin/chkconfig --add %{name}
122/sbin/service %{name} condrestart >/dev/null 2>&1 || :
123
124%preun
125# if we are uninstalling...
126if [ "$1" = 0 ]; then
127   /sbin/service %{name} stop > /dev/null 2>&1 ||:
128   /sbin/chkconfig --del %{name}
129fi
130
131%postun
132# if we are upgrading...
133if [ "$1" -ge "1" ]; then
134   /sbin/service %{name} condrestart >/dev/null 2>&1 || :
135fi
136
137%check
138%{__make} %{?_smp_mflags} check
139
140%clean
141%{__rm} -rf %{buildroot}
142
143%files
144%defattr(0755,root,root,0755)
145%{_sbindir}/%{name}
146%{_initrddir}/%{name}
147%{_libdir}/%{name}
148%defattr(0644,root,root,0755)
149%license COPYING
150%doc AUTHORS README
151%if %{with doc}
152%doc doc/%{name}.txt doc/%{name}.ps doc/%{name}.html
153%endif
154%doc %{_mandir}/man?/*
155%config(noreplace) %{_sysconfdir}/%{name}.conf
156%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
157%dir %{_localstatedir}/log/%{name}
158%exclude %{_libdir}/%{name}/*.la
159%exclude %{_libdir}/%{name}/%{name}_output_DBI.so
160%exclude %{_libdir}/%{name}/%{name}_output_MYSQL.so
161%exclude %{_libdir}/%{name}/%{name}_output_PGSQL.so
162%exclude %{_libdir}/%{name}/%{name}_output_PCAP.so
163%exclude %{_libdir}/%{name}/%{name}_output_SQLITE3.so
164
165%files libdbi
166%defattr(0755,root,root,0755)
167%{_libdir}/%{name}/%{name}_output_DBI.so
168%defattr(0644,root,root,0755)
169%license COPYING
170
171%files mysql
172%defattr(0755,root,root,0755)
173%{_libdir}/%{name}/%{name}_output_MYSQL.so
174%defattr(0644,root,root,0755)
175%license COPYING
176
177%files pgsql
178%defattr(0755,root,root,0755)
179%{_libdir}/%{name}/%{name}_output_PGSQL.so
180%defattr(0644,root,root,0755)
181%license COPYING
182
183%files pcap
184%defattr(0755,root,root,0755)
185%{_libdir}/%{name}/%{name}_output_PCAP.so
186%defattr(0644,root,root,0755)
187%license COPYING
188
189%files sqlite
190%defattr(0755,root,root,0755)
191%{_libdir}/%{name}/%{name}_output_SQLITE3.so
192%defattr(0644,root,root,0755)
193%license COPYING
194
195%changelog
196* Sun Aug 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.7-1
197- new upstream release.
198- added Source2: dropped in upstream.
199- disabled to build documents: raised tooooo many errors.
200
201* Sun Feb 25 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.5-1
202- new upstream release.
203
204* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-3
205- rebuild with libdbi-0.9.0
206
207* Mon Jul 14 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-2
208- fixed configuration for logrotate.
209
210* Sun Jun 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
211- new upstream release.
212- initial build for Vine Linux.
213
214* Tue Sep 24 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-2
215- added accidentaly removed dist suffix in release
216- fixed up bogus dates in changelog
217
218* Mon Sep 09 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-1
219- update version
220
221* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-5.beta4
222- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
223
224* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4.beta4
225- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
226
227* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-3.beta4
228- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
229
230* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-2.beta4
231- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
232
233* Wed Nov 23 2011 Stephen Beahm <stephenbeahm@comcast.net> - 2.0.0-1.beta4
234- update version.
235- spec review.
236- (rebased on top of the remaining 1.24 changes, original date was Nov 16 2010)
237
238* Wed Mar 23 2011 Dan Horák <dan@danny.cz> - 1.24-15
239- rebuilt for mysql 5.5.10 (soname bump in libmysqlclient)
240
241* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-14
242- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
243
244* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.24-13
245- rebuilt with new openssl
246
247* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-12
248- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
249
250* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-11
251- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
252
253* Sat Jan 24 2009 Aurelien Bompard <abompard@fedoraproject.org> 1.24-10
254- rebuild for mysql
255
256* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.24-9
257- Autorebuild for GCC 4.3
258
259* Wed Jan 9 2008 Leopold Aichinger <linuxtrainer@gmx.at> 1.24-8
260- Support for libpcap added
261
262* Thu Dec 06 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.24-7
263- Rebuild for deps
264
265* Tue Aug 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-5
266- Fix the deprecated way of getting the DSO initializers run, causing
267  builds to fails with rpm-build > 4.4.2.1-3 (new find-debuginfo.sh script)
268
269* Sat Jul 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-4
270- add patch to fix bug 247345
271- update URL
272- fix initscript (bug 247083)
273- unmark init script as %%config (Fedora policy)
274
275* Sat Dec 09 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-3
276- rebuild
277
278* Thu Aug 31 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-2
279- rebuild
280
281* Wed Feb 22 2006 Aurelien Bompard <gauret[AT]free.fr> 1.24-1
282- version 1.24
283- drop patch3 (applied upstream)
284- drop patch4 (upstream uses mysql-config to detect libdir now)
285- drop patch5 (applied upstream)
286
287* Tue Feb 21 2006 Aurelien Bompard <gauret[AT]free.fr> 1.23-3
288- rebuild for FC5
289
290* Sun Jul 24 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-2
291- compress rotated logs
292- start after mysql in the init process
293- use dist tag
294
295* Tue Apr 19 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-1.fc4
296- version 1.23
297- change release tag for FC4
298- add patch for GCC4 (upstream bug #323)
299
300* Thu Apr 07 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
301- rebuilt
302
303* Wed Mar 09 2005 Aurelien Bompard <gauret[AT]free.fr> 1.22-1
304- version 1.22
305- add gpg signature to sources
306
307* Sun Feb 20 2005 Aurelien Bompard <gauret[AT]free.fr> 1.21-1
308- version 1.21
309
310* Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-8
311- revise x86_64 patch to remove more hardcoded /lib badness
312
313* Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-7
314- x86_64, patch configure to look for mysql/pgsql below %%_libdir.
315- delete undefined %%epoch in mysql/pgsql sub package dep.
316
317* Sun Oct 31 2004 Aurelien Bompard <gauret[AT]free.fr> 1.02-6
318- apply Michael Schwendt's suggestions in bug 1598
319
320* Wed Oct 20 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.5
321- enable MySQL and PostgreSQL in subpackages
322- add man page from Debian
323
324* Wed Oct 06 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.4
325- apply QA suggestions (bug 1598)
326
327* Sat Jul 10 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.3
328- disable parallel builds
329- add chkconfig to Requires(pre,post)
330- set the right mode for /etc/logrotate.d/ulogd
331- rotate weekly
332
333* Sun May 16 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.2
334- Add Epoch: 0
Note: See TracBrowser for help on using the repository browser.