source: projects/specs/trunk/u/ulogd/ulogd-vl.spec @ 12383

Revision 12383, 11.1 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

OpenEXR-2.4.1-1

ipset-7.6-1

meson-0.54.0-1

ninja-1.10.0-1

postsrsd-1.6-2

stunnel-5.56-1

ulogd-2.0.7-2

Line 
1%bcond_with systemd
2%bcond_with doc
3
4Summary: Userspace logging daemon for netfilter
5Name: ulogd
6Version: 2.0.7
7Release: 2%{?_dist_release}%{?with_systemd:.systemd}
8Group: System Environment/Daemons
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: GPLv2+
13URL: https://netfilter.org/projects/ulogd/
14Source0: https://netfilter.org/projects/ulogd/files/%{name}-%{version}.tar.bz2
15Source1: %{name}.init
16Source2: %{name}.logrotate
17Source3: %{name}.service
18
19BuildRequires: libnetfilter_conntrack-devel >= 0.0.95
20BuildRequires: libnetfilter_log-devel >= 1.0.0
21BuildRequires: libnfnetlink-devel >= 0.0.39
22BuildRequires: libnetfilter_acct-devel >= 1.0.1
23BuildRequires: libmnl-devel
24%if %{with doc}
25BuildRequires: linuxdoc-tools
26BuildRequires: texlive-collection-fontsrecommended
27%endif
28
29%if %{with systemd}
30%{?systemd_requires}
31%else
32Requires(post): /sbin/service
33Requires(post): /sbin/chkconfig
34Requires(preun): /sbin/chkconfig
35Requires(preun): /sbin/service
36Requires(postun): /sbin/service
37%endif
38
39%description
40%{name} is a logging daemon that reads event messages coming from the Netfilter
41connection tracking and the Netfilter packet logging subsystem. You have to
42enable support for connection tracking event delivery; ctnetlink and the NFLOG
43target in your Linux kernel 2.6.x or load their respective modules. The
44deprecated ULOG target (which has been superseded by NFLOG) is also supported.
45
46%package libdbi
47Summary: Libdbi framework output plugin for %{name}
48Group: System Environment/Daemons
49BuildRequires: libdbi-devel
50Requires: %{name} = %{version}
51%description libdbi
52%{name}-libdbi is a libdbi output plugin for %{name}. It enables logging of
53firewall information through a libdbi interface.
54
55%package mysql
56Summary: MySQL output plugin for %{name}
57Group: System Environment/Daemons
58BuildRequires: libmariadb-devel
59Requires: %{name} = %{version}
60%description mysql
61%{name}-mysql is a MySQL output plugin for %{name}. It enables logging of
62firewall information into a MySQL database.
63
64%package pgsql
65Summary: PostgreSQL output plugin for %{name}
66Group: System Environment/Daemons
67BuildRequires: libpq-devel
68Requires: %{name} = %{version}
69%description pgsql
70%{name}-pgsql is a PostgreSQL output plugin for %{name}. It enables logging of
71firewall information into a PostgreSQL database.
72
73%package pcap
74Summary: PCAP output plugin for %{name}
75Group: System Environment/Daemons
76BuildRequires: libpcap-devel
77Requires: %{name} = %{version}
78%description pcap
79%{name}-pcap is a output plugin for %{name} that saves packet logs as PCAP
80file. PCAP is a standard format that can be later analyzed by a lot of tools
81such as tcpdump and wireshark.
82
83%package sqlite
84Summary: SQLITE output plugin for %{name}
85Group: System Environment/Daemons
86BuildRequires: sqlite3-devel
87Requires: %{name} = %{version}
88%description sqlite
89%{name}-sqlite is a SQLITE output plugin for %{name}. It enables logging of
90firewall information into an SQLITE database.
91
92%prep
93%setup -q
94
95%{__sed} -i -e 's|/var/log/|%{_localstatedir}/log/%{name}/|g' %{name}.conf.in
96
97%build
98%configure \
99   --disable-static \
100   --enable-shared \
101   --with-dbi-lib=%{_libdir} \
102   --with-pcap-lib=%{_libdir} \
103   --with-sqlite3-lib=%{_libdir}
104
105%{__make} %{?_smp_mflags}
106%if %{with doc}
107%{__make} %{?_smp_mflags} -C doc
108%endif
109
110%install
111%{__rm} -rf %{buildroot}
112%{__make} DESTDIR=%{buildroot} install
113
114%{__mkdir_p} -m 0755 %{buildroot}%{_localstatedir}/log/%{name}/
115
116%{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/
117%{__install} -m 0644 %{name}.conf %{buildroot}%{_sysconfdir}/
118
119%{__mkdir_p} -m 0755 %{buildroot}%{_sysconfdir}/logrotate.d/
120%{__install} -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
121
122%if %{with systemd}
123%{__mkdir_p} -m 0755 %{buildroot}%{_unitdir}/
124%{__install} -m 0644 %{SOURCE3} %{buildroot}%{_unitdir}/%{name}.service
125%else
126%{__mkdir_p} -m 0755 %{buildroot}%{_initrddir}/
127%{__install} -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
128%endif
129
130
131%post
132%if %{with systemd}
133%systemd_post %{name}.service
134%else
135/sbin/chkconfig --add %{name}
136/sbin/service %{name} condrestart >/dev/null 2>&1 || :
137%endif
138
139%preun
140%if %{with systemd}
141%systemd_preun %{name}.service
142%else
143# if we are uninstalling...
144if [ "$1" = 0 -o -x /bin/systemctl ]; then
145   /sbin/service %{name} stop > /dev/null 2>&1 ||:
146   /sbin/chkconfig --del %{name}
147fi
148%endif
149
150%postun
151%if %{with systemd}
152%systemd_postun_with_restart %{name}.service
153%else
154# if we are upgrading...
155if [ "$1" -ge "1" ]; then
156   /sbin/service %{name} condrestart >/dev/null 2>&1 || :
157fi
158%endif
159
160
161%check
162%{__make} %{?_smp_mflags} check
163
164
165%clean
166%{__rm} -rf %{buildroot}
167
168
169%files
170%defattr(0755,root,root,0755)
171%{_sbindir}/%{name}
172%if %{with systemd}
173%{_unitdir}/%{name}.service
174%else
175%{_initrddir}/%{name}
176%endif
177%{_libdir}/%{name}
178%defattr(0644,root,root,0755)
179%license COPYING
180%doc AUTHORS README
181%if %{with doc}
182%doc doc/%{name}.txt doc/%{name}.ps doc/%{name}.html
183%endif
184%doc %{_mandir}/man?/*
185%config(noreplace) %{_sysconfdir}/%{name}.conf
186%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
187%dir %{_localstatedir}/log/%{name}
188%exclude %{_libdir}/%{name}/*.la
189%exclude %{_libdir}/%{name}/%{name}_output_DBI.so
190%exclude %{_libdir}/%{name}/%{name}_output_MYSQL.so
191%exclude %{_libdir}/%{name}/%{name}_output_PGSQL.so
192%exclude %{_libdir}/%{name}/%{name}_output_PCAP.so
193%exclude %{_libdir}/%{name}/%{name}_output_SQLITE3.so
194
195%files libdbi
196%defattr(0755,root,root,0755)
197%{_libdir}/%{name}/%{name}_output_DBI.so
198%defattr(0644,root,root,0755)
199%license COPYING
200
201%files mysql
202%defattr(0755,root,root,0755)
203%{_libdir}/%{name}/%{name}_output_MYSQL.so
204%defattr(0644,root,root,0755)
205%license COPYING
206
207%files pgsql
208%defattr(0755,root,root,0755)
209%{_libdir}/%{name}/%{name}_output_PGSQL.so
210%defattr(0644,root,root,0755)
211%license COPYING
212
213%files pcap
214%defattr(0755,root,root,0755)
215%{_libdir}/%{name}/%{name}_output_PCAP.so
216%defattr(0644,root,root,0755)
217%license COPYING
218
219%files sqlite
220%defattr(0755,root,root,0755)
221%{_libdir}/%{name}/%{name}_output_SQLITE3.so
222%defattr(0644,root,root,0755)
223%license COPYING
224
225%changelog
226* Sat Apr 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.7-2
227- added systemd support (disabled as default).
228
229* Sun Aug 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.7-1
230- new upstream release.
231- added Source2: dropped in upstream.
232- disabled to build documents: raised tooooo many errors.
233
234* Sun Feb 25 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.5-1
235- new upstream release.
236
237* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-3
238- rebuild with libdbi-0.9.0
239
240* Mon Jul 14 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-2
241- fixed configuration for logrotate.
242
243* Sun Jun 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.4-1
244- new upstream release.
245- initial build for Vine Linux.
246
247* Tue Sep 24 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-2
248- added accidentaly removed dist suffix in release
249- fixed up bogus dates in changelog
250
251* Mon Sep 09 2013 Martin Preisler <mpreisle@redhat.com> 2.0.2-1
252- update version
253
254* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-5.beta4
255- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
256
257* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4.beta4
258- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
259
260* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-3.beta4
261- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
262
263* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-2.beta4
264- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
265
266* Wed Nov 23 2011 Stephen Beahm <stephenbeahm@comcast.net> - 2.0.0-1.beta4
267- update version.
268- spec review.
269- (rebased on top of the remaining 1.24 changes, original date was Nov 16 2010)
270
271* Wed Mar 23 2011 Dan Horák <dan@danny.cz> - 1.24-15
272- rebuilt for mysql 5.5.10 (soname bump in libmysqlclient)
273
274* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-14
275- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
276
277* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.24-13
278- rebuilt with new openssl
279
280* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-12
281- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
282
283* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.24-11
284- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
285
286* Sat Jan 24 2009 Aurelien Bompard <abompard@fedoraproject.org> 1.24-10
287- rebuild for mysql
288
289* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.24-9
290- Autorebuild for GCC 4.3
291
292* Wed Jan 9 2008 Leopold Aichinger <linuxtrainer@gmx.at> 1.24-8
293- Support for libpcap added
294
295* Thu Dec 06 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.24-7
296- Rebuild for deps
297
298* Tue Aug 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-5
299- Fix the deprecated way of getting the DSO initializers run, causing
300  builds to fails with rpm-build > 4.4.2.1-3 (new find-debuginfo.sh script)
301
302* Sat Jul 14 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.24-4
303- add patch to fix bug 247345
304- update URL
305- fix initscript (bug 247083)
306- unmark init script as %%config (Fedora policy)
307
308* Sat Dec 09 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-3
309- rebuild
310
311* Thu Aug 31 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.24-2
312- rebuild
313
314* Wed Feb 22 2006 Aurelien Bompard <gauret[AT]free.fr> 1.24-1
315- version 1.24
316- drop patch3 (applied upstream)
317- drop patch4 (upstream uses mysql-config to detect libdir now)
318- drop patch5 (applied upstream)
319
320* Tue Feb 21 2006 Aurelien Bompard <gauret[AT]free.fr> 1.23-3
321- rebuild for FC5
322
323* Sun Jul 24 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-2
324- compress rotated logs
325- start after mysql in the init process
326- use dist tag
327
328* Tue Apr 19 2005 Aurelien Bompard <gauret[AT]free.fr> 1.23-1.fc4
329- version 1.23
330- change release tag for FC4
331- add patch for GCC4 (upstream bug #323)
332
333* Thu Apr 07 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
334- rebuilt
335
336* Wed Mar 09 2005 Aurelien Bompard <gauret[AT]free.fr> 1.22-1
337- version 1.22
338- add gpg signature to sources
339
340* Sun Feb 20 2005 Aurelien Bompard <gauret[AT]free.fr> 1.21-1
341- version 1.21
342
343* Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-8
344- revise x86_64 patch to remove more hardcoded /lib badness
345
346* Fri Dec 17 2004 Michael Schwendt <mschwendt[AT]users.sf.net> 1.02-7
347- x86_64, patch configure to look for mysql/pgsql below %%_libdir.
348- delete undefined %%epoch in mysql/pgsql sub package dep.
349
350* Sun Oct 31 2004 Aurelien Bompard <gauret[AT]free.fr> 1.02-6
351- apply Michael Schwendt's suggestions in bug 1598
352
353* Wed Oct 20 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.5
354- enable MySQL and PostgreSQL in subpackages
355- add man page from Debian
356
357* Wed Oct 06 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.4
358- apply QA suggestions (bug 1598)
359
360* Sat Jul 10 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.3
361- disable parallel builds
362- add chkconfig to Requires(pre,post)
363- set the right mode for /etc/logrotate.d/ulogd
364- rotate weekly
365
366* Sun May 16 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.02-0.fdr.2
367- Add Epoch: 0
Note: See TracBrowser for help on using the repository browser.