source: projects/specs/trunk/u/uim/uim-vl.spec @ 12376

Revision 12376, 38.3 KB checked in by tomop, 7 months ago (diff)

updated 19 packages

g-wrap-1.9.15-2

gjs-1.54.3-2

glib2-2.64.2-2

gobject-introspection-1.64.1-1

guile-2.2.7-1

guile20-2.0.14-5

hardinfo-0.5.1-4

llvm-10.0.0-2

libffi-3.3-1

libffi321-3.2.1-1

p11-kit-0.23.20-2

pycairo-1.18.2-1

pygobject-2.28.6-7

pygobject3-3.34.0-1

python-cffi-1.14.0-1

python-2.7.17-1

python3-3.5.9-1

ruby-2.6.6-2

uim-1.8.8-3

Line 
1%global commit c79432cb5aba3a67fb7e7557f4817c749865cc8a
2%global shortcommit %(c=%{commit}; echo ${c:0:7})
3
4%global sigscheme_commit cfcb6dd2ae93fd7b22b5e3a1403e2f0197602c79
5%global sigscheme_shortcommit %(c=%{sigscheme_commit}; echo ${c:0:7})
6%global sigscheme_version 0.9.0
7
8%global libgcroots_commit 514c4fe1af59b39e2b4b68f0a3c55b8bf573b4dc
9%global libgcroots_shortcommit %(c=%{libgcroots_commit}; echo ${c:0:7})
10%global libgcroots_version 0.3.1
11
12# build emacsen uim bridge ("--without emacs" to disable)
13%bcond_without emacsen
14# do not build gtk2 immodule ("--with qt3" to enable qt3)
15%bcond_with gtk2
16# do not build qt3 immodule ("--with qt3" to enable qt3)
17%bcond_with qt3
18# build qt4 immodule ("--without qt4" to disable qt4)
19%bcond_without qt4
20# build qt5 immodule ("--without qt5" to disable qt4)
21%bcond_without qt5
22# do not build KDE applet ("--with kde" to enable kde)
23%bcond_with kde
24# build mana support ("--without mana" to disable mana)
25%bcond_without mana
26
27# do not build GNOME applet ("--with gnome" to enable gnome)
28%bcond_with gnome
29# do not build Canna module ("--with canna" to enable canna)
30%bcond_with canna
31
32
33%if %{with qt3}
34# Qt3 version detection
35%define qt3_ver 3.3.8
36%define _qt3_version %(pkg-config --modversion --silence-errors qt-mt 2>/dev/null || echo %{qt3_ver})
37%define _qt3_prefix  %{_libdir}/qt-%{_qt3_version}
38%define _qt3_plugindir %{_qt3_prefix}/plugins
39%endif
40
41%if %{with qt4}
42# Qt4 version detection
43%define qt4_ver 4.8.6
44%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
45%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
46%define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
47%endif
48
49%if %{with qt5}
50# Qt5 version detection
51%define qt5_ver 5.6.3
52%define _qt5_version %(pkg-config --modversion --silence-errors Qt5 2>/dev/null || echo %{qt4_ver})
53%define _qt5_prefix %(pkg-config --variable prefix --silence-errors Qt5 2>/dev/null || echo %{_libdir}/qt4)
54%define _qt5_plugindir %(pkg-config --variable plugindir --silence-errors Qt5 2>/dev/null || echo %{_qt4_prefix}/plugins)
55%endif
56
57#define extraver beta
58
59Name: uim
60Summary: Uim an input method library
61Summary(ja): 入力メソッドライブラリ
62Version: 1.8.8
63#Release: 6.git%{shortcommit}%{?_dist_release}
64Release: 3%{?_dist_release}
65Group: System Environment/Libraries
66Vendor: Project Vine
67Distribution: Vine Linux
68Packager: iwaim
69
70# pinyin-big5.scm and elatin-rules.scm are licensed under GPL
71License: BSD, LGPLv2 and GPL
72URL: https://github.com/uim/uim
73Source0: https://github.com/uim/uim/releases/download/%{version}/uim-%{version}.tar.bz2
74Source1: uim-el-install.sh
75Source2: uim-el-remove.sh
76Source3: uim-update-installed-modules.sh.in
77Source4: vine-default-uim-el.el
78Source5: uim-el-init.el
79Source6: https://github.com/uim/sigscheme/releases/download/%{sigscheme_version}/sigscheme-%{sigscheme_version}.tar.bz2
80Source7: https://github.com/uim/libgcroots/releases/download/%{libgcroots_version}/libgcroots-%{libgcroots_version}.tar.bz2
81
82BuildRoot: %{_tmppath}/%{name}-%{version}-root
83BuildRequires: libXft-devel libX11-devel libXext-devel
84BuildRequires: libXrender-devel libXau-devel libXdmcp-devel libXt-devel
85BuildRequires: gtk3-devel
86BuildRequires: ncurses-devel
87BuildRequires: anthy-devel m17n-lib-devel eb-devel
88BuildRequires: libedit-devel libffi-devel expat-devel curl-devel
89BuildRequires: gettext-devel desktop-file-utils
90%if %{with gnome}
91BuildRequires: gnome-panel-devel
92BuildRequires: libgnomeui-devel
93%endif
94%if %{with kde}
95BuildRequires: kdelibs4-devel
96BuildRequires: cmake
97%endif
98%if %{with canna}
99BuildRequires: Canna-devel
100%endif
101%if %{with mana}
102BuildRequires: mana
103%endif
104%if %{with emacsen}
105BuildRequires: emacs
106%endif
107# for Git
108BuildRequires: librsvg2, ruby, perl, asciidoc
109
110BuildConflicts: uim-devel < 1.4.0
111Requires(post): coreutils, grep, sed
112Requires(postun): coreutils, grep, sed
113
114%description
115The uim is a collection of input method for a lot of languages.
116
117%description -l ja
118uim は様々な言語の入力メソッドのコレクションです。
119
120%package xim
121Summary: XIM frontend for Uim
122Summary(ja): uim を利用した XIM サーバ
123License: BSD and LGPLv2
124Group: User Interface/X
125Requires: %{name} = %{version}-%{release}
126
127%description xim
128uim-xim is a XIM bridge of libuim.
129
130%description -l ja xim
131uim-xim は libuim を利用した XIM サーバです。
132XIM 経由で入力を行う場合に必要です。
133
134%if %{with gtk2}
135%package gtk
136Summary: GTK helper for uim
137Summary(ja): uim の GTK ヘルパー
138License: BSD and LGPLv2
139Group: User Interface/Desktops
140BuildRequires: gtk2-devel
141Requires: %{name} = %{version}-%{release}
142Requires: gtk2
143Requires(post): gtk2 >= 2.10.0
144Requires(post): %{name} = %{version}-%{release}
145Requires(postun): gtk2 >= 2.10.0
146
147%description gtk
148This package contains some applications like toolbar, system tray,
149input pad, candidate window, and preference tool using GTK.
150
151%description -l ja gtk
152このパッケージには、GTK を使ったツールバーやシステムトレイ、入力パッド、
153候補ウィンドウ、設定ツールなどが含まれています。
154%endif
155
156%package gtk3
157Summary: GTK3 helper for uim
158Summary(ja): uim の GTK3 ヘルパー
159License: BSD and LGPLv2
160Group: User Interface/Desktops
161Requires: %{name} = %{version}-%{release}
162Requires: gtk3
163Requires(post): gtk3
164Requires(post): %{name} = %{version}-%{release}
165Requires(postun): gtk3
166
167%description gtk3
168This package contains some applications like toolbar, system tray,
169input pad, candidate window, and preference tool using GTK3.
170
171%description -l ja gtk3
172このパッケージには、GTK3 を使ったツールバーやシステムトレイ、入力パッド、
173候補ウィンドウ、設定ツールなどが含まれています。
174
175
176%if %{with qt3}
177%package qt
178Summary: Qt3 support for Uim
179Summary(ja): uim の Qt3 サポート
180Group: User Interface/Desktops
181License: BSD and LGPLv2
182BuildRequires: qt-devel
183Requires: %{name}-xim = %{version}-%{release}
184Requires: qt >= %{_qt3_version}
185
186Obsoletes: %{name}-qt-immodule < 1.5.6-2
187Obsoletes: %{name}-qt-common < %{version}-%{release}
188Obsoletes: uim-qtkde-helper
189Provides: %{name}-qt-immodule = %{version}-%{release}
190Provides: uim-qtkde-helper
191
192%description qt
193This package contains some applications like toolbar, candidate window,
194and preference tool using Qt.
195
196%description -l ja qt
197このパッケージには、Qt を使ったツールバーや候補ウィンドウ、設定ツールなど
198が含まれています。
199%endif
200
201%if %{with qt4}
202%package qt4
203Summary: Qt4 support for Uim
204Summary(ja): Uim の Qt4 サポート
205License: BSD and LGPLv2
206Group: User Interface/Desktops
207BuildRequires: qt4-devel
208Requires: %{name}-xim = %{version}-%{release}
209Requires: qt4 >= %{_qt4_version}
210Obsoletes: %{name}-qt-common < %{version}-%{release}
211
212%description qt4
213This package contains some applications like toolbar, candidate window,
214and preference tool using Qt4.
215
216%description -l ja qt4
217このパッケージには、Qt4 を使ったツールバーや候補ウィンドウ、設定ツールなど
218が含まれています。
219%endif
220
221%if %{with qt5}
222%package qt5
223Summary: Qt5 support for Uim
224Summary(ja): Uim の Qt5 サポート
225License: BSD and LGPLv2
226Group: User Interface/Desktops
227BuildRequires: qt5-qtbase-devel qt5-qtx11extras-devel qt5-rpm-macros
228Requires: %{name}-xim = %{version}-%{release}
229Obsoletes: %{name}-qt-common < %{version}-%{release}
230
231%description qt5
232This package contains some applications like toolbar, candidate window,
233and preference tool using Qt5.
234
235%description -l ja qt5
236このパッケージには、Qt5 を使ったツールバーや候補ウィンドウ、設定ツールなど
237が含まれています。
238%endif
239
240%if %{with gnome}
241%package applet
242Summary: GNOME panel applet for Uim
243Summary(ja): uim の GNOME 用パネルアプレット
244License: BSD and LGPLv2
245Group: User Interface/Desktops
246Requires: %{name}-xim = %{version}-%{release}
247Requires: %{name}-gtk3 = %{version}-%{release}
248
249%description applet
250uim-applet is GNOME panel applet for uim.
251
252%description -l ja applet
253uim-applet は uim の入力状態を表示する GNOME 用パネルアプレットです。
254%endif
255
256%if %{with kde}
257%package kde-applet
258Summary: KDE panel applet for Uim
259Summary(ja): uim の KDE 用パネルアプレット
260License: BSD and LGPLv2
261Group: User Interface/Desktops
262Requires: kdelibs4
263Requires: %{name}-qt4 = %{version}-%{release}
264Requires: %{name}-xim = %{version}-%{release}
265
266%description kde-applet
267uim-kde-applet is KDE panel applet for uim.
268
269%description -l ja kde-applet
270uim-kde-applet は uim の入力状態を表示する KDE 用パネルアプレットです。
271%endif
272
273%package fep
274Summary: an Input Method for console
275Summary(ja): コンソール用インプットメソッド
276License: BSD
277Group: Applications/System
278Requires: %{name} = %{version}-%{release}
279Requires: ncurses
280Obsoletes: uim-screen
281
282%description fep
283uim-fep is a FEP (Front End Processer) using uim as backend.
284
285%description -l ja fep
286uim-fep は uim を利用してコンソールで日本語を入力するための
287FEP (フロントエンドプロセッサ) です。
288
289%package anthy
290Summary: Anthy support for Uim
291Summary(ja): uim の Anthy モジュール
292License: BSD and LGPLv2
293Group: System Environment/Libraries
294Requires: %{name} = %{version}-%{release}
295Requires: anthy
296Requires(post): %{name} = %{version}-%{release}
297Requires(postun): %{name}
298Obsoletes: %{name} < 1.0.0
299
300%description anthy
301This package provides support for Anthy, a Japanese input method.
302
303%description -l ja anthy
304連文節かな漢字変換エンジン Anthy を使って日本語を入力・変換するための
305モジュールです。
306
307%if %{with canna}
308%package canna
309Summary: Canna support for Uim
310Summary(ja): uim の Canna モジュール
311License: BSD and LGPLv2
312Group: System Environment/Libraries
313Requires: %{name} = %{version}-%{release}
314Requires: Canna
315Requires(post): %{name} = %{version}-%{release}
316Requires(postun): %{name}
317
318%description canna
319This package provides support for Canna, a Japanese input method.
320
321%description -l ja canna
322連文節かな漢字変換エンジン Canna を使って日本語を入力・変換するための
323モジュールです。
324%endif
325
326%package skk
327Summary: SKK support for Uim
328Summary(ja): uim の SKK モジュール
329Group: System Environment/Libraries
330Requires: %{name} = %{version}-%{release}
331Requires: skkdic
332Requires(post): %{name} = %{version}-%{release}
333Requires(postun): %{name}
334
335%description skk
336This package provides support for SKK, a Japanese input method.
337
338%description -l ja skk
339SKK 入力方式で日本語を入力・変換するためのモジュールです。
340
341%if %{with mana}
342%package mana
343Summary: Mana support for Uim
344Summary(ja): uim の真字モジュール
345License: BSD
346Group: System Environment/Libraries
347Requires: %{name} = %{version}-%{release}
348Requires: mana, manadic
349Requires(post): %{name} = %{version}-%{release}
350Requires(postun): %{name}
351
352%description mana
353This package provides support for mana, a Japanese input method.
354
355%description -l ja mana
356連文節かな漢字変換エンジン 真字 (Mana) を使って日本語を入力・変換するための
357モジュールです。
358%endif
359
360%if %{with emacsen}
361%package el
362Summary: Emacsen uim bridge
363Summary(ja): Emacsen-uim ブリッジ
364License: BSD
365Group: Applications/Editors/Emacs
366Requires: %{name} = %{version}-%{release}
367Requires: emacsen
368Requires(post): emacsen-common
369Requires(preun): emacsen-common
370
371%description el
372uim.el is a bridge software between Emacsen and uim.
373
374uim.el makes you able to use uim supported IMs from Emacs
375directly.
376
377%description -l ja el
378uim.el は uim と Emacsen を結ぶブリッジです。
379
380uim.el を導入すると、Emacsen 上で uim を利用した文字入力が可能と
381なります。
382%endif
383
384%package m17n
385Summary: m17n-lib support for Uim
386Summary(ja): uim の m17n-lib モジュール
387License: BSD
388Group: System Environment/Libraries
389Requires: uim = %{version}-%{release}
390Requires(post): gtk2 /usr/bin/uim-module-manager
391Requires(postun): gtk2 /usr/bin/uim-module-manager
392
393%description m17n
394This package provides support for m17n-lib, which allows input of
395many languages using the input table map from m17n-db.
396
397%package devel
398Summary: Development tools for libuim applications.
399Summary(ja): libuim を使ったアプリケーションを開発するためのファイル
400License: BSD and LGPLv2
401Group: Development/Libraries
402Requires: %{name} = %{version}-%{release}
403
404%description devel
405uim-devel package contains the header files and static libraries to
406develop a libuim applications.
407
408%description -l ja devel
409uim-devel パッケージには libuim を利用したアプリケーションを開発
410するためのヘッダファイルとライブラリが含まれています。
411
412%prep
413%setup -q -n %{name}-%{version}%{?extraver:-%extraver}
414#%setup -q -a 6 -a 7 -n %{name}-%{commit}
415# for Git
416#%{__rm} -rf sigscheme
417#%{__mv} sigscheme-%{sigscheme_commit} sigscheme
418#%{__rm} -rf sigscheme/libgcroots
419#%{__mv} libgcroots-%{libgcroots_commit} sigscheme/libgcroots
420
421%build
422%if %{with qt3}
423unset QTDIR
424export QTDIR=%{_qt3_prefix}
425%endif
426
427#for Git
428#pushd sigscheme/libgcroots
429#./autogen.sh
430#popd
431#pushd sigscheme
432#./autogen.sh
433#popd
434#./autogen.sh
435%configure --with-x --with-xft \
436        --with-anthy --with-anthy-utf8 \
437        --without-scim --without-prime \
438        --with-gtk3 \
439        --with-m17nlib \
440        --with-curl \
441        --with-expat \
442        --with-ffi \
443        --with-eb --with-eb-conf=%{_sysconfdir}/eb.conf \
444        --disable-static \
445        --enable-maintainer-mode \
446        --enable-default-toolkit=gtk3 \
447%if %{with gnome}
448        --enable-gnome3-applet \
449%else
450        --disable-gnome-applet \
451%endif
452%if %{with gtk2}
453        --with-gtk2 \
454%else
455        --without-gtk2 \
456%endif
457%if %{with qt3}
458        --with-qt \
459        --with-qt-immodule \
460%else
461        --without-qt \
462        --without-qt-immodule \
463%endif
464%if %{with qt4}
465        --with-qt4 \
466        --with-qt4-immodule \
467%else
468        --without-qt4 \
469        --without-qt4-immodule \
470%endif
471%if %{with qt5}
472        --with-qt5 \
473        --with-qt5-immodule \
474%else
475        --without-qt5 \
476        --without-qt5-immodule \
477%endif
478%if %{with kde}
479        --disable-kde-applet \
480        --enable-kde4-applet \
481%else
482        --disable-kde-applet \
483        --disable-kde4-applet \
484%endif
485%if %{with canna}
486        --with-canna \
487%else
488        --without-canna \
489%endif
490%if %{without emacsen}
491        --disable-emacs \
492%endif
493%if %{with mana}
494        --with-mana
495%else
496        --without-mana
497%endif
498
499#sed -i -e 's/^\(hardcode_direct=\)$/\1no/' -e 's/^\(hardcode_minus_L=\)$/\1no/' -e 's/^\(libext=\)$/\1"a"/' libtool
500#LD_LIBRARY_PATH=$RPM_BUILD_DIR/%{name}-%{version}/uim/.libs:$LD_LIBRARY_PATH make
501make %{_smp_mflags}
502
503%install
504[ "%{buildroot}" != "/" ] && %__rm -rf %{buildroot}
505
506# remove anthy,canna,skk,mana from {installed-modules,loader}.scm
507#pushd scm
508#srcdir=%{_builddir}/%{buildsubdir}
509#LIBUIM_SCM_FILES=${srcdir}/scm LIBUIM_PLUGIN_LIB_DIR=${srcdir}/uim/.libs \
510#       %{_builddir}/%{buildsubdir}/uim/uim-module-manager \
511#       --path ${srcdir}/scm --unregister anthy skk mana
512#popd
513
514make install DESTDIR=%{buildroot}
515%find_lang %{name}
516
517# remove unneeded files
518%__rm -f %{buildroot}%{_libdir}/lib*.la
519%__rm -f %{buildroot}%{_datadir}/uim/scim.scm
520#__rm -f %{buildroot}%{_datadir}/uim/m17nlib.scm
521%__rm -f %{buildroot}%{_datadir}/uim/prime.scm
522%__rm -f %{buildroot}%{_datadir}/uim/prime-*.scm
523%__rm -f %{buildroot}%{_libdir}/gtk-2.0/*/immodules/*.{a,la}
524%__rm -f %{buildroot}%{_libdir}/gtk-3.0/*/immodules/*.{a,la}
525%__rm -f %{buildroot}%{_libdir}/uim/plugin/*.{a,la}
526%__rm -f %{buildroot}%{_datadir}/uim/pixmaps/scim.*
527%__rm -f %{buildroot}%{_datadir}/uim/pixmaps/prime*.*
528%__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
529%__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
530
531%if %{without canna}
532%__rm -f %{buildroot}%{_libdir}/uim/plugin/libuim-canna.so
533%__rm -f %{buildroot}%{_datadir}/uim/canna*.scm
534%__rm -f %{buildroot}%{_datadir}/uim/pixmaps/canna.*
535%endif
536
537%if %{without mana}
538%__rm -f %{buildroot}%{_libdir}/uim/plugin/libuim-mana.so
539%__rm -f %{buildroot}%{_datadir}/uim/mana.scm
540%__rm -f %{buildroot}%{_datadir}/uim/mana-*.scm
541%__rm -f %{buildroot}%{_datadir}/uim/pixmaps/mana.*
542%endif
543
544%if %{without qt3}
545%__rm -f %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/uim-chardict-qt.mo
546%endif
547
548%if %{without qt4}
549%__rm -f %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/uim-chardict-qt4.mo
550%endif
551
552%if %{without qt5}
553%__rm -f %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/uim-chardict-qt5.mo
554%endif
555
556%if %{with emacsen}
557%__mkdir_p %{buildroot}%{emacsen_pkgdir}/install
558%__mkdir_p %{buildroot}%{emacsen_pkgdir}/remove
559
560%_installemacsenscript %{name}-el %{SOURCE1}
561
562%_removeemacsenscript  %{name}-el %{SOURCE2}
563
564%__cp -p %{SOURCE4} %{SOURCE5} %{buildroot}%{_datadir}/emacs/site-lisp/uim-el
565
566%endif
567
568# move documents for sigscheme
569rm -rf installed-doc
570mkdir -p installed-doc/sigscheme
571cp -p sigscheme/doc/*.txt installed-doc/sigscheme
572#cp -p sigscheme/doc/*.html installed-doc/sigscheme
573
574# script to register prefered engine
575%__cat %{SOURCE3} \
576        | sed -e "s|@BINDIR@|%{_bindir}|g" \
577              -e "s|@SYSCONFDIR@|%{_sysconfdir}|g" \
578              -e "s|@DATADIR@|%{_datadir}|g" \
579        > update-installed-modules.sh
580%__install -m755 update-installed-modules.sh %{buildroot}%{_datadir}/%{name}
581
582# prefered engines
583%__mkdir_p %{buildroot}%{_sysconfdir}/sysconfig
584%__cat << EOF > %{buildroot}%{_sysconfdir}/sysconfig/uim
585PREFERED_ENGINE=anthy
586EOF
587
588perl -pi -e 's/uim-pref-gtk$/uim-pref-gtk3/' %{buildroot}%{_datadir}/applications/uim.desktop
589
590
591%clean
592[ "%{buildroot}" != "/" ] && %__rm -rf %{buildroot}
593
594%post -p /sbin/ldconfig
595
596%postun -p /sbin/ldconfig
597
598%if %{with gtk2}
599%post gtk
600%{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules ||:
601
602%postun gtk
603if [ $1 = 0 ] ; then
604        %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules ||:
605fi
606%endif
607
608%post gtk3
609%{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
610
611%postun gtk3
612if [ $1 = 0 ] ; then
613        %{_bindir}/gtk-query-immodules-3.0 --update-cache || : > /dev/null 2>&1
614fi
615
616%post anthy
617%{_datadir}/uim/update-installed-modules.sh --register anthy > /dev/null 2>&1
618
619%preun anthy
620if [ $1 = 0 ] ; then
621        %{_bindir}/uim-module-manager --unregister anthy > /dev/null 2>&1
622fi
623
624%if %{with canna}
625%post canna
626%{_datadir}/uim/update-installed-modules.sh --register canna > /dev/null 2>&1
627
628%preun canna
629if [ $1 = 0 ] ; then
630        %{_bindir}/uim-module-manager --unregister canna > /dev/null 2>&1
631fi
632%endif
633
634%post skk
635%{_datadir}/uim/update-installed-modules.sh --register skk > /dev/null 2>&1
636
637%preun skk
638if [ $1 = 0 ] ; then
639        %{_bindir}/uim-module-manager --unregister skk > /dev/null 2>&1
640fi
641
642%if %{with mana}
643%post mana
644%{_datadir}/uim/update-installed-modules.sh --register mana > /dev/null 2>&1
645
646%preun mana
647if [ $1 = 0 ] ; then
648        %{_bindir}/uim-module-manager --unregister mana > /dev/null 2>&1
649fi
650%endif
651
652%if %{with emacsen}
653%post el
654if [ $1 = 2 ] ; then
655        %_emacsenPackageRemove %{name}-el
656
657fi
658%_addemacsenlist %{name}-el
659
660%_emacsenPackageInstall %{name}-el
661
662
663%preun el
664if [ $1 = 0 ] ; then
665        %_emacsenPackageRemove %{name}-el
666
667        %_removeemacsenlist %{name}-el
668
669fi
670%endif
671
672%post m17n
673%{_datadir}/uim/update-installed-modules.sh --register m17nlib > /dev/null 2>&1
674
675%preun m17n
676if [ $1 = 0 ] ; then
677        %{_bindir}/uim-module-manager --unregister m17nlib > /dev/null 2>&1
678fi
679
680%files -f %{name}.lang
681%defattr(-,root,root)
682%{!?_licensedir:%global license %%doc}
683%license COPYING
684%doc AUTHORS ChangeLog* NEWS README RELNOTE
685%config(noreplace) %{_sysconfdir}/sysconfig/uim
686%{_bindir}/uim-help
687%{_bindir}/uim-sh
688%{_bindir}/uim-module-manager
689%{_libdir}/*.so.*
690%{_datadir}/uim
691%exclude %{_datadir}/uim/anthy*.scm
692%exclude %{_datadir}/uim/skk*.scm
693%exclude %{_datadir}/uim/pixmaps/anthy.*
694%exclude %{_datadir}/uim/pixmaps/skk.*
695%if %{with canna}
696%exclude %{_datadir}/uim/canna*.scm
697%exclude %{_datadir}/uim/pixmaps/canna.*
698%endif
699%if %{with mana}
700%exclude %{_datadir}/uim/mana.scm
701%exclude %{_datadir}/uim/mana-*.scm
702%exclude %{_datadir}/uim/pixmaps/mana.*
703%endif
704%dir %{_libdir}/uim
705%dir %{_libdir}/uim/plugin
706%{_libdir}/uim/plugin/libuim-curl.so
707%{_libdir}/uim/plugin/libuim-custom-enabler.so
708%{_libdir}/uim/plugin/libuim-eb.so
709%{_libdir}/uim/plugin/libuim-editline.so
710%{_libdir}/uim/plugin/libuim-expat.so
711%{_libdir}/uim/plugin/libuim-ffi.so
712%{_libdir}/uim/plugin/libuim-fileio.so
713%{_libdir}/uim/plugin/libuim-lolevel.so
714%{_libdir}/uim/plugin/libuim-look.so
715%{_libdir}/uim/plugin/libuim-process.so
716%{_libdir}/uim/plugin/libuim-socket.so
717%{_libexecdir}/uim-helper-server
718
719%files xim
720%defattr(-,root,root)
721%doc xim/README
722%{_bindir}/uim-xim
723%{_mandir}/man1/uim-xim.1*
724
725%if %{with gtk2}
726%files gtk
727%defattr(-,root,root)
728%{_bindir}/uim-im-switcher-gtk
729%{_bindir}/uim-input-pad-ja
730%{_bindir}/uim-pref-gtk
731%{_bindir}/uim-toolbar-gtk
732%{_bindir}/uim-toolbar-gtk-systray
733%{_libexecdir}/uim-candwin-gtk
734%{_libexecdir}/uim-candwin-horizontal-gtk
735%{_libexecdir}/uim-candwin-tbl-gtk
736%{_libdir}/gtk-2.0/*/immodules/*.so
737%{_datadir}/applications/uim.desktop
738%endif
739
740%files gtk3
741%defattr(-,root,root)
742%{_bindir}/uim-im-switcher-gtk3
743%{_bindir}/uim-input-pad-ja-gtk3
744%{_bindir}/uim-pref-gtk3
745%{_bindir}/uim-toolbar-gtk3
746%{_bindir}/uim-toolbar-gtk3-systray
747%{_libexecdir}/uim-candwin-gtk3
748%{_libexecdir}/uim-candwin-horizontal-gtk3
749%{_libexecdir}/uim-candwin-tbl-gtk3
750%{_libdir}/gtk-3.0/*/immodules/*.so
751%{_datadir}/applications/uim.desktop
752
753%if %{with qt3}
754%files qt
755%defattr(-,root,root)
756# BSD and LGPLv2+
757%{_bindir}/uim-chardict-qt
758# BSD
759%{_bindir}/uim-im-switcher-qt
760# BSD and LGPLv2+
761%{_bindir}/uim-pref-qt
762# BSD
763%{_bindir}/uim-toolbar-qt
764%{_libexecdir}/uim-candwin-qt
765%{_qt3_plugindir}/inputmethods/*.so
766%endif
767
768%if %{with qt4}
769%files qt4
770%defattr(-,root,root)
771# BSD and LGPLv2+
772%{_bindir}/uim-chardict-qt4
773# BSD
774%{_bindir}/uim-im-switcher-qt4
775# BSD and LGPLv2+
776%{_bindir}/uim-pref-qt4
777# BSD
778%{_bindir}/uim-toolbar-qt4
779%{_libexecdir}/uim-candwin-qt4
780%{_qt4_plugindir}/inputmethods/*.so
781%endif
782
783%if %{with qt5}
784%files qt5
785%defattr(-,root,root)
786# BSD and LGPLv2+
787%{_bindir}/uim-chardict-qt5
788# BSD
789%{_bindir}/uim-im-switcher-qt5
790# BSD and LGPLv2+
791%{_bindir}/uim-pref-qt5
792# BSD
793%{_bindir}/uim-toolbar-qt5
794%{_libexecdir}/uim-candwin-qt5
795%{_qt5_plugindir}/platforminputcontexts/*.so
796%endif
797
798%if %{with gnome}
799%files applet
800%defattr(-,root,root)
801%{_libexecdir}/uim-toolbar-applet-gnome3
802%{_datadir}/dbus-1/services/org.gnome.panel.applet.UimAppletFactory.service
803%{_datadir}/gnome-panel/4.0/applets/UimApplet.panel-applet
804%endif
805
806%if %{with kde}
807%files kde-applet
808%defattr(-,root,root)
809%{_libdir}/kde4/plasma_applet_uim.*
810%{_datadir}/kde4/services/plasma-applet-uim.desktop
811%endif
812
813%files fep
814%defattr(-,root,root)
815%license fep/COPYING
816%doc fep/README* fep/INSTALL
817%{_bindir}/uim-fep
818%{_bindir}/uim-fep-tick
819
820%files anthy
821%defattr(-,root,root)
822%{_libdir}/uim/plugin/libuim-anthy.so
823%{_libdir}/uim/plugin/libuim-anthy-utf8.so
824%{_datadir}/uim/anthy*.scm
825%{_datadir}/uim/pixmaps/anthy.*
826
827%if %{with canna}
828%files canna
829%defattr(-,root,root)
830%{_libdir}/uim/plugin/libuim-canna.so
831%{_datadir}/uim/canna*.scm
832%{_datadir}/uim/pixmaps/canna.*
833%endif
834
835%files skk
836%defattr(-,root,root)
837%{_libdir}/uim/plugin/libuim-skk.so
838%{_datadir}/uim/skk*.scm
839%{_datadir}/uim/pixmaps/skk.*
840
841%if %{with mana}
842%files mana
843%defattr(-,root,root)
844%{_libdir}/uim/plugin/libuim-mana.so
845%{_datadir}/uim/mana.scm
846%{_datadir}/uim/mana-*.scm
847%{_datadir}/uim/pixmaps/mana.*
848%endif
849
850%if %{with emacsen}
851%files el
852%defattr(-,root,root)
853%license emacs/COPYING
854%doc emacs/README*
855%{_bindir}/uim-el-agent
856%{_bindir}/uim-el-helper-agent
857%{_datadir}/emacs/site-lisp/uim-el
858%{emacsen_pkgdir}/*/%{name}-el
859%endif
860
861%files m17n
862%defattr (-, root, root, -)
863%license COPYING
864%doc AUTHORS ChangeLog* NEWS README
865%{_bindir}/uim-m17nlib-relink-icons
866%{_libdir}/uim/plugin/libuim-m17nlib.so
867%{_datadir}/uim/m17nlib.scm
868%dir %{_datadir}/uim
869
870%files devel
871%defattr(-,root,root)
872%doc doc/PLUGIN installed-doc/sigscheme
873%{_libdir}/*.so
874%{_libdir}/uim/plugin/*.so
875%{_includedir}/*.h
876%{_includedir}/uim
877%{_libdir}/pkgconfig/*
878
879%changelog
880* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.8-3
881- rebuilt with libffi-3.3.
882
883* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.8-2
884- disabled gtk2, qt3 and kde.
885
886* Sat May 19 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.8-1
887- update to 1.8.8
888- add Packager
889
890* Sat Mar 24 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.6-6.gitc79432c
891- update to current Git master
892 - add BuildRequires: librsvg2
893 - add BuildRequres: perl, ruby, asciidoc
894 - add '--enable-maintainer-mode'
895- drop Patch1: upstream fixed (#76)
896
897* Thu Dec 14 2017 Toshiaki Ara <ara_t@384.jp> 1.8.6-5
898- add Patch1 (uim-gtk2_immodule_uim-cand-win-gtk.c.patch)
899  - fix the issue that conversion candidates are not displayed
900
901* Thu Jul 28 2016 Toshiaki Ara <ara_t@384.jp> 1.8.6-4
902- add %{!?_licensedir:%global license %%doc}
903
904* Thu Jul  7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.6-3
905- rebuilt with new toolchain.
906
907* Thu Apr  2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.8.6-2
908- fixed Requires in qt4 subpackage
909- used bcond macros
910
911* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.6-1
912- new upstream release
913- drop %%{name}-applet subpackage
914
915* Sat Sep 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.1-4
916- rebuild with qt4-4.8.3
917
918* Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.1-3
919- rebuild with qt4-4.8.2
920
921* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.1-2
922- rebuilt with qt4-4.8.0
923
924* Sun Aug 21 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.1-1
925- new upstream release
926- built with gtk3 and GNOME3
927
928* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-2
929- rebuilt with qt4-4.7.2
930
931* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.1-1
932- new upstream release
933- built with qt4-4.7.1
934
935* Sun Jan  2 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.0-4
936- build with eb 4.4.3
937
938* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 1.6.0-3
939- rebuilt with rpm-4.8.1 for pkg-config
940
941* Mon Aug 30 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.0-2
942- apply vine-default for el subpackage
943 - add vine-default-uim-el.el (Source4)
944 - add uim-el-init.el (Source5)
945 - update uim-el-{install,remove}.sh (Source1,2)
946- update BuildRequires for with_emacsen: emacsen to emacs
947- using emacsen_pkgdir rpm macro
948
949* Sat Aug 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.0-1
950- new upstream release
951- dropt Patch0
952- Obsoletes: uim-qt-common
953
954* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.7-1
955- new upstream release
956- added Patch0
957- added BR: cmake
958- provides KDE4 applets
959- updated Qt version auto detection macros
960
961* Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-6
962- updated Qt version detection macros to build properly
963
964* Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-5
965- rebuilt with qt-4.6.1
966
967* Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-4
968- fixed kde-applet Requires:
969
970* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-3
971- fixed kde-applet BR
972
973* Fri Oct 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-2
974- made uim-qt4, uim-qt-common sub-package
975
976* Thu Jul 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-1
977- applied new versioning policy, spec in UTF-8
978- new upstream release
979- disabled canna subpackage
980- added m17n subpackage
981- removed lib*.la, lib*.a from devel package
982
983* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.2-1vl5
984- new upstream release
985
986* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-0vl5
987- rebuild with qt-3.3.8-0vl2
988
989* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl4
990- rebuild with new environment/toolchain
991
992* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl3
993- rebuild with gtk+-2.10
994
995* Mon Mar 26 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl2
996- add BuildConflicts: uim-devel < 1.4.0
997
998* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
999- upstream release
1000
1001* Sat Feb 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
1002- upstream release
1003- run uim-module-manager with absolute path in %%install section
1004- add '--disable-static' option to %%configure
1005
1006* Mon Dec 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl2
1007- add Requires: manadic to uim-mana package
1008- add Japanese summaries and descriptions
1009- add new sub-package: uim-kde-applet
1010
1011* Fri Dec 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
1012- upstream release
1013
1014* Sun Dec 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl1
1015- upstream release
1016- drop obsolete workaround-for-flashplayer.patch (patch11)
1017
1018* Sun Oct 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl6
1019- add workaround-for-flashplayer.patch (svn trunk r3938:r3941)
1020
1021* Tue Sep 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl5
1022- add support for immodule for Qt
1023
1024  * Thu Sep 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl4.0qtimm.1
1025  - add Requires: %%{name}-qt-immodule (qt) if qtimm is enabled
1026
1027  * Thu Sep 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl4.0qtimm
1028  - add support for immodule for Qt
1029
1030* Tue Sep 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl4
1031- add --without-eb option to %%configure
1032
1033* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl3
1034- changed uim-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
1035- changed uim-applet Group to User Interface/Desktops
1036
1037* Fri Sep 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
1038- add %%with_canna, %%with_gnome
1039- use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
1040- for biarch support
1041  - update required gtk2 version (>= 2.8.13)
1042  - use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gtk.immodules
1043
1044* Mon Aug 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
1045- upstream release
1046
1047* Fri Aug 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
1048- upstream release
1049- add Makefile.patch (patch1)
1050
1051* Sat Jul 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
1052- upstream release
1053- drop Obsoletes: %%{name} < 1.0.0 from uim-mana
1054- move %%postun el script to %%preun el
1055
1056* Sat Jun 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
1057- upstream release
1058
1059* Sun Jun 04 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl0.0beta.1
1060- add Requires(post): %{name} = %{version} for uim-gtk
1061
1062* Fri Jun 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl0.0beta
1063- update to uim-1.1.0-beta
1064
1065* Sun May 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl0.0alpha.1
1066- update uim-update-installed-modules.sh (source3) for uim-1.1.0-alpha
1067
1068* Sun May 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl0.0alpha
1069- update to uim-1.1.0-alpha
1070- update desktop.patch (patch0), kanji-key.patch (patch10)
1071- update %%files
1072
1073* Sun May 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl5
1074- fix %%preun script to avoid incorrect re-registration
1075- add mana support
1076
1077* Wed Apr 12 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl4
1078- add uim-update-installed-modules.sh (source3)
1079
1080* Tue Jan 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl3
1081- fix typo
1082- remove prime*.scm
1083
1084* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
1085- separate uim-{anthy,canna,skk} sub-packages
1086- update {installed-modules,loader}.scm at %%install
1087
1088* Fri Dec 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
1089- upstream release
1090- drop anthy-use-with-vi.patch
1091- update desktop.patch
1092- change groups
1093- add Requires: libgnomeui to uim-applet sub-package
1094- add uim-gtk sub-package
1095  - move uim-*-gtk, uim.desktop from main package
1096  - move uim-candwin-gtk from uim-xim sub-package
1097- add uim-qt sub-package
1098  - BuildRequires: qt-devel
1099  - Obsoletes/Provides: uim-qtkde-helper
1100- add uim-el sub-package
1101  - add uim-el-{install,remove}.sh (source1,2)
1102  - BuildRequires: emacsen
1103
1104* Sat Oct 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.9.1-0vl1
1105- [SECURITY] upstream release
1106  - fix privilege escalation
1107- reverse-import desktop.patch (patch0) from momonga
1108
1109  * Fri Sep 30 2005 Ichiro Nakai <ichiro@n.email.ne.jp>
1110  - (0.4.9.1-2m)
1111  - revise Patch10: uim-0.4.9.1-desktop.patch
1112
1113  * Thu Sep 29 2005 Ichiro Nakai <ichiro@n.email.ne.jp>
1114  - (0.4.9.1-1m)
1115  - import and modify desktop.patch from VineSeedPlus
1116
1117* Sat Sep 17 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.9-0vl1
1118- upstream release
1119
1120* Tue Aug 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
1121- upstream release
1122- update anthy-use-with-vi patch (patch11)
1123  - implemented in svn r1197
1124- update desktop.patch (patch0)
1125
1126* Sat Aug 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.7.1-0vl2
1127- make uim-anthy friendly for vi users (patch11)
1128  - exit vi's insert mode and switch IM to Latin mode
1129
1130* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.7.1-0vl1
1131- upstream release
1132
1133* Sat Jul 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.7-0vl3
1134- remove %%{_libdir}/uim/plugin/*.{a,la}
1135- add doc/PLUGIN instead of doc/LIB (uim-devel)
1136
1137* Mon Jul 18 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.7-0vl2
1138- update uim.desktop (patch0)
1139
1140* Sun Jul 17 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.7-0vl1
1141- [SECURITY] new upstream release
1142- use ja.po in source archive
1143- add BuildRequires:
1144  - ncurses-devel, libbonoboui-devel, libgnomeui-devel, anthy-devel
1145- add new files:
1146  - uim package:
1147    - %%{_bindir}/uim-pref-gtk
1148    - %%{_bindir}/uim-im-swicher-gtk (instead of uim-im-switcher)
1149    - %%{_libdir}/uim
1150    - %%{_datadir}/applications/uim.desktop
1151- use %%find_lang macro
1152- update kanji-key.patch (patch10)
1153
1154* Wed Oct 20 2004 IWAI, Masaharu <iwai@alib.jp> 0.4.5-0vl1
1155- new upstream release
1156- add new files:
1157  - uim package: uim-toolbar-gtk, uim-toolbar-gtk-systray
1158                 uim-im-switcher and uim-input-pad-ja in %%{_bindir}
1159  - uim-xim package: %%{_bindir}/uim-candwin-gtk
1160  - uim-applet package: %%{_libexecdir}/uim-toolbar-applet
1161- update ja.po ( Source10 ): based original po file
1162- update kanji-key patch ( Patch10 )
1163- drop unnecessary patches:
1164  - skk.scm patch ( Patch1 )
1165  - prime patch ( Patch2 )
1166  - xim_crash patch ( Patch3 )
1167
1168* Sat Sep 11 2004 IWAI, Masaharu <iwai@alib.jp> 0.4.3-0vl1
1169- new upstream release
1170- add some files in devel package
1171- update ja.po ( Source10 )
1172- update kanji-key patch ( Patch10 )
1173- add skk.scm patch ( Patch1 ): from subversion repository ( [Anthy-dev 1029] )
1174- add prime patch ( Patch2 ): from [Anthy-dev 1031]
1175- add xim_crash patch ( Patch3 ): from [Anthy-dev 1033]
1176
1177* Wed Jun 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.1-0vl1
1178- new upstream release
1179- obsoletes uim-screen
1180- add uim-fep
1181
1182* Mon Jun 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.9-0vl1
1183- new upstream release
1184
1185* Tue May 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-0vl1
1186- new upstream release
1187
1188* Mon May 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.7-0vl1
1189- new upstream release
1190
1191* Thu May  6 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.6-0vl1
1192- new upstream release
1193
1194* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.4.2-0vl1
1195- new upstream release
1196
1197* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.4.1-0vl1
1198- new upstream release
1199
1200* Sun Mar 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.3-0vl1
1201- new upstream release
1202
1203* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl2
1204- rebuild with gtk+-2.4.0
1205- add Patch0 to use \$(GTK_VERSION) in gtk/Makefile
1206
1207* Sun Mar  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
1208- new upstream release
1209
1210* Mon Mar  1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.1-0vl1
1211- new upstream release
1212
1213* Sun Feb 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0.1-0vl1
1214- new upstream release
1215
1216* Mon Feb 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-0vl1
1217- new upstream release
1218- add uim-screen subpackage
1219- add documentations
1220- drop obsolete patches
1221
1222* Thu Feb 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.8-0vl1
1223- new upstream release
1224
1225* Tue Jan 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.7-0vl1
1226- new upstream release
1227
1228* Sat Jan 24 2004 IWAI, Masaharu <iwai@alib.jp> 0.2.5.2-0vl1
1229- new upstream release
1230
1231* Mon Jan 12 2004 IWAI, Masaharu <iwai@alib.jp> 0.2.4-0vl2
1232- add %%{_includedir}/uim directory in uim-devel package
1233- update URL and Source0 values: moved the project web site
1234
1235* Sun Jan 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.4-0vl1
1236- new upstream release
1237
1238* Tue Jan 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3.1-0vl1
1239- new upstream release
1240
1241* Wed Dec 31 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.2-0vl1
1242- new upstream release
1243
1244* Tue Dec 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.1-0vl1
1245- new upstream release
1246
1247* Mon Dec 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.0-0vl1
1248- new upstream release
1249
1250* Tue Dec 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.7-0vl1
1251- new upstream release
1252
1253* Thu Nov 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.6-0vl1
1254- new upstream release
1255
1256* Mon Nov 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.5-0vl1
1257- new upstream release
1258
1259* Sun Nov 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.4.1-0vl1
1260- new upstream release
1261- split xim/uim-applet stuff to sub packages
1262
1263* Tue Oct 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.2-0vl1
1264- new upstream release
1265
1266* Wed Oct 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.0-0vl2
1267- add patch10 to use "Kanji" keysyms instead of "Zenkaku-Hankaku"
1268- update ja.po
1269
1270* Wed Oct 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.0-0vl1
1271- new upstream release
1272- add patch0 to make status window smaller.
1273
1274* Sun Oct 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.9-0vl1
1275- new upstream release
1276
1277* Mon Sep 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.8-0vl1
1278- new upstream release
1279
1280* Sat Sep 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.7-0vl1
1281- new upstream release
1282
1283* Sun Sep 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.6-0vl1
1284- new upstream release
1285- split development files to uim-devel subpackage.
1286
1287* Sun Sep 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.4-0vl1
1288- new upstream release
1289
1290* Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.2.1-0vl1
1291- new upstream release
1292
1293* Fri Aug 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-0vl2
1294- run ldconfig in %%post and %%postun script
1295- remove uim entry from gtk.immodule when uim is removed
1296
1297* Fri Aug 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.1-0vl1
1298- build for Vine Linux
1299- add Japanese summary and description
1300
1301* Wed Aug 27 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp> 0.0.1-1
1302- Version updated.
1303- Added serial for version number.
1304- Added uim-comm-client and uim-comm-server.
1305* Fri Aug 15 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp> 2013-1
1306- Version updated.
1307- Added Japanese locale file.
1308* Tue Aug 12 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp> 2010-1
1309- Version updated.
1310* Sun Aug 10 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp> 2005-1
1311- Version updated.
1312- Removed --without-canna option at configure.
1313- Added Canna-devel to BuildRequires.
1314- Changed command for cleaning rpm_build_root because of the safety.
1315* Tue Aug 5 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp> 2002-1
1316- Version updated.
1317- Used _prefix variable.
1318- Added uim-xim.
1319- Added BuildRequires.
1320* Sat Jul 5 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp> 1928-1
1321- Version updated.
1322* Sat Jul 5 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp> 1903-1
1323- Version updated.
1324- Added description.
1325* Sat Dec 7 2002 TABATA Yusuke <yusuke@localhost.localdomain>
1326- Initial build.
Note: See TracBrowser for help on using the repository browser.