source: projects/specs/trunk/u/ufraw/ufraw-vl.spec @ 10773

Revision 10773, 6.8 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%bcond_with     cinepaint
2
3Summary:        Utility for digital camera raw images
4Summary(ja):    デジタルカメラの RAW 画像ユーティリティ
5Name:           ufraw
6Version:        0.22
7Release:        2%{?_dist_release}
8
9License:        GPLv2
10Group:          Applications/Graphics
11URL:            http://ufraw.sourceforge.net/
12
13Source0:        %{name}-%{version}.tar.gz
14# added Japanese comment
15Source10:       %{name}.desktop
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  cfitsio-devel
19BuildRequires:  exiv2-devel
20BuildRequires:  gimp-devel
21BuildRequires:  glib2-devel >= 2.12
22BuildRequires:  gtk2-devel >= 2.12
23BuildRequires:  gtkimageview-devel >= 1.6.1
24BuildRequires:  lcms2-devel
25BuildRequires:  lensfun-devel >= 0.2.5
26BuildRequires:  libexif-devel
27BuildRequires:  libjpeg-devel
28BuildRequires:  libpng-devel
29BuildRequires:  libtiff-devel
30BuildRequires:  perl
31BuildRequires:  zlib-devel
32%if %{with cinepaint}
33BuildRequires: cinepaint-devel >= 0.22
34%define cinepaintplugindir %(pkg-config --variable=programplugindir cinepaint-gtk)/plug-ins
35%endif
36Requires(post): GConf2, shared-mime-info, desktop-file-utils
37Requires(postun): shared-mime-info, desktop-file-utils
38Requires(pre): GConf2
39Requires(preun): GConf2
40
41%description
42Application allowed to read and manipulate raw images from digital
43cameras. Takes care of the color management, handles the Nikon curve
44formats and has editor for the tone curves. It allows easy process more
45images in a batch on command-line.
46
47%description -l ja
48デジタルカメラから RAW 画像を読み込み、操作するためのアプリケーション
49です。カラーマネージメント機能を持ち、Nikon のカーブフォーマットの読み
50込みやトーンカーブの編集が可能です。また大量のファイルをコマンドライン
51から簡単にバッチ処理できます。
52
53#---------------------------------------------------------------------------
54
55%package gimp
56Summary:        Raw image loader plugin for The GIMP
57Summary(ja):    GIMP 用の RAW 画像読み込みプラグイン
58Group:          Applications/Graphics
59Requires:       gimp
60
61%description gimp
62ufraw-gimp is a GIMP plug-in to read and manipulate raw images from
63digital cameras.
64
65%description gimp -l ja
66ufraw-gimp はデジタルカメラの RAW 画像を読み込み、操作するための GIMP プラグインです。
67
68#---------------------------------------------------------------------------
69%if %{with cinepaint}
70%package cinepaint
71Summary:        CinePaint plugin to retrieve raw image data from digital cameras
72Group:          Applications/Multimedia
73Requires:       ufraw = %{version}-%{release}
74Requires:       cinepaint
75
76%description cinepaint
77The ufraw-cinepaint package contains a CinePaint plugin for opening raw format
78images of digital cameras.
79%endif
80#---------------------------------------------------------------------------
81       
82%prep
83%setup -q
84
85cp -p %{SOURCE10} .
86
87%build
88%configure --enable-mime --enable-extras --with-gimp DESTDIR=$RPM_BUILD_ROOT
89make schemasdir=%{_sysconfdir}/gconf/schemas
90
91%install
92rm -rf $RPM_BUILD_ROOT
93
94make install DESTDIR=$RPM_BUILD_ROOT
95
96# don't ship dcraw binary
97rm -f $RPM_BUILD_ROOT%{_bindir}/dcraw
98
99# install schemas to sysconfdir manually.
100%{__install} -d $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
101./generate_schemas.sh %{_prefix} $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/ufraw.schemas
102mv $RPM_BUILD_ROOT%{_datadir}/gconf/schemas/ufraw.schemas $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
103rm -rf $RPM_BUILD_ROOT%{_datadir}/gconf/schemas
104
105# install mime-info manually. (But this has been included in shared-mime-info >= 0.21)
106%{__install} -d $RPM_BUILD_ROOT%{_datadir}/mime/packages
107%{__install} -m 644 ufraw-mime.xml $RPM_BUILD_ROOT%{_datadir}/mime/packages
108
109%find_lang %{name}
110
111
112%clean
113%{__rm} -rf ${RPM_BUILD_ROOT}
114
115
116%post
117update-mime-database %{_datadir}/mime >& /dev/null ||:
118export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
119gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/ufraw.schemas > /dev/null ||:
120update-desktop-database %{_datadir}/applications >& /dev/null ||:
121
122%pre
123if [ "$1" -gt 1 ]; then
124    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
125    gconftool-2 --makefile-uninstall-rule \
126        %{_sysconfdir}/gconf/schemas/ufraw.schemas > /dev/null ||:
127fi
128
129%preun
130if [ "$1" -eq 0 ]; then
131    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
132    gconftool-2 --makefile-uninstall-rule \
133        %{_sysconfdir}/gconf/schemas/ufraw.schemas > /dev/null ||:
134fi
135
136%postun
137update-mime-database %{_datadir}/mime >& /dev/null ||:
138update-desktop-database %{_datadir}/applications >& /dev/null ||:
139
140
141%files -f %{name}.lang
142%defattr(-,root,root)
143%doc COPYING MANIFEST README TODO
144%{_bindir}/ufraw
145%{_bindir}/ufraw-batch
146#{_bindir}/dcraw
147%{_bindir}/nikon-curve
148%{_sysconfdir}/gconf/schemas/ufraw.schemas
149%{_datadir}/appdata/%{name}.appdata.xml
150%{_datadir}/applications/ufraw.desktop
151%{_datadir}/mime/packages/ufraw-mime.xml
152%{_datadir}/pixmaps/ufraw.png
153%{_mandir}/man1/ufraw.1*
154
155%files gimp
156%defattr(-,root,root)
157%{_libdir}/gimp/2.0/plug-ins/ufraw-gimp
158
159%if %{with cinepaint}
160%files cinepaint
161%defattr(-, root, root, -)
162%{cinepaintplugindir}/ufraw-cinepaint
163%endif
164
165%changelog
166* Sat Sep 03 2016 Toshiaki Ara <ara_t@384.jp> 0.22-2
167- rebuild with gcc-5.4.0
168
169* Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22-1
170- new upstream release
171
172* Tue Mar 10 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.21-1
173- updated to 0.21
174- removed %{_bindir}/dcraw to avoid conflicting with dcraw package
175- added BR: lensfun-devel
176- added BR: lcms2-devel instead of lcms-devel
177
178* Wed Feb 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.18-6
179- rebuilt with cfitsio 3.370
180
181* Wed Jan 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-5
182- rebuild with libpng-1.6.12
183
184* Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-4
185- rebuild with exiv2-0.23
186
187* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-3
188- rebuild with exiv2-0.23
189
190* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18-2
191- rebuild with exiv2-0.22
192
193* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.18-1
194- new upstream release
195- built with exiv2-0.21.1
196- added BR: cfitsio-devel, libtiff-devel
197
198* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
199- new upstream release
200- built with exiv2-0.19
201
202* Sun Apr 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-1
203- new upstream release
204
205* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.13-1vl5
206- new upstream release
207
208* Thu Sep 25 2008 Shu KONNO <owa@bg.wakwak.com> 0.12.1-1vl5
209- applied new versioning policy, spec in utf-8
210- built with exiv2
211
212* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-0vl1
213- new upstream release.
214- add Requires(post, postun)
215
216* Tue Aug 07 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-0vl1
217- new upstream release.
218- add BuildRequires gtkimageview-devel >= 1.3.0
219
220* Mon Jun 11 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.11-0vl1
221- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.