source: projects/specs/trunk/u/udisks2/udisks2-vl.spec @ 8732

Revision 8732, 5.4 KB checked in by Takemikaduchi, 10 years ago (diff)

shotwell: new upstream release
others: rebuild

Line 
1%define glib2_version           2.40.0
2%define dbus_version            1.6.14
3%define dbus_glib_version       0.98
4%define polkit_version          0.104
5%define parted_version          2.3
6%define mdadm_version           2.6.7
7%define device_mapper_version   1.02
8%define libatasmart_version     0.17
9%define sg3_utils_version       1.27
10%define smp_utils_version       0.94
11%define lvm2_version            2.02.78
12
13Summary: Storage Management Service
14Name: udisks2
15Version: 2.1.3
16Release: 3%{?_dist_release}
17License: GPLv2+
18Group: System Environment/Libraries
19URL: http://www.freedesktop.org/wiki/Software/udisks
20
21Source0: http://udisks.freedesktop.org/releases/udisks-%{version}.tar.bz2
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24
25BuildRequires: glib2-devel >= %{glib2_version}
26BuildRequires: dbus-devel  >= %{dbus_version}
27BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
28BuildRequires: polkit-devel >= %{polkit_version}
29BuildRequires: parted-devel >= %{parted_version}
30BuildRequires: device-mapper-devel >= %{device_mapper_version}
31BuildRequires: libacl-devel
32BuildRequires: intltool
33BuildRequires: libatasmart-devel >= %{libatasmart_version}
34BuildRequires: eudev-libgudev1-devel
35BuildRequires: eudev-libudev-devel
36BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
37BuildRequires: lvm2-devel >= %{lvm2_version}
38BuildRequires: gobject-introspection-devel
39
40# needed to pull in the system bus daemon
41Requires: dbus >= %{dbus_version}
42# needed to pull in the udev daemon
43Requires: eudev
44# we need at least this version for bugfixes / features etc.
45Requires: libatasmart >= %{libatasmart_version}
46Requires: mdadm >= %{mdadm_version}
47# for smp_rep_manufacturer
48Requires: smp_utils >= %{smp_utils_version}
49# for mount, umount, mkswap
50Requires: util-linux-ng
51# for mkfs.ext3, mkfs.ext3, e2label
52Requires: e2fsprogs
53# for mkfs.xfs, xfs_admin
54Requires: xfsprogs
55# for mkfs.vfat
56Requires: dosfstools
57# for mlabel
58Requires: mtools
59# for mkntfs - no ntfsprogs on ppc, though
60%ifnarch ppc ppc64
61Requires: ntfsprogs
62%endif
63
64# for /proc/self/mountinfo, only available in 2.6.26 or higher
65Conflicts: kernel < 2.6.26
66
67# we need liblvm2app at least this recent since the ABI changed (sizes
68# reported in number of bytes instead of number of sectors) without
69# the sonumber changing
70#
71Requires: lvm2-libs >= %{lvm2_version}
72
73Vendor: Project Vine
74Distribution: Vine Linux
75
76%description
77udisks provides a daemon, D-Bus API and command line tools
78for managing disks and storage devices.
79
80%package devel
81Summary: D-Bus interface definitions for udisks
82Group: Development/Libraries
83Requires: %{name} = %{version}-%{release}
84
85# See comment above
86#
87%description devel
88D-Bus interface definitions and documentation for udisks.
89
90
91%package        docs
92Summary:        Documentation for udisks2
93Group:          Documentation
94Requires:       %{name} = %{version}-%{release}
95BuildArch:              noarch
96Provides:       %{name}-doc = %{version}-%{release}
97
98%description    docs
99This package contains documentation for udisks2.
100
101
102%prep
103%setup -q -n udisks-%{version}
104
105%build
106%configure \
107        --enable-gtk-doc
108make
109
110%install
111rm -rf $RPM_BUILD_ROOT
112
113make install DESTDIR=$RPM_BUILD_ROOT
114
115rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
116rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
117
118# for now, include a compat symlink for the command-line tool
119# and man page
120ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
121ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
122
123mkdir $RPM_BUILD_ROOT/run
124
125%find_lang %{name}
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post -p /sbin/ldconfig
131
132%postun -p /sbin/ldconfig
133
134%files -f %{name}.lang
135%defattr(-,root,root,-)
136%doc README AUTHORS NEWS COPYING HACKING
137%{_sysconfdir}/dbus-1/system.d/org.freedesktop.UDisks2.conf
138/lib/udev/rules.d/80-udisks2.rules
139%{_bindir}/devkit-disks
140%{_bindir}/udisksctl
141%{_sbindir}/umount.udisks2
142%dir %{_prefix}/lib/udisks2
143%{_prefix}/lib/udisks2/udisksd
144%{_libdir}/libudisks2.so.*
145%{_libdir}/girepository-1.0/UDisks-2.0.typelib
146%{_datadir}/bash-completion/completions/udisksctl
147%{_datadir}/dbus-1/system-services/org.freedesktop.UDisks2.service
148%{_datadir}/polkit-1/actions/org.freedesktop.udisks2.policy
149%{_mandir}/man1/*
150%{_mandir}/man8/*
151%attr(0700,root,root) %dir %{_localstatedir}/lib/udisks2
152%attr(0755,root,root) %dir /run
153
154%files devel
155%defattr(-,root,root,-)
156%{_includedir}/udisks2
157%{_libdir}/libudisks2.so
158%{_libdir}/pkgconfig/udisks2.pc
159%{_datadir}/gir-1.0/UDisks-2.0.gir
160
161%files docs
162%defattr(-,root,root,-)
163%{_datadir}/gtk-doc/html/%{name}
164
165#
166%changelog
167* Thu Jul 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.3-3
168- change BuildRequires: eudev-libgudev1-devel instead of libgudev1-devel
169- change BuildRequires: eudev-libudev-devel instead of libudev-devel
170
171* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.3-1
172- new upstream release
173
174* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.1-2
175- rebuild with VineSeed environment
176
177* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.1-1
178- new upstream release
179
180* Thu Mar 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
181- new upstream release
182
183* Thu Jan 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.1-1
184- new upstream release
185
186* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.0-1
187- new upstream release
188
189* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.99.0-1
190- new upstream release
191
192* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.98.0-1
193- new upstream release
194- add BuildRequires: libacl-devel
195
196* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.94.0-1
197- Initial build for Vine Linux
198
Note: See TracBrowser for help on using the repository browser.