source: projects/specs/trunk/u/udisks2/udisks2-vl.spec @ 8353

Revision 8353, 5.3 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1%define glib2_version           2.40.0
2%define dbus_version            1.6.14
3%define dbus_glib_version       0.98
4%define polkit_version          0.104
5%define parted_version          2.3
6%define udev_version            175
7%define mdadm_version           2.6.7
8%define device_mapper_version   1.02
9%define libatasmart_version     0.17
10%define sg3_utils_version       1.27
11%define smp_utils_version       0.94
12%define lvm2_version            2.02.78
13
14Summary: Storage Management Service
15Name: udisks2
16Version: 2.1.3
17Release: 2%{?_dist_release}
18License: GPLv2+
19Group: System Environment/Libraries
20URL: http://www.freedesktop.org/wiki/Software/udisks
21
22Source0: http://udisks.freedesktop.org/releases/udisks-%{version}.tar.bz2
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires: glib2-devel >= %{glib2_version}
27BuildRequires: dbus-devel  >= %{dbus_version}
28BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
29BuildRequires: polkit-devel >= %{polkit_version}
30BuildRequires: parted-devel >= %{parted_version}
31BuildRequires: device-mapper-devel >= %{device_mapper_version}
32BuildRequires: libacl-devel
33BuildRequires: intltool
34BuildRequires: libatasmart-devel >= %{libatasmart_version}
35BuildRequires: libgudev1-devel >= %{udev_version}
36BuildRequires: libudev-devel >= %{udev_version}
37BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
38BuildRequires: lvm2-devel >= %{lvm2_version}
39BuildRequires: gobject-introspection-devel
40
41# needed to pull in the system bus daemon
42Requires: dbus >= %{dbus_version}
43# needed to pull in the udev daemon
44Requires: udev >= %{udev_version}
45# we need at least this version for bugfixes / features etc.
46Requires: libatasmart >= %{libatasmart_version}
47Requires: mdadm >= %{mdadm_version}
48# for smp_rep_manufacturer
49Requires: smp_utils >= %{smp_utils_version}
50# for mount, umount, mkswap
51Requires: util-linux-ng
52# for mkfs.ext3, mkfs.ext3, e2label
53Requires: e2fsprogs
54# for mkfs.xfs, xfs_admin
55Requires: xfsprogs
56# for mkfs.vfat
57Requires: dosfstools
58# for mlabel
59Requires: mtools
60# for mkntfs - no ntfsprogs on ppc, though
61%ifnarch ppc ppc64
62Requires: ntfsprogs
63%endif
64
65# for /proc/self/mountinfo, only available in 2.6.26 or higher
66Conflicts: kernel < 2.6.26
67
68# we need liblvm2app at least this recent since the ABI changed (sizes
69# reported in number of bytes instead of number of sectors) without
70# the sonumber changing
71#
72Requires: lvm2-libs >= %{lvm2_version}
73
74Vendor: Project Vine
75Distribution: Vine Linux
76
77%description
78udisks provides a daemon, D-Bus API and command line tools
79for managing disks and storage devices.
80
81%package devel
82Summary: D-Bus interface definitions for udisks
83Group: Development/Libraries
84Requires: %{name} = %{version}-%{release}
85
86# See comment above
87#
88%description devel
89D-Bus interface definitions and documentation for udisks.
90
91
92%package        docs
93Summary:        Documentation for udisks2
94Group:          Documentation
95Requires:       %{name} = %{version}-%{release}
96BuildArch:              noarch
97Provides:       %{name}-doc = %{version}-%{release}
98
99%description    docs
100This package contains documentation for udisks2.
101
102
103%prep
104%setup -q -n udisks-%{version}
105
106%build
107%configure \
108        --enable-gtk-doc
109make
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114make install DESTDIR=$RPM_BUILD_ROOT
115
116rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
117rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
118
119# for now, include a compat symlink for the command-line tool
120# and man page
121ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
122ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
123
124mkdir $RPM_BUILD_ROOT/run
125
126%find_lang %{name}
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%post -p /sbin/ldconfig
132
133%postun -p /sbin/ldconfig
134
135%files -f %{name}.lang
136%defattr(-,root,root,-)
137%doc README AUTHORS NEWS COPYING HACKING
138%{_sysconfdir}/dbus-1/system.d/org.freedesktop.UDisks2.conf
139/lib/udev/rules.d/80-udisks2.rules
140%{_bindir}/devkit-disks
141%{_bindir}/udisksctl
142%{_sbindir}/umount.udisks2
143%dir %{_prefix}/lib/udisks2
144%{_prefix}/lib/udisks2/udisksd
145%{_libdir}/libudisks2.so.*
146%{_libdir}/girepository-1.0/UDisks-2.0.typelib
147%{_datadir}/bash-completion/completions/udisksctl
148%{_datadir}/dbus-1/system-services/org.freedesktop.UDisks2.service
149%{_datadir}/polkit-1/actions/org.freedesktop.udisks2.policy
150%{_mandir}/man1/*
151%{_mandir}/man8/*
152%attr(0700,root,root) %dir %{_localstatedir}/lib/udisks2
153%attr(0755,root,root) %dir /run
154
155%files devel
156%defattr(-,root,root,-)
157%{_includedir}/udisks2
158%{_libdir}/libudisks2.so
159%{_libdir}/pkgconfig/udisks2.pc
160%{_datadir}/gir-1.0/UDisks-2.0.gir
161
162%files docs
163%defattr(-,root,root,-)
164%{_datadir}/gtk-doc/html/%{name}
165
166#
167%changelog
168* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.3-1
169- new upstream release
170
171* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.1-2
172- rebuild with VineSeed environment
173
174* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.1-1
175- new upstream release
176
177* Thu Mar 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.0-1
178- new upstream release
179
180* Thu Jan 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.1-1
181- new upstream release
182
183* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.0-1
184- new upstream release
185
186* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.99.0-1
187- new upstream release
188
189* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.98.0-1
190- new upstream release
191- add BuildRequires: libacl-devel
192
193* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.94.0-1
194- Initial build for Vine Linux
195
Note: See TracBrowser for help on using the repository browser.