source: projects/specs/trunk/u/udisks2/udisks2-vl.spec @ 6951

Revision 6951, 4.8 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.1

Line 
1%define glib2_version           2.32.0
2%define dbus_version            1.4.20
3%define dbus_glib_version       0.98
4%define polkit_version          0.104
5%define parted_version          2.3
6%define udev_version            175
7%define mdadm_version           2.6.7
8%define device_mapper_version   1.02
9%define libatasmart_version     0.17
10%define sg3_utils_version       1.27
11%define smp_utils_version       0.94
12%define lvm2_version            2.02.78
13
14Summary: Storage Management Service
15Name: udisks2
16Version: 2.0.0
17Release: 1%{?_dist_release}
18License: GPLv2+
19Group: System Environment/Libraries
20URL: http://www.freedesktop.org/wiki/Software/udisks
21
22Source0: http://udisks.freedesktop.org/releases/udisks-%{version}.tar.bz2
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires: glib2-devel >= %{glib2_version}
27BuildRequires: dbus-devel  >= %{dbus_version}
28BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
29BuildRequires: polkit-devel >= %{polkit_version}
30BuildRequires: parted-devel >= %{parted_version}
31BuildRequires: device-mapper-devel >= %{device_mapper_version}
32BuildRequires: libacl-devel
33BuildRequires: intltool
34BuildRequires: libatasmart-devel >= %{libatasmart_version}
35BuildRequires: libgudev1-devel >= %{udev_version}
36BuildRequires: libudev-devel >= %{udev_version}
37BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
38BuildRequires: lvm2-devel >= %{lvm2_version}
39BuildRequires: gobject-introspection-devel
40
41# needed to pull in the system bus daemon
42Requires: dbus >= %{dbus_version}
43# needed to pull in the udev daemon
44Requires: udev >= %{udev_version}
45# we need at least this version for bugfixes / features etc.
46Requires: libatasmart >= %{libatasmart_version}
47Requires: mdadm >= %{mdadm_version}
48# for smp_rep_manufacturer
49Requires: smp_utils >= %{smp_utils_version}
50# for mount, umount, mkswap
51Requires: util-linux-ng
52# for mkfs.ext3, mkfs.ext3, e2label
53Requires: e2fsprogs
54# for mkfs.xfs, xfs_admin
55Requires: xfsprogs
56# for mkfs.vfat
57Requires: dosfstools
58# for mlabel
59Requires: mtools
60# for mkntfs - no ntfsprogs on ppc, though
61%ifnarch ppc ppc64
62Requires: ntfsprogs
63%endif
64
65# for /proc/self/mountinfo, only available in 2.6.26 or higher
66Conflicts: kernel < 2.6.26
67
68# we need liblvm2app at least this recent since the ABI changed (sizes
69# reported in number of bytes instead of number of sectors) without
70# the sonumber changing
71#
72Requires: lvm2-libs >= %{lvm2_version}
73
74Vendor: Project Vine
75Distribution: Vine Linux
76
77%description
78udisks provides a daemon, D-Bus API and command line tools
79for managing disks and storage devices.
80
81%package devel
82Summary: D-Bus interface definitions for udisks
83Group: Development/Libraries
84Requires: %{name} = %{version}-%{release}
85
86# See comment above
87#
88%description devel
89D-Bus interface definitions and documentation for udisks.
90
91
92%package        doc
93Summary:        Documentation for udisks2
94Group:          Documentation
95Requires:       %{name} = %{version}-%{release}
96BuildArch:      noarch
97
98%description    doc
99This package contains documentation for udisks2.
100
101
102%prep
103%setup -q -n udisks-%{version}
104
105%build
106%configure \
107        --enable-gtk-doc
108make
109
110%install
111rm -rf $RPM_BUILD_ROOT
112
113make install DESTDIR=$RPM_BUILD_ROOT
114
115rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
116rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
117
118# for now, include a compat symlink for the command-line tool
119# and man page
120ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
121ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
122
123mkdir $RPM_BUILD_ROOT/run
124
125%find_lang %{name}
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post -p /sbin/ldconfig
131
132%postun -p /sbin/ldconfig
133
134%files -f %{name}.lang
135%defattr(-,root,root,-)
136%doc README AUTHORS NEWS COPYING HACKING
137%{_sysconfdir}/dbus-1/system.d/org.freedesktop.UDisks2.conf
138/lib/udev/rules.d/80-udisks2.rules
139%{_bindir}/devkit-disks
140%{_bindir}/udisksctl
141%{_sbindir}/umount.udisks2
142%dir %{_prefix}/lib/udisks2
143%{_prefix}/lib/udisks2/udisksd
144%{_libdir}/libudisks2.so.*
145%{_libdir}/girepository-1.0/UDisks-2.0.typelib
146%{_datadir}/bash-completion/completions/udisksctl
147%{_datadir}/dbus-1/system-services/org.freedesktop.UDisks2.service
148%{_datadir}/polkit-1/actions/org.freedesktop.udisks2.policy
149%{_mandir}/man1/*
150%{_mandir}/man8/*
151%attr(0700,root,root) %dir %{_localstatedir}/lib/udisks2
152%attr(0755,root,root) %dir /run
153
154%files devel
155%defattr(-,root,root,-)
156%{_includedir}/udisks2
157%{_libdir}/libudisks2.so
158%{_libdir}/pkgconfig/udisks2.pc
159%{_datadir}/gir-1.0/UDisks-2.0.gir
160
161%files doc
162%defattr(-,root,root,-)
163%{_datadir}/gtk-doc/html/%{name}
164
165#
166%changelog
167* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.0-1
168- new upstream release
169
170* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.99.0-1
171- new upstream release
172
173* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.98.0-1
174- new upstream release
175- add BuildRequires: libacl-devel
176
177* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.94.0-1
178- Initial build for Vine Linux
179
Note: See TracBrowser for help on using the repository browser.