source: projects/specs/trunk/u/udisks/udisks-vl.spec @ 8607

Revision 8607, 6.8 KB checked in by Takemikaduchi, 10 years ago (diff)

NEW: eudev
rtmpdump: add R: gmp-devel
gpac: remove Requires
others: rebuild with eudev

Line 
1%define glib2_version           2.6.0
2%define dbus_version            1.2
3%define dbus_glib_version       0.82
4%define polkit_version          0.92
5%define parted_version          2.3
6%define eudev_version           1.7
7%define mdadm_version           2.6.7
8%define device_mapper_version   1.02
9%define libatasmart_version     0.12
10%define sg3_utils_version       1.27
11%define smp_utils_version       0.94
12%define lvm2_version            2.02.78
13
14Summary: Storage Management Service
15Name: udisks
16Version: 1.0.4
17Release: 4%{?_dist_release}
18License: GPLv2+
19Group: System Environment/Libraries
20URL: http://www.freedesktop.org/wiki/Software/udisks
21Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
22BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23BuildRequires: glib2-devel >= %{glib2_version}
24BuildRequires: dbus-devel  >= %{dbus_version}
25BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
26BuildRequires: polkit-devel >= %{polkit_version}
27BuildRequires: parted-devel >= %{parted_version}
28BuildRequires: device-mapper-devel >= %{device_mapper_version}
29BuildRequires: intltool
30BuildRequires: libatasmart-devel >= %{libatasmart_version}
31BuildRequires: eudev-libgudev1-devel >= %{eudev_version}
32BuildRequires: eudev-libudev-devel >= %{eudev_version}
33BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
34BuildRequires: lvm2-devel >= %{lvm2_version}
35# needed to pull in the system bus daemon
36Requires: dbus >= %{dbus_version}
37# needed to pull in the udev daemon
38Requires: eudev >= %{eudev_version}
39# we need at least this version for bugfixes / features etc.
40Requires: libatasmart >= %{libatasmart_version}
41Requires: mdadm >= %{mdadm_version}
42# for smp_rep_manufacturer
43Requires: smp_utils >= %{smp_utils_version}
44# for mount, umount, mkswap
45Requires: util-linux-ng
46# for mkfs.ext3, mkfs.ext3, e2label
47Requires: e2fsprogs
48# for mkfs.xfs, xfs_admin
49Requires: xfsprogs
50# for mkfs.vfat
51Requires: dosfstools
52# for mlabel
53Requires: mtools
54# for mkntfs - no ntfsprogs on ppc, though
55%ifnarch ppc ppc64
56Requires: ntfsprogs
57%endif
58
59# for /proc/self/mountinfo, only available in 2.6.26 or higher
60Conflicts: kernel < 2.6.26
61
62# we need liblvm2app at least this recent since the ABI changed (sizes
63# reported in number of bytes instead of number of sectors) without
64# the sonumber changing
65#
66Requires: lvm2-libs >= %{lvm2_version}
67
68# Obsolete and Provide DeviceKit-disks - udisks provides exactly the same
69# ABI just with a different name and versioning-scheme
70#
71Obsoletes: DeviceKit-disks <= 009
72Provides: DeviceKit-disks = 010
73
74Vendor: Project Vine
75Distribution: Vine Linux
76
77%description
78udisks provides a daemon, D-Bus API and command line tools
79for managing disks and storage devices.
80
81%package devel
82Summary: D-Bus interface definitions for udisks
83Group: Development/Libraries
84Requires: %{name} = %{version}-%{release}
85Requires: gtk-doc
86
87# See comment above
88#
89Obsoletes: DeviceKit-disks-devel <= 009
90Provides: DeviceKit-disks-devel = 010
91
92%description devel
93D-Bus interface definitions and documentation for udisks.
94
95%prep
96%setup -q
97
98%build
99%configure \
100        --enable-gtk-doc \
101        --enable-lvm2
102make
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
107make install DESTDIR=$RPM_BUILD_ROOT
108
109rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
110rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
111
112# for now, include a compat symlink for the command-line tool
113# and man page
114ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
115ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
116
117# TODO: should be fixed upstream
118chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/udisks-bash-completion.sh
119
120%find_lang %{name}
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%files -f %{name}.lang
126%defattr(-,root,root,-)
127
128%doc README AUTHORS NEWS COPYING HACKING doc/TODO
129
130%{_sysconfdir}/avahi/services/udisks.service
131%{_sysconfdir}/dbus-1/system.d/*.conf
132%{_sysconfdir}/profile.d/*.sh
133/lib/udev/rules.d/*.rules
134
135/lib/udev/udisks-part-id
136/lib/udev/udisks-dm-export
137/lib/udev/udisks-probe-ata-smart
138/lib/udev/udisks-probe-sas-expander
139/lib/udev/udisks-lvm-pv-export
140/sbin/umount.udisks
141
142%{_bindir}/*
143%{_libexecdir}/*
144
145%{_mandir}/man1/*
146%{_mandir}/man7/*
147%{_mandir}/man8/*
148
149%{_datadir}/polkit-1/actions/*.policy
150
151%{_datadir}/dbus-1/system-services/*.service
152
153%attr(0700,root,root) %dir %{_localstatedir}/lib/udisks
154
155%files devel
156%defattr(-,root,root,-)
157
158%{_datadir}/dbus-1/interfaces/*.xml
159%{_datadir}/pkgconfig/udisks.pc
160
161%dir %{_datadir}/gtk-doc/html/udisks
162%{_datadir}/gtk-doc/html/udisks/*
163
164# Note: please don't forget the %{?dist} in the changelog. Thanks
165#
166%changelog
167* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-4
168- change BuildRequires: eudev-libudev-devel instead of libudev-devel
169- change BuildRequires: eudev-libgudev1-devel instead of libgudev1-devel
170
171* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-3
172- rebuild with parted-3.1
173
174* Thu Jan 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
175- rebuild with parted-3.0
176
177* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
178- new upstream release
179
180* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
181- new upstream release
182- drop Patch0
183
184* Sun Aug 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
185- add Patch0 (10-ide-cd-support.patch) from ubuntu
186
187* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
188- new upstream release
189
190* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1-2
191- rebuilt with parted 2.3
192
193* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
194- new upstream release
195
196* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
197- Initial build for Vine Linux
198
199
200* Tue Mar 30 2010 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-2%{?dist}
201- Bump release and rebuild so we link to the new libparted.
202
203* Mon Mar 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-1%{?dist}
204- Update to release 1.0.0
205
206* Tue Feb 23 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100223.1%{?dist}
207- Update to new git snapshot
208
209* Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.3%{?dist}
210- Require lvm2-libs >= 2.02.61 to get the right ABI for liblvm2app
211
212* Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.2%{?dist}
213- Update for new liblvm2app library
214
215* Mon Feb 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.1%{?dist}
216- Update to git snapshot
217
218* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.2%{?dist}
219- Rebuild
220
221* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.1%{?dist}
222- New git snapshot with LVM support
223
224* Tue Jan 12 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.3%{?dist}
225- Rebuild for new libparted
226
227* Mon Dec 07 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.2%{?dist}
228- Rebuild
229
230* Fri Dec 04 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.1%{?dist}
231- Updated for package review (#543608)
232
233* Wed Dec 02 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202%{?dist}
234- Git snapshot for upcoming 1.0.0 release
Note: See TracBrowser for help on using the repository browser.