source: projects/specs/trunk/u/udisks/udisks-vl.spec @ 12361

Revision 12361, 7.3 KB checked in by tomop, 4 years ago (diff)

updated 8 packages

cryptsetup-2.3.1-1

gdisk-1.0.5-1

kernel-4.14.174-1

lvm2-2.03.09-1

libblockdev-2.23-1

libmicrohttpd-0.9.70-1

udisks-1.0.5-1

udisks2-2.8.4-1

Line 
1%define glib2_version           2.6.0
2%define dbus_version            1.2
3%define dbus_glib_version       0.82
4%define polkit_version          0.92
5%define parted_version          2.3
6%define eudev_version           1.7
7%define mdadm_version           2.6.7
8%define device_mapper_version   1.02
9%define libatasmart_version     0.12
10%define sg3_utils_version       1.27
11%define smp_utils_version       0.94
12
13Summary: Storage Management Service
14Name: udisks
15Version: 1.0.5
16Release: 1%{?_dist_release}
17Group: System Environment/Libraries
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22License: GPLv2+
23URL: http://www.freedesktop.org/wiki/Software/udisks
24Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
25# https://bugs.freedesktop.org/show_bug.cgi?id=90778
26Patch0:  udisks-1.0.5-fix-build-with-glibc-2.20.patch
27Patch1:  fix_bash_completion.patch
28# https://bugzilla.redhat.com/show_bug.cgi?id=1238664
29Patch2:  udisks-1.0.5-fix-service-file.patch
30Patch3:  udisks-1.0.5-fix-makedev-failure.patch
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
33BuildRequires: glib2-devel >= %{glib2_version}
34BuildRequires: dbus-devel  >= %{dbus_version}
35BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
36BuildRequires: polkit-devel >= %{polkit_version}
37BuildRequires: parted-devel >= %{parted_version}
38BuildRequires: device-mapper-devel >= %{device_mapper_version}
39BuildRequires: intltool
40BuildRequires: libatasmart-devel >= %{libatasmart_version}
41BuildRequires: eudev-libgudev1-devel >= %{eudev_version}
42BuildRequires: eudev-libudev-devel >= %{eudev_version}
43BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
44# needed to pull in the system bus daemon
45Requires: dbus >= %{dbus_version}
46# needed to pull in the udev daemon
47Requires: eudev >= %{eudev_version}
48# we need at least this version for bugfixes / features etc.
49Requires: libatasmart >= %{libatasmart_version}
50Requires: mdadm >= %{mdadm_version}
51# for smp_rep_manufacturer
52Requires: smp_utils >= %{smp_utils_version}
53# for mount, umount, mkswap
54Requires: util-linux-ng
55# for mkfs.ext3, mkfs.ext3, e2label
56Requires: e2fsprogs
57# for mkfs.xfs, xfs_admin
58Requires: xfsprogs
59# for mkfs.vfat
60Requires: dosfstools
61# for mlabel
62Requires: mtools
63# for mkntfs - no ntfsprogs on ppc, though
64%ifnarch ppc ppc64
65Requires: ntfsprogs
66%endif
67
68# for /proc/self/mountinfo, only available in 2.6.26 or higher
69Conflicts: kernel < 2.6.26
70
71# we need liblvm2app at least this recent since the ABI changed (sizes
72# reported in number of bytes instead of number of sectors) without
73# the sonumber changing
74#
75Requires: lvm2-libs >= %{lvm2_version}
76
77# Obsolete and Provide DeviceKit-disks - udisks provides exactly the same
78# ABI just with a different name and versioning-scheme
79#
80Obsoletes: DeviceKit-disks <= 009
81Provides: DeviceKit-disks = 010
82
83%description
84udisks provides a daemon, D-Bus API and command line tools
85for managing disks and storage devices.
86
87%package devel
88Summary: D-Bus interface definitions for udisks
89Group: Development/Libraries
90Requires: %{name} = %{version}-%{release}
91Requires: gtk-doc
92
93# See comment above
94#
95Obsoletes: DeviceKit-disks-devel <= 009
96Provides: DeviceKit-disks-devel = 010
97
98%description devel
99D-Bus interface definitions and documentation for udisks.
100
101%prep
102%setup -q
103%autopatch -p1
104
105# https://bugzilla.redhat.com/show_bug.cgi?id=673544#c15
106rm -f src/*-glue.h tools/*-glue.h
107
108autoreconf --force --install
109
110%build
111%configure \
112        --enable-gtk-doc \
113        %{nil}
114make %{_smp_mflags}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118
119make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
120
121rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
122rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
123
124# for now, include a compat symlink for the command-line tool
125# and man page
126ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
127ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
128
129# TODO: should be fixed upstream
130chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/udisks-bash-completion.sh
131
132%find_lang %{name}
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%files -f %{name}.lang
138%defattr(-,root,root,-)
139%license COPYING
140%doc README AUTHORS NEWS HACKING doc/TODO
141%{_sysconfdir}/avahi/services/udisks.service
142%{_sysconfdir}/dbus-1/system.d/*.conf
143%{_sysconfdir}/profile.d/*.sh
144/lib/udev/rules.d/*.rules
145
146/lib/udev/udisks-part-id
147/lib/udev/udisks-dm-export
148/lib/udev/udisks-probe-ata-smart
149/lib/udev/udisks-probe-sas-expander
150/sbin/umount.udisks
151
152%{_bindir}/*
153%{_libexecdir}/*
154
155%{_mandir}/man1/*
156%{_mandir}/man7/*
157%{_mandir}/man8/*
158
159%{_datadir}/polkit-1/actions/*.policy
160
161%{_datadir}/dbus-1/system-services/*.service
162
163%attr(0700,root,root) %dir %{_localstatedir}/lib/udisks
164
165%files devel
166%defattr(-,root,root,-)
167
168%{_datadir}/dbus-1/interfaces/*.xml
169%{_datadir}/pkgconfig/udisks.pc
170
171%dir %{_datadir}/gtk-doc/html/udisks
172%{_datadir}/gtk-doc/html/udisks/*
173
174# Note: please don't forget the %{?dist} in the changelog. Thanks
175#
176%changelog
177* Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.5-1
178- new upstream release.
179
180* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-4
181- change BuildRequires: eudev-libudev-devel instead of libudev-devel
182- change BuildRequires: eudev-libgudev1-devel instead of libgudev1-devel
183
184* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-3
185- rebuild with parted-3.1
186
187* Thu Jan 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
188- rebuild with parted-3.0
189
190* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
191- new upstream release
192
193* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
194- new upstream release
195- drop Patch0
196
197* Sun Aug 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
198- add Patch0 (10-ide-cd-support.patch) from ubuntu
199
200* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
201- new upstream release
202
203* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1-2
204- rebuilt with parted 2.3
205
206* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
207- new upstream release
208
209* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
210- Initial build for Vine Linux
211
212
213* Tue Mar 30 2010 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-2%{?dist}
214- Bump release and rebuild so we link to the new libparted.
215
216* Mon Mar 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-1%{?dist}
217- Update to release 1.0.0
218
219* Tue Feb 23 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100223.1%{?dist}
220- Update to new git snapshot
221
222* Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.3%{?dist}
223- Require lvm2-libs >= 2.02.61 to get the right ABI for liblvm2app
224
225* Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.2%{?dist}
226- Update for new liblvm2app library
227
228* Mon Feb 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.1%{?dist}
229- Update to git snapshot
230
231* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.2%{?dist}
232- Rebuild
233
234* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.1%{?dist}
235- New git snapshot with LVM support
236
237* Tue Jan 12 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.3%{?dist}
238- Rebuild for new libparted
239
240* Mon Dec 07 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.2%{?dist}
241- Rebuild
242
243* Fri Dec 04 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.1%{?dist}
244- Updated for package review (#543608)
245
246* Wed Dec 02 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202%{?dist}
247- Git snapshot for upcoming 1.0.0 release
Note: See TracBrowser for help on using the repository browser.