source: projects/specs/trunk/u/udisks/udisks-vl.spec @ 12462

Revision 12462, 7.7 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

libblockdev-2.24-1

parted-3.3-1

sg3_utils-1.45-1

udisks-1.0.5-2

udisks2-2.9.0-1

Line 
1%bcond_with systemd
2
3%define glib2_version           2.6.0
4%define dbus_version            1.2
5%define dbus_glib_version       0.82
6%define polkit_version          0.92
7%define parted_version          2.3
8%define eudev_version           1.7
9%define mdadm_version           2.6.7
10%define device_mapper_version   1.02
11%define libatasmart_version     0.12
12%define sg3_utils_version       1.27
13%define smp_utils_version       0.94
14
15Summary: Storage Management Service
16Name: udisks
17Version: 1.0.5
18Release: 2%{?_dist_release}%{?with_systemd:.systemd}
19Group: system
20Vendor: Project Vine
21Distribution: Vine Linux
22
23License: GPLv2+
24URL: https://www.freedesktop.org/wiki/Software/udisks
25Source0: https://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
26# https://bugs.freedesktop.org/show_bug.cgi?id=90778
27Patch0:  udisks-1.0.5-fix-build-with-glibc-2.20.patch
28Patch1:  fix_bash_completion.patch
29# https://bugzilla.redhat.com/show_bug.cgi?id=1238664
30Patch2:  udisks-1.0.5-fix-service-file.patch
31Patch3:  udisks-1.0.5-fix-makedev-failure.patch
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34BuildRequires: glib2-devel >= %{glib2_version}
35BuildRequires: dbus-devel  >= %{dbus_version}
36BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
37BuildRequires: polkit-devel >= %{polkit_version}
38BuildRequires: parted-devel >= %{parted_version}
39BuildRequires: device-mapper-devel >= %{device_mapper_version}
40BuildRequires: intltool
41BuildRequires: libatasmart-devel >= %{libatasmart_version}
42BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
43%if %{with systemd}
44BuildRequires: systemd-devel
45BuildRequires: libgudev-devel
46%{?systemd_requires}
47%else
48BuildRequires: eudev-libgudev1-devel >= %{eudev_version}
49BuildRequires: eudev-libudev-devel >= %{eudev_version}
50%endif
51# needed to pull in the system bus daemon
52Requires: dbus >= %{dbus_version}
53# needed to pull in the udev daemon
54Requires: eudev >= %{eudev_version}
55# we need at least this version for bugfixes / features etc.
56Requires: libatasmart >= %{libatasmart_version}
57Requires: mdadm >= %{mdadm_version}
58# for smp_rep_manufacturer
59Requires: smp_utils >= %{smp_utils_version}
60# for mount, umount, mkswap
61Requires: util-linux-ng
62# for mkfs.ext3, mkfs.ext3, e2label
63Requires: e2fsprogs
64# for mkfs.xfs, xfs_admin
65Requires: xfsprogs
66# for mkfs.vfat
67Requires: dosfstools
68# for mlabel
69Requires: mtools
70# for mkntfs - no ntfsprogs on ppc, though
71%ifnarch ppc ppc64
72Requires: ntfsprogs
73%endif
74
75# for /proc/self/mountinfo, only available in 2.6.26 or higher
76Conflicts: kernel < 2.6.26
77
78# we need liblvm2app at least this recent since the ABI changed (sizes
79# reported in number of bytes instead of number of sectors) without
80# the sonumber changing
81#
82Requires: lvm2-libs >= %{lvm2_version}
83
84# Obsolete and Provide DeviceKit-disks - udisks provides exactly the same
85# ABI just with a different name and versioning-scheme
86#
87Obsoletes: DeviceKit-disks <= 009
88Provides: DeviceKit-disks = 010
89
90%description
91udisks provides a daemon, D-Bus API and command line tools
92for managing disks and storage devices.
93
94
95%package devel
96Summary: D-Bus interface definitions for udisks
97Group: programming
98Requires: %{name} = %{version}-%{release}
99Requires: gtk-doc
100# See comment above
101#
102Obsoletes: DeviceKit-disks-devel <= 009
103Provides: DeviceKit-disks-devel = 010
104
105%description devel
106D-Bus interface definitions and documentation for udisks.
107
108
109%prep
110%setup -q
111%autopatch -p1
112
113# https://bugzilla.redhat.com/show_bug.cgi?id=673544#c15
114rm -f src/*-glue.h tools/*-glue.h
115
116autoreconf --force --install
117
118
119%build
120%configure \
121        --enable-gtk-doc \
122        %{nil}
123make %{_smp_mflags}
124
125
126%install
127rm -rf $RPM_BUILD_ROOT
128make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
129
130rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
131rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
132
133# for now, include a compat symlink for the command-line tool
134# and man page
135ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
136ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
137
138# TODO: should be fixed upstream
139chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/udisks-bash-completion.sh
140
141%find_lang %{name}
142
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147
148%if %{with systemd}
149%post
150%systemd_post udisks.service
151
152%preun
153%systemd_preun udisks.service
154
155%postun
156%systemd_postun_with_restart udisks.service
157%endif
158
159
160%files -f %{name}.lang
161%defattr(-,root,root,-)
162%license COPYING
163%doc README AUTHORS NEWS HACKING doc/TODO
164%{_sysconfdir}/avahi/services/udisks.service
165%{_sysconfdir}/dbus-1/system.d/*.conf
166%{_sysconfdir}/profile.d/*.sh
167
168%if %{with systemd}
169%{_unitdir}/udisks.service
170%endif
171
172/lib/udev/rules.d/*.rules
173/lib/udev/udisks-part-id
174/lib/udev/udisks-dm-export
175/lib/udev/udisks-probe-ata-smart
176/lib/udev/udisks-probe-sas-expander
177/sbin/umount.udisks
178
179%{_bindir}/*
180%{_libexecdir}/*
181
182%{_mandir}/man1/*
183%{_mandir}/man7/*
184%{_mandir}/man8/*
185
186%{_datadir}/polkit-1/actions/*.policy
187
188%{_datadir}/dbus-1/system-services/*.service
189
190%attr(0700,root,root) %dir %{_localstatedir}/lib/udisks
191
192%files devel
193%defattr(-,root,root,-)
194
195%{_datadir}/dbus-1/interfaces/*.xml
196%{_datadir}/pkgconfig/udisks.pc
197
198%dir %{_datadir}/gtk-doc/html/udisks
199%{_datadir}/gtk-doc/html/udisks/*
200
201
202%changelog
203* Tue Aug 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.5-2
204- rebuilt with sg3_utils-1.45.
205- added systemd support (disabled as default).
206
207* Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.5-1
208- new upstream release.
209
210* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-4
211- change BuildRequires: eudev-libudev-devel instead of libudev-devel
212- change BuildRequires: eudev-libgudev1-devel instead of libgudev1-devel
213
214* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-3
215- rebuild with parted-3.1
216
217* Thu Jan 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
218- rebuild with parted-3.0
219
220* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
221- new upstream release
222
223* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
224- new upstream release
225- drop Patch0
226
227* Sun Aug 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
228- add Patch0 (10-ide-cd-support.patch) from ubuntu
229
230* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
231- new upstream release
232
233* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1-2
234- rebuilt with parted 2.3
235
236* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
237- new upstream release
238
239* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
240- Initial build for Vine Linux
241
242
243* Tue Mar 30 2010 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-2%{?dist}
244- Bump release and rebuild so we link to the new libparted.
245
246* Mon Mar 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-1%{?dist}
247- Update to release 1.0.0
248
249* Tue Feb 23 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100223.1%{?dist}
250- Update to new git snapshot
251
252* Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.3%{?dist}
253- Require lvm2-libs >= 2.02.61 to get the right ABI for liblvm2app
254
255* Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.2%{?dist}
256- Update for new liblvm2app library
257
258* Mon Feb 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.1%{?dist}
259- Update to git snapshot
260
261* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.2%{?dist}
262- Rebuild
263
264* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.1%{?dist}
265- New git snapshot with LVM support
266
267* Tue Jan 12 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.3%{?dist}
268- Rebuild for new libparted
269
270* Mon Dec 07 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.2%{?dist}
271- Rebuild
272
273* Fri Dec 04 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.1%{?dist}
274- Updated for package review (#543608)
275
276* Wed Dec 02 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202%{?dist}
277- Git snapshot for upcoming 1.0.0 release
Note: See TracBrowser for help on using the repository browser.