source: projects/specs/trunk/u/udisks/udisks-vl.spec @ 4616

Revision 4616, 6.4 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

RevLine 
[805]1%define glib2_version           2.6.0
2%define dbus_version            1.2
3%define dbus_glib_version       0.82
4%define polkit_version          0.92
[2193]5%define parted_version          2.3
[805]6%define udev_version            145
7%define mdadm_version           2.6.7
8%define device_mapper_version   1.02
9%define libatasmart_version     0.12
10%define sg3_utils_version       1.27
11%define smp_utils_version       0.94
[2323]12%define lvm2_version            2.02.78
[805]13
14Summary: Storage Management Service
15Name: udisks
[4616]16Version: 1.0.3
17Release: 1%{?_dist_release}
[805]18License: GPLv2+
19Group: System Environment/Libraries
20URL: http://www.freedesktop.org/wiki/Software/udisks
21Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
22BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23BuildRequires: glib2-devel >= %{glib2_version}
24BuildRequires: dbus-devel  >= %{dbus_version}
25BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
26BuildRequires: polkit-devel >= %{polkit_version}
27BuildRequires: parted-devel >= %{parted_version}
28BuildRequires: device-mapper-devel >= %{device_mapper_version}
29BuildRequires: intltool
30BuildRequires: libatasmart-devel >= %{libatasmart_version}
31BuildRequires: libgudev1-devel >= %{udev_version}
32BuildRequires: libudev-devel >= %{udev_version}
33BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
34BuildRequires: lvm2-devel >= %{lvm2_version}
35# needed to pull in the system bus daemon
36Requires: dbus >= %{dbus_version}
37# needed to pull in the udev daemon
38Requires: udev >= %{udev_version}
39# we need at least this version for bugfixes / features etc.
40Requires: libatasmart >= %{libatasmart_version}
41Requires: mdadm >= %{mdadm_version}
42# for smp_rep_manufacturer
43Requires: smp_utils >= %{smp_utils_version}
44# for mount, umount, mkswap
45Requires: util-linux-ng
46# for mkfs.ext3, mkfs.ext3, e2label
47Requires: e2fsprogs
48# for mkfs.xfs, xfs_admin
49Requires: xfsprogs
50# for mkfs.vfat
51Requires: dosfstools
52# for mlabel
53Requires: mtools
54# for mkntfs - no ntfsprogs on ppc, though
55%ifnarch ppc ppc64
56Requires: ntfsprogs
57%endif
58
59# for /proc/self/mountinfo, only available in 2.6.26 or higher
60Conflicts: kernel < 2.6.26
61
62# we need liblvm2app at least this recent since the ABI changed (sizes
63# reported in number of bytes instead of number of sectors) without
64# the sonumber changing
65#
66Requires: lvm2-libs >= %{lvm2_version}
67
68# Obsolete and Provide DeviceKit-disks - udisks provides exactly the same
69# ABI just with a different name and versioning-scheme
70#
71Obsoletes: DeviceKit-disks <= 009
72Provides: DeviceKit-disks = 010
73
[4616]74Vendor: Project Vine
75Distribution: Vine Linux
76
[805]77%description
78udisks provides a daemon, D-Bus API and command line tools
79for managing disks and storage devices.
80
81%package devel
82Summary: D-Bus interface definitions for udisks
83Group: Development/Libraries
84Requires: %{name} = %{version}-%{release}
85Requires: gtk-doc
86
87# See comment above
88#
89Obsoletes: DeviceKit-disks-devel <= 009
90Provides: DeviceKit-disks-devel = 010
91
92%description devel
93D-Bus interface definitions and documentation for udisks.
94
95%prep
96%setup -q
97
98%build
99%configure --enable-gtk-doc
100make
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
105make install DESTDIR=$RPM_BUILD_ROOT
106
107rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
108rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
109
110# for now, include a compat symlink for the command-line tool
111# and man page
112ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
113ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
114
115# TODO: should be fixed upstream
116chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/udisks-bash-completion.sh
117
118%find_lang %{name}
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%files -f %{name}.lang
124%defattr(-,root,root,-)
125
126%doc README AUTHORS NEWS COPYING HACKING doc/TODO
127
128%{_sysconfdir}/avahi/services/udisks.service
129%{_sysconfdir}/dbus-1/system.d/*.conf
130%{_sysconfdir}/profile.d/*.sh
131/lib/udev/rules.d/*.rules
132
133/lib/udev/udisks-part-id
134/lib/udev/udisks-dm-export
135/lib/udev/udisks-probe-ata-smart
136/lib/udev/udisks-probe-sas-expander
137/lib/udev/udisks-lvm-pv-export
138/sbin/umount.udisks
139
140%{_bindir}/*
141%{_libexecdir}/*
142
143%{_mandir}/man1/*
144%{_mandir}/man7/*
145%{_mandir}/man8/*
146
147%{_datadir}/polkit-1/actions/*.policy
148
149%{_datadir}/dbus-1/system-services/*.service
150
151%attr(0700,root,root) %dir %{_localstatedir}/run/udisks
152%attr(0700,root,root) %dir %{_localstatedir}/lib/udisks
153
154%files devel
155%defattr(-,root,root,-)
156
157%{_datadir}/dbus-1/interfaces/*.xml
158%{_datadir}/pkgconfig/udisks.pc
159
160%dir %{_datadir}/gtk-doc/html/udisks
161%{_datadir}/gtk-doc/html/udisks/*
162
163# Note: please don't forget the %{?dist} in the changelog. Thanks
164#
165%changelog
[4616]166* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
167- new upstream release
168- drop Patch0
169
[4506]170* Sun Aug 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
171- add Patch0 (10-ide-cd-support.patch) from ubuntu
172
[2323]173* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
174- new upstream release
175
[2193]176* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1-2
177- rebuilt with parted 2.3
178
[2041]179* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
180- new upstream release
[1996]181
[805]182* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
183- Initial build for Vine Linux
184
185
186* Tue Mar 30 2010 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-2%{?dist}
187- Bump release and rebuild so we link to the new libparted.
188
189* Mon Mar 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-1%{?dist}
190- Update to release 1.0.0
191
192* Tue Feb 23 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100223.1%{?dist}
193- Update to new git snapshot
194
195* Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.3%{?dist}
196- Require lvm2-libs >= 2.02.61 to get the right ABI for liblvm2app
197
198* Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.2%{?dist}
199- Update for new liblvm2app library
200
201* Mon Feb 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.1%{?dist}
202- Update to git snapshot
203
204* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.2%{?dist}
205- Rebuild
206
207* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.1%{?dist}
208- New git snapshot with LVM support
209
210* Tue Jan 12 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.3%{?dist}
211- Rebuild for new libparted
212
213* Mon Dec 07 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.2%{?dist}
214- Rebuild
215
216* Fri Dec 04 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.1%{?dist}
217- Updated for package review (#543608)
218
219* Wed Dec 02 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202%{?dist}
220- Git snapshot for upcoming 1.0.0 release
Note: See TracBrowser for help on using the repository browser.