source: projects/specs/trunk/u/udisks/udisks-vl.spec @ 4506

Revision 4506, 6.4 KB checked in by Takemikaduchi, 13 years ago (diff)

bug fix: support for IDE

RevLine 
[805]1%define glib2_version           2.6.0
2%define dbus_version            1.2
3%define dbus_glib_version       0.82
4%define polkit_version          0.92
[2193]5%define parted_version          2.3
[805]6%define udev_version            145
7%define mdadm_version           2.6.7
8%define device_mapper_version   1.02
9%define libatasmart_version     0.12
10%define sg3_utils_version       1.27
11%define smp_utils_version       0.94
[2323]12%define lvm2_version            2.02.78
[805]13
14Summary: Storage Management Service
15Name: udisks
[2323]16Version: 1.0.2
[4506]17Release: 2%{?_dist_release}
[805]18License: GPLv2+
19Group: System Environment/Libraries
20URL: http://www.freedesktop.org/wiki/Software/udisks
21Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
[4506]22Patch0: 10-ide-cd-support.patch
[805]23BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24BuildRequires: glib2-devel >= %{glib2_version}
25BuildRequires: dbus-devel  >= %{dbus_version}
26BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
27BuildRequires: polkit-devel >= %{polkit_version}
28BuildRequires: parted-devel >= %{parted_version}
29BuildRequires: device-mapper-devel >= %{device_mapper_version}
30BuildRequires: intltool
31BuildRequires: libatasmart-devel >= %{libatasmart_version}
32BuildRequires: libgudev1-devel >= %{udev_version}
33BuildRequires: libudev-devel >= %{udev_version}
34BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
35BuildRequires: lvm2-devel >= %{lvm2_version}
36# needed to pull in the system bus daemon
37Requires: dbus >= %{dbus_version}
38# needed to pull in the udev daemon
39Requires: udev >= %{udev_version}
40# we need at least this version for bugfixes / features etc.
41Requires: libatasmart >= %{libatasmart_version}
42Requires: mdadm >= %{mdadm_version}
43# for smp_rep_manufacturer
44Requires: smp_utils >= %{smp_utils_version}
45# for mount, umount, mkswap
46Requires: util-linux-ng
47# for mkfs.ext3, mkfs.ext3, e2label
48Requires: e2fsprogs
49# for mkfs.xfs, xfs_admin
50Requires: xfsprogs
51# for mkfs.vfat
52Requires: dosfstools
53# for mlabel
54Requires: mtools
55# for mkntfs - no ntfsprogs on ppc, though
56%ifnarch ppc ppc64
57Requires: ntfsprogs
58%endif
59
60# for /proc/self/mountinfo, only available in 2.6.26 or higher
61Conflicts: kernel < 2.6.26
62
63# we need liblvm2app at least this recent since the ABI changed (sizes
64# reported in number of bytes instead of number of sectors) without
65# the sonumber changing
66#
67Requires: lvm2-libs >= %{lvm2_version}
68
69# Obsolete and Provide DeviceKit-disks - udisks provides exactly the same
70# ABI just with a different name and versioning-scheme
71#
72Obsoletes: DeviceKit-disks <= 009
73Provides: DeviceKit-disks = 010
74
75%description
76udisks provides a daemon, D-Bus API and command line tools
77for managing disks and storage devices.
78
79%package devel
80Summary: D-Bus interface definitions for udisks
81Group: Development/Libraries
82Requires: %{name} = %{version}-%{release}
83Requires: gtk-doc
84
85# See comment above
86#
87Obsoletes: DeviceKit-disks-devel <= 009
88Provides: DeviceKit-disks-devel = 010
89
90%description devel
91D-Bus interface definitions and documentation for udisks.
92
93%prep
94%setup -q
[4506]95%patch0 -p1
[805]96
97%build
98%configure --enable-gtk-doc
99make
100
101%install
102rm -rf $RPM_BUILD_ROOT
103
104make install DESTDIR=$RPM_BUILD_ROOT
105
106rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
107rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
108
109rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.la
110rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.a
111
112# for now, include a compat symlink for the command-line tool
113# and man page
114ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
115ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
116
117# TODO: should be fixed upstream
118chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/udisks-bash-completion.sh
119
120%find_lang %{name}
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%files -f %{name}.lang
126%defattr(-,root,root,-)
127
128%doc README AUTHORS NEWS COPYING HACKING doc/TODO
129
130%{_sysconfdir}/avahi/services/udisks.service
131%{_sysconfdir}/dbus-1/system.d/*.conf
132%{_sysconfdir}/profile.d/*.sh
133/lib/udev/rules.d/*.rules
134
135/lib/udev/udisks-part-id
136/lib/udev/udisks-dm-export
137/lib/udev/udisks-probe-ata-smart
138/lib/udev/udisks-probe-sas-expander
139/lib/udev/udisks-lvm-pv-export
140/sbin/umount.udisks
141
142%{_bindir}/*
143%{_libexecdir}/*
144
145%{_mandir}/man1/*
146%{_mandir}/man7/*
147%{_mandir}/man8/*
148
149%{_datadir}/polkit-1/actions/*.policy
150
151%{_libdir}/polkit-1/extensions/*.so
152
153%{_datadir}/dbus-1/system-services/*.service
154
155%attr(0700,root,root) %dir %{_localstatedir}/run/udisks
156%attr(0700,root,root) %dir %{_localstatedir}/lib/udisks
157
158%files devel
159%defattr(-,root,root,-)
160
161%{_datadir}/dbus-1/interfaces/*.xml
162%{_datadir}/pkgconfig/udisks.pc
163
164%dir %{_datadir}/gtk-doc/html/udisks
165%{_datadir}/gtk-doc/html/udisks/*
166
167# Note: please don't forget the %{?dist} in the changelog. Thanks
168#
169%changelog
[4506]170* Sun Aug 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
171- add Patch0 (10-ide-cd-support.patch) from ubuntu
172
[2323]173* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
174- new upstream release
175
[2193]176* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1-2
177- rebuilt with parted 2.3
178
[2041]179* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
180- new upstream release
[1996]181
[805]182* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
183- Initial build for Vine Linux
184
185
186* Tue Mar 30 2010 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-2%{?dist}
187- Bump release and rebuild so we link to the new libparted.
188
189* Mon Mar 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-1%{?dist}
190- Update to release 1.0.0
191
192* Tue Feb 23 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100223.1%{?dist}
193- Update to new git snapshot
194
195* Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.3%{?dist}
196- Require lvm2-libs >= 2.02.61 to get the right ABI for liblvm2app
197
198* Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.2%{?dist}
199- Update for new liblvm2app library
200
201* Mon Feb 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.1%{?dist}
202- Update to git snapshot
203
204* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.2%{?dist}
205- Rebuild
206
207* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.1%{?dist}
208- New git snapshot with LVM support
209
210* Tue Jan 12 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.3%{?dist}
211- Rebuild for new libparted
212
213* Mon Dec 07 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.2%{?dist}
214- Rebuild
215
216* Fri Dec 04 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.1%{?dist}
217- Updated for package review (#543608)
218
219* Wed Dec 02 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202%{?dist}
220- Git snapshot for upcoming 1.0.0 release
Note: See TracBrowser for help on using the repository browser.