source: projects/specs/trunk/u/ucview/ucview-vl.spec @ 521

Revision 521, 3.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:          Image and video capture application using unicap toolkit
2Summary(ja):      unicap ツールキットを使用したイメージ/ビデオキャプチャアプリケーション
3Name:             ucview
4Version:          0.21
5Release:          1%{?_dist_release}
6License:          GPLv2+
7Group:            Applications/Multimedia
8URL:              http://www.unicap-imaging.org/
9Source0:          http://www.unicap-imaging.org/downloads/%{name}-%{version}.tar.gz
10Source1:          %{name}.desktop
11BuildRequires:    intltool, /usr/bin/perl, perl(XML::Parser), gettext
12BuildRequires:    unicap-devel >= 0.2.2, gtk2-devel >= 2.8.0, libglade2-devel
13BuildRequires:    glib2-devel, GConf2-devel, libXv-devel, desktop-file-utils
14BuildRequires:    libtheora-devel, libvorbis-devel, dbus-glib-devel >= 0.73
15Requires:         hicolor-icon-theme
16Requires(pre):    GConf2
17Requires(post):   GConf2, scrollkeeper
18Requires(preun):  GConf2
19Requires(postun): scrollkeeper
20BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22%description
23UCView is a video image capture application using the unicap toolkit.
24It provides a simple way to parametrise the video device, can capture
25still images from the video stream or record the stream as mpeg file.
26By using unicap, it can access many different video capture devices
27like webcams, video grabber boards, IEEE-1394 (FireWire) cameras and
28others.
29
30%prep
31%setup -q
32
33%build
34%configure --disable-schemas-install
35make %{?_smp_mflags}
36
37%install
38rm -rf $RPM_BUILD_ROOT
39export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
40make DESTDIR=$RPM_BUILD_ROOT install
41unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
42
43# Install a working ucview.desktop file
44desktop-file-install --vendor "" --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE1}
45
46# Don't install header files for ucview
47rm -rf $RPM_BUILD_ROOT%{_includedir}
48
49rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*.{a,la}
50
51
52%find_lang %{name}
53
54%pre
55if [ $1 -gt 1 ]; then
56  export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
57  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null 2>&1 || :
58fi
59
60%post
61scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
62export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
63gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null 2>&1 || :
64
65touch --no-create %{_datadir}/icons/hicolor
66if [ -x /usr/bin/gtk-update-icon-cache ]; then
67  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
68fi
69
70%preun
71if [ $1 -eq 0 ]; then
72  export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
73  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null 2>&1 || :
74fi
75
76%postun
77scrollkeeper-update -q || :
78
79touch --no-create %{_datadir}/icons/hicolor
80if [ -x /usr/bin/gtk-update-icon-cache ]; then
81  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
82fi
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%files -f %{name}.lang
88%defattr(-,root,root)
89%doc AUTHORS COPYING ChangeLog
90%{_sysconfdir}/gconf/schemas/%{name}.schemas
91%{_bindir}/%{name}
92%{_libdir}/%{name}/plugins/libhistogram.so
93%{_datadir}/%{name}
94%{_datadir}/applications/%{name}.desktop
95%{_datadir}/dbus-1/services/*.service
96%{_datadir}/icons/hicolor/*/apps/%{name}.png
97
98%changelog
99* Sun Jul 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.21-1
100- initial build for Vine Linux
101
102* Mon May 19 2008 Robert Scheck <robert@fedoraproject.org> 0.20.1-1
103- Upgrade to 0.20.1
104
105* Sun May 18 2008 Robert Scheck <robert@fedoraproject.org> 0.17-1
106- Upgrade to 0.17
107- Initial spec file for Fedora and Red Hat Enterprise Linux
Note: See TracBrowser for help on using the repository browser.